# Contents

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Legal Notices</td>
<td>11</td>
</tr>
<tr>
<td>1 Welcome to SOLIDWORKS 2018</td>
<td>14</td>
</tr>
<tr>
<td>Top Enhancements</td>
<td>14</td>
</tr>
<tr>
<td>For More Information</td>
<td>16</td>
</tr>
<tr>
<td>2 User Interface</td>
<td>17</td>
</tr>
<tr>
<td>Auto-Rotate View on Sketch Edit</td>
<td>17</td>
</tr>
<tr>
<td>Folder Icons in the FeatureManager Design Tree</td>
<td>18</td>
</tr>
<tr>
<td>Logging into SOLIDWORKS</td>
<td>19</td>
</tr>
<tr>
<td>Measure Tool Enhancements</td>
<td>20</td>
</tr>
<tr>
<td>Mouse Gestures Enhancements</td>
<td>21</td>
</tr>
<tr>
<td>Scaling of Entities on High-resolution Monitors</td>
<td>22</td>
</tr>
<tr>
<td>Show File Names and Descriptions in Design Library</td>
<td>22</td>
</tr>
<tr>
<td>Task Pane Changes</td>
<td>23</td>
</tr>
<tr>
<td>Touch-based Interactions</td>
<td>24</td>
</tr>
<tr>
<td>Custom Numeric Keypad</td>
<td>24</td>
</tr>
<tr>
<td>Magnified Selection</td>
<td>24</td>
</tr>
<tr>
<td>Touch Mode</td>
<td>25</td>
</tr>
<tr>
<td>Welcome Dialog Box</td>
<td>26</td>
</tr>
<tr>
<td>Home Tab</td>
<td>26</td>
</tr>
<tr>
<td>Recent Tab</td>
<td>27</td>
</tr>
<tr>
<td>Learn Tab</td>
<td>28</td>
</tr>
<tr>
<td>Alerts Tab</td>
<td>29</td>
</tr>
<tr>
<td>3 SOLIDWORKS Fundamentals</td>
<td>30</td>
</tr>
<tr>
<td>Adobe Illustrator Creative Cloud Files</td>
<td>30</td>
</tr>
<tr>
<td>Application Programming Interface</td>
<td>30</td>
</tr>
<tr>
<td>Default Templates for New Documents</td>
<td>31</td>
</tr>
<tr>
<td>Include or Exclude Suppressed Components in Pack and Go</td>
<td>32</td>
</tr>
<tr>
<td>Rebuild Tools</td>
<td>32</td>
</tr>
<tr>
<td>Selecting Over Geometry</td>
<td>33</td>
</tr>
<tr>
<td>Support for 3D Printing Models Containing Surface Bodies and Graphics Bodies</td>
<td>34</td>
</tr>
<tr>
<td>4 Installation</td>
<td>36</td>
</tr>
<tr>
<td>Installing SOLIDWORKS CAM</td>
<td>36</td>
</tr>
<tr>
<td>Installing SOLIDWORKS Manage Professional</td>
<td>36</td>
</tr>
<tr>
<td>Upgrading SOLIDWORKS PCB Services</td>
<td>37</td>
</tr>
</tbody>
</table>
# Contents

5 Administration
- Controlling Dismissed Messages ................................................................. 38
- Displaying Document Open Time in Windows Explorer .......................... 39
- Specifying a Template for General Tables ............................................... 40
- Synchronizing Settings and Options Across Multiple Machines .......... 40
- Task Scheduler Supports Additional File Formats ................................. 41

6 Assemblies
- Asset Publisher and Magnetic Mates Enhancements ............................. 43
- Changing the Transparency of an Assembly or Multibody Part ............ 44
- Check Entity Enhancements ..................................................................... 44
- Mates ........................................................................................................... 45
  - Perpendicular Mates ........................................................................... 45
  - Temporarily Hiding Faces When Selecting Mates ............................... 45
- Misaligned Mates ..................................................................................... 46
  - Allowing Misaligned Concentric Mates .............................................. 46
  - Assemblies System Option for Misaligned Mates .............................. 47
- Document Properties - Mates .................................................................. 47
- Motion Study Menu Enhancements ......................................................... 48
- Pattern Enhancements ............................................................................ 48
  - Including Material and Visual Properties in a Mirrored Part ............. 48
  - Linear Pattern Enhancements .............................................................. 49
- Performance Evaluation Enhancements ............................................... 51
  - Assembly Open Progress Indicator ............................................... 51
  - Assembly Visualization Enhancements ............................................ 52
  - Performance Evaluation Tool Enhancements .................................. 52
- Smart Explode Lines ............................................................................. 54
  - Creating and Dissolving Smart Explode Lines ................................. 54
  - Smart Explode Lines PropertyManager ............................................. 56
- SpeedPak ................................................................................................. 58
  - Setting a Rebuild on Save Mark on SpeedPak Configurations .......... 58
  - Updating SpeedPak Configurations Automatically ......................... 58
- Treehouse Enhancements ...................................................................... 59
  - Display Files in a List View ................................................................. 59
  - Hiding Suppressed Documents ............................................................ 60
  - Print Options ......................................................................................... 61
  - User Interface ...................................................................................... 61

7 SOLIDWORKS CAM
- Documentation .......................................................................................... 62
- Rebranding ............................................................................................... 62
- Setting Subroutines for Parts ................................................................. 62
- Setting the Toolpath Output Folder ....................................................... 63
- Technology Database ............................................................................ 64
- User Interface Improvements ............................................................... 64
8 CircuitWorks ................................................................. 65
Ability to Recognize SOLIDWORKS Features in CircuitWorks .............................................. 65
Editing Hole Features in the CircuitWorks Export Wizard .................................................. 65
Exporting SOLIDWORKS Features Using the CircuitWorks Export Wizard ....................... 66
Building Model as a Part in CircuitWorks ........................................................................... 67
Usability Improvements ........................................................................................................ 68
Controlling CircuitWorks User Options from an Administrator Location Using Windows User
Permissions ........................................................................................................................ 68
Editing Reference Designators of Multiple Components .................................................... 68
Setting Up Administrator Rights .......................................................................................... 69

9 SOLIDWORKS Composer .................................................. 70
SOLIDWORKS Composer ........................................................................................................ 70
Label Orientation and Label Position for Measurements .................................................... 70
Padding for Measurements .................................................................................................. 70
Support of Favorite Context ............................................................................................... 70
Support of Pro/E Creo 3.0 ..................................................................................................... 71
Write Outlines ..................................................................................................................... 71
SOLIDWORKS Composer Sync ........................................................................................... 71
Support of Favorite Context ............................................................................................... 71
Support of Pro/E Creo 3.0 ..................................................................................................... 71
Write Outlines ..................................................................................................................... 71
SOLIDWORKS Composer Player .......................................................................................... 72
Label Orientation and Label Position for Measurements .................................................... 72
Padding for Measurements .................................................................................................. 72

10 SOLIDWORKS Costing .................................................... 73
Calculating the Cost of Custom Operations for Selected Materials ..................................... 73
Costing Template Enhancements ......................................................................................... 74
Limited-Access Multibody and Assembly Templates .......................................................... 74
Machining and Sheet Metal Template Enhancements ......................................................... 75
Evaluating the Cost of Assembly Operations ....................................................................... 75
Organizing and Saving Costing Data Locally ......................................................................... 76

11 DimXpert ............................................................................ 78
3D PMI Compare for DimXpert Annotations Is Enhanced .................................................. 78
Automatic Generation of DimXpert Annotations for Fastener Assemblies ......................... 78
Customizable General Tolerances for DimXpert ............................................................... 80
Customizing the General Tolerance File ............................................................................ 81
Using a Customized General Tolerance File ....................................................................... 82
Inserting a General Tolerance Table .................................................................................. 83
Displaying Component-level DimXpert Annotations in Assemblies .................................... 83
## Contents

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>General Profile Tolerance</td>
<td>84</td>
</tr>
<tr>
<td>Inserting a General Profile Tolerance in a Note</td>
<td>84</td>
</tr>
<tr>
<td>Editing a Geometric Profile Tolerance</td>
<td>85</td>
</tr>
<tr>
<td>Patterned Datums</td>
<td>85</td>
</tr>
<tr>
<td><strong>12 Detailing and Drawings</strong></td>
<td>89</td>
</tr>
<tr>
<td>Annotations</td>
<td>89</td>
</tr>
<tr>
<td>Auto Hatching in Section Views</td>
<td>89</td>
</tr>
<tr>
<td>Custom Property Improvement</td>
<td>89</td>
</tr>
<tr>
<td>Movable Datum Target</td>
<td>89</td>
</tr>
<tr>
<td>New Draft Symbols</td>
<td>92</td>
</tr>
<tr>
<td>New Geometric Tolerance Options</td>
<td>92</td>
</tr>
<tr>
<td>Dimensions</td>
<td>93</td>
</tr>
<tr>
<td>Hole Callouts Supported in Advanced Hole Tool</td>
<td>93</td>
</tr>
<tr>
<td>Trailing Zeroes</td>
<td>94</td>
</tr>
<tr>
<td>Drawing Views</td>
<td>97</td>
</tr>
<tr>
<td>Applying Layers and Colors to Hatches</td>
<td>97</td>
</tr>
<tr>
<td>Blocks in Break Views</td>
<td>98</td>
</tr>
<tr>
<td>Broken-Out Section Views</td>
<td>98</td>
</tr>
<tr>
<td>Inserting a 3D View in a Drawing</td>
<td>100</td>
</tr>
<tr>
<td>Output</td>
<td>101</td>
</tr>
<tr>
<td>Bookmarks in PDF Output</td>
<td>101</td>
</tr>
<tr>
<td>Tables</td>
<td>101</td>
</tr>
<tr>
<td>All Uppercase Characters</td>
<td>101</td>
</tr>
<tr>
<td>Revision Table Driven By SOLIDWORKS PDM</td>
<td>101</td>
</tr>
<tr>
<td><strong>13 eDrawings</strong></td>
<td>102</td>
</tr>
<tr>
<td>3D Views</td>
<td>102</td>
</tr>
<tr>
<td>Decals in eDrawings Files</td>
<td>102</td>
</tr>
<tr>
<td>Setting Options and Passwords for eDrawings Files</td>
<td>102</td>
</tr>
<tr>
<td>STEP Files in eDrawings Files</td>
<td>103</td>
</tr>
<tr>
<td>Attaching STEP Files to eDrawings Files</td>
<td>103</td>
</tr>
<tr>
<td>Opening STEP Files in eDrawings</td>
<td>103</td>
</tr>
<tr>
<td>User Interface Enhancements</td>
<td>105</td>
</tr>
<tr>
<td>Zooming In and Out</td>
<td>106</td>
</tr>
<tr>
<td><strong>14 SOLIDWORKS Electrical</strong></td>
<td>107</td>
</tr>
<tr>
<td>Connection Point Display</td>
<td>107</td>
</tr>
<tr>
<td>Global Project Drawing Styles</td>
<td>107</td>
</tr>
<tr>
<td>Global Wire Mark Display</td>
<td>108</td>
</tr>
<tr>
<td>Multilevel Terminals</td>
<td>108</td>
</tr>
<tr>
<td>Natural Sort Option for Marks</td>
<td>108</td>
</tr>
<tr>
<td>Other Enhancements for SOLIDWORKS Electrical</td>
<td>109</td>
</tr>
<tr>
<td>Project Level Attribute Styles</td>
<td>109</td>
</tr>
<tr>
<td>SOLIDWORKS Electrical and SOLIDWORKS Routing Integration</td>
<td>110</td>
</tr>
<tr>
<td>Symbol Editor</td>
<td>110</td>
</tr>
</tbody>
</table>
Contents

Terminal Strips ..........................................................................................................................110
Unused Wires ............................................................................................................................111
User Data for Manufacturer Parts ...............................................................................................111
Wire Numbering Group ...............................................................................................................111

15 SOLIDWORKS Flow Simulation ...........................................................................................112
Color Bar ....................................................................................................................................112
Component Explorer ...................................................................................................................113
Free Surface ...............................................................................................................................113
Full Template ..............................................................................................................................113
Noise Prediction .........................................................................................................................113
Plot Callouts ...............................................................................................................................113
Sector Periodicity .......................................................................................................................114

16 SOLIDWORKS 3D Interconnect ............................................................................................115
Additional File Formats Supported ............................................................................................115
JT Files ..................................................................................................................................115
STEP, IGES, and ACIS Files ................................................................................................115
Additional Information Supported for Reading from Third-Party Native CAD Files .................116
Assembly Cut Features .........................................................................................................116
Custom Properties .................................................................................................................116
Material Properties ................................................................................................................117
Unconsumed Sketches and Curves ......................................................................................117

17 SOLIDWORKS Inspection .................................................................................................118
SOLIDWORKS Inspection Add-in ..............................................................................................118
SOLIDWORKS Part and Assembly Support .........................................................................118
SOLIDWORKS Inspection Standalone ....................................................................................120
2D File Support ......................................................................................................................120
3D File Support ......................................................................................................................121
Balloon Sequences ...............................................................................................................121
CMM Data Management Import ............................................................................................122
Create and Place Sub-Balloons ............................................................................................122
Customizable Balloon Numbering .........................................................................................123
Customizable Tolerance Type ...............................................................................................123
Explode Note .........................................................................................................................124
Export to CAMS XML and Verisurf ......................................................................................124
Export to QualityXpert Improvements ...................................................................................124
ExtractionXpert ......................................................................................................................124
Full Specification ...................................................................................................................124
Ignore Basic Dimensions .......................................................................................................125
Improved Optical Character Recognition .............................................................................125
Improved User Interface ........................................................................................................125
Merge Characteristics ...........................................................................................................125
Net-Inspect Options .............................................................................................................126
Contents

Predefining Balloon Appearances ................................................................. 126
Publish Reports with Document Snapshots .............................................. 126
Revision Management ............................................................................... 127
Sampling ...................................................................................................... 127
Smart Extract .............................................................................................. 127
Undo and Redo ......................................................................................... 128

18 SOLIDWORKS MBD ............................................................................ 129
3D PDF Templates ..................................................................................... 129
3D PMI Compare Versions ........................................................................ 131
3D Views Slideshow .................................................................................. 132
Bill of Materials ......................................................................................... 132
Configuration-specific Properties in 3D PDF .......................................... 133
  Inserting Configuration-specific Properties in a Text Field ...................... 133
  Inserting Configuration-specific Properties in a Table ............................... 133
Import PMI ............................................................................................... 133
Insert a Note in a 3D PDF Field .............................................................. 133
MBD Templates ......................................................................................... 134

19 Model Display ..................................................................................... 135
Offloaded Rendering ................................................................................ 135
  Using Single Offloaded Rendering .......................................................... 135
  Using Scheduled Offloaded Rendering .................................................. 136

20 Parts and Features .............................................................................. 137
Advanced Hole ........................................................................................ 137
  Customizing Advanced Hole Callouts ..................................................... 137
  Defining Hole Elements with Baseline Dimensions ............................... 139
Block Editing of Linked Custom Properties in Derived Parts .................. 139
Cosmetic Threads Improvements ............................................................ 139
Creating a Bounding Box .......................................................................... 139
Defeature Tool Improvements ................................................................ 141
Extracting Geometry from a Corrupted Solid Body ................................... 141
Feature Freeze Bar Works with All Folders ............................................. 141
Hole Wizard Options to Match Size or Preserve Settings ....................... 142
Mesh BREP Bodies .................................................................................... 143
  Workflows for Working with Mesh BREP Bodies .................................... 145
  Options for Importing Mesh Files ......................................................... 146
Converting Solid, Surface or Graphics Bodies to Mesh ............................ 147
Selection Filters for Mesh Bodies ............................................................. 148
Creating a Surface From Mesh Feature .................................................. 149
Selecting Facets Using Paint Select ......................................................... 153
List of Features Supporting Mesh BREP Bodies ....................................... 153
Enhancements to Importing Mesh Files as Graphics Bodies .................... 156
### Contents

- Setting Dynamic Variable Values in Copy Tree ................................................................. 190
- SOLIDWORKS PDM Application Programming Interface .............................................. 191
- SOLIDWORKS PDM Support for Non-SOLIDWORKS CAD File References .................... 192

#### 24 SOLIDWORKS Plastics .......................................................................................... 193
- Clamp Force in Machine Opening Direction .................................................................... 193
- Density Result at End of PACK Analysis .......................................................................... 193
- Exclude Area from Clamp Force Calculation .................................................................... 194
- Export Deformed Geometry .............................................................................................. 194
- Mesh Enhancements .......................................................................................................... 194
- Shrinkage Percentage in Warp Measure ........................................................................... 195
- Temperature Criteria for Short Shots ................................................................................ 196

#### 25 Routing ................................................................................................................. 197
- Flattening Enhancements ................................................................................................. 197
- General Routing Enhancements ....................................................................................... 198
- Routing Library Manager Enhancements ......................................................................... 198
  - General Routing Library Manager Enhancements ......................................................... 198
  - SOLIDWORKS Electrical and Routing User Interface Integration ............................... 199

#### 26 Sheet Metal ............................................................................................................ 200
- Creating Normal Cuts ....................................................................................................... 200
- Tab and Slot ...................................................................................................................... 201
  - Creating a Tab and Slot ................................................................................................. 202
- Three Bend Corner Reliefs ............................................................................................... 204
  - Corner Relief Display .................................................................................................... 204
  - Creating Suitcase Corner Reliefs .................................................................................. 205

#### 27 SOLIDWORKS Simulation ....................................................................................... 207
- Topology Study ................................................................................................................. 207
  - Material Mass Plot ....................................................................................................... 209
  - Topology Optimization of a Plate .................................................................................. 210
- Allow for Dismissal of Warning Messages ....................................................................... 214
- Create a Results Plot from Imported Data ....................................................................... 214
- Displacement Control for Nonlinear Contact ................................................................. 215
- Email Notification for Completed Analyses ...................................................................... 215
- Factor of Safety Plot for Nonlinear Static Studies ............................................................ 215
- Import Simulation Study Features into Assemblies ............................................................ 215
- Improved Pin Connector ................................................................................................. 216
- Mesh Refinement for Stress Singularities ........................................................................ 216
1 Sensor for Simulation Mass Properties .................................................................217

28 Sketching ..............................................................................................................218
  Controlling the Tangency Direction .......................................................................218
  Creating Mirrored Entities in 3D Sketch .................................................................219
  Enabling and Disabling Automatic Solve and Undo for Sketches .............................219
  Fixing the Rotation of Sketch Pattern Instances .......................................................220
  Instance Limit Removed for Circular Sketch Patterns .............................................220
  Mirroring Entities Using Reference Planes and Planar Faces ...................................221
  Pen, Touch, and Gesture-based Sketching ...................................................................221
  Smart Dimension on the Context Toolbar .................................................................221
    Controlling Dimensions with the Context Toolbar .................................................222

29 SOLIDWORKS Toolbox ......................................................................................223
  Descriptions and Comments No Longer Disappear ...............................................223
  Hexalobular Hardware .............................................................................................223
  Importing and Exporting Hole Wizard Data .............................................................224
  Selecting PEM Inserts ...............................................................................................224
  Toolbox User Interface and Workflow ........................................................................225

30 SOLIDWORKS Utilities .......................................................................................226
  SOLIDWORKS Design Checker Misaligned Mates .................................................226

31 SOLIDWORKS Visualize .....................................................................................227
  3DConnexion Spacemouse Support .........................................................................227
  Area Light Enhancements .........................................................................................229
  Cloud Library Enhancements ....................................................................................229
  Decal Improvements ................................................................................................229
  Help Menu Improvements .......................................................................................231
  Import all SOLIDWORKS Cameras, Custom Views, and Lights ..............................231
  Interactivity Performance Improvements ...............................................................233
  Remove Camera Post-Processing from Backplates .................................................235
  Stereoscopic and 360° Cameras for Virtual Reality ..................................................235
    Application Examples .............................................................................................236
    360 Lens ..................................................................................................................236
    Stereoscopy .............................................................................................................237
  Updated User Interface .............................................................................................238

32 Weldments ............................................................................................................242
  Customizing Description for Bounding Box Properties ............................................242
  Linking a Cut List Folder to a Cut List Property ......................................................242
The Software is a “commercial item” as that term is defined at 48 C.F.R. 2.101 (OCT 1995), consisting of “commercial computer software” and “commercial software documentation” as such terms are used in 48 C.F.R. 12.212 (SEPT 1995) and is provided to the U.S. Government (a) for acquisition by or on behalf of civilian agencies, consistent with the policy set forth in 48 C.F.R. 12.212; or (b) for acquisition by or on behalf of units of the Department of Defense, consistent with the policies set forth in 48 C.F.R. 227.7202-1 (JUN 1995) and 227.7202-4 (JUN 1995).

In the event that you receive a request from any agency of the U.S. Government to provide Software with rights beyond those set forth above, you will notify DS SolidWorks of the scope of the request and DS SolidWorks will have five (5) business days to, in its sole discretion, accept or reject such request. Contractor/Manufacturer: Dassault Systemes SolidWorks Corporation, 175 Wyman Street, Waltham, Massachusetts 02451 USA.

Copyright Notices for SOLIDWORKS Standard, Premium, Professional, and Education Products

Portions of this software © 1986-2017 Siemens Product Lifecycle Management Software Inc. All rights reserved.

This work contains the following software owned by Siemens Industry Software Limited:

D-Cubed® 2D DCM © 2017. Siemens Industry Software Limited. All Rights Reserved.


Portions of this software © 1998-2016 HCL Technologies Ltd.

Portions of this software incorporate PhysX™ by NVIDIA 2006-2010.

Portions of this software © 2001-2017 Luxology, LLC. All rights reserved, patents pending.

Portions of this software © 2007-2016 DriveWorks Ltd.

© 2011, Microsoft Corporation. All rights reserved.

Includes Adobe® PDF Library technology

Copyright 1984-2016 Adobe Systems Inc. and its licensors. All rights reserved. Protected by U.S. Patents 5,929,866; 5,943,063; 6,289,364; 6,563,502; 6,639,593; 6,754,382; Patents Pending.

Adobe, the Adobe logo, Acrobat, the Adobe PDF logo, Distiller and Reader are registered trademarks or trademarks of Adobe Systems Inc. in the U.S. and other countries.

For more DS SolidWorks copyright information, see Help > About SOLIDWORKS.

Copyright Notices for SOLIDWORKS Simulation Products

Portions of this software © 2008 Solversoft Corporation.

PCGLSS © 1992-2017 Computational Applications and System Integration, Inc. All rights reserved.
Copyright Notices for SOLIDWORKS PDM Professional Product

Outside In® Viewer Technology, © 1992-2012 Oracle
© 2011, Microsoft Corporation. All rights reserved.

Copyright Notices for eDrawings Products

Portions of this software © 2000-2014 Tech Soft 3D.
Portions of this software © 1995-1998 Jean-Loup Gailly and Mark Adler.
Portions of this software © 1998-2001 3Dconnexion.
Portions of this software © 1998-2014 Open Design Alliance. All rights reserved.
Portions of this software © 1995-2012 Spatial Corporation.
The eDrawings® for Windows® software is based in part on the work of the Independent JPEG Group.

Copyright Notices for SOLIDWORKS PCB Products

Portions of this software © 2017 Altium Limited.
Welcome to SOLIDWORKS 2018

This chapter includes the following topics:

- Top Enhancements
- For More Information

Image courtesy of S.C. ASTRA RAIL Industries S.R.L.

SOLIDWORKS® 2018 delivers many enhancements and improvements, most created in direct response to customer requests.

This release provides four new end-to-end process solutions that simplify the interactions between disciplines across product development to improve your business outcomes. Accelerate innovation and grow your business with the following new processes:

- Design to Manufacturing Process. A complete solution to bring your ideas to market.
- Distributed Data Management Process. The right data, at the right time, for the right people.
- Designer to Analyst Process. Analysis tools for every step of the design process.
- Electrical Design and Internet of Things (IOT) Process. Connect your smart devices to your customers.

Top Enhancements

The top enhancements for SOLIDWORKS 2018 provide improvements to existing products and innovative new functionality.

Throughout this guide, look for the symbol in these areas:
Welcome to SOLIDWORKS 2018

User Interface
- Mouse Gestures Enhancements on page 21
- Touch-based Interactions on page 24
- Welcome Dialog Box on page 26

SOLIDWORKS 3D Interconnect
- Additional File Formats Supported on page 115
- Additional Information Supported for Reading from Third-Party Native CAD Files on page 116
- STEP, IGES, and ACIS Files on page 115

Model Display
- Offloaded Rendering on page 135

Parts and Features
- Creating a Bounding Box on page 139
- Extracting Geometry from a Corrupted Solid Body on page 141

Sheet Metal
- Creating Normal Cuts on page 200
- Tab and Slot on page 201
- Three Bend Corner Reliefs on page 204

Sketching
- Creating Mirrored Entities in 3D Sketch on page 219
- Pen, Touch, and Gesture-based Sketching on page 221

SOLIDWORKS PDM
- Automated Drawing PDF Creation in SOLIDWORKS PDM Standard on page 165
- Data Card Editor Undo on page 167
- Design Branching and Merging on page 167
- Detailed Warning Messages on page 183
- Revision Table Integration on page 187
- SOLIDWORKS PDM Support for Non-SOLIDWORKS CAD File References on page 192

SOLIDWORKS Simulation
- Mesh Refinement for Stress Singularities on page 216
- Displacement Control for Nonlinear Contact on page 215
- Email Notification for Completed Analyses on page 215
- Factor of Safety Plot for Nonlinear Static Studies on page 215
- Topology Study on page 207
- Improved Pin Connector on page 216
- Import Simulation Study Features into Assemblies on page 215
- Sensor for Simulation Mass Properties on page 217

Weldments
- Customizing Description for Bounding Box Properties on page 242
- Linking a Cut List Folder to a Cut List Property on page 242
More Control Over Custom Properties on page 156

All features are available in SOLIDWORKS Standard, SOLIDWORKS Professional, and SOLIDWORKS Premium unless otherwise noted.

For More Information

Use the following resources to learn about SOLIDWORKS:

**What's New in PDF and HTML**
This guide is available in PDF and HTML formats. Click:
- Help > What's New > PDF
- Help > What's New > HTML

**Interactive What's New**
In SOLIDWORKS, click the symbol to display the section of this manual that describes an enhancement. The symbol appears next to new menu items and the titles of new and changed PropertyManagers.

To enable Interactive What's New, click Help > What's New > Interactive.

**What's New Examples**
What's New Examples are updated at every major release to provide examples of how to use most top enhancements in the release.

To open What's New Examples click Help > What's New > What's New Examples.

**Sample files**
To open sample files for this book, go to
system_dir:
- Users\Public\Public Documents\SOLIDWORKS\SOLIDWORKS 2018\samples\whatsnew\chapter_name\file_name.

For example, C:\Users\Public\Public Documents\SOLIDWORKS\SOLIDWORKS 2018\samples\whatsnew\sketching\Block.sldprt.

**Online Help**
Contains complete coverage of our products, including details about the user interface, samples, and examples.

**Release Notes**
Provides information about late changes to our products, including changes to the What's New book, online help, and other documentation.
2
User Interface

This chapter includes the following topics:

- Auto-Rotate View on Sketch Edit
- Folder Icons in the FeatureManager Design Tree
- Logging into SOLIDWORKS
- Measure Tool Enhancements
- Mouse Gestures Enhancements
- Scaling of Entities on High-resolution Monitors
- Show File Names and Descriptions in Design Library
- Task Pane Changes
- Touch-based Interactions
- Welcome Dialog Box

Auto-Rotate View on Sketch Edit

The system option, **Auto-rotate view normal to sketch plane on sketch creation**, has been renamed. It is now available when you edit an existing sketch, as well as when you create a new one.

In **Options > System Options > Sketch**, the option is renamed.

<table>
<thead>
<tr>
<th>New Name</th>
<th>Auto-rotate view normal to sketch plane on sketch creation and sketch edit</th>
</tr>
</thead>
<tbody>
<tr>
<td>Previous Name</td>
<td>Auto-rotate view normal to sketch plane on sketch creation</td>
</tr>
</tbody>
</table>

The view rotation behavior is now consistent, regardless of how you open the sketch. If the option is selected, the following behavior occurs:

- When you open a new or existing sketch, the view rotates to be normal to the sketch plane.
- When you exit a sketch:
  - If you keep your changes, the view remains normal to the sketch plane. For example, click in the Confirmation Corner or **Insert > Exit Sketch**.
• If you discard your changes, the view reverts to the orientation it was before you opened the sketch. For example, click ✗ in Confirmation Corner or Edit > Exit Sketch without Saving Changes.

Folder Icons in the FeatureManager Design Tree

The folder icons in the FeatureManager design tree indicate the state of items in the folders.

Assemblies

In assemblies, the icons indicate if the folder contains shown, hidden, or suppressed items, or various combinations.

<table>
<thead>
<tr>
<th>Icon</th>
<th>Shown</th>
<th>Hidden</th>
<th>Suppressed</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image1" alt="Folder Icon" /></td>
<td><img src="image2" alt="X" /></td>
<td></td>
<td></td>
</tr>
<tr>
<td><img src="image3" alt="Folder Icon" /></td>
<td></td>
<td><img src="image2" alt="X" /></td>
<td></td>
</tr>
<tr>
<td><img src="image4" alt="Folder Icon" /></td>
<td></td>
<td></td>
<td><img src="image2" alt="X" /></td>
</tr>
<tr>
<td><img src="image5" alt="Folder Icon" /></td>
<td><img src="image2" alt="X" /></td>
<td></td>
<td></td>
</tr>
<tr>
<td><img src="image6" alt="Folder Icon" /></td>
<td><img src="image2" alt="X" /></td>
<td><img src="image2" alt="X" /></td>
<td></td>
</tr>
<tr>
<td><img src="image7" alt="Folder Icon" /></td>
<td></td>
<td><img src="image2" alt="X" /></td>
<td><img src="image2" alt="X" /></td>
</tr>
<tr>
<td><img src="image8" alt="Folder Icon" /></td>
<td><img src="image2" alt="X" /></td>
<td><img src="image2" alt="X" /></td>
<td><img src="image2" alt="X" /></td>
</tr>
</tbody>
</table>

Parts

In parts, the icons indicate if the folder contains unsuppressed or suppressed items, or both.

<table>
<thead>
<tr>
<th>Icon</th>
<th>Unsuppressed</th>
<th>Suppressed</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image9" alt="Folder Icon" /></td>
<td><img src="image2" alt="X" /></td>
<td></td>
</tr>
<tr>
<td><img src="image10" alt="Folder Icon" /></td>
<td></td>
<td><img src="image2" alt="X" /></td>
</tr>
<tr>
<td><img src="image11" alt="Folder Icon" /></td>
<td><img src="image2" alt="X" /></td>
<td><img src="image2" alt="X" /></td>
</tr>
</tbody>
</table>
Logging into SOLIDWORKS

SOLIDWORKS provides a login feature. You use the same SOLIDWORKS ID to access the Customer Portal, MySolidWorks, and the SOLIDWORKS Forums.

You can use the Login dialog box, but you can continue to start SOLIDWORKS as you currently do.

Benefits to logging in with the SOLIDWORKS ID are:

- Hyperlinks to web content within the SOLIDWORKS software will automatically log you into SOLIDWORKS websites, such as:
  - MySolidWorks
  - SOLIDWORKS Forum
  - Customer Portal
  - Get Support

- You can synchronize your system settings automatically across multiple computers while logged in. To synchronize settings, click Tools > Options > Synchronize Settings.

  When you log in, customization and system options (excluding file locations) are synchronized by default.

  You can synchronize the following settings:
  - File locations listed in Tools > Options and Toolbox/Hole Wizard.
  - Customizations including toolbar layouts, menu customizations, mouse gestures, and keyboard shortcuts.

To log into the SOLIDWORKS software:

1. In the SOLIDWORKS title bar, click the Login icon.
2. In Email, enter your SOLIDWORKS ID.

   The SOLIDWORKS ID can be your email address.

3. In Password, enter your password.
4. Click Log in.

   The Login icon changes color to indicate that you are logged in.

You remain logged in until you click the Login icon and click Log Out. Closing SOLIDWORKS does not log you out.
Measure Tool Enhancements

The **Measure** tool supports the following additional features:

- **Input box.** The input box that lists selections now includes six items.

  ![Input Box Comparison](image)

  **SOLIDWORKS 2017**
  
  **SOLIDWORKS 2018**

- **Quick Copy.** When you hover over a numeric value, the numeric value gets highlighted in the dialog box and **Copy** is displayed. Click to copy the value to the clipboard. You can paste the value at the required location.

  ![Quick Copy Example](image)

- **Font Size.** You can adjust the font size of the text in the Measure dialog box. Click to increase the font size. Click to decrease the font size.

  You cannot decrease the font size below the default size.
• Pin. Click ⬇️ to pin the Measure dialog box to the graphics area. Click ✎ to close the dialog box.

Click ⬆️ to unpin the Measure dialog box. Press Esc to close the dialog box only if the dialog box is unpinned.

Mouse Gestures Enhancements

Mouse gestures are easier to customize.

You can set the number of mouse gestures to 2, 3, 4, 8, or 12 gestures. If you set the number to 2 gestures, you can orient them vertically or horizontally.

To set the number of mouse gestures, click Tools > Customize > Mouse Gestures. From the drop-down list, select the desired number of mouse gestures.

You can also customize the mouse gesture assignments through a visual drag-and-drop user interface. Drag tools from the list of commands to any of the mouse gestures guides. If you drag a tool to an empty position, the tool is added to the gesture guide. If you drag a tool to an occupied position, it replaces the tool on the gesture guide. If you Ctrl + drag a tool from one gesture guide position to another, it is copied to the second position. You can copy a tool within one gesture guide, as well as across gesture guides.

Icons are added for the following tools:

<table>
<thead>
<tr>
<th>Icon</th>
<th>Tool</th>
</tr>
</thead>
<tbody>
<tr>
<td>📌</td>
<td>Shortcut Bar</td>
</tr>
<tr>
<td>⚪</td>
<td>Escape</td>
</tr>
<tr>
<td>📔</td>
<td>Expand/ Collapse Tree</td>
</tr>
<tr>
<td>👤</td>
<td>Collapse all Items</td>
</tr>
<tr>
<td>☑️</td>
<td>Exit Sketch without Saving Changes</td>
</tr>
<tr>
<td>⏯️</td>
<td>Repeat Last Command</td>
</tr>
<tr>
<td>📖</td>
<td>Browse Open Documents</td>
</tr>
<tr>
<td>📚</td>
<td>Browse Recent Folders</td>
</tr>
<tr>
<td>🖼️</td>
<td>Browse Recent Documents</td>
</tr>
<tr>
<td>📦</td>
<td>Pack and Go</td>
</tr>
</tbody>
</table>
The following options have changed:

- The four columns showing mouse gesture assignments for Part, Assembly, Drawing, and Sketch are removed. They are replaced by the Mouse Gesture Guide window.
- Show only commands with mouse gestures assigned are removed.
- Print List is changed to Print Gesture Guides.

### Scaling of Entities on High-resolution Monitors

Entities such as 3D arrows and sketch relations scale well on high-resolution monitors. These entities scale properly according to the screen size, resolution, and display setting. Improved scaling increases the visibility of these entities and makes it easier to work on high-resolution monitors.

Enhancements include:

- The bitmap size increases based on the display scaling.
- The size of the entities in the graphics area increases proportionately according to the scaling factor.
- Scaling of selection changes based on the resolution or DPI setting of the screen.
- 3D arrows in the graphic area scale well on high-resolution monitors. You can easily grab and drag them on a touch screen using your fingers or stylus.

### Show File Names and Descriptions in Design Library

You can display file names or descriptions of reusable elements (such as features, sketches, parts, or assemblies) in the lower panel of the Design Library.

To show file names and descriptions:

- Right-click in the lower panel of the Design Library, and click Show File Name or Show Description.

Previously, commands in this shortcut menu were limited to displaying Large Icons, Small Icons, or Adding New Folders.
### Task Pane Changes

Some items from the Task Pane have been moved to the new Welcome dialog box.

The following sections have been removed from the SOLIDWORKS Resources tab in the Task Pane:

- Getting Started
- Community
- Tip of the Day

The following table summarizes the moved items, their new names (if changed), and their new locations within the Welcome dialog box.

<table>
<thead>
<tr>
<th>Removed Task Pane Item</th>
<th>New Name (if changed)</th>
<th>New Location (Tab in Welcome dialog box)</th>
</tr>
</thead>
<tbody>
<tr>
<td>New Document</td>
<td>New</td>
<td>Home</td>
</tr>
<tr>
<td>Open a Document</td>
<td>Open</td>
<td>Home</td>
</tr>
<tr>
<td>Tutorials</td>
<td></td>
<td>Learn</td>
</tr>
<tr>
<td>Online Training</td>
<td>MySolidWorks Training</td>
<td>Learn</td>
</tr>
<tr>
<td>What's New</td>
<td></td>
<td>Home</td>
</tr>
<tr>
<td>Introducing SOLIDWORKS</td>
<td></td>
<td>Learn</td>
</tr>
<tr>
<td>General Information</td>
<td>Get Support</td>
<td>Home</td>
</tr>
<tr>
<td>Customer Portal</td>
<td></td>
<td>Home</td>
</tr>
<tr>
<td>User Groups</td>
<td></td>
<td>Home</td>
</tr>
<tr>
<td>Discussion Forum</td>
<td>SOLIDWORKS Forum</td>
<td>Home</td>
</tr>
<tr>
<td>Technical Alerts and News</td>
<td>Technical Alerts</td>
<td>Alerts</td>
</tr>
<tr>
<td>Tip of the Day</td>
<td></td>
<td>Home</td>
</tr>
</tbody>
</table>

#### To access the items in their new location:

In the Task Pane, at the top of the SOLIDWORKS Resources tab, click **Welcome to SOLIDWORKS** 🏡.

For more information, see **Welcome Dialog Box** on page 26.
Touch-based Interactions ✪

Touch-based interactions are easier and more intuitive.

Custom Numeric Keypad

Touch gestures improve the user experience. The custom numeric keypad for a touch-enabled device makes it faster and easier to input values. The keypad is proportionate to the tool to maximize the visible area.

Previously you used the default operating system keypad that covered a large portion of the screen.

You can turn on touch mode by clicking View > Touch Mode. When you touch the numeric input field with your finger or stylus, the custom numeric keypad appears.

The numeric keypad has the following features:

• The keypad gives you more screen space to view and proofread your work.
• You can trigger the numeric keypad for all numeric input fields with spinner controls.
• When you click the More Options button, it shows all the parameters associated with the field. For example, the Equation input fields have the following parameters:
  • Global Variables
  • Functions
  • File Properties
  • Units
• Tapping anywhere outside the numeric keypad dismisses the keypad and accepts the new value.

From the taskbar, you can turn on the built-in keypad to enter non-numeric values.

Magnified Selection

The Magnified Selection tool is available in touch devices.

If you press the screen for two seconds or more, then drag your finger, the Magnified Selection magnifying glass appears. If you press the screen for less than two seconds, then drag your finger, the mouse gesture guide appears.
Touch Mode

Touch mode makes the user interface easier to interact with when you use a touch-enabled device. It optimizes the size of on-screen manipulators, context toolbars, breadcrumbs, and selection.

To turn on touch mode, click **View > Touch Mode 📌**.

Touch mode is optimized for left- or right-handed users based on your Windows settings. When you turn on touch mode, a toolbar of commonly used tools appears on the left or right side of the SOLIDWORKS window, including:

<table>
<thead>
<tr>
<th>Icon</th>
<th>Tool</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>🔧 <strong>Escape</strong></td>
<td>Exits the current mode or selection.</td>
<td></td>
</tr>
<tr>
<td>🔧 <strong>Shortcut</strong> (S) <strong>Key</strong></td>
<td>Opens the shortcut bar.</td>
<td></td>
</tr>
</tbody>
</table>
| 🔧 **Multi-select** | Lets you:  
• Select more than one item at a time. It is equivalent to **Ctrl +** select with a mouse.  
• Drag your finger to box select or lasso entities. |
| ❌ **Delete** | Deletes the selected item. |
| 🔧 **Zoom Up** and **Zoom Down** | Changes the zoom scale for the magnifying glass. |
| 🔧 **Lock 3D Rotate** | (Sketch mode only) Locks the ability to rotate the model so you do not accidentally rotate the model while sketching. |
Welcome Dialog Box

When you open the SOLIDWORKS software, the Welcome dialog box provides a convenient means to open documents, view folders, access SOLIDWORKS resources, and stay updated on SOLIDWORKS news.

You can also click **Welcome to SOLIDWORKS** (Standard toolbar), **Help > Welcome to SOLIDWORKS**, or **Welcome to SOLIDWORKS** on the SOLIDWORKS Resources tab in the Task Pane to open the Welcome dialog box.

The Welcome dialog box has tabs for: Home, Recent, Learn, and Alerts.

Some of the content from the Task Pane has moved to the Welcome dialog box to avoid duplication.

Home Tab

The Home tab lets you open new and existing documents, view recent documents and folders, and access SOLIDWORKS resources.

Sections in the Home tab include **New**, **Recent Documents**, **Recent Folders**, and **Resources**.

**New**

The **New** section includes:

<table>
<thead>
<tr>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Part" /></td>
<td>Opens a new document. The document is based on a template from the Default Templates page of the System Options dialog box.</td>
</tr>
<tr>
<td><img src="image" alt="Assembly" /></td>
<td>Opens the New SOLIDWORKS Document dialog box, where you can open a new document based on an alternate template.</td>
</tr>
<tr>
<td><img src="image" alt="Drawing" /></td>
<td></td>
</tr>
<tr>
<td><img src="image" alt="Advanced" /></td>
<td>Opens the Open dialog box, where you can select an existing document to open.</td>
</tr>
</tbody>
</table>

**Recent Documents**

The **Recent Documents** section includes thumbnails of documents that you have opened recently. Click **View all** to open the Recent tab to see a longer list of recent documents.

Functionality in the **Recent Documents** section is identical to previous versions of the SOLIDWORKS software. The Welcome dialog box replaces the Recent Documents window.
Recent Folders

The **Recent Folders** section includes a list of folders from which you have opened documents recently. Click **View all** to open the Recent tab to see a longer list of recent folders.

When you hover over a folder, you can click to keep the folder at the top of the **Recent Folders** list until you unpin it.

To access the **Recent Folders** list after you close the Welcome dialog box, click **File > Open Recent > Browse Recent Folders**.

Resources

The **Resources** section includes links to:

- **What's New**
- **MySolidWorks**
- **SOLIDWORKS Forum**
- **Customer Portal**
- **User Groups**
- **Get Support**

Tip of the Day 🕵️

Shows a new tip each time that you open the Welcome dialog box. Click ⬅️ or ⬆️ to see other tips.

Recent Tab

The Recent tab lets you view a longer list of recent documents and folders.

Sections in the Recent tab include **Documents** and **Folders**.

Documents

The **Documents** section includes thumbnails of documents that you have opened recently.

You can do the following:

- Click a thumbnail to open the document.
- Drag a thumbnail and drop it in the empty graphics area, an open part, assembly, or drawing, or Windows Explorer.
Hover over a thumbnail to see document information such as full path and last saved date, and click ▼ to see more options and information.

Right-click a thumbnail and click **Remove, Pin, or Clear unpinned items.**

Click **Browse** to open the Open dialog box for the current folder.

If the Welcome dialog box is closed, you can open the Recent tab by clicking one of the following:

- **Open > Browse Recent Documents**
- **File > Open Recent > Browse Recent Documents**

### Folders

The **Recent Folders** section includes a list of folders from which you have opened documents recently.

You can do the following:

- Click a folder to open the folder in the Open dialog box.
- Hover over a folder and click ▼ to keep the folder at the top of the list.
- Right-click a folder and click **Remove, Pin, or Clear unpinned items.**
- Click **Browse** to open the Open dialog box for the current folder.

If the Welcome dialog box is closed, you can open the Recent tab by clicking **File > Open Recent > Browse Recent Folders.**

### Learn Tab

The Learn tab lets you access instructional resources to help you learn more about the SOLIDWORKS software.

Sections in the Learn tab include:

<table>
<thead>
<tr>
<th>Section</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Introducing SOLIDWORKS</strong></td>
<td>Opens the <em>Introducing SOLIDWORKS</em> book.</td>
</tr>
<tr>
<td><strong>Tutorials</strong></td>
<td>Opens the step-by-step tutorials in the software.</td>
</tr>
<tr>
<td><strong>MySolidWorks Training</strong></td>
<td>Opens the <strong>Training</strong> section at MySolidWorks.com.</td>
</tr>
<tr>
<td><strong>Samples</strong></td>
<td>Opens local folders containing sample models.</td>
</tr>
<tr>
<td><strong>3DContentCentral</strong></td>
<td>Opens 3DContentCentral.com.</td>
</tr>
<tr>
<td><strong>Online Tutorials</strong></td>
<td>Opens the SOLIDWORKS Tutorials (videos) section at solidworks.com.</td>
</tr>
<tr>
<td><strong>My Training</strong></td>
<td>Opens the <strong>My Training</strong> section at MySolidWorks.com.</td>
</tr>
<tr>
<td><strong>Certification</strong></td>
<td>Opens the SOLIDWORKS Certification Program section at solidworks.com.</td>
</tr>
</tbody>
</table>
Curriculum
Opens the Curriculum section at solidworks.com.

When you install the software, if you do not install the Help Files or Example Files, the Tutorials and Samples links are unavailable.

Alerts Tab

The Alerts tab keeps you updated with SOLIDWORKS news.

Sections in the Alerts tab include Critical, Troubleshooting, and Technical Alerts.

Critical

The Critical section includes important messages that used to appear in a dialog box.

The Critical section appears if there are critical alerts to display. If a critical alert exists, the Welcome dialog box opens to the Critical section automatically on startup, even if you selected Do not show on startup in the dialog box. Alerts are displayed until you select Do not show this message again.

Troubleshooting

The Troubleshooting section includes troubleshooting messages and recovered documents that used to be on the SOLIDWORKS Recovery tab in the Task Pane.

The Troubleshooting section appears if there are crash diagnostic messages or recovered documents to display. If the software has a technical problem and an associated troubleshooting message exists, the Welcome dialog box opens to the Troubleshooting section automatically on startup, even if you selected Do not show on startup in the dialog box.

Technical Alerts

The Technical Alerts section opens the contents of the SOLIDWORKS Support Bulletins RSS feed at solidworks.com.
This chapter includes the following topics:

- Adobe Illustrator Creative Cloud Files
- Application Programming Interface
- Default Templates for New Documents
- Include or Exclude Suppressed Components in Pack and Go
- Rebuild Tools
- Selecting Over Geometry
- Support for 3D Printing Models Containing Surface Bodies and Graphics Bodies

Adobe Illustrator Creative Cloud Files

SOLIDWORKS supports the Adobe Illustrator Creative Cloud platform. You can import Creative Cloud files using the SOLIDWORKS application.

Application Programming Interface

See SOLIDWORKS API Help: Release Notes for late-breaking updates.

SOLIDWORKS 2018 API includes the ability to:

- Access general tolerance table annotations and features.
- Access hidden content in tables.
- Add a distance mate between cylindrical components of an assembly.
- Add and edit pairs of concentric mates (hole sets) between the same two components, allowing for misalignment of concentric mates.
- Add rebuild and save marks to multiple configurations and remove them from all configurations.
- Add specific display dimensions by type.
- Create a spline constrained to a surface.
- Create a trimmed sheet body with a specified tolerance.
- Create advanced assembly mates and sweeps using improved API architecture.
- Create advanced holes in parts.
- Create and upgrade VB.NET and C# macros using Microsoft Visual Studio® Tools for Applications (VSTA) 2015.
- Create bidirectional twist and thin-walled sweep features.
- Create internal and external threads.
• Edit third-party native CAD components in assemblies.
• Expand and collapse indented items in BOMs.
• Get corresponding objects between drawing views and parts or assemblies.
• Get, edit, insert, or delete the below frame text of geometric tolerances.
• Get layer items by type.
• Get or set a custom property builder template for parts or weldments.
• Get or set component display state-specific properties in multiple assembly display states.
• Get or set geometric tolerance leader options, All Over This Side and All Around This Side.
• Get or set the balloon padding for existing notes in drawings.
• Get or set whether a configuration node is expanded in the ConfigurationManager.
• Get or set whether table text is all upper case.
• Get or set whether to automatically rebuild equations.
• Get or set whether to automatically repair files on opening.
• Get or set whether to display configuration names and descriptions in the ConfigurationManager.
• Get or set whether to import DimXpert annotations when inserting or mirroring parts.
• Get or set whether to lock a magnetic mate.
• Get or set whether to show a slit in the corner relief of Flat-Pattern features.
• Get whether a custom property is editable in a configuration.
• Handle pre- and post-notify events when converting bodies.
• Import and export Hole Wizard and Toolbox data.
• Modify control points and interior knots in sketch splines.
• Offload PhotoView 360 rendering to other networked machines.
• Optionally rebuild a model after adding configurations.
• Override default part or assembly templates when creating a Split feature.
• Quickly check whether an interference exists between components.
• Save and restore the current SOLIDWORKS software settings.
• Select exploded views, create a regular explode step with rotation parameters, create a radial explode step, and edit explode steps.
• Set table anchors at selected sketch points on drawing sheets.
• Set whether to expand all configurations in a specified pane of the ConfigurationManager.
• Show the preview of a configuration selected in the ConfigurationManager.

Default Templates for New Documents

The templates specified in System Options > Default Templates are always used when you create new documents directly from the Novice page of the New SOLIDWORKS Document dialog box or from the Welcome dialog box.

Previously, if you created multiple templates, then depending on the template names and folder locations, those templates might have been used instead of those specified in Default Templates. You can still use alternate templates by clicking Advanced in the New SOLIDWORKS Document dialog box or the Welcome dialog box.
Include or Exclude Suppressed Components in Pack and Go

This new option makes it easier for you to package a simplified copy of an assembly for analysis, rendering, or other purposes, and to exclude proprietary components that you do not want to share.

Suppressed components appear in the grid with the [Suppressed] notation. Clear Include suppressed components to remove these from the grid and the target Pack and Go file or folder. The suppressed components will still appear in the FeatureManager of the packaged assembly, but their corresponding files will be excluded.

You can also include or exclude any components suppressed in the active configuration, along with decals, drawings, and simulation results associated with those components.

This option is only available when you launch Pack and Go from the SOLIDWORKS File menu.

Rebuild Tools

The Force Regen and Force Regen the Top Level Assembly tools have been renamed to use the word Rebuild instead of Regen so that all rebuild tools use consistent terminology.

The tools include:

<table>
<thead>
<tr>
<th>Tool</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Rebuild</td>
<td>Rebuilds changed features.</td>
</tr>
<tr>
<td>Rebuild All Configurations</td>
<td>Rebuilds changed features in all configurations.</td>
</tr>
<tr>
<td>Force Rebuild</td>
<td>Rebuilds all features.</td>
</tr>
<tr>
<td>Force Rebuild All Configurations</td>
<td>Rebuilds all features in all configurations.</td>
</tr>
<tr>
<td>Force Rebuild Top Level Assembly</td>
<td>Rebuilds all features in the top level assembly.</td>
</tr>
</tbody>
</table>

Forced rebuilds can take significantly more time, depending on model complexity.

The Force Rebuild toolbar buttons are located on the Standard toolbar. You can add the tools to the CommandManager, shortcut bars, and mouse gestures.

Keyboard shortcuts for Ctrl + Q and Ctrl + Shift + Q remain unchanged. This table shows the various keyboard shortcuts:

<table>
<thead>
<tr>
<th></th>
<th>Part</th>
<th>Assembly</th>
<th>Drawing</th>
<th>Sketch</th>
</tr>
</thead>
<tbody>
<tr>
<td>Rebuild</td>
<td>Ctrl + B</td>
<td>Ctrl + B</td>
<td>Ctrl + B</td>
<td>Ctrl + B</td>
</tr>
<tr>
<td>Part</td>
<td>Assembly</td>
<td>Drawing</td>
<td>Sketch</td>
<td></td>
</tr>
<tr>
<td>----------------------</td>
<td>---------------------------</td>
<td>--------------------------</td>
<td>-------------------------</td>
<td></td>
</tr>
<tr>
<td>Rebuild All</td>
<td>Ctrl + Shift + B</td>
<td>Ctrl + Shift + B</td>
<td>Ctrl + Shift + B</td>
<td></td>
</tr>
<tr>
<td>Configurations</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Force Rebuild</td>
<td>Ctrl + Q</td>
<td>Ctrl + Q</td>
<td>Ctrl + Q</td>
<td></td>
</tr>
<tr>
<td>Force Rebuild</td>
<td>Ctrl + Shift + Q</td>
<td>Ctrl + Shift + Q</td>
<td>Ctrl + Shift + Q</td>
<td></td>
</tr>
<tr>
<td>Top Level</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Assembly</td>
<td>Ctrl + Q</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Selecting Over Geometry

The Select over Geometry tool lets you drag a box or lasso over a model without starting the drag from a blank region of the graphics area.

Select over Geometry is helpful when you cannot start the drag from a blank region. For example, use it when the model fills the graphics area or when unwanted items would be included in the selection.

Without Select over Geometry, if you start the drag on top of geometry, the drag fails and the geometry under your initial click is selected:

To select over geometry:

1. Do one of the following:
   - Click Select over Geometry (Standard toolbar).
   - Click Tools > Select over Geometry.
   - Press and release T.

Select over Geometry is also available in mouse gestures.

Select over Geometry mode is activated.
2. Drag a box or lasso around the items to select.

The geometry is selected:

When Select over Geometry mode is active, you can do the following:

- Drag a box or lasso to clear the current selection and select different items.
- **Shift** + drag a box or lasso to add items to the current selection.
- Perform an operation on the current selection (for example, add fillets to selected edges), and then drag a box or lasso to make another selection.

3. To exit Select over Geometry mode, do one of the following:

- Click anywhere in the graphics area (for example, on a face or edge, or in a blank region).
- Click Select over Geometry (Standard toolbar) or Tools > Select over Geometry.

Support for 3D Printing Models Containing Surface Bodies and Graphics Bodies

SOLIDWORKS supports 3D printing of models that contain surface bodies and graphics bodies only if they form a watertight manifold volume.

Previously, 3D printing of surface and graphics bodies was not supported and you could only 3D print solid bodies. Now, you can 3D print surfaces or graphics bodies provided they form a watertight manifold volume. Bodies that do not form a watertight manifold volume are temporarily hidden and bodies that form a watertight manifold volume get 3D printed.
To 3D print a model, click File > Print3D.
This chapter includes the following topics:

- Installing SOLIDWORKS CAM
- Installing SOLIDWORKS Manage Professional
- Upgrading SOLIDWORKS PCB Services

## Installing SOLIDWORKS CAM

SOLIDWORKS CAM is a manufacturing application that creates CNC programs to machine your SOLIDWORKS parts and assemblies. It supports mill, turn, and mill assembly machining. It is installed by SOLIDWORKS Installation Manager as part of the Individual installation.

SOLIDWORKS CAM converts the design view of parts created by the SOLIDWORKS software to a manufacturing view. It uses the part or assembly file to create machinable features and generate toolpaths. When you update the model, those changes are automatically reflected in the toolpaths.

## Installing SOLIDWORKS Manage Professional

SOLIDWORKS Manage Professional provides advanced data management tools to SOLIDWORKS PDM Professional.

It offers capabilities for advanced version control, and for project, process, and item management. Interactive dashboards and reports help you track items, activities, and progress toward completing projects.

SOLIDWORKS Manage Professional has a similar architecture as SOLIDWORKS PDM Professional. It uses a client-server architecture, with a Microsoft SQL Server database to manage item and project data.

There are three services for database, file server, and web server functions, which support both thick clients and web browser clients. The three services can be hosted on the same server or separate servers. Users with SOLIDWORKS Manage Professional Editor licenses can use a SOLIDWORKS Manage Add-in to access Manage data directly from within SOLIDWORKS.

You can use the SOLIDWORKS Installation Manager to install the SOLIDWORKS Manage Professional server and client.

For instructions on installing SOLIDWORKS Manage Professional, see the SOLIDWORKS PDM/SOLIDWORKS Manage Installation Guide.
Upgrading SOLIDWORKS PCB Services

When you are upgrading SOLIDWORKS PCB Services to 2018, the SOLIDWORKS Installation Manager upgrades the Firebird database from release 2.0 to 3.0, and automatically migrates your data. Before upgrading, you should make a manual backup of the database.
This chapter includes the following topics:

- Controlling Dismissed Messages
- Displaying Document Open Time in Windows Explorer
- Specifying a Template for General Tables
- Synchronizing Settings and Options Across Multiple Machines
- Task Scheduler Supports Additional File Formats

Controlling Dismissed Messages

The Settings Administrator Tool lets you manage common dismissed messages by users.

When you run the Settings Administrator Tool, you can block users from dismissing messages by applying controls for **Messages/Errors/Warnings**. You can ensure that some error messages and warnings always display or never display. These settings are saved in the *.sldSettings file.

The Settings Administrator Tool was introduced in the previous release. Administrators can use the tool to set system options when deploying the SOLIDWORKS software. It is available when you install an **Administrative Image** and is stored in the following default location: C:\SolidWorksAdmin\SOLIDWORKS <version>\64bit\SOLIDWORKS\Program Files 64\SOLIDWORKS\sldSettingsAdmin.exe.

To enable control of dismissed messages:

1. Launch the Settings Administrator Tool and in the System Options tab, click **Messages/Errors/Warnings**.
2. Check **Apply** and optionally check **Lock** for the messages you want to manage.
3. Set the message to **Show** or **Don’t Show**.

If you select **Show**, the message is removed from a user's dismissed message list, and displays to the user at the appropriate time. If you select **Don’t Show**, the message is automatically added to a user's dismissed messages list, and does not display when the user is working on a model.

This table describes the behavior in the software:

<table>
<thead>
<tr>
<th>Apply</th>
<th>Lock</th>
<th>Show</th>
<th>Don’t Show</th>
<th>Behavior</th>
</tr>
</thead>
<tbody>
<tr>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>Force the message to show.</td>
</tr>
<tr>
<td>X</td>
<td></td>
<td></td>
<td>X</td>
<td>Dismisses the message and adds the message to the dismissed message list.</td>
</tr>
<tr>
<td>X</td>
<td></td>
<td>X</td>
<td></td>
<td>For forces the message to show and disables the option to <strong>Don’t show again</strong> in the message box.</td>
</tr>
<tr>
<td>X</td>
<td>X</td>
<td></td>
<td>X</td>
<td>Dismisses the message and bars user from enabling it in <strong>Tools &gt; Options &gt; Messages/Errors/Warnings</strong>.</td>
</tr>
</tbody>
</table>

4. When you choose **Don’t Show**, you must also select a response to the silenced prompt. The response to a message might be **OK**, **Yes**, **No**, or a short text string.

Users can override locked settings if you supply them with a password. When users hover over a lock icon in **Messages/Errors/Warnings**, a dialog box prompts for a password. With this password, users can unlock a message, and remove or add a message from their dismissed messages list.

### Displaying Document Open Time in Windows Explorer

The file property, **Last Open Time**, appears in a tooltip when you hover the pointer over a SOLIDWORKS part, assembly or drawing document in Windows Explorer.

**Last Open Time** displays the time it took for the SOLIDWORKS software to open the file, the last time it was opened. This file property is helpful for managing your time when you have large data sets that are time consuming to open.

The time displays in minutes and seconds, and is available for models which are opened directly from disk saved in SOLIDWORKS 2018. For assemblies opened in Lightweight mode, the tooltip displays **Last LW Open Time**.

**Last Open Time** does not update in reference files when they are saved while open in memory, but does update when the reference files are saved while open in their own window.

You can also add a column in the Details view of Windows Explorer to display **SW Open Time**, and you can identify files saved in earlier versions of the SOLIDWORKS software by adding a column for **SW Last Save with**.
If you are running Windows 10, Windows Explorer has been renamed to File Explorer. These instructions also apply to File Explorer.

**To add columns for SW Open Time and SW Last Save with in Windows Explorer:**

1. Open a folder with SOLIDWORKS documents.
   The contents of that folder appear in the Details view of Windows Explorer.

2. In the Details view, right-click on the header. Typically, the header displays columns for **Name**, **Type**, and **Size**. Then in the context menu, select **More**.
   The Choose Details dialog box appears.

3. Under **Details**, scroll to **SW Last Save With** and **SW Open Time**. You can select one or both options.

4. Click **OK**.

**Specifying a Template for General Tables**

You can specify a file path for a general tables template in **Systems Options > File Locations**. This template helps users to consolidate styles and formatting.

Previously, users could not specify a file location for a general tables template.

**Synchronizing Settings and Options Across Multiple Machines**

If you use the SOLIDWORKS software with multiple machines, you can update your settings on any of the machines and synchronize those settings across all machines that run SOLIDWORKS 2018.

Settings synchronization is a service and may be blocked by some network configurations. To access the cloud storage service, ensure that firewall or proxy servers allow communications to *.solidworks.com.*

**To synchronize settings and options across multiple machines:**

1. Log in to the SOLIDWORKS software.
   See **Logging into SOLIDWORKS** on page 19.

2. In **Tools > Options**, click **Synchronize Settings**.
3. Choose a manual or automatic method:

- **Synchronize Now**
  
  **Upload Settings.** Sends your settings from the current machine to the cloud storage service. Update your settings in the cloud at any time by uploading them again later.

  **Download Settings.** Downloads and applies your settings from the cloud storage service to the current machine.

- **Automatic Synchronization**
  
  Automatically synchronizes the current machines with the cloud storage service. Your selected settings and customizations automatically upload to the cloud storage services as they are updated, and download and applied on startup or login.

  Synchronization settings can vary on different machines. For example, you can set one machine to automatically synchronize system options and file locations, but not customizations, while another machine is set for manual downloads and uploads of all types of option settings.

  With the synchronization process, you cannot overwrite administrator settings which are applied or locked.

4. Click **OK**.

### Task Scheduler Supports Additional File Formats

The Task Scheduler imports and exports additional file formats.

The following tables list the different types of files you can import and export using the SOLIDWORKS software:

<table>
<thead>
<tr>
<th>Formats for Import</th>
<th>Extension</th>
</tr>
</thead>
<tbody>
<tr>
<td>Parasolid</td>
<td>.x_t; .x_b; .xmt_txt; .xmt_bin</td>
</tr>
<tr>
<td>IGES</td>
<td>.igs; .iges</td>
</tr>
<tr>
<td>STEP</td>
<td>.stp, .step</td>
</tr>
<tr>
<td>ACIS</td>
<td>.sat</td>
</tr>
<tr>
<td>VDAFS</td>
<td>.vda</td>
</tr>
<tr>
<td>SLDXML</td>
<td>.sldlm</td>
</tr>
<tr>
<td>Rhino</td>
<td>.3dm</td>
</tr>
</tbody>
</table>

For IGES, STEP, ACIS and SLDXML files, you have an option to run import diagnostics and to import multiple bodies as parts.
<table>
<thead>
<tr>
<th>Formats for Export</th>
<th>Extension</th>
</tr>
</thead>
<tbody>
<tr>
<td>Parasolid</td>
<td>.x_t, .x_b</td>
</tr>
<tr>
<td>ACIS</td>
<td>.sat</td>
</tr>
<tr>
<td>VDAFS</td>
<td>.vda</td>
</tr>
<tr>
<td>VRML</td>
<td>.wrl</td>
</tr>
<tr>
<td>STL</td>
<td>.stl</td>
</tr>
<tr>
<td>3D Manufacturing Format</td>
<td>.3mf</td>
</tr>
<tr>
<td>Microsoft XAML</td>
<td>.XAML</td>
</tr>
<tr>
<td>CATIA Graphics File</td>
<td>.cgr</td>
</tr>
<tr>
<td>HOOPS HSF</td>
<td>.hsf</td>
</tr>
<tr>
<td>HCG</td>
<td>.hcg</td>
</tr>
</tbody>
</table>

Certain file types have their own tab in the Task Scheduler where you can select more options for export.
Assemblies

This chapter includes the following topics:

- **Asset Publisher and Magnetic Mates Enhancements**
- **Changing the Transparency of an Assembly or Multibody Part**
- **Check Entity Enhancements**
- **Mates**
- **Misaligned Mates**
- **Motion Study Menu Enhancements**
- **Pattern Enhancements**
- **Performance Evaluation Enhancements**
- **Smart Explode Lines**
- **SpeedPak**
- **Treehouse Enhancements**

**Asset Publisher and Magnetic Mates Enhancements**

- You can define multiple ground planes in an assembly. You can have only one active ground plane at a time. Components with magnetic mates and a defined ground plane are placed on the active ground plane.
- When inserting a component with a magnetic mate, you can cycle through the connection points by using keyboard shortcuts. Use the left bracket [ to cycle through connection points on the moving component. Use the right bracket ] to cycle through connection points on the static component.
- After inserting a component with a magnetic mate, you can enable the magnetic mate lock by clicking the Lock mate icon near the cursor.

**Defining Multiple Ground Planes in an Assembly**

An arrow indicates the active ground plane. You can add a ground plane or activate a different ground plane.

**To add a ground plane:**

1. Click **Insert > Reference Geometry > Ground Plane**.
   
   For assemblies that have an existing ground plane, right-click the Ground Planes folder in the FeatureManager design tree, and click **Insert Ground Plane**.

2. Select a ground plane.
3. Click ✅.

**To activate a ground plane:**

1. In the FeatureManager design tree, expand the Ground Planes folder 🌲.
2. Double-click the ground plane 🌳 that you want to activate, or right-click the ground plane and click **Activate**.

Using the Keyboard Shortcuts

**To use the keyboard shortcuts to cycle through connection points:**

Select the component to use in a magnetic mate. With the component selected, use [ or ] to cycle through the connection points.

**To customize the keyboard shortcuts:**

1. Click **Tools** > **Customize** > **Keyboard**.
2. In Category, select **Others**.
3. Under Command, select Cycle connection point (moving component) or Cycle connection point (static component) to change the keyboard shortcut.

### Changing the Transparency of an Assembly or Multibody Part

You can change the transparency of all components in an assembly or in a multibody part. Multibody parts and components that display in **Shaded 🌳** or **Shaded with Edges 🌳** modes change from opaque to transparent.

To change the transparency, right-click the assembly and click **Top Level Transparency 🌳** on the context toolbar.

For components that are transparent when you change the assembly to transparent:

- If you do not change the transparency of the component, the component remains transparent when you change the assembly to opaque.
- If you change the transparency of the component, the component becomes opaque when you change the assembly to opaque.

### Check Entity Enhancements

For assembly documents, the Check Entity dialog box returns information about the component name if an assembly contains components that have undesirable geometry. Examples of undesirable geometry include invalid faces, invalid edges, short edges, minimum radius of curvature, edge gaps, and vertex gaps.

To exclude checks for open surfaces in an assembly, clear the **Open surface(s)** option. Use the **Isolate** command to isolate the components that have undesirable geometry.
To isolate a component:

1. With an open assembly, click Check (Tools toolbar) or Tools > Evaluate > Check.
2. Click Check to check for components that have undesirable geometry.
3. Select a component from the Result list to highlight the component in the graphics area. Information about the component appears in the message area.
4. Click Isolate to isolate the component.
5. Click Exit Isolate (Isolate pop-up toolbar) to return to the Check Entity dialog box.
6. Click Close and Isolate faults to isolate all components that have undesirable geometry when you close the Check Entity dialog box.

Mates

Perpendicular Mates

You can apply a perpendicular mate between a complex, non-analytic surface and a linear entity like a line, an edge, an axis, or an axial entity.

To create a perpendicular mate:

1. Click Mate (Assembly toolbar) or Insert > Mate.
2. In the Mate PropertyManager, under Standard Mates, click Perpendicular.
3. For Entities to mate, select a linear entity and a non-analytic surface.
4. Click twice to close the PropertyManager.

Temporarily Hiding Faces When Selecting Mates

Use the Alt key to temporarily hide a face when you need to select an obscured face for mates.

You can use this keyboard shortcut only with the following Mate commands:

- Insert Mates
- Edit Mates
- Copy with Mates
- Mated Entities

The components must be displayed in Shaded or Shaded with Edges modes. After you select a mate, the hidden faces become visible.

To temporarily hide a face:

1. Click Mate (Assembly toolbar) or Insert > Mate.
2. With focus in the graphics area, hover over a face and press Alt. The face is temporarily hidden.
3. To show the temporarily hidden face, press Shift + Alt.
4. To show all temporarily hidden faces in a semi-transparent state, press Ctrl + Shift + Alt.
5. To restore visibility to all temporarily hidden faces, press **ESC**.

Misaligned Mates

Allowing Misaligned Concentric Mates

If you have components with two holes, you can mate those components even when the holes are not the same distance apart.

You can align the mate to resolve exactly with either the first or the second concentric mate and apply the offset to the concentric mate that is not aligned. Or you can apply the offset equally to both sets of mated holes. You can also specify an allowed tolerance, beyond which the misaligned mates over define the assembly and display an error.

**To allow misaligned mates:**

1. In an assembly, add a concentric mate between the first pair of holes.

2. Add a concentric mate between the second pair of holes.
3. In the dialog box, click **Create this mate using misalignment options**.

If you do not see **Create this mate using misalignment options** in the dialog box, go to **Tools > Options > System Options > Assemblies** and select the **Allow creation of misaligned mates** option.

4. In the PropertyManager, select **Align Linked mate** for the misalignment type.

5. Click ✓.

In the graphics area, you can click **Section View** (Heads-up View toolbar) and zoom to view the edges of each mate. Notice the gap between the surface and edge in the second mate.

First mate solves exactly

Second mate displays misalignment distance

In the FeatureManager design tree, the two concentric mates show in a Misaligned folder under the Mates folder.

**Assemblies System Option for Misaligned Mates**

You can enable or disable the creation of misaligned mates in System Options.

To allow creation of misaligned mates:

1. Click **Tools > Options > System Options > Assemblies**.
2. Select **Allow creation of misaligned mates**.

**Document Properties - Mates**

You can specify document properties for misaligned mates.

With an assembly open, click **Tools > Options > Document Properties > Mates**.
Misaligned mates

<table>
<thead>
<tr>
<th>Maximum deviation</th>
<th>Specify the maximum deviation allowed for misaligned mates.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default misalignment</td>
<td>Select a default misalignment type:</td>
</tr>
<tr>
<td>Align first concentric mate</td>
<td>Solves the first concentric mate exactly, and applies all the misalignment to the second concentric mate.</td>
</tr>
<tr>
<td>Align second concentric mate</td>
<td>Solves the second concentric mate exactly, and applies all the misalignment to the first concentric mate.</td>
</tr>
<tr>
<td>Symmetric</td>
<td>Applies half of the misalignment to each concentric mate.</td>
</tr>
</tbody>
</table>

Motion Study Menu Enhancements

Motion symbols automatically appear when you export animations of motion studies. You can hide or show motion symbols for motion studies by selecting View > Hide/Show > Motion Symbols 🌐.

Pattern Enhancements

Including Material and Visual Properties in a Mirrored Part

When you mirror a part from a part environment or an assembly context, you can select the material and the visual appearance of the part to include in the derived part.

In the Mirror Components PropertyManager, the Material option is selected by default. To change the material of the derived part, clear the Material option.

The Propagate from original part option in the Visual Properties section mirrors color assignments from the parent part to the derived part. Mirrored colors include colors assigned to the part, bodies, features, and faces.

The Material and Propagate from original part options are available only when you mirror a part or when you insert a part into another part for the first time. These options are not available when you edit the mirror feature or the inserted part.
Select material and visual appearance to include in a derived part:

1. Click **Mirror Components** (Assembly toolbar) or **Insert > Mirror Components**.
2. In the PropertyManager, follow the steps to create a mirror pattern.

   Click **Create opposite hand version** in **Step 2: Set Orientation** to continue through the PropertyManager.

3. In **Step 4: Import Features**, under Transfer, select **Material**. Under **Visual Properties**, select **Propagate from original part**.
4. Click ✔️ to create the mirrored component.

Linear Pattern Enhancements

Use linear patterns to rotate pattern instances along a pattern direction.

You can rotate instances as follows:

- Rotate instances based on an input value.
- Rotate instances about a selected axis.
- Align rotated instances to the seed instance.

**To rotate a linear pattern along pattern Direction 1:**

1. Click **Linear Component Pattern** (Assembly toolbar) or **Insert > Component Pattern > Linear Pattern**.
2. In the Components to Pattern section, add a component to pattern.
3. In the PropertyManager, select options under **Direction 1**:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Pattern Direction</strong></td>
<td>Defines the direction to extend the pattern. Select a linear edge or a linear dimension.</td>
</tr>
<tr>
<td><strong>Number of Instances</strong></td>
<td>Specifies the total number of instances including the seed components.</td>
</tr>
<tr>
<td><strong>Rotate instances</strong></td>
<td>Rotates the instances based on an input value around a selected axis.</td>
</tr>
<tr>
<td><strong>Axis of rotation</strong></td>
<td>Specifies the axis that the pattern rotates around. The axis must be parallel to Direction 1.</td>
</tr>
<tr>
<td><strong>Reverse Direction</strong></td>
<td>Reverses the direction of the rotation.</td>
</tr>
<tr>
<td><strong>Angle</strong></td>
<td>Specifies the angular increment for each pattern instance.</td>
</tr>
<tr>
<td><strong>Align to seed</strong></td>
<td>Aligns each instance to match the original alignment of the seed feature.</td>
</tr>
<tr>
<td><strong>Reference point</strong></td>
<td>Select a reference point:</td>
</tr>
<tr>
<td></td>
<td>• <strong>Bounding box center</strong></td>
</tr>
<tr>
<td></td>
<td>• <strong>Component origin</strong></td>
</tr>
<tr>
<td></td>
<td>These options appear when you select <strong>Align to seed</strong>.</td>
</tr>
</tbody>
</table>

4. Click ✓.
Performance Evaluation Enhancements

Assembly Open Progress Indicator

The Assembly Open Progress indicator provides information on the status of operations while you open an assembly.

For assemblies that take longer than 60 seconds to open, the indicator remains open after the assembly opens.

The indicator provides information on the following operations:

<table>
<thead>
<tr>
<th>Operation</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Open Components</strong></td>
<td>Loads the top-level assembly and reference documents. Shows the number of components opened and the total number of files in the assembly.</td>
</tr>
<tr>
<td><strong>Update Assembly</strong></td>
<td>Updates models including mates, assembly features, patterns, and in-context models.</td>
</tr>
<tr>
<td><strong>Update Graphics</strong></td>
<td>Generates graphics.</td>
</tr>
<tr>
<td><strong>Elapsed time</strong></td>
<td>Shows the amount of time required to open the assembly.</td>
</tr>
<tr>
<td><strong>Previous time to open</strong></td>
<td>Shows the amount of time required to open the assembly the last time the assembly was opened.</td>
</tr>
</tbody>
</table>

The **Previous time to open** operation is specific to the assembly mode. This information is saved for Large Assembly mode, Lightweight mode, and Resolved mode.

After opening the assembly, click **Performance Evaluation** in the indicator dialog box to view performance information specific to opening the assembly. To view the performance information at a later time, click **Tools > Evaluate > Performance Evaluation**.

You can suppress the Assembly Open Progress indicator by selecting **Do not show again**. To restore the progress indicator, click **Tools > Options > System Options > Messages/Errors/Warnings**, and select **Assembly Open Progress Indicator**.
If you enable the **No preview during open (faster)** option, the **Do not show again** option does not appear. To disable the **No preview during open (faster)** option, click **Tools > Options > System Options > Performance** to clear the option.

### Assembly Visualization Enhancements

The Assembly Visualization tool includes a set of predefined columns to help troubleshoot assembly performance. You can view the open and rebuild times for the components, and the total number of graphics triangles for all instances of components.

Other enhancements include the addition of a **Performance Analysis** button, and moving the buttons to the same line as the Filter field. An updated user interface improves the usability by using more readable text and icons.

**To view Performance Analysis information:**

1. Click **Assembly Visualization** (Tools toolbar or Evaluate tab on the CommandManager) or **Tools > Evaluate > Assembly Visualization**.

2. On the Assembly Visualization tab, click the **Performance Analysis** button. You can also click the arrow to the right of the column headers and click **Performance Analysis**.

The following columns appear:

- File Name
- Quantity
- Total Graphics-Triangles
- SW-Open Time
- SW-Rebuild Time

### Performance Evaluation Tool Enhancements

Performance Evaluation provides more information on the open, display, and rebuild performance of models in an assembly.

**To open the Performance Evaluation tool:**

- Click **Performance Evaluation** in the Assembly Open Progress Indicator dialog box.
- Click **Tools > Evaluate > Performance Evaluation**.

New Performance Evaluation checks that are available:

<table>
<thead>
<tr>
<th>Document Open File Details</th>
<th>Lists files by the amount of time required to open the file.</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Modified on Open</strong></td>
<td>Indicates the number of files that are updated while the assembly opens. Click <strong>Show These Files</strong> to view the list of updated files.</td>
</tr>
</tbody>
</table>
| **Graphics Triangles** | Lists files by the number of graphic triangles contained in a part.  
Files with less than 5,000 graphic triangles are not listed. |
|------------------------|---------------------------------------------------------------|
| **Shaded Image Quality** | Lists the files where image quality is medium-high or very high. Click Show These Files to view a list of affected files.  
For image quality, click Tools > Options > Document Properties > Image Quality. In the Shaded and draft quality HLR/HLV resolution section, move the Low (faster) - High (slower) slider to change the image resolution.  
Parts with very high image quality have the slider set at 80% or greater. Parts with medium-high image quality have the slider set at 60% - 80%.  
If the list of files does not appear, go to Tools > Options > Document Properties > Image Quality and clear the Apply to all referenced part documents option. A message about assembly image quality appears when you have the Apply to all referenced part documents option selected and meet the following conditions:  
• Shaded and draft quality HLR/HLV resolution slider is set above sixty percent.  
• Number of components in the assembly is equal or above the Large Assembly Mode threshold. |
| **Appearance** | Displays a warning if a file contains over 100 appearances applied to faces. Click Show These Files to view the list of affected files. |

Performance Evaluation checks are organized in the following categories:

| **Open Performance** | Open Summary  
Document Open File Details  
Previous Version References  
Modified on Open |
|----------------------|---------------------------------------------------------------|
| **Display Performance** | Graphics Triangles  
Shaded Image Quality  
Display Speed  
Appearance  
Components Far From Origin |
In SOLIDWORKS 2018, the In-Context Circular References check is renamed to Assembly Rebuild Report.

**Settings Performance**
- Verification on Rebuild
- Large Assembly Mode

**Statistics**
- Parts
- Subassemblies
- Components
- Assembly

Click **Assembly Visualization** to open the Assembly Visualization tool.

## Smart Explode Lines

### Creating and Dissolving Smart Explode Lines

You can create smart explode lines automatically for components in an exploded view.

You can view the associated explode steps for a selected component in the Smart Explode Lines PropertyManager. Smart explode lines use the bounding box center as a reference point by default.

You can use smart explode lines along with manually created explode lines. To use a different path for an explode line, you must manually create the explode line or dissolve the smart explode line. You cannot add a component to the explode steps using the Smart Explode Lines PropertyManager.

When you change the explode steps, the smart explode lines update automatically.

**To create smart explode lines:**
1. Open an assembly that contains an exploded view.
2. On the ConfigurationManager tab, expand the active configuration.
3. Right-click the ExplView feature and click Smart Explode Lines.
4. In the Smart Explode Lines PropertyManager, click.
   The exploded view contains the smart explode lines.

**To edit smart explode lines:**
1. On the ConfigurationManager tab, expand the active configuration.
2. Right-click the ExplView feature and click Edit Smart Explode Lines.
3. In the Smart Explode Lines PropertyManager, modify the settings for the smart explode lines.
4. Click.

**Dissolving Smart Explode Lines**

To change a line created by using the Smart Explode Lines option, you must dissolve the smart explode line.

**To dissolve a smart explode line:**
1. On the ConfigurationManager tab, expand the active configuration.
2. Expand the ExplView feature.
3. Right-click the 3DExplode sketch and click Edit Sketch.
When you edit the sketch, the smart explode lines appear in the color selected for the Highlight setting. To change this color, click Tools > System Options > Colors. In the Color scheme settings section, select Highlight.

4. Right-click the smart explode line and click Dissolve Entities.

In the following image, the route line on the right side is dissolved. The route line on the left side remains a smart explode line.

To dissolve all smart explode lines:
1. On the ConfigurationManager tab, expand the active configuration.
2. Expand the ExplView feature.
3. Right-click the 3DExplode sketch and click Dissolve Smart Explode Lines.

To edit the lines, you must edit the sketch.

Smart Explode Lines PropertyManager

In an assembly exploded view, you can create explode route lines automatically for selected components by using the Smart Explode Lines PropertyManager.

To open the Smart Explode Lines PropertyManager:
1. On the ConfigurationManager tab, expand the configuration.
2. Right-click the ExplView feature and click Smart Explode Lines.
If smart explode lines already exist, click **Edit Smart Explode Lines.**

### Components

<table>
<thead>
<tr>
<th><strong>Components</strong></th>
<th>Select the components that have an associated explode step.</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Apply to all component instances</strong></td>
<td>Copies the explode line options from one component to the other instances of the same component.</td>
</tr>
<tr>
<td></td>
<td>This functionality is available when:</td>
</tr>
<tr>
<td></td>
<td>• The <strong>Component origin</strong> option in the Component Route Line section is selected.</td>
</tr>
<tr>
<td></td>
<td>• The <strong>Components</strong> section contains at least one other instance of the selected component. The configuration and display state of the other component instance must match the configuration and display state of the selected component.</td>
</tr>
<tr>
<td></td>
<td>• The explode steps of the other instances match the explode steps of the selected component.</td>
</tr>
<tr>
<td></td>
<td>The comparison of the explode steps occurs in the parent explode view. The comparison does not occur in the Explode Step check boxes.</td>
</tr>
</tbody>
</table>

| **Select the subassembly parts** | When selected, enables you to select individual components of a subassembly. When cleared, enables you to select an entire subassembly. |

### Component Route Line

| **Bounding box center** | Locates the explode line relative to the bounding box center of the selected component. |
| **Component origin** | Locates the explode line relative to the origin of the selected component. |
| **Selected point** | Locates the explode line relative to the selected point. |
| **Select reference point** | Select a point to use for the **Selected point**. The selected point can be a point, a vertex, a sketch arc, an edge arc, a sketch line, or an edge line. |
Explode Steps

<table>
<thead>
<tr>
<th>Explode Step</th>
<th>Lists the explode steps in order.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Route line</td>
<td>Select the explode steps to include in the route line.</td>
</tr>
</tbody>
</table>

**SpeedPak**

**Setting a Rebuild on Save Mark on SpeedPak Configurations**

You can set a Rebuild on Save mark on a SpeedPak Configuration in multiple ways.

**Setting a Mark in the ConfigurationManager**

1. On the ConfigurationManager tab, right-click the assembly and click **Rebuild on Save Mark**.
2. Select **Add Mark for SpeedPak Configurations**.

**Setting a Mark in the SpeedPak PropertyManager**

1. On the ConfigurationManager tab, under the active configuration, right-click an existing SpeedPak configuration and click **Edit SpeedPak**.
2. In the SpeedPak PropertyManager, select **Add Rebuild on Save Mark** in the Options section.

**Updating SpeedPak Configurations Automatically**

You can use the **Update out-of-date SpeedPak configurations when saving files** option to automatically update SpeedPak configurations. You can lock this option in the Settings Administrator Tool.

Use this option on top-level assemblies. This option does not work for subassemblies.

**To specify the Update out-of-date SpeedPak configurations when saving files option:**

1. Click **Tools > Options > System Options > Assemblies**.
2. For **Update out-of-date SpeedPak configurations when saving files**, select one of these options:

<table>
<thead>
<tr>
<th>All</th>
<th>Update all out-of-date SpeedPak configurations.</th>
</tr>
</thead>
<tbody>
<tr>
<td>None</td>
<td>Do not update any out-of-date SpeedPak configurations.</td>
</tr>
<tr>
<td>With Rebuild on Save mark</td>
<td>Update out-of-date SpeedPak configurations that have the Rebuild on Save mark.</td>
</tr>
</tbody>
</table>
Treehouse Enhancements

Display Files in a List View

You can perform many of the same tasks in the list view that you perform when viewing the Treehouse structure in the graphical user interface:

- To open a file, right-click the icon in the Type column and click **Open**.
- To hide a column, right-click a column heading and clear the column entry. To reorder columns, drag the column.
- To save an existing document as a new copy, double-click the document name and change the name.

The document name turns green to indicate that the document is saved as a new document.

When saving an existing document as a new copy, you must work from the top down. For example, if you have an existing assembly document in the hierarchy and you want to save a component of that assembly as a new document, you must first save the assembly as a new document.

- For new documents, to change the file path in the Destination Folder Path column, click **Select the Save to Folder** and select the destination folder.

A new document can have the same name as an existing document when the Destination Folder Path is different.

- To open the Treehouse structure in Microsoft® Excel, click **Open in Excel**.

**To display files in a list view:**

1. Click **Display in a List view** to open the list view.
In the List view, suppressed files are not shown and you cannot change the active configuration.

**To change the active configuration:**

1. In the graphical user interface, hover over an assembly and click ![gear icon].
2. In the configuration list, select the configuration to switch from.
3. In the drop-down list, select a configuration to switch to.
4. Click **Switch**.

### Hiding Suppressed Documents

You can hide suppressed documents to simplify the assembly structure that appears in Treehouse.

**To hide suppressed documents:**

1. Click ![gear icon].
2. Clear **Display the suppressed documents** in the View section.
3. Click **Apply** and then **OK**.
Print Options

Click **Print** to view these options:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Print Extents</strong></td>
<td>Prints to the extents of the structure.</td>
</tr>
<tr>
<td><strong>Print Display</strong></td>
<td>Prints the part of the extents that are displayed. Use <strong>Zoom to Area</strong> to print a specific part of an extent.</td>
</tr>
<tr>
<td><strong>Print Preview</strong></td>
<td>Shows a preview of the current print selection. The preview is based on the paper size, scale, and orientation.</td>
</tr>
</tbody>
</table>

User Interface

User interface enhancements include:

- To view a specified area of the Treehouse structure, click **Zoom to Area**.
- Double-click the middle mouse button to zoom extents.
This chapter includes the following topics:

- **Documentation**
- **Rebranding**
- **Setting Subroutines for Parts**
- **Setting the Toolpath Output Folder**
- **Technology Database**
- **User Interface Improvements**

SOLIDWORKS CAM is offered in two versions. SOLIDWORKS CAM Standard is included with any SOLIDWORKS license that has SOLIDWORKS Subscription Service.

SOLIDWORKS CAM Professional is available as a separately purchased product that you can use with SOLIDWORKS Standard, SOLIDWORKS Professional, and SOLIDWORKS Premium.

**Documentation**

All documentation, including the installation guide, online help, and tutorials, is available for SOLIDWORKS CAM.

**Rebranding**

Geometric Ltd. and HCL have merged. All rebranding changes have been completed in the installer, software, registry, and related documents.

Geometric Ltd. is now HCL Technologies Ltd.

**Setting Subroutines for Parts**

You can set the subroutines to specify whether parts are output in subprogram format or long code.

**To set subroutines for parts:**
1. In the SOLIDWORKS CAM tree, in the Machine dialog box, click the Posting tab.
2. Under **Subroutines**, select an option:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Output subroutines for patterned Features</td>
<td>(Mill module only.) Sets subprograms for mill parts to work for pattern Features.</td>
</tr>
<tr>
<td>Output subroutines</td>
<td>(Assembly module only.) Sets subprograms for similar parts in assemblies that are managed in the PartManager.</td>
</tr>
</tbody>
</table>

3. Click **OK**.

### Setting the Toolpath Output Folder

You can set the toolpath output folder by tool, feature, and part for multiple parts in assemblies.

**To set the toolpath output folder:**

1. In the SOLIDWORKS CAM tree, in the Machine dialog box, click the Setup tab.
2. Under **Output multiple parts by**, select an option:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tool</td>
<td>Processes (posts/simulates) all toolpaths machined by the tool on one part, then repeats the sequence for other part instances. This process starts with the first feature and continues for consecutive operations that use the same tool.</td>
</tr>
<tr>
<td>Feature</td>
<td>Processes the toolpath on each instance of a feature before moving to the next feature.</td>
</tr>
<tr>
<td>Part</td>
<td>Processes all of the toolpaths on a part, then processes the next part.</td>
</tr>
</tbody>
</table>

3. Click **OK**.
Technology Database

Non-supported operations and conditions have been removed from the Technology Database.

User Interface Improvements

Several improvements have been made to the user interface.

CommandManager

For readability, icons of 64, 98, and 128 DPI are available in the CommandManager. In addition, the icons are stacked with horizontal text.

Display Colors

The default display colors have been modified for Stock, Features, Operations, and Simulation.

Save Operation Plan

For ease of use, the Save Operation Plan tool is available on the CommandManager.

Previously, the Save Operation Plan tool was only available when you right-clicked a feature.
CircuitWorks

This chapter includes the following topics:

- Ability to Recognize SOLIDWORKS Features in CircuitWorks
- Building Model as a Part in CircuitWorks
- Usability Improvements

CircuitWorks is available in SOLIDWORKS Professional and SOLIDWORKS Premium.

Ability to Recognize SOLIDWORKS Features in CircuitWorks

When you export SOLIDWORKS board files to CircuitWorks using the CircuitWorks Export Wizard, the Wizard recognizes and translates the SOLIDWORKS features into CircuitWorks terms.

Supported features:

- Fillet
- Chamfer
- Cut Extrude Holes/ Simple Holes/ Advanced Holes/ Hole Wizard
- Linear Pattern
- Sketch Driven Pattern
- Curve Driven Pattern
- Circular Pattern
- Blocks in sketches.

Editing Hole Features in the CircuitWorks Export Wizard

You can edit individual hole features in the CircuitWorks Export Wizard Task Pane by clearing individual hole selections or renaming instances.

To edit hole features in CircuitWorks:

1. Open system_dir:\Users\Public\Public Documents\SOLIDWORKS\SOLIDWORKS 2018\samples\whatsnew\circuitworks\BoardFeatures2.sldprt.

2. In the SOLIDWORKS software, click Export to CircuitWorks (CircuitWorks toolbar) or CircuitWorks > Export to CircuitWorks.

3. In the CircuitWorks Export Wizard Task Pane, click Next until you reach Select the Board Outline.
4. For **Select the Board Outline:**
   a) Click **Use the following SOLIDWORKS feature.**
   b) When you click on the feature, the software converts the feature name to CircuitWorks-specific name. The old name appears under **Selected Feature** and the new name appears under **New Name** in the CircuitWorks Task Pane.

   In the FeatureManager design tree, select **Board** and **Fillet1**.
   c) Click **Next**.

5. For **Select the Nonplated Hole Features:**
   a) In the FeatureManager design tree, click **Hole1**.
   b) Click **Next**.

6. For **Select the Plated Hole Features:**
   a) In the FeatureManager design tree, click **CirPattern2**.
   b) In the Task Pane, under **Feature Name**, clear **PTH 2** and **PTH 3**.
   c) For **PTH**, under **New Name**, type **Seed Hole**.
   d) Click **Next** until you reach **Finish**.

7. Click **Finish**.

   The software exports the board, containing only the selected holes using the renamed instances, into CircuitWorks. The board opens in the CircuitWorks application.

## Exporting SOLIDWORKS Features Using the CircuitWorks Export Wizard

You can export selected features from SOLIDWORKS parts into CircuitWorks using the CircuitWorks Export Wizard Task Pane.

**To export SOLIDWORKS features using the CircuitWorks Export Wizard:**
1. Open `system_dir:\Users\Public\Public Documents\SOLIDWORKS\SOLIDWORKS 2018\samples\whatsnew\circuitworks\BoardFeatures1.sldprt`.
2. In the SOLIDWORKS software, click **Export to CircuitWorks** (CircuitWorks toolbar) or **CircuitWorks > Export to CircuitWorks**.
3. In the CircuitWorks Export Wizard Task Pane, Select **Top of Board** and click **Next** until you reach **Select the Board Outline**.
4. For **Select the Board Outline:**
   a) Click **Use the following SOLIDWORKS feature.**
   b) When you click on the feature, the software converts the feature name to CircuitWorks-specific name. The old name appears under **Selected Feature** and the new name appears under **New Name** in the CircuitWorks Task Pane.

   In the FeatureManager design tree, select the **Board** and **Chamfer1** features.
   c) Click **Next**.
5. For **Select the Nonplated Hole Features**:
   a) In the FeatureManager design tree, select Hole1.
   b) Click **Next**.

6. For **Select the Plated Hole Features**:
   a) In the FeatureManager design tree, select Hole2.
   b) Continue to click **Next** in the CircuitWorks Export Wizard Task Pane, until you reach **Finish**.

7. Click **Finish**.

   The software exports the part into CircuitWorks and opens it in the CircuitWorks application.

---

## Building Model as a Part in CircuitWorks

You can open ECAD files directly in CircuitWorks using an option in the SOLIDWORKS software.

You can open an IDF file directly in CircuitWorks by clicking **File > Open** in SOLIDWORKS. Previously, with this option, you could only build a CircuitWorks file as an assembly in SOLIDWORKS. A new option in CircuitWorks allows you to build a CircuitWorks file as a part in SOLIDWORKS.

**To build a model as a part in CircuitWorks:**

1. Click **Tools > Add-Ins** to load the CircuitWorks add-in.
2. Click **CircuitWorks Options** (CircuitWorks toolbar) or **Tools > CircuitWorks > CircuitWorks Options**.
3. In the CircuitWorks Options dialog box, on the **General tab**, under **General options**, clear **Open files in CircuitWorks Lite**.
4. Click **File > Open** and navigate to `system_dir:\Users\Public\Public Documents\SOLIDWORKS\SOLIDWORKS 2018\samples\whatsnew\CircuitWorks\BasicBoard.emn`

   The file opens in CircuitWorks.

   You can edit any of the board entity properties by right-clicking **Components**, clicking **Properties**, and modifying the **Component Instance Properties**.

5. In the CircuitWorks menu, click **Tools > Build Model as Part**.
6. If a dialog box prompting a warning appears, click **OK**.

   The CircuitWorks file is built as a part in SOLIDWORKS.

   You can edit the part in SOLIDWORKS and export it back to CircuitWorks by clicking **Tools > CircuitWorks > Export to CircuitWorks**.
Usability Improvements

Controlling CircuitWorks User Options from an Administrator Location Using Windows User Permissions

You can control the CircuitWorks options by setting up the Administrator Options file location in the CircuitWorks Setup Wizard.

To control CircuitWorks user options from an administrator location using Windows User Permissions:

1. Set up CircuitWorks options for users. For details, refer to Setting Up Administrator Rights on page 69.

   An administrator location can be any shared folder where the Options XML file is present. A user can be an administrator or a client depending on his Windows user rights on the shared folder.

2. In SOLIDWORKS, click CircuitWorks Options (CircuitWorks toolbar) or Tools > CircuitWorks > CircuitWorks Options.


4. In CircuitWorks Setup Wizard, do the following:
   a) Click Next.
   b) On the Set Library Location pane, for Select Admin XML File, click Browse to specify the location.

5. In the Browse For Folder dialog:
   a) Navigate to the folder specified in step 4.
   b) Double-click the file with the name ecadopt.xml/ecadoptAdmin.xml or any valid xml options file.

Editing Reference Designators of Multiple Components

You can edit Reference Designators of multiple components simultaneously in SOLIDWORKS.

To edit multiple reference designators:

1. In the SOLIDWORKS software, click File > Open and open a CircuitWorks file.

2. On the CircuitWorks tab, right-click a component and click Edit Reference Designators.

3. In the Edit Reference Designators dialog box, under New Reference Designators column, type the new reference designators for components.

4. Click Update.
Setting Up Administrator Rights

You can set up the administrator rights or user rights for CircuitWorks options. You can enable or disable the rights of other users to edit files by providing access to folders for a fully-editable or read-only mode.

To set up administrator rights:

1. In SOLIDWORKS, click **CircuitWorks Options** (CircuitWorks toolbar) or **Tools > CircuitWorks > CircuitWorks Options**.
2. In CircuitWorks Options, in the General tab, do one of the following:
   - Under **Specify Admin file to set CircuitWorks options**, click to specify the XML file.
   - Under **CircuitWorks Setup Wizard**, click **Show Wizard** and do the following:
     a. In CircuitWorks Setup Wizard, navigate to **Set Library Location** pane, for **Select Admin XML File**.
     b. Click **Browse** to specify the location.
3. In the Browse For Folder dialog box:
   a) Navigate to the file specified in step 3.
   b) Right-click the file and click **Share with > Specific people** to provide **Read** or **Read/Write** access.
SOLIDWORKS Composer

This chapter includes the following topics:

- SOLIDWORKS Composer
- SOLIDWORKS Composer Sync
- SOLIDWORKS Composer Player

SOLIDWORKS Composer

SOLIDWORKS® Composer™ software streamlines the creation of 2D and 3D graphical contents for product communication and technical illustrations.

Label Orientation and Label Position for Measurements

A new section, Label, has been created in the Properties pane for measurements, to manage the display of measurement labels. It contains two new properties, Label orientation and Label position.

A few existing properties have been moved to this new Label section: Center value, Shape, Color, and Opacity. See Measurement Properties in the Composer help.

Padding for Measurements

In certain cases, the software applies padding around measurement values to improve legibility.

When the label orientation is set to Auto, if a measurement value overlaps the leader line and you set its label’s shape to None, some padding will be applied around the measurement value to ensure that it remains easy to read.

Support of Favorite Context

When importing 3DXML files that contain 3D Tolerancing & Annotation captures, favorite context is now supported.

The visibility of geometrical elements is properly managed, provided that the favorite context is defined on the annotation set that contains the capture.
Support of Pro/E Creo 3.0

Pro/E Creo 3.0 is now supported.

See About Supported Import Formats in the Composer help.

Write Outlines

A new document property is available to configure SMG outputs.

It saves outlines along with the 3D model. Thus, whenever the model is opened, or whenever you change to a render mode that uses outlines, outlines are loaded immediately (as it is no longer required to compute them each time they must be loaded).

See SMG, SMGXML, SMGPROJ Output in the Composer help.

Composer files in SMG, SMGXML, and SMGPROJ formats for which outlines are saved now contain a .smgOutlines file.

SOLIDWORKS Composer Sync

Support of Favorite Context

When importing 3DXML files that contain 3D Tolerancing & Annotation captures, favorite context is now supported.

The visibility of geometrical elements is properly managed, provided that the favorite context is defined on the annotation set that contains the capture.

Support of Pro/E Creo 3.0

Pro/E Creo 3.0 is now supported.

See About Supported Import Formats in the Composer help.

Write Outlines

A new document property is available to configure SMG outputs.

It saves outlines along with the 3D model. Thus, whenever the model is opened, or whenever you change to a render mode that uses outlines, outlines are loaded immediately (as it is no longer required to compute them each time they must be loaded).

See SMG, SMGXML, SMGPROJ Output in the Composer help.

Composer files in SMG, SMGXML, and SMGPROJ formats for which outlines are saved now contain a .smgOutlines file.
Label Orientation and Label Position for Measurements

A new section, **Label**, has been created in the **Properties** pane for measurements, to manage the display of measurement labels. It contains two new properties, **Label orientation** and **Label position**.

A few existing properties have been moved to this new **Label** section: **Center value**, **Shape**, **Color**, and **Opacity**. See **Measurement Properties** in the Composer help.

Padding for Measurements

In certain cases, the software applies padding around measurement values to improve legibility.

When the label orientation is set to **Auto**, if a measurement value overlaps the leader line and you set its label's shape to **None**, some padding will be applied around the measurement value to ensure that it remains easy to read.
This chapter includes the following topics:

- Calculating the Cost of Custom Operations for Selected Materials
- Costing Template Enhancements
- Evaluating the Cost of Assembly Operations
- Organizing and Saving Costing Data Locally

SOLIDWORKS Costing is available in SOLIDWORKS Professional and SOLIDWORKS Premium. Costing for assemblies is available in SOLIDWORKS Premium only.

Calculating the Cost of Custom Operations for Selected Materials

You can define Material class for custom operations for selected materials or all materials in the Custom tab of the Costing Template Editor.

To calculate the cost of custom operations for selected materials:

1. Open a sheet metal or machined part.
2. Click Costing (Evaluate tab on the CommandManager) or Tools > SOLIDWORKS Applications > Costing.
3. Click Begin Cost Estimation.
4. In the Costing Task Pane, click Launch Template Editor.
5. On the Custom tab of the Costing Template Editor, for the Painting custom operation:
   a) Click All to display the drop-down list.
   b) Click Selected.
   c) In the dialog box, under Available Material class, select Steel.
   d) Click Add.
   e) Click OK.
6. Click Save As.
7. In the dialog box:
   a) Navigate to system_dir: \Program Files\SOLIDWORKS Corp\SOLIDWORKS\lang\english\Costing templates if it is not your default location.
   b) For File name, type SteelTemplate.
   c) For Save as type, select Template database files(*.sldctm) for machined parts, and Template database files(*.sldcts) for sheet metal parts.
   d) Click Save.
   e) Click \.

8. In the Costing Task Pane:
   a) Under Template, select SteelTemplate.
   b) Under Material, select Steel for Class.

   When you select Always Include, the calculated cost for the Painting custom operation is always included in the CostingManager for SteelTemplate.

Costing Template Enhancements

Limited-Access Multibody and Assembly Templates

You can create limited-access templates for multibody parts and assemblies that limit the visibility of certain elements.

In the Costing Template Editor, when you click Save As Limited Access Copy, an information message prompts you to click Yes or No. When you click Yes, the template is saved as a limited-access template with the costs visible. When you click No, the template is saved as a limited-access template with costs of the following elements hidden:

<table>
<thead>
<tr>
<th>Element</th>
<th>Sub-Element</th>
</tr>
</thead>
<tbody>
<tr>
<td>Costing DisplayManager</td>
<td></td>
</tr>
<tr>
<td>Show Cost</td>
<td></td>
</tr>
<tr>
<td>Show Time</td>
<td></td>
</tr>
<tr>
<td>Tooltips</td>
<td></td>
</tr>
<tr>
<td>Template costs</td>
<td></td>
</tr>
<tr>
<td>Element</td>
<td>Sub-Element</td>
</tr>
<tr>
<td>-------------------------</td>
<td>--------------------------</td>
</tr>
<tr>
<td>Costing Task Pane</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Material &gt; Material Cost</td>
</tr>
<tr>
<td></td>
<td>Markup/Discount</td>
</tr>
<tr>
<td></td>
<td>Shop Rate</td>
</tr>
<tr>
<td></td>
<td>Estimated Cost Per Part &gt; Breakdown</td>
</tr>
</tbody>
</table>

The above parameters are also hidden in the Costing report.

Machining and Sheet Metal Template Enhancements

On the Milling tab of machining templates, you can input values for **TER: Tool engagement ratio** under **TER (%)**. On the Cut tab of sheet metal templates, you can input values in **Unit** for the **Cut Type of Length**.

You can assign three types of **Unit**, for the **Cut Type of Length**:

- USD/mm
- USD/cm
- USD/m

These options allow you to choose the area and cost per unit for Costing.

Evaluating the Cost of Assembly Operations

You can assign assembly operation costs in the template. You can override template costs, and add assembly operation time in the PropertyManager.

**To evaluate the cost of assembly operations:**

1. Open system_dir:\Users\Public\Public Documents\SOLIDWORKS\SOLIDWORKS 2018\samples\whatsnew\costing\Conveyor\Conveyor.sldasm.
2. Click **Costing** (Evaluate tab on the CommandManager) or **Tools > SOLIDWORKS Applications > Costing**.
3. In the CostingManager, right-click **Assembly Operations** and click **Add Assembly Operation**.
4. In the Assembly Operations PropertyManager, under **Name**, type **Fastening**.
5. In the PropertyManager, click **Each selected component**, and **Ctrl** + select four fasteners of a corner in the graphics area.
6. In the PropertyManager, do the following:
   a) Under **Operation Time**, type **10**.
   
   b) The default value is 60 USD/hr.
      
      Under **Assembly Operation Cost**, type **20**.
      
   c) Click ‣.

7. In the CostingManager, right-click **Assembly Operations** and click **Add Assembly Operation**.

8. In the Assembly Operations PropertyManager, under **Name**, type **Inspection**.

9. In the PropertyManager, click **Entire selection**, and select the entire assembly in the graphics area.

10. In the PropertyManager, do the following:
    a) Under **Operation Time**, type **3600**.
    b) Under **Assembly Operation Cost**, type **100**.
    c) Click ‣.

11. In the Costing Task Pane, click **Begin Cost Estimation**.

Organizing and Saving Costing Data Locally

You can save Costing data. Such data includes CAD files, Costing templates, and Costing reports locally as a package, with the **Costing Pack and Go** tool.

**To organize and save Costing data locally:**

1. Open an assembly.

2. Click **Costing** (Evaluate tab on the CommandManager) or **Tools > SOLIDWORKS Applications > Costing**.

3. Click **Begin Cost Estimation**.

4. In the Costing Task Pane, click **Generate Report**.

5. In the Report Options dialog box, choose the report options and click **Publish**.

6. In the Costing Task Pane, click **Costing Pack and Go**.

   If a warning message prompts you to save the assembly, click **OK** and save the assembly.
7. In the Costing Pack and Go dialog box:
   a) The default file name is the same as the CAD file name. You can rename the file name.
      For **File name**, type a name.
   b) For **Save to**, click and browse to the location where you want to save the report.
   c) Select **Include Costing report** and click to browse to the location of the report to include.
   d) Click **Save**.
This chapter includes the following topics:

- **3D PMI Compare for DimXpert Annotations Is Enhanced**
- **Automatic Generation of DimXpert Annotations for Fastener Assemblies**
- **Customizable General Tolerances for DimXpert**
- **Displaying Component-level DimXpert Annotations in Assemblies**
- **General Profile Tolerance**
- **Patterned Datums**

### 3D PMI Compare for DimXpert Annotations Is Enhanced

When using the **3D PMI Compare** tool, the restriction that the modified part starts as a copy of the reference part is removed. You can apply DimXpert to each model independently. There is an assumption that the face IDs of the parts are consistent.

### Automatic Generation of DimXpert Annotations for Fastener Assemblies

You can use DimXpert to automatically annotate one of the two components of a fixed or floating fastener assembly.

Starting with the source component, its annotations are used to create the annotations on the target component using the fixed and floating fastener formulas, as outlined in ASME Y14.5, to compute the necessary tolerances.

**To use DimXpert to automatically annotate one of the two components of a fixed or floating fastener assembly:**

1. Click **Tools > DimXpert > Auto Pair Tolerance.**
2. In **Source**, select the source component (red arrow).
3. In **Target**, select the target component (black arrow).

4. Click ✅.
Customizable General Tolerances for DimXpert

You can view the general tolerance file used in DimXpert and TolAnalyst and customize it to conform to your specific design requirements.

To specify the folder for DimXpert general tolerance file, click **Tools > Options > System Options > File Locations.** Under **Show folder for**, select **DimXpert General Tolerance File** and click **OK**.

Default general tolerance file:

<table>
<thead>
<tr>
<th>Linear</th>
<th>Description</th>
<th>from</th>
<th>up to</th>
<th>0</th>
<th>3</th>
<th>6</th>
<th>30</th>
<th>120</th>
<th>400</th>
<th>1000</th>
<th>2000</th>
<th>4000</th>
<th>4000</th>
</tr>
</thead>
<tbody>
<tr>
<td>C1</td>
<td>Custom1</td>
<td>0.1</td>
<td>0.1</td>
<td>0.2</td>
<td>0.3</td>
<td>0.5</td>
<td>0.8</td>
<td>1.2</td>
<td>2</td>
<td>3</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>C2</td>
<td>Custom2</td>
<td>0.05</td>
<td>0.1</td>
<td>0.3</td>
<td>0.5</td>
<td>0.6</td>
<td>1</td>
<td>1.5</td>
<td>3</td>
<td>4</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Broken Edge</th>
<th>Description</th>
<th>from</th>
<th>up to</th>
<th>0</th>
<th>3</th>
<th>6</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>C1</td>
<td>Custom1</td>
<td>0.1</td>
<td>0.5</td>
<td>1</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>C2</td>
<td>Custom2</td>
<td>0.2</td>
<td>0.8</td>
<td>2</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Angular</th>
<th>Description</th>
<th>from</th>
<th>up to</th>
<th>0</th>
<th>10</th>
<th>50</th>
<th>120</th>
<th>400</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>C1</td>
<td>Custom1</td>
<td>0.1</td>
<td>0.1</td>
<td>0.2</td>
<td>0.3</td>
<td>0.4</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>C2</td>
<td>Custom2</td>
<td>0.05</td>
<td>0.1</td>
<td>0.3</td>
<td>0.5</td>
<td>0.7</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

**Units**

- Linear: mm
- Angular: Degrees
Customizing the General Tolerance File

You can customize the general tolerance file used in DimXpert to conform to your specific design requirements.

**To customize the general tolerance file:**
1. In the folder specified in System Options > File Locations > DimXpert General Tolerance File, use Microsoft Excel to open general tolerances.xlsx.

The file contains the following sections:

<table>
<thead>
<tr>
<th>Section</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Linear</td>
<td>Specifies ranges and tolerances for linear dimensions.</td>
</tr>
<tr>
<td>Broken Edge</td>
<td>Specifies ranges and tolerances for chamfer and fillet dimensions.</td>
</tr>
<tr>
<td>Angular</td>
<td>Specifies ranges and tolerances for angular dimensions.</td>
</tr>
<tr>
<td>Units</td>
<td>Specifies the units of measure for linear and angular values in the table.</td>
</tr>
</tbody>
</table>

2. Under Units, set the units of measure for values in the table.
   If you use the general tolerance file in a model that uses different units, the values are automatically converted to match the model’s units.
3. Customize values in the file.
   For example:
   a) To modify Custom1 for linear dimensions, locate the Linear section.

   b) Change the values in the Custom1 row.
   For example, to change the tolerance from 0.2 to 0.3 for linear dimensions that are in the range over 6 and up to 30, you change the corresponding Custom1 value from 0.2 to 0.3.

   Formatting in the general tolerance file must be maintained. If you change formatting, the file is not recognized as valid, and default values are used instead. For example, do not rearrange cells or leave cells blank.

4. Save the Microsoft Excel file.

   You must load the general tolerance file every time you update values in it or change its location.

5. To load the file:
   a) Click Tools > Options > Document Properties > DimXpert.
   b) Under General tolerance, for Tolerance class, select a custom class.
   c) Click Load Custom, and then click OK to confirm your selection.

Using a Customized General Tolerance File

In DimXpert, when you use the General Tolerance method, you can use the general tolerance file that you have customized for your specific design requirements.

To use a customized general tolerance file:

1. Click Options (Standard toolbar) or Tools > Options.
3. Under Methods, select General Tolerance. Options in the General tolerance section are enabled. The following options are available for Tolerance class:
   - Four non-customizable options (Fine, Medium, Coarse, Very Coarse) based on ISO 2768-1.
   - Two customizable options (Custom1 and Custom2) defined in the custom general tolerance file (general tolerances.xlsx).

4. For Tolerance class:
   a) Select Custom1 or Custom2.
   b) Click Load Custom to load the custom values.

Later, if you make changes to the general tolerance file or change the file location, return to this dialog box and click Load Custom again.

5. Click OK to confirm that you want to load the values.
6. Click OK.

To use Custom1 or Custom2 as the default tolerance class in new models, edit your existing document template or create a new document template. Otherwise, every time you create a new model, you need to click Tools > Options > Document Properties > DimXpert, select Custom1 or Custom2, and click Load Custom.

Inserting a General Tolerance Table

You can insert a table in a model to display the current general tolerances in use.

To insert a general tolerance table:
1. Click Insert > Tables > General Tolerance.
2. In the PropertyManager, set the options.
3. Click .
4. Click in the graphics area to place the table.

Displaying Component-level DimXpert Annotations in Assemblies

To display component-level DimXpert annotations in an assembly, click Tools > Options > Document Properties > Detailing and select Show DimXpert when viewing component annotations.
General Profile Tolerance

General all over profile tolerance is available to let you fully define models using a single profile tolerance feature control frame. You can insert a general profile tolerance in a note or table cell.

Inserting a General Profile Tolerance in a Note

To insert a general profile tolerance in a note:

1. Click Insert > Annotations > Note.
2. In the graphics area, click to place the note.
3. In the PropertyManager, under Text Format, select Insert DimXpert General Profile Tolerance.
4. Set the options.
5. Click .
Editing a Geometric Profile Tolerance

After creating a geometric profile tolerance, you can modify it using the Geometric Tolerance Properties dialog box.

To edit a geometric profile tolerance:
1. In the DimXpertManager, right-click the geometric profile tolerance feature and click Edit General Profile Tolerance. In this example, right-click Surface Profile 1.

2. In the Properties dialog box, select the geometric tolerance options.
3. Click OK.

Patterned Datums

You can assign datums to hole patterns, concentric holes with gaps between them, width patterns, and concentric bosses. You can create datums as individual features or patterns using counterbores and countersinks.
Four-hole pattern used as secondary datum

Two concentric hole pattern used as secondary datum
Five-hole radial pattern used as primary datum

Two boss features used to define datum A
Two width features used to define datum B

Two counterbore holes used to define datum C

Two countersink holes used to define datum B
12

Detailing and Drawings

This chapter includes the following topics:

- Annotations
- Dimensions
- Drawing Views
- Output
- Tables

Annotations

Auto Hatching in Section Views

Auto hatching in section views and broken-out section views has a new option. The Randomize scale option randomizes the hatch scale for the same material in the drawing view. Clear this setting to keep the scale identical for all hatches of multiple parts of the same material.

1. In a drawing, click **Insert > Drawing View > Section**.
2. In the Section View Assist PropertyManager, set the options.
3. Click ✅.
4. In the Section View PropertyManager, under **Section View**, select **Auto hatching**.
5. Select or clear **Randomize scale**.
6. Set the options.
7. Click ✅.

Custom Property Improvement

In annotations and tables, you can create or reference a File property or Cut list property with the correct evaluated value when it contains quotes in its expression name.

Movable Datum Target

You can create movable datum targets with the Datum Target tool.

The options include:
- Horizontal movable
- Rotational movable

**Horizontal Movable**

Horizontal Movable creates a movable datum target where the movable symbol is always pointing either left or right with an arrow that can extend in any direction.

![Horizontal Movable Diagram]

<table>
<thead>
<tr>
<th>Left pointing</th>
<th>Right pointing</th>
</tr>
</thead>
</table>

**Rotational Movable**

Rotational Movable creates a movable datum target where the movable symbol always points directly at the datum target center. You can choose **Up, Down, Left, Right, Free Drag**, or **By Selection**.
Creating a Horizontal Movable Datum Target

**To create a horizontal movable datum target:**

1. Click **Datum Target** (Annotation toolbar), or click **Insert > Annotations > Datum Target**.
2. In the PropertyManager, under **Settings**, select **Horizontal Movable**.
3. Click in the graphics area to place the target. You can drag the pointer left or right to change the direction of the symbol before clicking again to place the symbol.
4. Click to place the symbol.

   - You cannot select other options in the PropertyManager until you place the symbol. To set other options, such as **Lock Leader Angle** to drag the circle along the angle specified in **Angle** only, you must reselect the datum target and set the options in the PropertyManager.

5. Click **✓**.

Creating a Rotational Movable Datum Target

**To create a rotational movable datum target:**

1. Click **Datum Target** (Annotation toolbar), or click **Insert > Annotations > Datum Target**.
2. In the PropertyManager, under **Settings**, select **Rotational Movable**.
3. Click in the graphics area to place the target. You can freely drag the pointer to any angle before clicking again to place the symbol.
4. Click to place the symbol.

You cannot select other options in the PropertyManager until you place the symbol. To set other options, such as Left, Right, Up, Down, Free Drag, or By Selection, you must reselect the datum target and set the options in the PropertyManager.

5. Click ✓.

New Draft Symbols

Draft is a new category in the Symbol Library. The draft symbols include:

<table>
<thead>
<tr>
<th>Symbol</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>+DFT</td>
<td>Plus Draft</td>
</tr>
<tr>
<td>-DFT</td>
<td>Minus Draft</td>
</tr>
<tr>
<td></td>
<td>Parting Line Diamond</td>
</tr>
<tr>
<td></td>
<td>Parting Line</td>
</tr>
<tr>
<td></td>
<td>Tolerance Draft</td>
</tr>
</tbody>
</table>

New Geometric Tolerance Options

Per ASME Y14.8 requirements, two new geometric tolerance options are available, All Over This Side and All Around This Side.

To access the options, click Insert > Annotations > Geometric Tolerance. In the PropertyManager, under Leader, select All Over This Side or All Around This Side.
Dimensions

Hole Callouts Supported in Advanced Hole Tool

You can create hole callouts for holes created with the Advanced Hole tool.
You can reverse the callout order. In the Dimension PropertyManager, under Dimension Text, select Reverse Callout Order. You may need to reverse the callout order when you place a callout on the far side face.

Reverse Callout Order selected
You can define the callout in the feature by including additional text. In the Dimension PropertyManager, under **Dimension Text**, type the text to include in **Text Above**, and **Text Below**.

**Reverse Callout Order** cleared

**Trailing Zeroes**

New options in the Options dialog box let you control individual values for trailing zeroes in dimensions, tolerances, and property values.

The legacy options **Smart** and **Standard** for trailing zeroes are no longer available for documents created in SOLIDWORKS 2018 and later. Documents created in SOLIDWORKS 2017 and earlier retain these settings with legacy behavior if they are used.
Setting Trailing Zeroes in Dimensions

To set trailing zeroes in dimensions:

1. Click **Tools > Options > Document Properties > Dimensions.**
2. In **Zeroes, under Trailing zeroes, in Dimensions,** select:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Smart</td>
<td>To maintain trailing zero behavior from SOLIDWORKS 2017 for dimensions, tolerances, and properties.</td>
</tr>
<tr>
<td></td>
<td><strong>When</strong> <strong>Smart</strong> is selected, <strong>Tolerances</strong> and <strong>Properties</strong> are not available for selection.</td>
</tr>
<tr>
<td>Show</td>
<td>To display trailing zeroes up to the number of decimal places applied to each dimension.</td>
</tr>
<tr>
<td></td>
<td><strong>When</strong> <strong>Show</strong> is selected, <strong>Tolerances</strong> and <strong>Properties</strong> are available for selection.</td>
</tr>
<tr>
<td>Remove</td>
<td>To remove trailing zeroes from each dimension.</td>
</tr>
<tr>
<td></td>
<td><strong>When</strong> <strong>Remove</strong> is selected, <strong>Tolerances</strong> and <strong>Properties</strong> are not available for selection.</td>
</tr>
<tr>
<td>Standard</td>
<td>When <strong>Standard</strong> is selected, trailing zeros behavior for dimensions, tolerances, and properties appear according to the overall drafting standard. This selection is available for parts, assemblies, and drawings created prior to SOLIDWORKS 2018.</td>
</tr>
<tr>
<td></td>
<td><strong>When</strong> <strong>Standard</strong> is selected, <strong>Tolerances</strong> and <strong>Properties</strong> are not available for selection.</td>
</tr>
</tbody>
</table>

3. Click **OK.**
Setting Trailing Zeroes in Properties

This setting applies to each numeric property value on the Units page of Document Properties such as Mass, Density, Volume, Surface Area, Cost, Center of Mass, and Block Tolerance.

This setting also applies to numeric property values that are displayed in the graphics area or are evaluated in custom properties or other annotations such as notes and tables.

To set trailing zeroes in properties:
2. In Zeros, under Trailing zeroes in Dimensions, select Show.
3. In Properties, select:

<table>
<thead>
<tr>
<th>Show</th>
<th>To display trailing zeroes up to the number of decimal places applied to each numeric property from the Units page of Document Properties as well as displayed numeric properties in the graphics area or are evaluated in custom properties or other annotations such as notes and tables.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Remove</td>
<td>To remove trailing zeroes from each numeric property value.</td>
</tr>
</tbody>
</table>

4. Click OK.

Setting Trailing Zeroes in Tolerances

This setting applies to tolerance values for Arc Length, Chamfer, Diameter, Hole Callout, Linear, Ordinate, Radius, as well as the display of tolerance values that appear within other annotations such as notes and tables.

To set trailing zeroes in tolerances:
2. In Zeros, under Trailing zeroes in Dimensions, select Show.
3. In **Tolerances**, select:

<table>
<thead>
<tr>
<th>Show</th>
<th>To display trailing zeroes up to the number of decimal places applied to each tolerance within the dimension (Bilateral, Limit, and symmetric).</th>
</tr>
</thead>
<tbody>
<tr>
<td>Remove</td>
<td>To remove trailing zeroes from each tolerance (Bilateral, Limit, and symmetric).</td>
</tr>
<tr>
<td>Remove only on zero</td>
<td>To remove trailing zeroes from each tolerance when the displayed value is zero. Also, when the value of the displayed tolerance is not equal to zero, trailing zeroes are displayed up to the number of decimal places that apply to each tolerance in the dimension.</td>
</tr>
</tbody>
</table>

4. Click **OK**.

**Drawing Views**

**Applying Layers and Colors to Hatches**

You can apply hatches to specific layers. When you apply a hatch to a specific layer, the hatch inherits the show/hide, print on/off, and color properties of the layer.

**To apply a hatch to a specific layer:**
1. In the graphics area, select the hatch.
2. In the Area Hatch/Fill PropertyManager, under **Layer**, select the layer.
3. Click ✓.
Blocks in Break Views

You can choose whether or not to clip sketch blocks in break views.

In a break view, in the Break View PropertyManager under **Break View Settings:**

- Select **Break sketch blocks** to clip the sketch blocks.
- Clear **Break sketch blocks** to display the sketch blocks with no clipping.

For example:

<table>
<thead>
<tr>
<th>Break sketch blocks selected</th>
<th>Break sketch blocks cleared</th>
</tr>
</thead>
<tbody>
<tr>
<td>ABCDEFGH RSTUVXXYZ</td>
<td>ABCDEFGH HIJKLMNOPQRSTUVWXYZ</td>
</tr>
</tbody>
</table>

Broken-Out Section Views

Broken-Out Section View on Alternate Position View

You can add broken-out section views to alternate position views.

To add a broken-out section view to an alternate position view:

1. In an alternate position view, click **Insert > Drawing View > Broken-out Section**.
Broken-out sections can only cut the reference configuration of the drawing view, not the alternate positions.

2. Sketch a closed profile such as a spline.
3. In the PropertyManager, set options.
4. Click ✓.

**Broken-Out Section View on Detail View**

You can add broken-out section views to detail views.

---

**To add a broken-out section view to a detail view:**

1. In a detail view, click **Insert > Drawing View > Broken-out Section**.
2. Sketch a closed profile such as a spline.
3. In the PropertyManager, set options.
4. Click ✓.
Broken-Out Section View on Section View

You can add broken-out section views to section views.

To add a broken-out section view to a section view:
1. In a section view, click **Insert > Drawing View > Broken-out Section**.
2. Sketch a closed profile such as a spline.
3. In the PropertyManager, set options.
4. Click ✓.

Inserting a 3D View in a Drawing

If you create 3D views in SOLIDWORKS MBD, you can insert them in drawing views. In addition, you can insert any annotations that you create in the 3D view if they are orthogonal to the drawing view.

To insert a 3D view in a drawing:
1. In SOLIDWORKS MBD, create a 3D view.
2. In the drawing view, on the View Palette, select the 3D view.
3. Drag the 3D view to the drawing sheet and release.
4. Optionally, in the Drawing View PropertyManager, under **Import options**, select **Import annotations** and **3D View annotations**.
5. Click ✓.
Output

Bookmarks in PDF Output

You can choose to include or exclude bookmarks when you save a drawing as PDF.

Click Tools > Options > System Options > Export. In File Format, select PDF. Select Include bookmarks to include bookmarks in the PDF output. Clear Include bookmarks to exclude bookmarks in the PDF output.

Tables

All Uppercase Characters

You can specify all characters in a table to be uppercase.

Click Tools > Options > Document Properties > Drafting Standard. Under Uppercase, select All uppercase for tables to apply uppercase characters to all table entries in any table type.

In SOLIDWORKS 2018, the option All uppercase is renamed to All uppercase for notes, which continues to control uppercase characters for all notes.

To specify all characters in a table cell to be uppercase, select a cell and on the table editing toolbar, click All uppercase. Optionally, in the Table PropertyManager, under Text Format, select or clear All uppercase.

Revision Table Driven By SOLIDWORKS PDM

You can use SOLIDWORKS PDM to drive a revision table.

When you manage a revision table from SOLIDWORKS PDM, in Options > Document Properties > Tables > Revisions:

- Alpha/numerical control is disabled and Revision driven from SOLIDWORKS PDM is displayed.
- Under Multiple sheet style, Independent is disabled and Independent type Revision Table is not supported while revision is driven from SOLIDWORKS PDM is displayed.

For more information, see the SOLIDWORKS PDM chapter in this document.
This chapter includes the following topics:

- 3D Views
- Decals in eDrawings Files
- Setting Options and Passwords for eDrawings Files
- STEP Files in eDrawings Files
- User Interface Enhancements
- Zooming In and Out

eDrawings® Professional is available in SOLIDWORKS Professional and SOLIDWORKS Premium.

3D Views

You can display all of the 3D Views associated with a model.

In the 3D Views pane, click **Show All** to display all of the 3D Views associated with the model. Otherwise, only the 3D Views associated with the active configuration are displayed.

The **Show All** functionality is available for models saved in SOLIDWORKS 2018 and later.

Decals in eDrawings Files

You can include decals in published eDrawings files.

Previously, eDrawings only displayed stock decals and decals whose image data was in a separate file, such as .png or .jpg, on your computer.

To include decals in published eDrawings files, in the SOLIDWORKS software, click **Tools > Options > Document Properties > Model Display** and select **Store appearance, decal, and scene data in model file**.

Setting Options and Passwords for eDrawings Files

When you save or publish a file as an eDrawings file, the options and password settings are streamlined.

When you save or publish an eDrawings file, the **Options** and **Password** buttons are no longer in the Save As dialog box. Instead, the Save Configurations to eDrawings file or Save Sheets to eDrawings file dialog box appears with the **Options** and **Password** buttons.
To set options and passwords for eDrawings files:

1. In the SOLIDWORKS software, click **Save As** or **File > Save As**.
2. In the Save As dialog box, in **Save as type**, select **eDrawings** and click **Save**.
3. In the Save Configurations to eDrawings file or Save Sheets to eDrawings file dialog box, click **Options** or **Password** to access settings.

   You can also click **Publish to eDrawings** or **File > Publish to eDrawings** to access these dialog boxes.

STEP Files in eDrawings Files

When you save or publish an eDrawings file, you can attach STEP files to each configuration of the eDrawings file. By attaching STEP files, you include the model geometry associated with the eDrawings file.

Attaching STEP Files to eDrawings Files

You can attach STEP files to parts and assemblies.

**To attach STEP files to eDrawings files:**

1. In the SOLIDWORKS software, click **Save As** (Standard toolbar) or **File > Save As**.

   You can also click **Publish eDrawings File** (Standard toolbar) or **File > Publish to eDrawings**.

2. In the Save As dialog box, in **Save as type**, select **eDrawings** and click **Save**.

3. In the Save Configurations to eDrawings file dialog box:
   a) In the column, select at least one configuration to save.
   b) In the column, select the STEP files to save.

   You can include a STEP attachment for any of the available configurations in the file. Including a STEP attachment is independent of including the eDrawings data for each configuration as long as you select at least one configuration for publishing the eDrawings data.

   c) In **Create and attach STEP file of type**, select the type of STEP file to attach. Supported STEP formats are STEP AP203 and STEP AP214. If you have a SOLIDWORKS MBD license, you can also attach STEP AP242 files, which support Product and Manufacturing Information (PMI).
   
   d) Click **OK**.

Opening STEP Files in eDrawings

**To open STEP files in eDrawings:**

1. In eDrawings, open a part or assembly document that has a STEP attachment.
2. Click **Attachments**.

3. In the Attachments pane:
   a) Select an attachment to open.
   b) Click one of the following:

<table>
<thead>
<tr>
<th>Action</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>View Attachment</strong></td>
<td>Opens the STEP file in eDrawings. An attachment icon appears in the tab with the file name.</td>
</tr>
<tr>
<td><strong>Extract Attachment</strong></td>
<td>Saves the STEP file to a location you choose.</td>
</tr>
<tr>
<td><strong>Delete Attachment</strong></td>
<td>Removes the STEP file from the eDrawings document. When you close the eDrawings document, the software prompts you to save changes. If you do not save the changes, the STEP file remains attached to the eDrawings file.</td>
</tr>
</tbody>
</table>
User Interface Enhancements

User interface updates streamline your overall workflow.

<table>
<thead>
<tr>
<th>Enhancement</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Quick access toolbar</td>
<td>Contains the <strong>Open</strong>, <strong>Save</strong>, <strong>Print</strong>, and <strong>Options</strong> tools.</td>
</tr>
<tr>
<td>Units for <strong>Feet and Inches</strong></td>
<td>Available when using the <strong>Move Component</strong> tool.</td>
</tr>
<tr>
<td><strong>Open</strong> button next to tabs</td>
<td>Lets you open a new document.</td>
</tr>
<tr>
<td>of other open documents</td>
<td></td>
</tr>
<tr>
<td>Enhancement</td>
<td>Description</td>
</tr>
<tr>
<td>-------------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Configuration names</td>
<td>Appear in the bottom of the window to indicate the active configuration. (SOLIDWORKS files only.)</td>
</tr>
<tr>
<td>Drawing sheet names</td>
<td>Appear in the bottom of the window to indicate the active sheet. (SOLIDWORKS files only.)</td>
</tr>
<tr>
<td>Markups</td>
<td>Graphical indicators notify you if the file contains a markup and if a comment is associated to a markup.</td>
</tr>
<tr>
<td>Recent Documents</td>
<td>Higher up in the File menu for easier access.</td>
</tr>
</tbody>
</table>

### Zooming In and Out

You can change the direction of the mouse wheel for zooming in and out.

**To change the zoom direction of the mouse wheel:**

1. Click **Options** or **Tools > Options**.
2. In the dialog box, on the General tab, select **Reverse mouse wheel zoom direction**.
3. Click **OK**.
This chapter includes the following topics:

- Connection Point Display
- Global Project Drawing Styles
- Global Wire Mark Display
- Multilevel Terminals
- Natural Sort Option for Marks
- Other Enhancements for SOLIDWORKS Electrical
- Project Level Attribute Styles
- SOLIDWORKS Electrical and SOLIDWORKS Routing Integration
- Symbol Editor
- Terminal Strips
- Unused Wires
- User Data for Manufacturer Parts
- Wire Numbering Group

SOLIDWORKS Electrical is available as a separately purchased product.

**Connection Point Display**

You can display connection points when symbols are not connected.

On the Graphic tab, set **Display** to **When not connected**.

**Global Project Drawing Styles**

You can define global settings that apply to all schematic drawings of the project. The settings ensure that every document has the same characteristics without you performing manual updates, to achieve consistency.

The drawing settings are saved in a template file that manages different sets of drawing styles.

To set the drawing styles, on the Project tab, click **Project** > **Configurations** > **Drawing styles**.
Global Wire Mark Display

In the Wire style manager dialog box, you can globally change options for displaying wire labels, wire marks, equipotential marks, and equipotential labels for all wires.

Multilevel Terminals

You can independently mark each level of multilevel terminals and set specific rules for renumbering multilevel marks.

Level definition dialog box

You can set:

- **Use terminal and level mark (1.1, 1.2, 2.1, 2.2)**
  Applies the `terminalmark.levelmark` numbering format.

- **Use level marks (1, 2, 3, 4)**
  Applies a unique mark to each level of multilevel terminals.

To access this dialog box, in the schematic, component tree, or Terminal strip manager, right-click and click **Terminals > Define levels**.

Renumber terminal strip terminals dialog box

You can set renumber order options to:

- **Vertical** or **Horizontal**
- **Bottom to Top** or **Top to Bottom**

To access this dialog box, in the Terminal strip manager, click **Advanced > Renumber**.

Component properties dialog box

On the Mark and data tab, after you set the levels, you can set individual component properties to use **Automatic**, **Manual**, or **Use level marks**.

To access this dialog box, in the schematic, right-click and click **Terminals > Component properties** or right-click the component tree and click **Select properties**.

Natural Sort Option for Marks

You can set the sort method of marks throughout the project by root and number sort or natural sort.

**To set the natural sort for marks:**
1. On the Project tab, click **Configurations > Project > Mark**.
2. Under **Sort by mark**, click one of the following for **Sort by mark mode**:
   - **Order by root and number, first automatic, manual after**
   - **Order by tag alphabetically natural, mixing automatic and manual marks**
Other Enhancements for SOLIDWORKS Electrical

For additional information about these enhancements, see SOLIDWORKS Electrical Help. SOLIDWORKS Electrical enhancements include:

<table>
<thead>
<tr>
<th>Library</th>
<th>Added fields for prefabricated cable lengths and manufacturer part data file link.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Marks</td>
<td>• You can set the <strong>Manual</strong> mark mode as the default when using insert symbol.</td>
</tr>
<tr>
<td></td>
<td>• You can edit the <strong>Automatic/Manual</strong> mark mode when you select multiple objects.</td>
</tr>
<tr>
<td></td>
<td>• Renumber marks include harnesses.</td>
</tr>
</tbody>
</table>

| Import/export | • In the file selector for outputs, you can filter on **Opened drawings only** to keep only the drawing opened by the current user. |
|               | • **Import DWG files** can reconnect lines that are close to each other according to the offset distance you specify. |

| User interface | • In **Cross reference settings**, you can set whether to use the cross reference limit defined in the title block. |
|               | • When you update or replace a title block in a drawing, the Display Task dialog box lets you apply the changed title block to only the selected drawing or to all project schematics in the project that use the same title block. |
|               | • More formulas are available on the Font tab for cable core and cable text to customize text displayed on drawings for **Origin-Destination** and **Function/Location Outline**. |

| Open and archive | • The software retains the most recent file from each project. It reopen the last 2D or 3D file when you open a project. |
|                 | • In the archive environment, you can set an option to archive **All projects**. |

Project Level Attribute Styles

You can define a common style for attributes that applies everywhere the attribute is used in the project. For example, you can use the same attributes format in a symbol or title block without performing manual updates.

In the Project configuration dialog box, on the Attribute tab, you can create custom attributes or use predefined attributes.
SOLIDWORKS Electrical and SOLIDWORKS Routing Integration

You can create C-points and define mate references for electrical components from the Routing Library Manager instead of the Electrical Component Wizard.

To access the Routing Library Manager from the SOLIDWORKS Electrical 3D tab, on the SOLIDWORKS Electrical 3D CommandManager, click **Electrical Component Wizard**.

SOLIDWORKS Electrical 3D enhancements in the Routing Component Wizard tab of the Routing Library Manager let you:

- Define C-points, mate references, and component alignment using the same options as in the Electrical Component Wizard.
- Set **Select Component Type** to **DIN Rail Component**.

Symbol Editor

Enhancements to the Symbol editor are available when you modify attributes and work with passive symbols.

When you modify attributes, you can use the:

- **Multiple attribute** and **Replace attribute** commands to quickly modify the index and language of one or more attributes when you edit a symbol or title block. These commands are available in **Edit Symbol** on the contextual menu.
- **Modify Revision Index** command when you edit a title block.

When you use passive symbols, the following options are unavailable in the Symbol properties dialog box:

- **Manufacturer part**
- **Characteristics**
- **Options**

Terminal Strips

<table>
<thead>
<tr>
<th>Accessory components</th>
<th>You can add accessory components to terminal strips, including end brackets, end covers, and separators. These are represented in terminal strip drawings.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Component properties dialog box</td>
<td>You can add <strong>Manufacturer parts and circuits</strong> for terminal strips.</td>
</tr>
<tr>
<td>Reorder terminals dialog box</td>
<td>You can set the sort criteria using <strong>Destination cable mark</strong> or <strong>Origin cable mark</strong>.</td>
</tr>
</tbody>
</table>
Terminal strip drawings | You can set the **Distance between cables** in terminal strip drawings.

---

### Unused Wires

You can use project configurations to number wires and equipotentials, cables, and components with unused wire marks.

In the Wire and component numbering dialog box, for **Assign unused mark**, select **Wires and equipotentials**, **Cables**, or **Components**. If you select any of these options, the software reuses unused numbers when numbering new wires, otherwise it uses the current highest mark +1.

### User Data for Manufacturer Parts

If you do not use the ERP data connection, user data fields are available for manufacturer parts.

### Wire Numbering Group

You can start the wire and equipotential numbering at each project location.

In the Numbering group dialog box, set **Start numbering at** to **Project**, **Book**, **File**, or **Location**.
This chapter includes the following topics:

- Color Bar
- Component Explorer
- Free Surface
- Full Template
- Noise Prediction
- Plot Callouts
- Sector Periodicity

SOLIDWORKS Flow Simulation is available as a separately purchased product that can be used with SOLIDWORKS Standard, SOLIDWORKS Professional, and SOLIDWORKS Premium.

Color Bar

On the Color Bar, you can change the value axis to logarithmic and orient the palette bar horizontally or vertically.
Component Explorer

In the Component Explorer, you can create and edit sources and materials from the table, and display total power.

Free Surface

Free surface lets you simulate flows with a freely moving interface between two immiscible fluids.

You can use the volume of fluid method (VOF) for tracking and locating the free surface (or fluid-fluid) interface.

The following pairs of fluids are available: gas-liquid and liquid-liquid. Any phase change transition, rotation, porous media, or fans are not allowed.

Full Template

You can save all project data to a template, such as boundary conditions, sources, and goals. This makes it easier to copy projects from model to model.

Noise Prediction

The Fast Fourier Transformation (FFT) algorithm converts a time signal to the complex frequency domain for transient analysis.

The FFT plot analyzes time-dependent pressure data using the FFT algorithm.

Plot Callouts

You can show the minimum and maximum values in callouts for cut and surface plots.
You can simulate sector periodicity problems, including rotation and heat conduction in solids.

Phase transitions (including isothermal cavitation), high Mach number flows, and mixing plane rotation regions are not allowed. When performing the simulation, the rotation axis should be parallel to one of the global coordinate system axes.
16
SOLIDWORKS 3D Interconnect

This chapter includes the following topics:

- Additional File Formats Supported
- Additional Information Supported for Reading from Third-Party Native CAD Files

Additional File Formats Supported

SOLIDWORKS 3D Interconnect now supports JT, STEP, IGES, and ACIS file formats.

JT Files

SOLIDWORKS 3D Interconnect supports JT files.

Version Supported: JT version 8.x, 9.x, and 10.x.

- 3D Interconnect reads parts containing JTBrep and XtBrep with visual properties.
- Assemblies with assembly structure of all four variations: Atomic, Monolithic, Shattered, and SameAs NX.

Limitations

SOLIDWORKS 3D Interconnect does not support:

- JT files with no Brep, or visualization data, or only with tessellation data.
- JT files that have desolated data
- Custom properties of JT files

STEP, IGES, and ACIS Files

SOLIDWORKS 3D Interconnect supports STEP, IGES, and ACIS file formats.

SOLIDWORKS 3D Interconnect can read Reference Planes and User Defined Attributes or Custom Properties from these neutral formats.

When you import custom properties from files, the translator reads user-defined attributes, if present, and writes them into SOLIDWORKS custom properties.

You can read STEP, IGES, and ACIS assembly files as a multibody files. From the System Options dialog box, you can choose to map and import the assembly structure as a part with multiple imported bodies or as a multibody part.
Additional Information Supported for Reading from Third-Party Native CAD Files

SOLIDWORKS 3D Interconnect reads the following additional information from third-party native CAD files:

- Assembly cut features
- Custom properties
- Material properties
- Unconsumed sketches and curves
- Reference axes from CATIA® V5 files only.

Assembly Cut Features

SOLIDWORKS 3D Interconnect can read assembly cut features from PTC® Creo and UG files.

You can optionally import the material properties, custom properties, and unconsumed sketches and curves from these files. To import these entities, in the System Options dialog box, click **Import** and select the required entity.

Custom Properties

SOLIDWORKS 3D Interconnect can read custom properties, metadata, or user-defined attributes from third-party native CAD files and map them to the custom properties of SOLIDWORKS.

SOLIDWORKS 3D Interconnect can read custom properties from these formats:

- ACIS
- Autodesk® Inventor
- CATIA® V5
- IGES
- PTC® Creo
- Solid Edge®
- STEP
- UG

The custom properties are locked when the third-party CAD file and the SOLIDWORKS file are linked. To overwrite these properties, you must break the link.
Material Properties

SOLIDWORKS 3D Interconnect can read the material properties from third-party native CAD files. SOLIDWORKS 3D Interconnect reads only the material name and density attributes.

Unconsumed Sketches and Curves

SOLIDWORKS 3D Interconnect can read unconsumed sketches or curve data from third-party native CAD files. Unconsumed sketches are sketches that are not consumed by any feature. These sketches read the curve data from third-party native CAD files and form single 2D or 3D sketches.
SOLIDWORKS Inspection

This chapter includes the following topics:

- **SOLIDWORKS Inspection Add-in**
- **SOLIDWORKS Inspection Standalone**

SOLIDWORKS Inspection is available as a separately purchased product that can be used with SOLIDWORKS Standard, SOLIDWORKS Professional, and SOLIDWORKS Premium or as a completely separate application (see *SOLIDWORKS Inspection Standalone*).

**SOLIDWORKS Inspection Add-in**

**SOLIDWORKS Part and Assembly Support**

You can create complete inspection reports using existing SOLIDWORKS part and assembly files (*.sldprt and *.sldasm).*
When you open a SOLIDWORKS part or assembly that contains 3D annotations or Product and Manufacturing Information (PMI), you can create a new inspection project and extract all the information for the inspection checklist.

**To create an inspection report from a SOLIDWORKS part or assembly:**

1. Click **New Inspection Project** (CommandManager).
2. Select project settings and extraction settings.

Use the check boxes to set up the project. For example, you can include or exclude **Dimensions**, **Notes**, **GD&Ts**, and **Hole Callouts**, SOLIDWORKS Inspection then adds the balloons to the PMI. Quality inspectors can then refer to the inspection spreadsheet and the 3D model to understand which characteristics to inspect.

You can use either **Automatic** or **Manual** extraction mode.

The Inspection characteristics are listed in the Characteristic Tree. You can modify the properties of a characteristic to include additional information such as Operation, Classification, and Method of Inspection. Additionally, you can reorder them.
When the project is complete, you can generate:

- Microsoft® Excel report
- 2D PDF
- 3D PDF (if SOLIDWORKS MBD is available)
- eDrawings file

SOLIDWORKS Inspection Standalone

2D File Support

You can open and import 2D files from other CAD systems directly into an inspection project.

SOLIDWORKS Inspection 2018 supports these formats:

- AutoCAD® DWG files
- CATIA® V5 CATDrawing files

You can use the Smart Extract feature to extract one or more characteristics based on predefined settings.

After completing the inspection project, you can generate a Microsoft Excel file or a 2D PDF.
3D File Support

You can open and import 3D files from other CAD systems directly into an inspection project.

SOLIDWORKS Inspection 2018 supports these formats:

- 3D XML files
- PTC® and Creo Parametric files
- CATIA® V5 CATPart and CATProduct files

You can navigate between the different views of the 3D file using the navigation tree in the top right corner.

The characteristics are ballooned and added to the Bill of Characteristics.

After completing the inspection project, you can generate a Microsoft Excel file, a 2D PDF, or a 3D PDF.

Balloon Sequences

You can create balloon sequences in options and assign them to project characteristics.

You can do the following:

- To access balloon options, on the Home tab, click **Options > Project Options > Ballooning.**
• To add a balloon sequence, click +.
• To remove a balloon sequence, click −.
• Under Balloon Sequence, you can customize the Sequence Name and Starting Value.

Characteristics that you balloon are numbered based on the sequence selected in the CommandManager or in the characteristic window. When you select a sequence, all new characteristics start at the Starting Value and increment by 1. If a sequence already has characteristics, any new characteristic begins at the end of the list.

If you modify a sequence in the options, balloon numbers update accordingly.

Balloon sequencing, incrementing, and customizable numbering must be used independently of one another in a project.

CMM Data Management Import

There are new filters that help identify assigned and unassigned items.

Create and Place Sub-Balloons

When a characteristic refers to multiple instances of a feature, you can add multiple balloons to the drawing to identify each instance.

For example, this radius refers to two fillets:

To add multiple balloons:
1. In the Table Manager:
   a) Create a line for each instance.
   b) Right-click an instance and click Create and Place Sub balloons.
2. Click anywhere in the document to place additional balloons.
   In this example, you add balloon 2.2. Balloon 2 automatically changes to 2.1.
Customizable Balloon Numbering

You can renumber characteristics in the **Bill of Characteristics** and include gaps.

To renumber characteristics, on the Characteristics tab, double-click the Characteristics Number field (**#Char**) and type the new number. All subsequent characteristics are renumbered accordingly.

Balloon sequencing, incrementing, and customizable numbering must be used independently of one another in a project.

Customizable Tolerance Type

You can customize default tolerances if an explicit tolerance is not specified in the 2D or 3D file for one or multiple characteristics.

In addition to the **Linear** and **Angular** default tolerances, you can add new tolerances.

You can do the following:

- To access the tolerance options, on the Home tab, click **Options** > **Project Options** > **General**.
- To add a new tolerance, under **Default Tolerances**, click + at the top of the table.
- To rename a tab, double-click it and type the new name.
- Use + and - to add and remove lines in the tolerance table.
- You can select tolerance values **By Precision** or **By Range**.

After completing the tolerance table, you can select it in the characteristic window.
Explode Note

If a drawing note contains multiple characteristics to inspect, you can explode the note into multiple instances.

To explode a note:
1. In the Table Manager, right-click the note and select **Explode Note**.
2. Select each characteristic and create a new instance or use **Auto-Explode**.
   
   You can also add, remove, copy, and combine rows.

Export to CAMS XML and Verisurf

You can export your inspection projects to CAMS XML and Verisurf.

Export to QualityXpert Improvements

In QualityXpert, you can use a mobile device to publish your inspection plans to the web for inspection on the shop floor.

ExtractionXpert

The ExtractionXpert™ tool improves Optical Character Recognition (OCR) readings.

ExtractionXpert automatically tries different OCR settings such as **Sharpen**, **Dilate**, and **Edge Enhancement**. The tool uses more than 200 combinations to recommend the best settings based on the entered values.

ExtractionXpert accounts for scaling, so you no longer need to manually rescale .pdf and .tiff drawings. Therefore, in **Options > Project Options**, the Drawings tab has been eliminated.

Full Specification

When extracting characteristics from a 2D or 3D file, the full specification is calculated in the characteristic window. Some companies require their users to have the full specification (for example, tolerances, degree, diameter symbols) displayed in the inspection report.
Ignore Basic Dimensions

You can ignore basic dimensions from measurements input so they are not flagged.

Improved Optical Character Recognition

An enhanced Optical Character Recognition (OCR) engine improves the recognition of documents and fonts, and requires less user input.

Improved User Interface

The user interface is improved for added clarity.

- Menus, dialogs, and buttons are updated to be more consistent.
- Options and settings are reorganized.
- In the Bill of Characteristics, the status for items such as Key and Basic characteristics is now shown as **True** or **False** instead of a check mark.

Merge Characteristics

You can merge multiple characteristics into one.

For example, this hole dimension is listed as three separate characteristics. You want it to be listed as a single characteristic.
To merge characteristics:
1. In the Table Manager, select the characteristics to merge.
2. Right-click and select **Merge Characteristics**.
   The characteristics are combined into one.

Net-Inspect Options

Net-Inspect is a web-based quality management system used by many large companies to manage their inspection processes both internally and with suppliers worldwide.

To set Net-Inspect options, click **Home > Options > Net-Inspect Options**.

Predefining Balloon Appearances

In **Project Options**, under **Ballooning**, you can use the Characteristic Identification feature to predefine unique balloon appearances for special characteristics for easy identification when performing an inspection.

The Characteristic Identification feature can be applied to Key Characteristics. Therefore, the Key Characteristics options **Identified** and **Placement** have been eliminated.

Publish Reports with Document Snapshots

You can include captures, views, and drawing sheets in Microsoft Excel inspection reports.

You can select views and sheets to include in published reports. Also, you can manually create and include snapshots. You can reorder the snapshots before exporting to Microsoft Excel.
Revision Management

You can use the Revision Management tool to analyze changes between two CAD files and view a summary of all added, removed, or modified annotations.

SOLIDWORKS Inspection can automatically process all of the changes between revisions or highlight changed items in the project, allowing you to review each item individually.

The manual revision mode provides a summary of the changes as well as instruction to make the changes. The automatic mode displays a summary with options and user preferences for automatic processing.

Sampling

Acceptance Quality Limit (AQL) is a method of sampling that is used by many companies as the standard tool for choosing sample size for product inspection. You can define sampling and AQL in the SOLIDWORKS Inspection Standalone application for an entire project or for each individual characteristic.

Smart Extract

The Smart Extract tool lets you extract multiple characteristics when the PDF document contains a searchable text layer that supports Smart Extract.

Smart Extract supports PDFs created from the following applications:

- CATIA V5
- Solid Edge

To extract characteristics, click **Smart Extract** (CommandManager) or right-click and click **Smart Extract**. You can extract a single characteristic or multiple characteristics.
This is useful for extracting GD&T without manually recognizing each element. Using predefined settings, you can extract multiple characteristics at once. The quality of the extraction depends on the software that was used to create the 2D drawing.

Undo and Redo

Undo and Redo are available to cancel or redo the last action.
This chapter includes the following topics:

- **3D PDF Templates**
- **3D PMI Compare Versions**
- **3D Views Slideshow**
- **Bill of Materials**
- **Configuration-specific Properties in 3D PDF**
- **Import PMI**
- **Insert a Note in a 3D PDF Field**
- **MBD Templates**

SOLIDWORKS MBD is available as a separately purchased product that you can use with SOLIDWORKS Standard, SOLIDWORKS Professional, and SOLIDWORKS Premium.

**3D PDF Templates**

New 3D PDF templates are available for parts and assemblies.

In addition, there are custom versions that you can use as a basis for your specific needs.

To access the 3D PDF templates:

1. Click **3D PDF Template Editor** 🖋️ (SOLIDWORKS MBD toolbar).
2. Click **Open** 📁.
Multipage Assembly (a4 landscape)

Multipage Assembly Custom (a4 landscape)

3D PMI Compare Versions
Using the 3D PMI Compare tool, you can compare PDM revisions of the same document.

**To compare PDM revisions of the same document:**
1. Click **Tools > Compare > 3D PMI**.
2. In the Task Pane, select the **Reference document**.
3. Select **Within SOLIDWORKS PDM**.
4. Under **Within SOLIDWORKS PDM**, select the PDM revisions in **Version 1** and **Version 2**.
5. Click **Run Comparison**.

### 3D Views Slideshow

You can watch 3D Views as a slideshow from the 3D PDF.

In a 3D PDF, click **Play** in the preview pane to automatically sequence through the model views. To stop or pause the presentation, click **Pause**.

### Bill of Materials

When you publish a model containing a bill of materials to 3D PDF, you can determine which columns to include.

**To specify the columns in a bill of materials:**
1. In a model that contains a BOM, in the Publish to 3D PDF PropertyManager, click.
2. Under **Output BOM Table**, in **Column List**, select the columns to include.
3. To specify the number of columns to display in the 3D PDF, under **Columns in grid**, select the number of columns.

   For example, if you select **2** for **Columns in grid** and you select more than two in **Column List**, the 3D PDF displays the values of 2 columns in the BOM. When you select a BOM row, the remaining column values appear in the BOM.

4. To display all of the BOM columns in the 3D PDF, select **Show all columns in PDF**.
5. Set other options.
6. Click **✓**.
Configuration-specific Properties in 3D PDF

You can insert configuration-specific properties in text fields and tables when you publish a model to 3D PDF. For notes, there is a 3D PDF Template Editor option that assigns the property as configuration-specific.

Inserting Configuration-specific Properties in a Text Field

To insert configuration-specific properties in a text field:

1. In the SOLIDWORKS 3D PDF Template Editor, click Text.
2. Click to place the text block on the page.
3. In the PropertyManager, click Custom Property Field.
4. Under Custom Property Field, select Configuration Specific.
5. Set the options.
6. Click .

Inserting Configuration-specific Properties in a Table

To insert configuration-specific properties in a table:

1. In the SOLIDWORKS 3D PDF Template Editor, click Generic Table.
2. In the Open dialog box, select a table and click Open.
3. Optionally, drag and resize the placeholder on the template.
4. Click outside of the table to release it.

Import PMI

You can import PMI (Product Manufacturing Information) with NX, Creo, and STEP AP242 formats as semantic graphical annotations.

You can assign color to graphical annotations. Click Tools > Options > System Options > Colors. Under Color scheme settings, select Graphical Annotations.

Insert a Note in a 3D PDF Field

You can select and insert notes, such as a GTOL, from a part or assembly into their own fields in a published 3D PDF.

To insert a note in a 3D PDF field:

1. In the 3D PDF Editor, click Imported Notes.
2. Click to place the Imported Note Placeholder on the template page.
3. Set the properties.
4. Click ✓.
5. Save the template.

MBD Templates

MBD templates for parts and assemblies are included with all versions of SOLIDWORKS 2018 where the text sizes scale properly to the component and assembly sizes.

The new MBD templates have predefined settings based on your model size. When you use these templates, you will automatically get the proper scaling for your model and text. For example, select **Part 0001 mm to 0010 mm** if the model you are designing will be in the range of one to ten mm. This template is designed for this part size, which helps simplify your work.

The new templates are installed with your SOLIDWORKS installation.

**To use a template:**
1. Click **File > New**.
2. In the New SOLIDWORKS Document dialog box, click the **MBD** tab.
3. Select a template.
4. Click **OK**.
Model Display

This chapter includes the following topics:

- **Offloaded Rendering**

## Offloaded Rendering

Offloaded rendering lets you send a rendering to another machine that uses the PhotoView 360 Net Render Client. Offloaded rendering frees up your computer while the rendering is calculated on another machine.

When you use offloaded rendering, two machines are required:

- **Coordinator**: The machine running the SOLIDWORKS software and PhotoView 360. The coordinator must have a license of SOLIDWORKS Professional or higher and an active subscription service license.

- **Client**: The machine running the PhotoView 360 Net Render Client. The client does not need a SOLIDWORKS license.

There are two types of offloaded rendering:

- **Single offloaded rendering**: Sends a single static image to render on the client.

- **Scheduled offloaded rendering**: Sends a single static image to the SOLIDWORKS Task Scheduler to start the task at a later time.

### Using Single Offloaded Rendering

**To use single offloaded rendering:**

1. Click **Options** (Render Tools toolbar) or **PhotoView 360 > Options**.
2. In the PropertyManager:
   a) Select **Network Rendering** and **Offload Rendering**.
   b) Click ✔.

When you render the model, it renders on the client that uses the PhotoView 360 Net Render Client. If the client is busy or unavailable, you are asked if you want to render on the coordinator or cancel the rendering. On the coordinator machine, you have full access to the SOLIDWORKS software while the offloaded rendering takes place.
Using Scheduled Offloaded Rendering

Use scheduled offloaded rendering to start the task in the SOLIDWORKS Task Scheduler at a later time, such as after business hours.

To use scheduled offloaded rendering:

1. Click Schedule Render (Render Tools toolbar) or PhotoView 360 > Schedule Render.

2. In the dialog box:
   a) Select Start Offloaded Rendering Now.
      **Start Offloaded Rendering Now** is not available if the SOLIDWORKS Task Scheduler is performing tasks, a rendering is already scheduled, or if a rendering is currently taking place.
   b) If there is already a task scheduled in the SOLIDWORKS Task Scheduler, select Start after Previous Task to put the task into the queue.
   c) Click Finish.

SOLIDWORKS Task Scheduler schedules the rendering. If the client is busy or unavailable when the render task is scheduled to start, the coordinator machine performs the render.
This chapter includes the following topics:

- Advanced Hole
- Block Editing of Linked Custom Properties in Derived Parts
- Cosmetic Threads Improvements
- Creating a Bounding Box
- Defeature Tool Improvements
- Extracting Geometry from a Corrupted Solid Body
- Feature Freeze Bar Works with All Folders
- Hole Wizard Options to Match Size or Preserve Settings
- Mesh BREP Bodies
- More Control Over Custom Properties

Advanced Hole

Customizing Advanced Hole Callouts

You can customize hole callouts for advanced holes, which is useful for manufacturing processes.

The manufacturing processes for holes do not always match the order shown in the advanced hole flyout. You can customize hole callouts that match the order and variables needed for manufacturing, then use the callouts in manufacturing drawings.

For example, the advanced hole flyout might show this order:
• (1) Nearside Counterbore
• (2) Straight
• (3) Straight Threaded

However, this is the order in which manufacturing creates the holes:
• (3) Straight Threaded
• (2) Straight
• (1) Nearside Counterbore

To customize advanced hole callouts:
1. In the Advanced Hole PropertyManager, under Hole Callout, click Customize callout.
2. To reorder the callouts, select the Callout String and click Move Up and Move Down.
3. To customize a callout string, double-click it in the Callout String list and select variables. You can also select Callout Variables to display a list of all variables. Modified strings are marked with an asterisk in the list.
4. To restore the default settings for individual Callout String items, right-click a string and click Restore Default String.
5. To remove all customizations, under Hole Callout, click Default callout.

Default callout removes all customizations you made to all hole callouts in the PropertyManager.
Defining Hole Elements with Baseline Dimensions

You can use baseline dimensions to define advanced holes.

When you select this option in the Advanced Hole PropertyManager, the SOLIDWORKS software measures near and far side elements from the same initial baseline dimension. This option also sets the end condition automatically to Offset from Surface for each element in the hole stack.

The same hole stack can chain elements, defined with baseline dimensions, with other neighboring hole elements.

Other changes related to using baseline dimensions include:

- For a counterbore, countersink, or taper threaded element, you can select Use standard depth to ensure that the depth of the element is the same depth defined in the Hole Wizard data table.
- For a straight threaded element, you can select a formula from a drop-down list to calculate its depth.

To access this option, click Insert > Features > Advanced Hole. In the Advanced Hole PropertyManager, under Near And Far Side Faces, select a face and click Use baseline dimensions.

Block Editing of Linked Custom Properties in Derived Parts

On the Custom Properties tab in the Task Pane, you cannot edit or delete file properties and cut list properties which are linked to parent parts. These options will appear unavailable (grayed out).

Cosmetic Threads Improvements

When you mirror a feature, the geometry for cosmetic threads generates more reliably. There are also improvements related to patterns, the hole wizard, and line representation for depth.

Creating a Bounding Box

With the Bounding Box tool in Reference Geometry, you can create a box that completely encloses a model within a minimum volume. You can create a bounding box for a multibody, single body, or sheet metal part.

In the Bounding Box PropertyManager, you can orient a bounding box by selecting a planar face of the part or a reference plane. When the part updates, the bounding box automatically resizes.

You can include hidden bodies and surfaces in the bounding box. You can also hide, show, suppress, and unsuppress a bounding box from a shortcut menu.
Four bounding box properties are available in the **Configuration Specific** tab of the Summary Information dialog box. The dimensions in these properties can help you determine the space required to ship and package product. You can reference these properties in BOMs and other tables.

Calculating a bounding box for a part with many faces can be time consuming. If a part has many faces, you should create the bounding box after you finish modeling the part. Previously, you could only create a bounding box for a cut list item in weldments.

**To create a bounding box and view its properties:**

1. In a part document, click **Bounding Box** (Reference Geometry toolbar) or **Insert > Reference Geometry > Bounding Box**.

2. In the Bounding Box PropertyManager, leave **Best Fit** selected and click [√].

   The software automatically calculates the bounding box for the part as shown. In the FeatureManager design tree, **Bounding Box** is added after **Origin**.

3. To view bounding box properties, click **File > Properties > Configuration Specific** tab.

   Values for thickness, width, length, and volume of the bounding box are listed.

4. If you hide a body in the part, the bounding box automatically updates and only encloses the visible bodies in the model.

5. To edit the bounding box, in the FeatureManager design tree, right-click **Bounding Box**, and click **Edit Feature** [-pencil]. Then in the PropertyManager, click **Include hidden bodies** and click [√].

The bounding box calculated by the SOLIDWORKS software might not have the minimum volume for some bodies and parts. You should use past experience and experimental data to review the suggested bounding box, and modify it if necessary.
Defeature Tool Improvements

The Defeature tool is more reliable in displaying features that have been selected to keep, and in selecting and keeping holes, especially in spherical bodies.

When you save the results from the Defeature tool and select the option to save the model as a separate file, the file is saved as Document Name_Defeature.sldprt.

In a part or assembly, click Defeature (Tools toolbar) or click Tools > Defeature.

Extracting Geometry from a Corrupted Solid Body

When the SOLIDWORKS software attempts to repair a corrupt file and cannot resolve the problem, the software prompts you with an option to extract geometry if the body data of the file is still intact.

If you accept this option, the software imports the geometry from the corrupted file into a new file. You can use the geometry and add features to create a new model. However, the new file will not have the feature history associated with the imported geometry.

Feature Freeze Bar Works with All Folders

The Feature Freeze bar freezes all features above the bar in the FeatureManager design tree even when the features in a folder were not created in chronological order.

Previously, the freeze bar could not freeze features in a folder if it contained sketches or features that had been created later than entities below the freeze bar. For example, suppose your part document contains Sketch1 and Sketch2, and you create Boss-Extrude1 feature from Sketch2 and Boss-Extrude2 feature from Sketch1. Then you add Boss-Extrude1 feature into Folder1. If you moved the freeze bar below Folder1, the software would not let you position it there, because Folder1 contains Sketch2, which is listed before Sketch1, in the design tree.

Now when you drag the freeze bar to Folder1, the software prompts you with a warning and temporarily unabsorbs Sketch1, so that it can freeze Folder1, Boss-Extrude1, and Sketch2. This behavior is consistent with how the rollback bar works with absorbed features.
Another enhancement is that the Feature command displays when you right-click any feature in the FeatureManager design tree. It displays after the Delete command in the shortcut menu.

Hole Wizard Options to Match Size or Preserve Settings

The sizing matching functionality for Hole Wizard, Hole Series, and Advanced Hole has improved to match hole sizes when changing from one hole type to another.

In Tools > Options > Hole Wizard/Toolbox, you can choose between two options for size matching:

- **Preserve settings for each Hole Wizard hole type** uses legacy behavior to save settings for each hole type. For example, if the size setting for tapped holes is M6, that setting is not affected by the size settings of other hole types. This behavior was used by SOLIDWORKS version 2015 and earlier releases.

- **Transfer settings when changing Hole Wizard Hole type** attempts to match the size settings of the last hole type used and the size settings available for the new hole type. Matching is done based on string comparison. This behavior is set by default for all new and upgrade installations to preserve the existing SOLIDWORKS version 2017 behavior.

  - Example 1: If you create a counterbore hole and set the size at M6, and then create a countersink hole, the M6 setting carries over to the new hole type.
  - Example 2: If you create a counterbore hole and set the size at M6, and then change it to a tapped hole, the M6 setting carries over to the new hole type setting it to M6x1.0. If multiple M6 tapped holes are listed (for example, M6x0.75 and M6x1.0), the first one listed (M6x0.75) will be matched.

In SOLIDWORKS Tools > Toolbox Settings, you can also customize size matching using the Name to Match column. For example, suppose the last hole you created was a ¼” ANSI inch counterbore hole, and in the Name to Match field you entered ¼” or M6. If you then switch to creating DIN counterbore holes, and there is a DIN counterbore hole with M6 in the Name to Match field, the hole size for DIN counterbore holes is set to M6.

The **Preserve settings for each Hole Wizard hole type** option is only available when using the Hole Wizard. Advanced Hole and Hole Series use the **Transfer settings when changing Hole Wizard Hole type** option at all times.

String matching is based on the following order of precedence:

<p>| IHT is an acronym for Initial Hole Type and FHT is an acronym for Final Hole Type. Special characters are ignored when performing a string in string match. |  |</p>
<table>
<thead>
<tr>
<th>String 1</th>
<th>String 2</th>
<th>Matching Method</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name to Match column (IHT)</td>
<td>Name to Match column (FHT)</td>
<td>Exact match, for example ¼” or M6 matched to ¼” or M6</td>
</tr>
<tr>
<td>Name to Match column (IHT)</td>
<td>Size Column (FHT)</td>
<td>Exact match, for example M6x1.0 matched to M6x1.0</td>
</tr>
<tr>
<td>Name to Match column (IHT)</td>
<td>Size Column (FHT)</td>
<td>String in string match, for example M6x0.75 matched to M6</td>
</tr>
<tr>
<td>Name to Match column (FHT)</td>
<td>Size Column (IHT)</td>
<td>String in string match, for example M6x0.75 matched to M6</td>
</tr>
<tr>
<td>Size column (IHT)</td>
<td>Size Column (FHT)</td>
<td>Exact match, for example M6 matched to M6</td>
</tr>
<tr>
<td>Size column (IHT)</td>
<td>Size Column (FHT)</td>
<td>String in string match, for example M6 matched to M6x1</td>
</tr>
<tr>
<td>Size column (FHT)</td>
<td>Size Column (IHT)</td>
<td>String in string match, for example M6x1 to M6</td>
</tr>
<tr>
<td>Size column (IHT)</td>
<td>Size Column (IHT)</td>
<td>Default to initial value, for example 1/8-27 NPSM matched to #0-80</td>
</tr>
</tbody>
</table>

**Mesh BREP Bodies**

Mesh BREP (boundary representation) bodies are made up of triangular polygons, called facets. Each facet has three vertices and three edges, referred to as fins.

The facets of a mesh BREP body can be collected into faces. These faces are similar to the faces in standard SOLIDWORKS BREP bodies, except that mesh faces do not have a geometric description. For example, the facets of a mesh face can make up a rectangle, but that face is defined simply as a collection of facets, not as rectangle with a height and width.

**Body Types Created from Mesh**

You can convert mesh files into three types of bodies:

- Standard SOLIDWORKS BREP bodies
- Mesh BREP bodies
- Graphics bodies

SOLIDWORKS BREP bodies are the standard bodies used in the SOLIDWORKS software. They can be solid or surface bodies. They do not include mesh surfaces. Every point on a face of these bodies can be determined with a mathematical equation.

Mesh BREP bodies can be solid or surface bodies. The bodies are made up of mesh facets. The facets can be grouped into faces. Facets can form a geometric shape such as a
rectangle, and the rectangle can have a BREP face associated with it, but not every point on every face can be determined with a mathematical equation.

Graphics bodies are defined entirely by their facets, without reference to equations. For example, what appears to be a circle in a graphics body is actually a large number of triangles, some of whose edges approximate the circumference of a circle. These mesh edges do not actually form a mathematical curve.

**Geometry Elements**

Mesh body types can include six geometric elements:

<table>
<thead>
<tr>
<th>Facets</th>
<th>Triangular faces of each unit of the mesh</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Facet Edges</strong></td>
<td>Edges or fins of the mesh facets</td>
</tr>
<tr>
<td><strong>Facet Vertices</strong></td>
<td>Vertices of mesh facets</td>
</tr>
</tbody>
</table>
BREP Faces  
Faces comprised of mesh facets

Edges  
Boundaries of mesh

BREP Vertices  
Vertices of the edges of mesh BREP faces

The edges of mesh BREP bodies may approximate mathematical curves, but do not have any geometric attributes.

**Workflows for Working with Mesh BREP Bodies**

There are three typical methods for working with mesh bodies:

- **Workflow #1**
  Import a mesh file (*.stl, *.obj, *.ply, *.ply2, or *.3MF) from a 3-D scanner, a mesh-based modeling software application or another CAD product, and convert it into a mesh BREP body.

- **Workflow #2**
  Import a mesh file (*.stl, *.obj, *.ply, *.ply2, or *.3MF) and convert it into a SOLIDWORKS graphics mesh body.

  Use the graphics mesh body as a physical or visual reference to design a model. You cannot modify or undo any revisions to a graphics mesh body.

- **Workflow #3**
Select a standard SOLIDWORKS BREP body, or a graphics closed or open body, and convert it to a mesh body. It is recommended that you complete all modifications to the SOLIDWORKS body first and convert it to mesh as the last step in the modeling process.

Working with Mesh

You can manipulate mesh geometry in a similar way as to how you work with SOLIDWORKS geometry and tools such as:

- Determine mass properties.
- Create reference planes for mesh BREP bodies (not graphics bodies).
- Select mesh vertices when sketching. Create sketch relations to a mesh facet vertex of a graphics body or a mesh BREP body.
- Measure distances between mesh elements, using the Measure tool.

You cannot create sensors for mesh bodies.

- Create section views.
- Trim surfaces.
- Shell, offset, and thicken mesh elements.
- Apply appearances and render.
- Detect interference.

Perform Boolean Operations

To combine, intersect, split, move, copy, and cut surfaces, you need to perform these tasks as Boolean operations; that is, create a solid volume before removing geometry.

You cannot combine or perform other Boolean operations on bodies with different geometry types. If you have standard SOLIDWORKS solid or surface bodies, you must convert them to BREP solid or surface bodies with mesh surfaces before performing Boolean operations with other mesh BREP bodies.

Options for Importing Mesh Files

Several system options are available for importing mesh files and converting them to mesh BREP bodies.

To import mesh files:

1. In Tools > Options > Import, under File Format, select one of the following:
   - STL/OBJ/OFF/PLY/PLY2
   - 3MF
2. Under Import as, select one of the following:
   - Solid Body
   - Surface Body
   - Graphics Body
3. Under **Mesh body options**, select one or both of the following for a solid body or surface body:
   - **Create mesh bodies bounded by single faces**
   - **Group facets into faces**

4. Click **OK**.
   If you select **Group facets into faces**, the software will attempt to group the mesh facets into selectable faces.

**Converting Solid, Surface or Graphics Bodies to Mesh**

You can convert a standard SOLIDWORKS body or graphics body to a mesh BREP body using the **Convert to Mesh Body** tool.

Because the tools for editing mesh BREP bodies are limited, you should do as much modeling as possible with the standard SOLIDWORKS BREP body before converting it to a mesh BREP body. After the conversion, you are limited to modifying the mesh BREP bodies using Boolean operations.

**To use the Convert to Mesh Body tool:**

1. With the standard SOLIDWORKS BREP body or graphic body open, click **Insert > Feature > Convert to Mesh Body**.

2. For **Selected Bodies**, select solid, surface, graphics closed, or open bodies.
   You cannot select mixed body types. You can only convert one body type at a time.

3. Make sure **Keep original body** is selected if you want to maintain a reference copy of the original solid or surface body in the model.

4. For graphics bodies, select **Group facets into faces** to group facets into multiple faces. The faces will match the faces of the original standard SOLIDWORKS BREP body. Clear the option if you want to convert the mesh into a single face.
5. Move the **Mesh Refinement** slider toward **Coarse** for fewer, larger facets on the mesh, and toward **Fine**, for more, smaller facets.

A preview of the mesh displays in the graphics area for the selected bodies.

---

**Coarse**

---

**Fine**

---

This option is useful if you have two standard SOLIDWORKS BREP bodies of significant different sizes. After you convert the first body to a mesh BREP body with facets of a certain size, you could convert the second standard SOLIDWORKS BREP body to a mesh BREP body, and adjust the mesh refinement, so that the mesh size of the second converted body is close to the mesh size of the first.

6. Instead of using the slider, you can adjust the facets in the mesh by:
   a) Selecting **Advanced Mesh Refinement** and specifying the **Maximum Distance Deviation** and **Maximum Angle Deviation** of the facets.
   b) Selecting **Define Maximum Element Size** and specifying the maximum length of the fins.

7. Click ![Check Mark].

The **Body-Convert to Mesh Body** feature is added to the FeatureManager design tree.

### Selection Filters for Mesh Bodies

The Selection Filter Toolbar lets you select and view the following geometric elements on mesh bodies:

- **Mesh facets**
Creating a Surface From Mesh Feature

The **Surface From Mesh** tool lets you manipulate a mesh object that you imported from an *.stl, *.obj, *.off, *.ply, *.ply2 or *.3MF file to create surfaces and solids.

The **Surface From Mesh** tool works best on mesh files with regular prismatic geometry such as planes, cylinders, cones, and spheres. The tool may not be appropriate for highly irregular meshes such as those created from a 3D scan of an organic shape. Because the feature only creates surfaces, the recommended workflow is to trim the surfaces to form a solid.

**To create a surface from mesh feature:**

1. In **Tools > Options > Import**, under **File Format**, select **STL/OBJ/OFF/PLY/PLY2** and click **Import as Graphics Body**. Then click **OK**.
2. Open a file of the format you just selected.

3. Click **Insert > Surface > Surface From Mesh**.
4. Under **Facets**, do the following:
   a) Clear **Dynamic Help** if you do not want to display detailed help.
   b) For surface type, select the type of surface you want to create. You can select either a **Planar**, **Spherical**, **Cylindrical**, or **Conical** surface.
   c) In the graphics area, select a group of facets to define the area of the surface you want to create by using the **Paint Select** tool.
      1. Access the tool by right-clicking **Selection Tools** in the graphics area and clicking **Paint Select Facets**.
      2. Press the left mouse button and hold while you drag the pointer and select the facets. The facets that intersect with the **Selection Circle** are highlighted.
      3. Adjust the radius of the **Selection Circle** by moving the slider or clicking the **Up** or **Down** arrow.
      4. To deselect facets, click **ALT + left mouse** button and drag the pointer over the facets you want to remove.
      5. Click ✓.

5. Adjust the **Facet tolerance** slider to include fewer mesh facets in the surface you are creating.

   Moving the slider left loosens the tolerance for the facets, while moving the slider right tightens the tolerance. For example, if you are attempting to create a plane, and there are three facets, one of which is at a slight angle to the other two, then a loose tolerance will include the angled facet in the plane, while a tight tolerance will exclude it.

6. Use the **Extend surface size**, setting to specify the extension distance of the surface body that fits the selected facets and geometric shape.
7. In the PropertyManager, click **Calculate**.
   A preview of the surface body displays in the graphics area.

8. Click ✓.
   The **Surface-From-Mesh** feature is added to the FeatureManager design tree.

You can continue to trim and knit the surfaces together to form a model.
Selecting Facets Using Paint Select

You can select groups of facets in the graphics area with the Paint Select Tool.

To select facets using paint select:
1. In the graphics area, select a mesh BREP body, right-click Selection Tools and click Paint Select Facets.
2. Press the left mouse button and hold while you drag the pointer and select the facets. The facets that intersect with the Selection Circle are highlighted.
3. Adjust the radius of the Selection Circle by moving the slider or clicking the Up or Down arrow.
4. To deselect facets, click ALT + left mouse button and drag the pointer over the facets you want to remove.
5. Click ✅.

List of Features Supporting Mesh BREP Bodies

The following tables list the functionality that supports solid, surface, and graphics mesh BREP bodies.

### Solid and Surface Mesh Type

<table>
<thead>
<tr>
<th>Function Type</th>
<th>Functionality</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Display</td>
<td>Apply an Appearance</td>
<td>Can apply appearance to the face, body, and part.</td>
</tr>
<tr>
<td></td>
<td>Apply a Decal</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Render in PhotoView</td>
<td></td>
</tr>
</tbody>
</table>
### Function Type |
<table>
<thead>
<tr>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Section View</strong></td>
</tr>
</tbody>
</table>

**Functionality**

- Supports all display modes (HLR, HLV, wireframe, shaded, shaded with edges)
  - Facets display shaded in edges mode.

**Evaluate**

- Clearance Detection
  - Mesh BREP bodies are included in clearance detection for an assembly.

- Interference Detection
  - Mesh BREP bodies are included in interference detection for an assembly.

**Geometry**

- Cavity

- Center of Mass

- Combine

- Convert to Mesh

- Split Line Curve and Project curve

- Cut with Surface
  - Applies to solid bodies only.

**Notes**

- Delete Body

- Delete Face
  - Only Face option available. Patch and Fill options are not available.

- Extend Surface
  - Only Distance as end condition and Linear as extension type apply.

- Intersect

- Isolate in shortcut menu

- Join

- Move and Copy Body
  - Can only use translate. Cannot use constraints to move and copy body.
### Function Type

<table>
<thead>
<tr>
<th>Function Type</th>
<th>Functionality</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Offset Surface</td>
<td>Resulting surface is mesh BREP.</td>
<td></td>
</tr>
<tr>
<td>Reference Plane</td>
<td>Supports mesh facets, facet vertices, and facet fins.</td>
<td></td>
</tr>
<tr>
<td>Save Bodies</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Scale</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Shell</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Split</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Split Line</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Surface From Mesh</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Thicken</td>
<td>Applies to surface only.</td>
<td></td>
</tr>
<tr>
<td>Trim Surface</td>
<td>Applies to surface only.</td>
<td></td>
</tr>
</tbody>
</table>

**Sketch**

<table>
<thead>
<tr>
<th>Function Type</th>
<th>Functionality</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Sketch Relations</td>
<td>Reference mesh BREP vertex in sketch</td>
<td>Ability to create coincident constraints for a sketch point by selecting a mesh edge or vertex. Mesh edges represent a sharp edge (created from groups of fins) and mesh vertex is a sharp vertex; that is, corner vertices from a combination of sharp edges. You cannot inference mesh facet faces and mesh fins in sketch commands. Also, you cannot use them to add sketch relations.</td>
</tr>
</tbody>
</table>

### Graphics Mesh Type

<table>
<thead>
<tr>
<th>Function Type</th>
<th>Functionality</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Display</td>
<td>Apply an Appearance</td>
<td>Can only apply appearance to the body or part.</td>
</tr>
</tbody>
</table>
### Enhancements to Importing Mesh Files as Graphics Bodies

When you import mesh files as graphics bodies, the SOLIDWORKS software now supports additional features.

- You can apply texture and appearances to mesh files that you import into SOLIDWORKS as graphics bodies.
- The imported graphics bodies are visible when you view them in HLR, HLV, and wireframe modes.
- The SOLIDWORKS software can render the imported graphics bodies along with solid and surface bodies.
- The imported graphics bodies can appear behind other geometry. Previously, they always appeared in the foreground even if the other geometry should have been displayed in front of the graphics bodies.
- Imported .3MF files that contain meshes with textures and appearances display the texture and appearances on the imported graphics bodies.

### More Control Over Custom Properties

You have more control over custom properties and cut list properties.

This functionality is available only when the part is created in SOLIDWORKS 2018.
Adding an @ Sign Before Quotation Marks

When you define a custom file property or cut list property that includes a single or double quotation mark (‘ or ”), type an @ sign in front of the quotation mark to ensure that the expression evaluates correctly.

The @ sign is required when the expression for the custom property includes a quotation mark to indicate inches, or references the name of a dimension, feature, sketch, cut list folder, weldment profile, annotation, bill of materials, or other entity that includes a quotation mark.

**To add an @ sign before quotation marks:**

1. In a part file, open the Cut List Properties dialog box by doing the following:
   a) In the FeatureManager design tree, expand **Cut list**.
   b) Right-click a cut list item and select **Properties**.
2. In the **Cut List Summary** tab, ensure that the top check box in the **Linked** column is clear.

   The **Link** column lets you select properties where the values and text in **Value/Text Expression** are linked to a parent part or a cut list folder.

   When the check boxes in the **Linked** column are clear, the values for **Value/Text Expression** become editable.

3. In **Value/Text Expression**, type an @ sign before each quotation mark, for example, 2@" X 2@" X 1/4@" and press **Enter**.

   The correct value appears in **Evaluated Value**.

   The @ sign also applies when referencing a **Property Name** that includes a quotation mark. For example, if you have a file property whose name is **Length12”**, you must add an @ sign in **Value/Text Expression** for that property.

Unlinking and Relinking Properties to a Parent Part

In the Custom Property dialog box, a new **Link** column lets you select properties where the text in **Value/Test Expression** can link to a parent part or a cut list folder. If the box in the **Link** column is clear, you can override the value in **Value/Test Expression**.

You can unlink one property at a time by clearing the link box for that property. You can also unlink all custom properties for a derived part by clearing the box at the top of the **Link** column and then enter new values for all properties.

The same logic applies to relinking. You can relink one property or all properties to the parent part. If the parent part is open, SOLIDWORKS automatically updates the **Value/Text Expression** with the value from the parent part.
If the parent part is not open when you relink the property, an (*) asterisk displays in the **Evaluated Value**, and a message, such as

*Calculated the next time the base part is opened

appears at the bottom of the dialog box. When you open the parent part again, the value updates and the message disappears.

In the **External References** dialog box, if **Break All** for the parent part is selected, then all links in a derived part are grayed out. You can enter new values for all properties, but you cannot relink properties to a parent part.
This chapter includes the following topics:

- **SOLIDWORKS Manage Overview**
- Project Management
- Process Management
- Item Management
- Dashboards and Reports

## SOLIDWORKS Manage Overview

SOLIDWORKS Manage is an advanced data management system that extends the global file management and application integrations enabled by SOLIDWORKS PDM Professional. SOLIDWORKS Manage is the key element in providing Distributed Data Management. This is accomplished by various functional areas:

- Project management
- Process management
- Item management
- Dashboards and reports

## Project Management

Project management provides information to help people focus on tasks and provides an overview of resource capacity for better planning and usage.

With project management, you can:

- Manage project stages, timelines, and milestones
- View resource usage and capacity
- Attach items and files and list deliverables
- Track progress with user tasks and timesheets
Process Management

Process management streamlines business processes and automates document creation. It also showcases new products to all involved stakeholders, from sales and marketing to production and support.

With process management, you can:
- Configure states and decision points for business processes
- Attach affected items and files
- Enable ad hoc approvers and user tasks

Item Management

Item management brings together all components required for product definition, whether represented by CAD models, documents, or items.

With item management, you can:
- Create, edit, and compare bills of materials (BOMs) using items and files
- Automatically or selectively create items for configurations in the SOLIDWORKS software
- Drive SOLIDWORKS drawing BOMs and item numbers

Dashboards and Reports

Dashboards and reports provide instant access to information in a readable format for better decision making.

With dashboards and reports, you can:
- Create interactive graphical dashboards to display critical information
- Configure reports to company standards and publish automatically or manually
This chapter includes the following topics:

- Adding Hardware to SOLIDWORKS CAD
- Component Movement in 3D CAD
- CST Integration
- IPC-Compliant Footprint Wizard
- DB Link
- PCB Services HTTPS Support
- Positioning Embedded Components
- Symbol Wizard
- Variant Collaboration

SOLIDWORKS PCB is available as a separately purchased product.

Adding Hardware to SOLIDWORKS CAD

You can add hardware (heat sinks, rails, and stiffeners) in the SOLIDWORKS software and push the hardware to SOLIDWORKS PCB using the SOLIDWORKS PCB Connector.

Component Movement in 3D CAD

Enhancements to SOLIDWORKS PCB eliminate potential ECAD data integrity issues during collaboration.

The Z-axis cannot change when you move components in the SOLIDWORKS software. Parts are mated to the surface of the board when moved, which eliminates the possibility to move a part above, below, or into a board.

If you move components with through holes, the hole locations update in SOLIDWORKS.
CST Integration

There is support to enable CST Integration through odb++ output.

IPC-Compliant Footprint Wizard

You can create IPC-compliant PCB footprints in a wizard. The set of productivity tools streamlines and automates footprint creation.

With the wizard, you can automatically generate footprints from dimension information according to IPC package standards. The wizard is based on formulas from the IPC-7351 standard.

DB Link

The DB link ensures component data integrity by using properties from an approved corporate database.

You can connect SOLIDWORKS PCB schematic parts to engineering or corporate databases of component and parametric data, such as:

- Procurement data
- Electrical parameters
- Device documentation

You can also transfer mapped information from database records to design component parameters.
PCB Services HTTPS Support

There is an additional layer of security for exchanging ECAD-MCAD data with SOLIDWORKS PCB Services.

SOLIDWORKS PCB Services has secure communication over networks using HTTPS protocol to protect data privacy and integrity. You can also install SOLIDWORKS PCB Services on a secure server.

Positioning Embedded Components

SOLIDWORKS PCB supports the correct positioning of embedded components when pushed from Altium Designer® to the SOLIDWORKS software through the SOLIDWORKS PCB Connector.

Symbol Wizard

The symbol wizard has productivity tools to streamline and automate symbol creation. The symbol wizard:

• Simplifies and quickens the symbol creation process, especially for large schematic devices.
- Is configured using grid-based, tabular data.
- Allows for copy, paste, and smart paste operations.

**Variant Collaboration**

You can align variations of electronic and mechanical base designs for a more accurate representation of form and fit.

SOLIDWORKS PCB Variants are expressed as configurations in the SOLIDWORKS software. Components marked as **Not installed** are suppressed.
This chapter includes the following topics:

- Automated Drawing PDF Creation in SOLIDWORKS PDM Standard
- Data Card Editor Undo
- Design Branching and Merging
- Detailed Warning Messages
- Enhanced Assignment of Explicit Folder Permission
- Enhanced File Version Upgrade Tool
- Enhanced Permission Control
- Quality Enhancements in SOLIDWORKS PDM
- Revision Table Integration
- Setting Dynamic Variable Values in Copy Tree
- SOLIDWORKS PDM Application Programming Interface
- SOLIDWORKS PDM Support for Non-SOLIDWORKS CAD File References

SOLIDWORKS® PDM is offered in two versions. SOLIDWORKS PDM Standard is included with SOLIDWORKS Professional and SOLIDWORKS Premium, and is available as a separately purchased license for non-SOLIDWORKS users. It offers standard data management capabilities for a small number of users.

SOLIDWORKS PDM Professional is a full featured data management solution for a small and large number of users, and is available as a separately purchased product.

Automated Drawing PDF Creation in SOLIDWORKS PDM Standard

SOLIDWORKS PDM Standard can convert a SOLIDWORKS Drawing file to PDF during a workflow transition using the same task technology used in SOLIDWORKS PDM Professional.

To provide access to the Convert task, you must add it to the vault by:

- Selecting the task when you create a new vault.
- Importing the task into an existing vault.
Configuring the Convert Task (For SOLIDWORKS PDM Standard only)

Administrators can configure the Drawing to PDF Convert task provided by the SOLIDWORKS Task Add-in to convert a SOLIDWORKS Drawing file to PDF. The task can map data card variables, and set the naming convention and destination for converted files.

To configure the Drawing to PDF Convert task:
1. In the Administration tool, expand Tasks and double-click Convert.
2. In the dialog box, in the left pane, click Execution Method.
3. Select the client computers that can be used to execute the task and how task execution is initiated.
   You must configure each client computer as a task host to appear in the list and run the Drawing to PDF Convert task on the computer where you initiate the workflow transition.
   Each client computer must have a licensed version of SOLIDWORKS to initiate the task.
4. Click Conversion Settings > Conversion Options to display the output file format's Advanced Conversion Options (Adobe PDF) dialog box.
   The only output file format available is Adobe PDF (default).
5. Under Source file references, specify the version of referenced files to convert.
6. Click File Card to map variables from the source file’s data card to the output file’s data card.
7. Click Output File Details to specify the output file name format and destination.
   You can specify only the output paths that are inside the vault.
8. Click OK.

Converting a SOLIDWORKS Drawing File to PDF

To convert a SOLIDWORKS Drawing file to PDF:
1. In the Administration tool, configure the Convert task.
2. Edit a workflow transition to add an action to execute the Drawing to PDF Convert task.
   When you change the state of a SOLIDWORKS Drawing file using a transition on which the Drawing to PDF Convert task is set, SOLIDWORKS PDM runs the task. The task:
   a. Launches a SOLIDWORKS session on the client computer.
   b. Opens the SOLIDWORKS Drawing file.
   c. Saves the file as PDF.
Data Card Editor Undo

SOLIDWORKS PDM lets you undo the changes done in the Card Editor for an active card. Previously, to undo the changes, you had to close and reopen the card without saving.

To undo the card editor changes, do one of the following:
• Click Edit > Undo.
• Click Undo in the Main toolbar.
• Ctrl + Z.

You can undo the data card changes only if you have not saved the changes.

SOLIDWORKS PDM supports undo for:
• Modifying cards using control properties and card properties.
• Adding and deleting card controls.
• Moving and resizing card controls.

You cannot redo the data card changes that Undo discards.

Design Branching and Merging

SOLIDWORKS PDM Professional has improved handling of various design change scenarios including multiple design improvement approaches, engineering change requests, and working with external design consultants.

Branching an existing file structure is similar to Copy Tree, but SOLIDWORKS PDM Professional maintains the history of source files and branched files. You can create new versions of the source files from the modified versions of branched files regardless of whether they have been moved or renamed.
Branching functionality lets you create complete or partial copies of a file structure with different names and place them in one or more folders. Placing the files into multiple folders lets you edit the branched files, retaining the source files in their original state and permission status. If the edits are approved, you can create new versions of the source files. Otherwise, you can delete the branched files.

### Branching Settings

You can branch a single file or a file with its references. After branching, the source file history and branched file history are updated.

Administrators can also set user and group properties to exclude selected folders from branching. The files in the excluded folders are not available for branching.

In the Administration tool, on the Settings - Branch page, you can select the following predefined variables from the list to update the variable values.
In the file list, right-click a branched file and select **Associated Branches** to list all the branches the file is a part of. Click a branch from the list to see the branch details.

## Branch Dialog Box

The Branch dialog box is similar to the Copy Tree dialog box and lets you copy selected file references, or retain the existing references.

If your administrator has excluded a folder from branching, a message appears in the **Warnings** column and the **Branch** option is unavailable.

**To display the Branch dialog box:**

- Select a file and click **Tools > Branch**.

### Branch Name

Enter a branch name.

You must enter a unique branch name.

### Default Destination

Displays the current folder location of the selected file. You can enter a new path or browse to specify the destination path for the folder in the vault.

### Settings

This group is a collapsible interface that includes:
### Version to Use

<table>
<thead>
<tr>
<th>Version</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Latest</td>
<td>Uses the latest version of the references for branching.</td>
</tr>
<tr>
<td>Referenced</td>
<td>Uses the attached version of the references for branching.</td>
</tr>
</tbody>
</table>

### Options

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Include simulation</strong></td>
<td>Branches SOLIDWORKS Simulation results associated with the selected files.</td>
</tr>
<tr>
<td><strong>Preserve relative paths</strong></td>
<td>Keeps the paths of references relative to the branched parent file, creating a folder structure as needed. When you clear <strong>Preserve relative paths</strong>, the folder hierarchy is flattened and all referenced files are branched to the same destination folder as the parent.</td>
</tr>
<tr>
<td><strong>Include drawings</strong></td>
<td>Shows any related drawing files in the file list so you can include them when branching the reference tree.</td>
</tr>
<tr>
<td><strong>Regenerate serial number in cards</strong></td>
<td>If serial numbers are used in data cards, assigns the next number in the sequence. For <strong>Rename with serial number</strong> transformations, the same serial numbers used to name the files are used in data cards.</td>
</tr>
<tr>
<td><strong>Name drawings after their models</strong></td>
<td>Sets drawing file names to the same as their associated assembly or part file names.</td>
</tr>
</tbody>
</table>
**Transform Operations**  
Modifies the file names of selected files using the transformation you select.

**Add Prefix**  
Adds the prefix you type to the file names.

**Add Suffix**  
Adds the suffix you type to the file names.

**Rename with serial number**  
Replaces file names with serial numbers.  
Only available when serial numbers are defined in the Administration tool.

**Replace**  
Replaces strings in file or folder names. In the Replace dialog box:
1. For **Find what**, type the string to replace.
2. For **Replace with**, type the replacement string.
3. Select whether to apply the change to all files or only the selected files.
4. Select to apply the change to file names, folder names, or both.

**Filter Display**  
Enter text to refine the list of files displayed. Use the column selection drop-down to limit the filtering to a specific column. For example, limit the columns to **File name**, or **All Columns**.

By default, the filter is applied to **All Columns**. You can expand the **All Columns** list and select a specific column to apply the filter to. The software searches for the text that you enter, displays rows that contain the text, and highlights the text for identification.

The search field supports these wildcard characters: *, ?, %, -, ., "".  

<table>
<thead>
<tr>
<th>*string</th>
<th>Displays rows that contain text that ends with the entered string. The string in the filtered rows is highlighted in pink.</th>
</tr>
</thead>
<tbody>
<tr>
<td>string*</td>
<td>Displays rows that contain text that starts with the entered string. The string in the filtered rows is highlighted in pink.</td>
</tr>
</tbody>
</table>

Instead of *, you can use ? or %.
-string or string- Displays rows that contain the entered string. If the hyphen is at the beginning, the text ending with the string is highlighted in pink. If the hyphen is at the end, the text starting with the string is highlighted.

"string or string" Displays rows that contain the entered string. The string in the filtered rows is highlighted in pink.

.string or string. Displays rows that contain the entered string and highlights the string with a preceding or a succeeding character depending on the position of the dot.

The filter options include:

**Invert Filter** or ! You can invert the filter by clicking or by entering the ! character as a prefix to the text in the search field. Files that do not include the entered text are displayed.

**Filter**
- File Type
  - Assemblies
  - Parts
  - Drawings
  - Others
- Selected For Branch
  - Yes, Selected
  - No, Not Selected
- Path/Name Changed
  - Yes, Changed
  - No, Not Changed
Filters the file list based on the text you enter and the column you select. You can select one of the following columns:

- Source File Name
- Warnings
- Version
- Checked Out By
- Checked Out In
- Source File Found In
- Branch File Found In
- Branch File Name
- State
- All Columns

This filter supports all custom columns that appear in the file list.

Removes all filters. This appears when you select an option in Filter.

Next Warning/Previous Warning

In the file list, changes the focus to the next file with a warning or the previous file with a warning.

Levels

Displays file references for the entire file hierarchy (Show All Levels) or just the top level of the file hierarchy (Top Level Only).

The setting defaults to the most recent setting you used.

Open File List

Open All opens a list of files in Microsoft Excel.

Open Visible opens a list of visible files in Microsoft Excel.

Save File List

Export All exports the file list of all files as comma-separated .txt file.

Export Visible exports the list of visible files as a comma-separated .txt file.
File List

To change the columns that are displayed, right-click any column heading and select columns to display them or clear columns to hide them. You can add up to 10 columns based on variables by clicking **More** and choosing variables from the Choose Columns dialog box.

You can sort the default and custom columns in tables in ascending, descending, or default order by clicking column headers. Column sorting is useful within large datasets. If you sort a column in ascending or descending order, the column is highlighted in green and an arrowhead appears. When you sort a column in a table, SOLIDWORKS PDM removes the file structure hierarchy. Sorting turns off **Show Tree Lines** and **Show Reference Selection Control**.

Drag a column head to change the position of a column.

<table>
<thead>
<tr>
<th><strong>Type</strong></th>
<th>Displays a thumbnail preview of the file when you hover over the file type icon.</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Source File Name</strong></td>
<td>Displays the source file name.</td>
</tr>
<tr>
<td><strong>Warnings</strong></td>
<td>Displays the warnings.</td>
</tr>
<tr>
<td></td>
<td>To quickly locate files with warnings or errors, use the <strong>Next Warning</strong> and <strong>Previous Warning</strong> toolbar buttons or <strong>Ctrl</strong> + the up-arrow or down-arrow on the numeric keypad.</td>
</tr>
<tr>
<td><strong>Branch</strong></td>
<td>Lets you select the files to branch.</td>
</tr>
<tr>
<td><strong>Version</strong></td>
<td>The first number is the local (cached) version of a source file or a hyphen (-) if locally modified. The second number is the latest version in the vault.</td>
</tr>
<tr>
<td><strong>Checked Out By</strong></td>
<td>User who has the source file checked out, or blank if not checked out.</td>
</tr>
<tr>
<td><strong>Checked Out In</strong></td>
<td>Path to computer and local folder where the source file is checked out, or blank if not checked out.</td>
</tr>
<tr>
<td><strong>Source File Found In</strong></td>
<td>Path to the folder that contains the source file.</td>
</tr>
<tr>
<td><strong>Branch File Found In</strong></td>
<td>Lets you change the path to a folder for the branched file.</td>
</tr>
<tr>
<td></td>
<td>The folder must be in the vault.</td>
</tr>
<tr>
<td><strong>Branch File Name</strong></td>
<td>Lets you change the branched file name.</td>
</tr>
<tr>
<td><strong>State</strong></td>
<td>State of the source file.</td>
</tr>
</tbody>
</table>
Check-in after branching

Checks in files on branching.
You can optionally enter the check-in comments.

Total to Branch

Displays the number and type of files you have selected for branching.

The warning ⚠ indicates that other files are selected for branching but do not appear in the file list because of the current filter.

Reset All

Resets all the changed file names and changed destination folder paths to default.

Merging Settings

In the Administration tool, on the Settings - Merge page, you can select the following predefined variables from the list to update the variable values.

<table>
<thead>
<tr>
<th>Branch File Name</th>
</tr>
</thead>
<tbody>
<tr>
<td>Branch File Name without extension</td>
</tr>
<tr>
<td>Branch File Path</td>
</tr>
<tr>
<td>Current time</td>
</tr>
<tr>
<td>Logged in user</td>
</tr>
<tr>
<td>Source File name</td>
</tr>
<tr>
<td>Source File name without extension</td>
</tr>
<tr>
<td>Source File path</td>
</tr>
<tr>
<td>Today's date</td>
</tr>
<tr>
<td>Use from Branch File</td>
</tr>
<tr>
<td>Use from Source File</td>
</tr>
<tr>
<td>User - Full name</td>
</tr>
<tr>
<td>User - initials</td>
</tr>
<tr>
<td>User - User data</td>
</tr>
</tbody>
</table>
Merge Dialog Box

The Merge dialog box lets you merge the branched file with the source file using different merging options.

**To display the Merge dialog box:**
- Select a branched file and click **Tools > Merge.**

**Settings**

<table>
<thead>
<tr>
<th>Branch References</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Latest</strong></td>
<td>Uses the latest version of the branched file for merging.</td>
</tr>
<tr>
<td><strong>Referenced</strong></td>
<td>Uses the attached version of the branched file for merging.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>New File Options</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Applicable for files that are newly created using merge option.</td>
<td></td>
</tr>
</tbody>
</table>

**Include simulation**
Merges SOLIDWORKS Simulation results associated with the selected files.

**Include drawings**
Shows any related drawing files in the file list so you can include them when merging the reference tree.

**Regenerate serial number in cards**
If serial numbers are used in data cards, assigns the next number in the sequence. For **Rename with serial number** transformations, the same serial numbers used to name the files are used in data cards.

**Name drawings after their models**
Sets drawing file names to the same as their associated assembly or part file names.
**Transform Operations**

Modifies the file names of selected files using the transformation you select. Applicable for files that are newly created using merge option.

**Add Prefix**

Adds the prefix you type to the file names.

**Add Suffix**

Adds the suffix you type to the file names.

**Rename with serial number**

Replaces file names with serial numbers.

- Only available when serial numbers have been defined in the Administration tool.

**Replace**

Replaces strings in file or folder names. In the Replace dialog box:

1. For **Find what**, type the string to replace.
2. For **Replace with**, type the replacement string.
3. Select whether to apply the change to all files or only the selected files.
4. Select to apply the change to file names, folder names, or both.

---

**Filter Display**

Lets you enter text to refine the list of files displayed. A column selection drop-down lets you limit the filtering to a specific column, for example, **File name**, or for **All Columns**.

By default, the filter is applied to **All Columns**. You can expand the **All Columns** list and select a specific column to apply the filter to. The software searches for the text that you enter, displays rows that contain the text, and highlights the text for easy identification.

The search field supports these wildcard characters: *, ?, %, -, ., "."

- **"string"**
  
  Displays rows that contain text that ends with the string. The string in the filtered rows is highlighted in pink.

- **string***
  
  Displays rows that contain text that starts with the string. The string in the filtered rows is highlighted in pink.

  Instead of *, you can use ? or %.
| **-string or string-** | Displays rows that contain the string.  
If the hyphen is at the beginning, the text ending with the string is highlighted in pink. If the hyphen is at the end, the text starting with the string is highlighted.

| **"string or string"** | Displays rows that contain the string. The string in the filtered rows is highlighted in pink.

| **.string or string.** | Displays rows that contain the string and highlights the string with a preceding or a succeeding character depending on the position of the dot.

The filter options include:

| **!** | You can invert the filter by entering character ! as a prefix to the text in the search field.  
Files that do not include the entered text are displayed.

### Filter

- **File Type**
  - Assemblies
  - Parts
  - Drawings
  - Others

- **Selected For Merge**
  - Yes, Selected
  - No, Not Selected

- **Path/Name Changed**
  - Yes, Changed
  - No, Not Changed
Filters the file list based on the text you enter and the column you select. You can select one of the following columns:

- Branch File Name
- Branch File Version
- Branch File Found In
- Branch File Checked Out By
- Branch File Checked Out In
- Branch File State
- Warnings
- Merge
- Merge Option
- Source File Name
- Source File Found In
- Source File Checked Out By
- Source File Checked Out In

This filter supports all custom columns that appear in the file list.

Clear Filter Text

Removes all filters. This appears when you select an option in Filter.

Toolbar Buttons

Next Warning/Previous Warning

In the file list, changes the focus to the next file with a warning or the previous file with a warning.

Levels

Displays file references for the entire file hierarchy (Show All Levels) or just the top level of the file hierarchy (Top Level Only).

The setting defaults to the most recent setting you used.

Open File List

Open All opens a list of files in Microsoft Excel.
Open Visible opens a list of visible files in Microsoft Excel.
Save File List

Export All exports the file list of all files as comma-separated .txt file.

Export Visible exports the list of visible files as a comma-separated .txt file.

File List

To change the columns that are displayed, right-click any column heading and select columns to display them or clear columns to hide them. You can add up to 10 columns based on variables by clicking More and choosing variables from the Choose Columns dialog box.

You can sort the default and custom columns in tables in ascending, descending, or default order by clicking column headers. Column sorting is useful within large datasets. If you sort a column in ascending or descending order, the column is highlighted in green and an arrowhead appears. When you sort a column in a table, SOLIDWORKS PDM removes the file structure hierarchy. Sorting turns off Show Tree Lines and Show Reference Selection Control.

Drag a column head to change the position of a column.

<table>
<thead>
<tr>
<th>Type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Branch File Name</td>
<td>Displays the branched file name and its references.</td>
</tr>
<tr>
<td>Branch File Version</td>
<td>The first number is the local (cached) version of a branched file or a hyphen (-) if locally modified. The second number is the latest version in the vault.</td>
</tr>
<tr>
<td>Branch File Found In</td>
<td>Path to the folder that contains the branched file.</td>
</tr>
<tr>
<td>Branch File Checked Out By</td>
<td>User who has the branched file checked out, or blank if not checked out.</td>
</tr>
<tr>
<td>Branch File Checked Out In</td>
<td>Path to computer and local folder where the branched file is checked out, or blank if not checked out.</td>
</tr>
<tr>
<td>Branch File State</td>
<td>State of the branched file.</td>
</tr>
<tr>
<td><strong>Warnings</strong></td>
<td>Displays the warnings 🔴 specific to source files and branched files. For multiple warnings for a file, a hyperlink appears. You can click the link to see the details of the warnings.</td>
</tr>
<tr>
<td>--------------</td>
<td>--------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td></td>
<td>To quickly locate files with warnings or errors, use the <strong>Next Warning</strong> and <strong>Previous Warning</strong> toolbar buttons or <strong>Ctrl</strong> + the up-arrow or down-arrow on the numeric keypad.</td>
</tr>
<tr>
<td></td>
<td><strong>You can complete the merge action only after you resolve the critical warnings.</strong></td>
</tr>
<tr>
<td><strong>Merge</strong></td>
<td>Lets you select files to merge.</td>
</tr>
<tr>
<td></td>
<td>If the <strong>Merge</strong> check box is not selected for a file, the references from the branched file are retained as they are, after the merge action.</td>
</tr>
</tbody>
</table>
**Merge Option**

**Merge**
Selected by default for the branched file that is modified. Creates a new version of a source file when a branched file is checked in through the Merge user interface. You can keep the file checked out and check it in later.

You must have read file permission and check out file permission for the source file.

**Use Source Reference**
Selected by default for the unmodified branched file only if its immediate parent file is selected to merge. SOLIDWORKS PDM repoints the reference to the source file after the merge action.

If Always work with the latest version of files is selected, SOLIDWORKS PDM repoints the reference to the latest version of the source file. You must have read file permission for the latest version.

If Always work with the latest version of files is cleared, the merge action repoints the reference to the version of the source file that is used during branching.

If this version is not available or in cold storage, or does not provide read access, the merge action repoints the reference to the latest version that has read-file permission.

**Merge As New File**
Available for a branched file. The parent file refers to the new file after the merge action. You must have the add or rename file permission for the vault folder that contains the new file.

By default, the Source File Name is the name of the branched file and its target location is the parent file location. You can change the file name and its target location.

**Create New File**
Available for the file that is not branched but is a part of the reference tree. You must have the add or rename file permission for the vault folder that contains the new file. The parent file refers to the new file after the merge action.

By default, the Source File Name is the name of the branched file and its target location is the parent file location. You can change the file name and its target location.
Source File Name: Lets you change the source file name only if the Merge Option is set to Merge As New File or Create New File.

Source File Found In: Lets you change the path to the vault folder that contains the source file only if the Merge Option is set to Merge As New File or Create New File.

Source File Checked Out By: User who has the source file checked out, or blank if not checked out.

Source File Checked Out In: Path to folder where the source file is checked out, or blank if not checked out.


Check-in on Merge

Checks in files on merging.
You can optionally enter the check-in comments.

Total to Merge

Displays the number and type of files you have selected for branching.

The warning indicates that other files are selected for branching but do not appear in the file list because of the current filter.

Reset All

Resets all the changed file names and changed destination folder paths to default.

Detailed Warning Messages

SOLIDWORKS PDM now provides more-detailed warning messages when a transition fails.
If one or more conditions are not met, the Warnings column displays:
- A warning in case of one failed condition.
- A hyperlink in case of multiple failed conditions or all failed OR conditions.
You can click the hyperlink to see the details of the conditions that are not met. Based on the conditions defined in the transition, the warning includes details like condition type, comparison criteria, value, and configuration details.

**Enhanced Assignment of Explicit Folder Permission**

SOLIDWORKS PDM lets you set explicit folder permissions on multiple folders at the same time.

Previously, you could set explicit permissions on one selected folder at a time.

On the Assigned Folder Permissions tab, to select multiple folders, do one of the following:

- **Shift** + click
- **Ctrl** + select
- Left-drag

The **Folder Permissions** area displays the assignable permissions. The status of check box changes as the folder permission assigned to selected folder changes.

<table>
<thead>
<tr>
<th>Check box status</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>✔️ (Selected)</td>
<td>Permission is set to all selected folders.</td>
</tr>
<tr>
<td>☐️ (Green)</td>
<td>Permission is set to one or more selected folders, but not all.</td>
</tr>
<tr>
<td>☐️ (Cleared)</td>
<td>Permission is not set to any selected folder.</td>
</tr>
</tbody>
</table>

**Enhanced File Version Upgrade Tool**

In the SOLIDWORKS PDM File Version Upgrade tool, vault analysis and upgrade are now quicker.

The enhancements in the upgrade tool let you:

- Upgrade the checked out files on other client workstations.
- Add or remove folders to upgrade.
- Sort the file list in Search Results.
- Stop the upgrade process and resume.
- View the summary of the file versions to upgrade.
- Monitor the upgrade process.
- Notify users about the upgrade process.

**Upgrade Tool Behavior for Checked out Files**

You can upgrade the checked out file and its references if the file is checked out on a machine other than the host machine.

You can upgrade the checked out file when:
Creating new versions of files
Overwriting existing versions of files

The following table describes the file handling of checked out file and its references:

<table>
<thead>
<tr>
<th>Option</th>
<th>Action on checked out file</th>
<th>Action on parent references</th>
<th>Action on child references</th>
</tr>
</thead>
<tbody>
<tr>
<td>Create new versions of files</td>
<td>Skip the file</td>
<td>Upgrade the latest version of the parent file</td>
<td>Upgrade the latest version of the child references</td>
</tr>
<tr>
<td>Overwrite existing versions of files</td>
<td>Upgrade all versions of the file</td>
<td>Upgrade all versions of the parent file</td>
<td>Upgrade all versions of the child references</td>
</tr>
</tbody>
</table>

You cannot upgrade the checked out file and its references if the file is checked out on the host machine.

When using **Overwrite existing versions of files** option, the upgrade tool does not check out the file, and the file is accessible to other users.

**File Version Upgrade Summary**

The upgrade tool shows the summary of the file versions to upgrade on the Ready to Upgrade Files screen.

The summary displays the following:
- Total number of SOLIDWORKS versions to update.
- Number of SOLIDWORKS part file versions.
- Number of SOLIDWORKS drawing file versions.
- Number of SOLIDWORKS assemblies file versions.
- Work instruction file names.
- Number of files in each work instruction file.

**Monitoring the Upgrade Process**

*To monitor the upgrade process, do one of the following:*
- On the Welcome screen, click **Monitor upgrade process.**
- Initiate the upgrade process and, on the Ready to Upgrade Files screen, click **Monitor.**

The Monitor upgrade screen displays the overall upgrade process progress and the upgrade progress of each work instruction file.
### Notifying Users About the Upgrade Process

SOLIDWORKS PDM notifies users whenever the upgrade process is started, paused, resumed, completed, or has failed.

**To notify users about the upgrade process:**
1. On the Upgrade Settings screen, select **Notify success/failure to users**.
2. Click **Add** and select the users to be notified.

SOLIDWORKS PDM sends notification emails to the designated users based on the status of work instruction files.

### Enhanced Permission Control

The Admin user can allow users to undo check out or check in the files that are checked out by another user.

The administrative permission, **Can undo check out files checked out by other users**, is selected by default for the Admin user.

With this permission, users can do the following to the files checked out by other users:
- Undo the Check out or Check in of files on the same machine and in the same vault view.
- Undo the Check out of files on a different machine and in a different vault view.

When a user does undo check out to a file checked out by another user, the details are added in history.

Previously, only administrators could undo the check out or check in of files that are checked out by another user.

### Quality Enhancements in SOLIDWORKS PDM

You can open the search results from the embedded Windows Explorer search tool in Microsoft Excel or export them as a comma-separated value (.csv) file. The **Open search result** and **Export search result** commands are available on the Search toolbar.

Click to export the search results as a comma-separated value (.csv) file. Click to open the search results in a Microsoft Excel spreadsheet.
You can copy links of files and paste them to notification messages to your colleagues. Right-click a file, select **Copy Link**, and paste the link in the new message. When you click the link, SOLIDWORKS PDM navigates you to the appropriate file in the vault.

In the Administrative Export File dialog box, you can expand or collapse specific nodes or all nodes. To expand or close all nodes, right-click a node or in the dialog box and select **Expand All Nodes** or **Close All Nodes**. When you remove the specific setting or variable, the expanded or collapsed structure is retained.

SOLIDWORKS PDM provides the `_SW_Last_Saved_With_` variable that provides mapping between the **Summary** block name and **Last Saved With** attribute name for slddrw, sldasm, and sldprt files. SOLIDWORKS PDM updates the value of the variable whenever you check in a file. In the Administration tool, in the Customizable Columns dialog box, you can select this variable to add a column in the file list or search result for specific users. You cannot delete this variable.

**Revision Table Integration**

SOLIDWORKS PDM can now read and write values from or to a SOLIDWORKS revision table. You can configure SOLIDWORKS PDM variables to automatically add information such as revision date, description, and approver to a new row in the table or to update the last row.

When you change the mapped variable values in the file's data card, the values in the latest row of the table are updated and vice versa.

The revision table row can be updated automatically by using:

- Set variable transition actions
- Set Revision command

**Configuring Revision Table Integration**

**To configure revision table integration:**

1. Configure the mapping between SOLIDWORKS PDM variables and revision table columns in the SOLIDWORKS drawing.
   
   For details, see **SOLIDWORKS PDM Administration Guide: Mapping Variables to File Properties**.

2. Configure the **Revision Table** node.

3. Set a variable that holds the custom property revision.
   
   You must set the Revision variable for the current state of a file during the set revision action and for the target state of a file during the change state action. For details, see **SOLIDWORKS PDM Administration Guide: Set Variables Dialog Box**.

4. Define the Set Variable transition actions for each variable.
   
   You need not define the Set Variable transition action for the Zone variable as it is read-only.
Configuring the Revision Table Node

You must configure the Revision Table node to update the revision table rows.

To configure the revision table node:
1. In the Administration tool, expand SOLIDWORKS and double-click Revision Table.
2. Select Enable Revision Table to manage the revision table by SOLIDWORKS PDM.
3. Set the values on the Revision Table Settings and Set Revision Command Settings tabs.
4. Click OK.

Configuring the Revision Table Settings

You can set options on the Revision Table Settings tab.

To configure the Revision Table Settings:
1. Open the Revision Table dialog box.
2. On the Revision Table Settings tab, set the number of visible rows in the revision table.
3. In the Revision placeholder character, enter a placeholder character or characters.

Configuring the Set Revision Command Settings

You can set options on the Set Revision Command Settings tab to update the revision table when you use the Set Revision command.

In the File Explorer, in the Set Revision dialog box, you must select Update Variable to update the revision table.

To configure the Set Revision Command Settings:
1. Open the Revision Table dialog box and select the Set Revision Command Settings tab.
2. Select Update Revision Table in SOLIDWORKS Drawing through "Set Revision" Command.
3. Select a check box under the Revision Table Column for a variable to appear in the revision table.
4. Enter a value under Column Value.
   You can click to select the system variable.
5. Select a corresponding variable under Variable Name.
6. Click OK.
Defining Variable Mapping

You can configure the mapping between SOLIDWORKS PDM variables and revision table columns in SOLIDWORKS drawings.

To configure the variable mapping:
1. Expand the **Variables** node and edit the variables.
   You can edit the current variables, **Approved by**, **Description**, **Date**, **Revision**, or create new variables. You must create the **Zone** variable as read-only because the value of this variable is read from the drawing.
2. In **Variable name**, type a name.
3. Set the **Variable type** as **Text**.
4. In **Block name**, type **SWRevTable**.
5. In **Attribute name**, select the attribute name.
   For a custom column, you must type the attribute name that is the same as the revision table column header.
   When you use the SWRevTable block for the default revision table column, you can select the attribute name from the list.
6. Type the file extension, **slddrw**, and click **OK**.

Revision Table Dialog Box

To open the Revision Table dialog box:
- Expand the **SOLIDWORKS** node and double-click **Revision Table**.

Enable Revision Table
Select this option to manage the SOLIDWORKS drawing revision table using SOLIDWORKS PDM.

When revision tables are enabled in SOLIDWORKS PDM, the SOLIDWORKS **Alpha/numerical control** options are not available for Revision Table in **Tools > Options > Document Properties > Tables > Revision**. A message, **Revision driven from SOLIDWORKS PDM** appears in the SOLIDWORKS Tables Options dialog box.

Revision Table Settings

<table>
<thead>
<tr>
<th><strong>Number of visible rows</strong></th>
<th>Sets the number of rows to display in the drawing revision table.</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>When the number of revision table rows in a drawing exceeds the set number, the oldest row is deleted.</td>
</tr>
</tbody>
</table>
**Revision placeholder character(s)**

Lets you enter characters that appear in the revision column of the revision table. The actual revision value replaces these characters when you change the revision in SOLIDWORKS PDM.

It is mandatory to enter one or more placeholder characters. The placeholder characters must be between 1 and 5 characters in length.

---

**Set Revision Command Settings**

**Update Revision Table in SOLIDWORKS Drawing through "Set Revision" Command**

Updates the revision table when you:

- Define the Set Revision action.
- Select **Update Variable** in the File Explorer in the Set Revision dialog box.

Select a check box to display a variable as a revision table column in the revision table.

<table>
<thead>
<tr>
<th>Revision table column</th>
<th>Column value</th>
<th>Variable Name</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Revision</strong></td>
<td>By default, set to revision value set with Set Revision action.</td>
<td>Select the mapped variable, <strong>Revision</strong>.</td>
</tr>
<tr>
<td><strong>Description, Date, Approver</strong></td>
<td>Click 🗂️ to select a variable to be added to the column. You can also type the text.</td>
<td>Select the variable.</td>
</tr>
</tbody>
</table>

---

**Setting Dynamic Variable Values in Copy Tree**

With the enhanced Copy Tree variable settings, it is possible to update variables with dynamic values. You can set dynamic variable values in the Settings dialog box - Copy Tree page.

Previously, you could only use static values.

**To set dynamic variable values in Copy Tree:**

1. In the Administration tool, in the Settings dialog box - Copy Tree page, under **File types**, click **Add**.
2. Click **Add Variable** and select predefined variables from the list.

3. For **Value**, click ➔ to select a dynamic value. The following dynamic values are available:

- Current time
- File Name
- File name without extension
- File Path
- Logged in user
- Target File Name
- Target File name without extension
- Target File Path
- Today’s date
- User - Full name
- User - initials
- User - User data

### SOLIDWORKS PDM Application Programming Interface

See *SOLIDWORKS API Help: Release Notes* for late-breaking updates.

SOLIDWORKS PDM 2018 API includes the ability to:

- Add a custom tab to PDM vault views:
  - Customers and third-party users can add custom tabs to PDM vault views in Windows Explorer using a PDM API add-in.
  - API hooks to third-party development code can display special items in these custom tabs.
  - Add-ins can implement custom tabs with custom names and icons.
  - Add-ins can add any number of custom tabs to the vault view in Windows Explorer.
  - Add-ins can programmatically remove custom tabs.
- Programmatically refresh a data card when its card variables change.
- Restore deleted files from the Recycle Bin.
- Select the transition to use when changing a file’s state.
- Specify whether to batch update only the variables that are part of the file data card.
- Get a list of values associated with a drop-down control on a data card.
- Provide more IEdmSearch comparators.
SOLIDWORKS PDM Support for Non-SOLIDWORKS CAD File References

SOLIDWORKS PDM supports the handling of references between SOLIDWORKS files and non-SOLIDWORKS CAD data created through 3D Interconnect.

You must add the non-SOLIDWORKS CAD files to the vault at the beginning so that they are referred from the file vault.

SOLIDWORKS PDM recognizes the non-SOLIDWORKS CAD references during check in of the parent SOLIDWORKS part or assembly and lists them as CAD references after check in is complete. You do not have to create any user-defined references. The CAD references are listed in the Contains tab, Bill of Materials tab, Where Used tab, and in any operation that lists the reference tree. This is true for both the parent SOLIDWORKS file and any parent non-SOLIDWORKS file.

For example, when you check in a SOLIDWORKS assembly along with an Inventor sub-assembly that is inserted in it, SOLIDWORKS PDM establishes PDM references between parent and its first level of child references. This also includes references between Inventor subassembly and its parts.

SOLIDWORKS PDM supports the following file formats through 3D Interconnect:

<table>
<thead>
<tr>
<th>File format</th>
<th>Extension</th>
</tr>
</thead>
<tbody>
<tr>
<td>Autodesk® Inventor</td>
<td>IPT, IAM</td>
</tr>
<tr>
<td>CATIA® V5</td>
<td>CATPART, CATPRODUCT</td>
</tr>
<tr>
<td>PTC®/CREO</td>
<td>PRT, PRT., XPR, ASM, ASM., XAS</td>
</tr>
<tr>
<td>Siemens™ NX</td>
<td>PRT</td>
</tr>
<tr>
<td>SOLID Edge®</td>
<td>PAR, PSM, ASM</td>
</tr>
</tbody>
</table>

This integration does not affect the behavior of a non-SOLIDWORKS CAD file in its native application, that is when working with the file outside 3D Interconnect.
This chapter includes the following topics:

- Clamp Force in Machine Opening Direction
- Density Result at End of PACK Analysis
- Exclude Area from Clamp Force Calculation
- Export Deformed Geometry
- Mesh Enhancements
- Shrinkage Percentage in Warp Measure
- Temperature Criteria for Short Shots

SOLIDWORKS Plastics Standard, SOLIDWORKS Plastics Professional, and SOLIDWORKS Plastics Premium are available as separately purchased products that can be used with SOLIDWORKS Standard, SOLIDWORKS Professional, and SOLIDWORKS Premium.

Clamp Force in Machine Opening Direction

You can specify the Injection Molding Machine Opening direction to estimate the clamp force in the selected direction.

In the Clamp Force PropertyManager, select one of the default axes (X, Y, or Z), or select a plane, planar face, or linear edge of your model to define a machine direction that is not aligned with a default axis.

To view the clamp force results:

- Create an X-Y plot.
- Access the Flow and Pack Summary where the clamp force in the user-defined machine direction is listed.

Density Result at End of PACK Analysis

You can view density results at the end of a PACK analysis for solid meshes.

Use the Density at End of Pack simulation result as a guideline to evaluate the effectiveness of your packing stage. The density should be relatively uniform across the part geometry. Large variations in density can lead to non-uniform shrinkage and warpage. Voids might form at areas with low density.
Exclude Area from Clamp Force Calculation

If your model contains undercuts or slides, you can exclude these areas from the clamp force estimation.

In the Clamp Force PropertyManager, click Exclude Area and select the elements of your model that represent the undercut or slide regions.

When you run the FLOW or PACK simulation, these elements are excluded from the clamp force calculation, for example the red areas that represent undercuts in the image.

Export Deformed Geometry

An enhancement to the Export Deformed Geometry feature allows you to choose a non-uniform deformation scaling factor for each of the three major axes.

With the new export deformed geometry feature, you can export warped mesh models in Abaqus, STL, Nastran, and native SOLIDWORKS Plastics formats.

If you use the Automatic option to create the mesh, this feature is unavailable with solid meshes.

Mesh Enhancements

Several mesh enhancements improve the mesh creation process.

- Application of previously defined mesh settings when creating a new surface mesh, and ability to re-mesh the part in one step.
- Creation of Mesh groups enables an easier identification of dependent domains (cavity, runner, inserts) and independent domains (mold, cooling channels) during surface meshing. For all parts inside a dependent domain, the mesh is compatible in areas where the parts come into contact.
- Identification of SOLIDWORKS CAD geometry as a mold domain.
Shrinkage Percentage in Warp Measure

The Warp measure tool now displays the shrinkage amount (the distance between two reference nodes) both in terms of the absolute value (dR) and percentage value (dR[%]).
Temperature Criteria for Short Shots

A Flow Analysis setting **Temperature Criteria for Short Shots** improves the FLOW simulation accuracy of predicting potential short shots.

Short shots may occur when the temperature at the melt-front falls below the Glass Transition temperature of the plastic material.

The **Temperature Criteria for Short Shots** setting with the default temperature value set to the Glass Transition temperature is enabled by default. When this setting is enabled, the temperature within the elements along the melt front is continuously monitored, and when the temperature falls below the specified value, a short shot is detected.
Routing

This chapter includes the following topics:

- **Flattening Enhancements**
- **General Routing Enhancements**
- **Routing Library Manager Enhancements**

Routing is available in SOLIDWORKS Premium.

### Flattening Enhancements

**Highlighting Route Segments of Selected Connectors**

In the flattened state, you can view the connected routes and components of selected route segments as highlighted routes in the graphics area.

When you right-click these entities, the shortcut menu options available are:

- Connectors: **View Connected Segments**.
- Route segments: **View Connected Connectors**.

**Flattening Support for Clips with Multiple Route Segments**

In the flattened state, where multiple, disjointed routes are present, clips are visually associated with at least one route segment and placed parallel to the route segment.

**Repositioning Disjointed Routes**

You can manually drag route assemblies in the flattened state. Select **Move Connected Route Segments** from the shortcut menu.

**Connector table enhancements:**

- You can view the following new options in the connector tables:
  - **Connected to Reference**
  - **Connected to Pin**
- You can add new columns in the connector table from a central location.
General Routing Enhancements

Piping: Grouping of Spool Components in BOMs

You can view spools in the Bill of Materials as separate entries. In the Bill of Materials PropertyManager, click **Routing Component Grouping > Group spool components.**

Electrical: Adding Splices to Routes

You can add splice components to routes with the **Add to Route** command. You can add splices in the graphics area and connect existing routes to it.

Routing Library Manager Enhancements

General Routing Library Manager Enhancements

Routing Library Manager Support for Non-English Languages

The Routing Library Manager supports routing library components in all standard SOLIDWORKS languages. When you create routing library parts in one language and open them in the Routing Library Manager of other languages, the software recognizes the routing-specific features.

Component Library Wizard

The Component Library Wizard enhancements include:

- The **Component library** node of the Component Library Wizard is divided into two sections - **Connectors Library**, and **Interconnect and Accessories Library**.
- For the **Interconnect and Accessories Library**, you can specify the library path and the specifications in the **Terminal List**. You can also add new accessories to the library with the **Add New** option.
- For the **Connectors Library**, you can specify the library path and the specifications in the **Component List** and the **Pin List**.
- You can add new columns in the **Pin List**. Right-click an existing column and click **Insert Column Left** or **Insert Column Right** on the shortcut menu.

Covering Library Wizard

The Covering Library Wizard enhancements include:

- The **Covering library** node of the Covering Library Wizard is divided into two sections - **Piping, Tubing, and Ducting**, and **Electrical**.
- For **Piping, Tubing, and Ducting**, you can specify the library path and the specifications in the **Covering List** and the **Material List**.
- For **Electrical**, you can specify the library path and the specifications in the **Covering List**.
Enhancements for Cable Wire Library Wizard, Component Library Wizard, and Covering Library Wizard

You can use vertical scroll bars to scroll through any of the lists in these wizards.

You can click after any of the library paths, to browse to a file for viewing and editing it.

SOLIDWORKS Electrical and Routing User Interface Integration

You can access the Routing Library Manager from the SOLIDWORKS Electrical 3D tab. You can create CPoints and define mate references for electrical components from the Routing Library Manager \(\text{Routing Library Manager} \) instead of the Electrical Component Wizard.

To access the Routing Library Manager from the SOLIDWORKS Electrical 3D CommandManager, click SOLIDWORKS Electrical 3D and click Routing Library Manager.

The SOLIDWORKS Electrical 3D enhancements on the Routing Component Wizard tab of the Routing Library Manager include:

• Three new options in Routing Functionality Points under Point Type:
  • Cpoint with circuit information
  • Cpoint from manufacturer part
  • Cable Cpoint

• Three new options in Mate Reference under Reference name:
  • For Rail
  • For Cabinet
  • For Cabinet Door

• A new command in Mate Reference under Component Alignment Options:Status, Define Faces.
26

Sheet Metal

This chapter includes the following topics:

- Creating Normal Cuts
- Tab and Slot
- Three Bend Corner Reliefs

Creating Normal Cuts

With the Normal Cut tool, you can normalize all non-normal side walls in sheet metal models.

The Normal Cut tool applies a normal cut feature that is independent from the tools that removed the material. You can select several faces to define a normal sheet metal side wall (not top or bottom faces).

Although you can create extruded cuts with the Normal Cut option, this option is limited to individual extruded cut features.

To create a normal cut:

1. Open system_dir:\Users\Public\Public Documents\SOLIDWORKS\SOLIDWORKS 2018\samples\whatsnew\sheet metal\normal_cut.sldprt.
   
   The part has lofted cuts with non-normal side walls.

2. Click Normal Cut (Sheet Metal toolbar) or Insert > Sheet Metal > Normal Cut.

3. In the PropertyManager, under Faces For Normal Cut, select Auto Propagation.
4. In the graphics area, select the face of the cut.

The software selects all faces of the cut.

5. In the PropertyManager, under **Normal Cut Parameters**, select **Extent**.
   With **Extent**, the maximum amount of geometry is cut based on the outline at the top and bottom face.

6. Click ✓.
   The faces of the cut are normal to the top and bottom faces of the part.

**Tab and Slot**

The **Tab and Slot** feature creates tabs on one body and slots (holes) on another body to interlock the two bodies. You can specify how the tabs and slots look and how they are distributed along the selected entities.

Tabs and slots make it easier to weld parts together and minimize the requirement to build complicated fixtures because you can interlock several sheet metal parts. This feature is available in all parts, not just sheet metal parts. You can use it in single bodies, multibodies, and parts in the context of an assembly.

Edges and faces must correspond to each other - when you select an edge for the tabs, you must select a matching face for the slots. The edges must be linear, the faces can be planar or cylindrical, but the edges and faces do not have to touch.
Creating a Tab and Slot

To create a tab and slot:

1. Open `system_dir:\Users\Public\Public Documents\SOLIDWORKS\SOLIDWORKS 2018\samples\whatsnew\sheet metal\tab_and_slot.sldprt`.

2. Click Tab and Slot (Sheet Metal toolbar) or Insert > Sheet Metal > Tab and Slot.

3. In the PropertyManager:
   a) Under Spacing, select Equal Spacing and set Number of Instances to 7.
   b) Under Tabs, set Length to 5mm, Height to Blind and Tab Height Value to 5mm.
4. In the graphics area:
   a) Select the edge shown for the **Tab Edge**.

   ![Diagram of Tab Edge]

   b) Select the back face shown for the **Slot Face**.

   ![Diagram of Slot Face]
5. Click ✓.

Three Bend Corner Reliefs ✗

Improvements to three bend corner reliefs include:
- If a corner relief is smaller than the required corner cutout, it is now visible in the folded state.
- The ability to create a suitcase corner - a closed spherical corner without any cutouts.

Corner Relief Display

Three bend corners are improved to create corner reliefs that are smaller than the required default corner treatment when in the folded state.

Previously, the software could only create three bend corner reliefs in the folded part when the corner treatment was bigger than the necessary cutout that was required to unfold the part.

The following shows a circular corner relief in the folded state.
Creating Suitcase Corner Reliefs

A suitcase corner relief is a closed spherical corner without any cutouts. The sphere is based on the existing sheet metal parameters.

To create a suitcase corner relief:

1. Open system_dir:
   Users\Public\Public Documents\SOLIDWORKS\SOLIDWORKS 2018\samples\whatsnew\sheet metal\bracket.sldprt.

2. Click Corner Relief or Insert > Sheet Metal > Corner Relief.
3. In the PropertyManager, under:
   a) **Corner Type**, select **3 Bend Corner**.
   b) **Corners**, click **Collect all corners**.
   c) **Relief Options**, select **Suitcase** and set the gap to one of the following:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default Suitcase</td>
<td>Leaves the gap unchanged.</td>
</tr>
<tr>
<td><img src="image" alt="Default Suitcase" /></td>
<td><img src="image" alt="Default Suitcase" /></td>
</tr>
<tr>
<td><strong>Extend the gap into the bend area</strong></td>
<td>Cuts the corner relief with the gap.</td>
</tr>
<tr>
<td><img src="image" alt="Extend the gap into the bend area" /></td>
<td><img src="image" alt="Extend the gap into the bend area" /></td>
</tr>
<tr>
<td><strong>Fill in some gap</strong></td>
<td>Extends the corner relief material into the gap.</td>
</tr>
<tr>
<td><img src="image" alt="Fill in some gap" /></td>
<td><img src="image" alt="Fill in some gap" /></td>
</tr>
</tbody>
</table>

4. Click ✅.
This chapter includes the following topics:

- **Topology Study**
- **Allow for Dismissal of Warning Messages**
- **Create a Results Plot from Imported Data**
- **Displacement Control for Nonlinear Contact**
- **Email Notification for Completed Analyses**
- **Factor of Safety Plot for Nonlinear Static Studies**
- **Import Simulation Study Features into Assemblies**
- **Improved Pin Connector**
- **Mesh Refinement for Stress Singularities**
- **Sensor for Simulation Mass Properties**

SOLIDWORKS Simulation Standard, SOLIDWORKS Simulation Professional, and SOLIDWORKS Simulation Premium are available as separately purchased products that can be used with SOLIDWORKS Standard, SOLIDWORKS Professional, and SOLIDWORKS Premium.

### Topology Study

Use a Topology study to explore design iterations of a component that satisfy a given optimization goal and geometric constraints.

Available in SOLIDWORKS Simulation Professional and SOLIDWORKS Simulation Premium.

A Topology study performs nonparametric topology optimization of parts. Starting with a maximum design space (which represents the maximum allowed size for a component) and considering all applied loads, fixtures, and manufacturing constraints, the topology optimization seeks a new material layout, within the boundaries of the maximum allowed geometry, by redistributing the material. The optimized component satisfies all the required mechanical and manufacturing requirements.

For example, you can optimize the part of a car hood opening mechanism, as shown in the image below in blue, in terms of strength and weight (image courtesy of Ring Brothers LLC).
With a Topology study, you can set a design goal to find the best stiffness to weight ratio, minimize the mass, or reduce the maximum displacement of a component.

It is recommended to start with the **Best Stiffness to Weight ratio** goal to get an initial optimized shape of your component.

In addition to the optimization goal, you define design constraints to ensure that the required mechanical properties, such as maximum deflection, percentage of mass removed, and also manufacturing processes are satisfied. For a successful Topology study run, the design proposal reached by the iterative optimization process should fulfill all structural and manufacturing requirements entered.

In the **Study** PropertyManager, select **Topology Study**.

To set up a Topology study, you define:

**One Goal**

The optimization goal drives the mathematical formulation of the optimization algorithm. In a Topology Study tree, right-click **Goals and Constraints**. In the Goals and Constraints PropertyManager, select one of the optimization objectives: **Best Stiffness to Weight Ratio**, **Minimize Mass**, or **Minimize Maximum Displacement**.

When you select **Best Stiffness to Weight Ratio**, the algorithm seeks to minimize the global compliance of the model which is a measure of the overall flexibility (reciprocal of stiffness). Compliance is defined by the sum of strain energies of all elements.

**Constraints**

Constraints limit the design space solutions by enforcing the percentage of mass that can be eliminated to be under a certain value, or by setting performance targets for the maximum displacement observed in your model. You can define up to two constraints for one optimization goal in the Goals and Constraints PropertyManager. The user interface filters the type of constraints you can apply based on the goal you select.

**Preserved Regions**

These are regions of your model that are excluded from the optimization process and are preserved in the final shape. The geometric entities where you apply loads and fixtures are preserved by default. To select the regions to exclude from optimization, go to **Topology > Options > Preserved (Frozen) Region settings**. To select additional faces to
preserve, right-click Manufacturing Control, and select Add Preserved Region.

**Manufacturing Controls**

Geometric constraints enforced by manufacturing processes ensure that the optimized part is manufacturable. Right-click Manufacturing Control, and define the desired controls like De-mold Direction, Thickness Control, or Symmetry Control. In the De-mold Direction PropertyManager, you can also apply a stamping constraint to create holes across the thickness of a part. With the Symmetry Control, you can enforce half, quarter, or one-eighth symmetry to the optimized shape of the component.

Depending on the settings of the optimization goal, manufacturing controls, mesh, loads, and boundary conditions, the optimization process yields an acceptable design that is a derivative of the initial maximum design space.

**Material Mass Plot**

When the iterative optimization process completes, you view the optimized geometry of the component in a Material Mass contour plot.

During a Topology Optimization, the program starts with the given maximum physical space of a component, which includes all elements, and through an iterative process determines a new material distribution by removing the "soft" elements that do not contribute to the stiffness of the component for the particular load scenario, boundary conditions, and manufacturing controls.

For each element, the optimization algorithm couples the material's Young's modulus with a relative mass density factor ranging from 0.0001 (for a void element without any load-carrying capacity) to 1.0 (for a solid element with load-carrying capacity).

Elements with low relative mass densities (less than 0.3) are considered "soft" elements. These elements do not contribute to the overall stiffness of the component, and they can be safely removed. Elements with high relative mass densities (larger than 0.7), are considered "solid". These elements contribute the most to the overall stiffness (as a measure of the load-carrying capacity) of the component, and they should remain intact in the final design. The "solid" elements distribute the applied loads more effectively than the "soft" elements. An isovalue slider adjusts the inclusion of elements in the Material Mass plot according to their relative mass density values. The default position of the isovalue slider removes the elements with relative mass density values less than 0.3. Moving the slider to Heavy includes all elements, whereas moving the slider to Light plots only the solid elements, which cannot be removed.

A Material Mass plot of the optimized car hood component is shown below. The "soft" elements are removed from the optimized geometry (image courtesy of Ring Brothers LLC).
In the Material Mass PropertyManager, option **Calculate Smoothed Mesh** creates a smooth mesh from the active **Material Mass** plot. A smoothed mesh plot of the optimized car hood component is shown below (image courtesy of Ring Brothers LLC).

To save the smoothed mesh of the optimized part as new geometry, right-click the **Material Mass** plot, and click **Export Smoothed Mesh**. You can save the mesh data in a new configuration, or in a new part file.

**Topology Optimization of a Plate**

In this tutorial, you set up a Topology study with the goal to find the best strength to weight ratio of a plate while reducing its mass by 50%.

You create a Topology study to examine optimized shapes of a steel plate fixed on one side and loaded with a 750 N load.
Opening the Part

To open the part file (plate.sldprt), browse to the file location

```
system_dir: \Users\Public\Public Documents\SOLIDWORKS\SOLIDWORKS 2018\samples\whatsnew\Simulation\plate.sldprt
```

The TopLoad_Ready study includes:

- A static study with solid mesh
- ASTM A36 Steel material applied to the part
- A fixed restraint on a face
- A load of 750 N

Creating a Topology Study

You create a Topology study with a goal to find the best strength to weight ratio of the plate, while reducing its mass by 50%.

1. Click **New Study** (Simulation CommandManager).
2. Under **Design Insight**, click **Topology Study** and click ✓. The **Topology Study 1** study tab is created.
3. Copy from the TopLoad_Ready static study the fixed restraint **Fixed-1** and the load TopForce (:Per item: -750 N) to the new topology study.
4. In the Topology study tree, right-click **Goals and Constraints**, and click **Best Stiffness to Weight ratio (default)**. In the Goals and Constraints PropertyManager:
   a) Under **Constraint 1**, for **Reduce mass by (percentage)** set 50 (%) for **Constraint Value**.
   b) Click ✓.

   The optimization algorithm will try to minimize the compliance of the model (reciprocal of stiffness) which is defined by the sum of strain energies of all elements.

**Setting Study Properties and Running the Study**

1. Right-click the top **Topology Study1** icon, and select **Properties**.
2. In the **Options** tab (Topology dialog box) do the following:
   a) For **Solver**, select **Intel Direct Sparse**.
   b) Select **Run Static analysis before running topology study**.
   c) Under **Preserved (Frozen) Region settings**, select **Regions with loads and fixtures**. Three regions remain unchanged by optimization.
   d) Click OK.
3. Click **Run This Study** (Simulation CommandManager).

   The optimization algorithm through several iterations will try to reach convergence.
Viewing Results

1. Under **Results**, double-click **Material Mass 1(-Material Mass)**.

   The Material Mass PropertyManager plots isovalues of the elements' relative mass densities. Elements with higher mass densities are considered solid, and they must remain in the "optimized" shape. Elements with lower mass densities are considered "soft" and can be removed. Move the slider under **Display** to the rightmost position **Light** to plot only elements with mass densities close to 1 (must keep). Move the slider to the leftmost position **Heavy** to plot all elements. The color chart option of the material mass plot is set to **Optimized for Material Mass**. Red and green colors are removed from the material mass plot color scale to better assist color-blind users when viewing the plot.

   The default position of the slider plots all elements with relative mass densities larger than 0.3. The remaining mass of the plate (at the default slider position) measures 25.56 Kg which equals to 52% of the original mass of 49.06 kg.
2. Click **Calculate Smoothed Mesh**. The program creates smooth surfaces of the optimized shape so that the final design is ready to manufacture.

3. Click **✓**. To save the smoothed mesh into a new configuration, or a new part, right-click **Material Mass1 (-Material Mass)**, and click **Export Smoothed Mesh**.

**Allow for Dismissal of Warning Messages**

You can suppress recurring warning messages that appear in a simulation workflow. Select **Do not show me this again** in the message dialog to suppress the recurrence of the message. You can restore the suppressed messages from the Simulation **System** options dialog box.

**Create a Results Plot from Imported Data**

You can create simulation results plots by importing data from an external file. Right-click the top study icon of a study tree, and click **Plot Imported Results**. Select the input file to import the external results data. The input file can be either a text **`.txt`** file, or a comma/space delimited **`.csv`** file. Mapping of results is achieved per node or element number. The current mesh of the active study and the mesh from which the imported results are derived must be identical.

The data are stored in two columns. First column lists the node or element number, and second column lists the scalar values associated to the respective node or element.
Displacement Control for Nonlinear Contact

You can use the **Displacement Control** method to solve nonlinear contact analysis with the Direct Sparse and Intel Direct Sparse solvers only.

The **Displacement Control** method is enhanced to handle post buckling behavior in nonlinear analysis. Only the surface-to-surface contact formulation is supported when activating **Displacement Control**.

Email Notification for Completed Analyses

Automatic email notification when the analysis completes allows you to track the status of a running Simulation study.

Click **System Options > Email Notification Settings** to set up the email server settings. You can set up email notification delivery to track the solution status of a simulation study. You get email notifications for these cases:

- The solver completes the simulation. Select **Email when simulation is completed** in the Notification tab of the study properties dialog box.
- The solver encounters numerical difficulties and does not complete the simulation.
- Time-based notification about the solution status of a study, for example every 20 min, 40 min, etc. Select **Time based notification** in the Notification tab of the study properties dialog box.

Factor of Safety Plot for Nonlinear Static Studies

The factor of safety plot is extended to nonlinear static studies.

After a nonlinear static analysis completes, you can create a factor of safety plot based on a defined failure criterion.

Right-click **Results** and click **Define Factor of Safety Plot**. Create a factor of safety plot from results derived from a selected solution step or from the extreme values across all solutions steps.

Import Simulation Study Features into Assemblies

When creating a new static study, you can copy simulation features defined on a part or sub-assembly document into the new study created on an assembly document.

**To import study features in an assembly document:**

- Right-click the top study icon, in a static study PropertyManager, and select **Import Study Features**, or
- When creating a new static study, in the Study PropertyManager, select **Import Study Features**.

In the Import Study Features dialog box, you can select from the **Assembly Hierarchy** the parts and sub-assemblies associated to the study features you want to import.
The simulation features you can import are material, element types, contact, connectors, fixtures, loads, and mesh control definitions from static studies. You can import all simulation features or select which features to import.

You cannot import study features from 2D Simplification studies (plane stress, plain strain, and axisymmetric).

For models that have multiple instances of parts or sub-assemblies, you can propagate the selected study features to all instances in the assembly (or part) document. Click **Propagate imported study features to all instances (✱)**.

**Improved Pin Connector ✱**

You can define a pin connector through more than two cylindrical surfaces in one definition. An improved user interface allows the definition of a single pin connector applied to multiple cylindrical faces (maximum ten). You select all coaxial cylindrical surfaces that are attached to the pin in a single selection box.

For example, for the two models shown below, you can define two pins (one for each model) to connect the two rotating parts and the six cylinders of a hinged plate.

This improved pin connector definition is available for linear static, frequency, buckling, and linear dynamic studies.

**Mesh Refinement for Stress Singularities ✱**

The Stress Hot Spot Diagnostics functionality is improved with the addition of Stress Singularity detection algorithm.

When the **Stress Hot Spot** diagnostics tool detects regions of the model that exhibit the highest stress gradients, you can apply local mesh controls to selected geometric edges, like sharp edges, in the hot spot regions. The improved algorithm with the addition of mesh refinement filters stress singularities from the stress hot spot regions.

The enhanced stress hot spot diagnostics tool allows you to:

- Select edges to apply mesh controls and change the mesh size.
• Refine the mesh locally up to three levels.
• View stress variations across different mesh levels on the selected edges to confirm
  the presence of stress singularities in your model.

Sensor for Simulation Mass Properties

You can monitor Simulation mass properties with a sensor.

To create a Simulation mass properties sensor:

In the Sensor PropertyManager, select Simulation Data for Sensor Type and
Simulation Mass Properties for Results.

The Simulation mass sensor tracks mass properties (mass, volume, surface area, and
center of mass coordinates) for bodies, remote masses, and bolts.

You can use a Simulation mass properties sensor either as a Constraint or as a Goal in
Design Studies.
Sketching

This chapter includes the following topics:

- **Controlling the Tangency Direction**
- **Creating Mirrored Entities in 3D Sketch**
- **Enabling and Disabling Automatic Solve and Undo for Sketches**
- **Fixing the Rotation of Sketch Pattern Instances**
- **Instance Limit Removed for Circular Sketch Patterns**
- **Mirroring Entities Using Reference Planes and Planar Faces**
- **Pen, Touch, and Gesture-based Sketching**
- **Smart Dimension on the Context Toolbar**

### Controlling the Tangency Direction

You can flip the tangency direction of certain curved sketch entities. This includes arcs and splines.

**To control the tangency direction:**

1. Open `system_dir:\Users\Public\Public Documents\SOLIDWORKS\SOLIDWORKS 2018\samples\whatsnew\sketching\Block.sldprt`.
2. In the FeatureManager design tree, under **Cut-Extrude1**, right-click **Sketch3** and click **Edit Sketch**.
3. In the graphics area, right-click the arc and click Reverse Endpoint Tangent on the shortcut menu.

The software reverses the tangency and flips the arc.

4. Click Edit > Rebuild.

Creating Mirrored Entities in 3D Sketch

You can use the Mirror Entities tool in 3D Sketch.

To create mirrored entities in 3D Sketch:
1. Click 3D Sketch (Sketch toolbar) or Insert > 3D Sketch.
2. Create sketch entities.
3. Click Mirror Entities or Tools > Sketch Tools > Mirror.
4. Select sketch entities for Entities to mirror.
5. Select any plane or planar face for Mirror about.
6. Click .

Enabling and Disabling Automatic Solve and Undo for Sketches

You can enable and disable Automatic Solve Mode and Undo, and modify the threshold limit for sketch entities.

Previously, when you worked with large sketches, the Automatic Solve Mode and Undo would repeatedly turn off in large sketches.
Parts and Assemblies

To control Automatic Solve and Undo in Parts and Assemblies:

Click Tools > Options > System Options > Sketch.

- To disable the behavior of automatic turn off of Automatic Solve Mode and Undo, clear Turn off Automatic Solve Mode and Undo when sketch contains more than this number of sketch entities.
- To modify the threshold limit, select Turn off Automatic Solve Mode and Undo when sketch contains more than this number of sketch entities and enter the input value in the input box.

Click OK.

Drawings

To control Automatic Solve, Undo, and No Solve Move in Drawings:

Click Tools > Options > System Options > Drawings > Performance.

- To disable the behavior of automatic turn off of Automatic Solve Mode and Undo, clear Turn off Automatic Solve Mode and Undo and turn on No Solve Move when drawing view contains more than this number of sketch entities.
- To modify the threshold limit, select Turn off Automatic Solve Mode and Undo and turn on No Solve Move when drawing view contains more than this number of sketch entities and enter the input value in the input box.

Click OK.

The system options above are selected by default. If you clear the options, Automatic Solve and Undo tools remain enabled regardless of the number of sketch entities you create.

Fixing the Rotation of Sketch Pattern Instances

In the Linear Sketch Pattern PropertyManager, you can fix the rotation of sketch instances to Direction 1 by selecting Fix X-axis direction under Direction 1. When you select this option, the pattern instances are fixed to Direction 1.

Instance Limit Removed for Circular Sketch Patterns

Circular sketch patterns are no longer limited to the number of instances allowed.
Mirroring Entities Using Reference Planes and Planar Faces

You can mirror entities about reference planes or planar model faces. Previously, you could only mirror entities about linear entities such as lines or edges.

Click Mirror (Sketch toolbar) or Tools > Sketch Tools > Mirror > Mirror About and select a reference plane or a planar face in the graphics area.

Pen, Touch, and Gesture-based Sketching

You can use pen and touch with compatible, touch-enabled devices to create free-hand sketch strokes and convert them into sketch geometry with the tools in the Sketch Ink CommandManager.

This functionality is available only on Windows 10 Creators Update.

To activate the Sketch Ink CommandManager, right-click the CommandManager tab and click Sketch Ink or View > Toolbars > Sketch Ink.

To access the Touch tool, in the Sketch Ink CommandManager, click Touch and use a finger to sketch entities in the graphics area.

To access the Pen tool, in the Sketch Ink CommandManager, click Pen and use a stylus or pen to sketch entities in the graphics area.

You can create:
- Lines
- Arcs
- Polygons
- Circles
- Ellipses

Smart Dimension on the Context Toolbar

You can dimension certain entities from the Auto Insert Dimension tool on the context toolbar.

Previously, you could only pre-select entities and then use the Smart Dimension tool to dimension entities.

The Smart Dimension tool on the context menu no longer supports pre-selection. If you want to add a dimension to your selection, use the Auto Insert Dimension on the context menu.

The Auto Insert Dimension tool automatically inserts the most appropriate dimensions for sketch entities.

The entities supported by the dimensioning tools on the context menu are:
• Line: Linear dimension
• Arc: Radial dimension
• Circle: Diameter dimension
• Two lines at an angle: Angular dimension between entities
• Two parallel lines: Linear dimension between entities
• Arc or circle, and line: Linear dimension between line and center point
• Point and line: Linear dimension between line and point
• Arc or circle, and point: Linear dimension between point and center point
• Arc/Arc or Circle/Circle or a combination thereof: Linear dimension between center points.

Controlling Dimensions with the Context Toolbar

To control dimensions with the context toolbar:

1. Create a sketch with two lines.
2. Ctrl + select two lines.
3. On the context toolbar, click Make Parallel \.
4. Ctrl + select the two lines and select Auto Insert Dimension on the context toolbar.
5. In the Modify dialog box, type a dimension.
6. Click ✔.

The dimension is applied to the entities.
SOLIDWORKS Toolbox

This chapter includes the following topics:

- **Descriptions and Comments No Longer Disappear**
- **Hexalobular Hardware**
- **Importing and Exporting Hole Wizard Data**
- **Selecting PEM Inserts**
- **Toolbox User Interface and Workflow**

SOLIDWORKS Toolbox is available in SOLIDWORKS Professional and SOLIDWORKS Premium.

**Descriptions and Comments No Longer Disappear**

For Toolbox components, if you add information in **Description** and **Comment**, the information is now preserved even if no **Part Number** is assigned.

Previously, the information was deleted if no **Part Number** was assigned.

In the Toolbox Configure Component PropertyManager, in the **Part Numbers** box, you are informed if a particular configuration has not been assigned a **Part Number** or a **Description** (if implemented). You can leave **Part Number** and **Description** unassigned, or add them through **Toolbox Settings** or by clicking **Edit** in the Toolbox Configure Component PropertyManager.

**Hexalobular Hardware**

Hexalobular (Torx) hardware is available in Toolbox.
The following hardware has been added:
- ISO 14587 (2011) Hexalobular Socket Raised Countersunk (oval) Head Tapping Screws
- ISO 14581 (2013) Hexalobular Socket Countersunk Flat Head Screws
- ISO 14582 (2013) Hexalobular Socket Countersunk Head screws, High Head
- ISO 14584 (2011) Hexalobular Socket Raised Countersunk Head Screws

To access this hardware, click **Design Library > Toolbox > ISO > Bolts and Screws > Self Tapping Screws** or **Hexalobular Socket Head Screws**.

**Importing and Exporting Hole Wizard Data**

You can import and export data from Microsoft Excel files for Hole Wizard holes. This is helpful when you edit an entire standard or create several new sizes of holes.

**To import and export hole wizard data:**

1. Do one of the following:
   - In SOLIDWORKS, click **Tools > Options > System Options > Hole Wizard/Toolbox > Configure**.
   - From the Windows **Start** menu, click **All Programs > SOLIDWORKS version > SOLIDWORKS Tools > Toolbox Settings version > Configure**.

2. In the dialog box, click **1. Hole Wizard**.
3. Browse to the type of hole to import or export data for, such as **ISO > Straight Holes > Tap Drills**.
4. Under Standard Properties, click the arrow on the **Microsoft Excel** button and click one of the following:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Import Hole Data Tables</strong></td>
<td>Imports hole table data into Toolbox. If there are errors in the data, an error report appears. After the import, you can:</td>
</tr>
<tr>
<td></td>
<td>- <strong>Replace existing data tables</strong>. Removes all existing data from the current data tables and replaces it with data from the imported file.</td>
</tr>
<tr>
<td></td>
<td>- <strong>Append new data to existing data tables</strong>. Adds the imported data to the end of the current data tables.</td>
</tr>
<tr>
<td><strong>Export Hole Data Tables</strong></td>
<td>Saves the hole table data to a Microsoft Excel file.</td>
</tr>
</tbody>
</table>
Selecting PEM Inserts

The workflow for selecting PEM inserts is improved.
In the Hole Wizard and Advanced Hole PropertyManagers, when you select **PEM Inch** or **PEM Metric** for **Standard**, the **Filter** field now appears above the **Type** field. This better matches the workflow of filtering before selecting the type.

Toolbox User Interface and Workflow

Visual and functional improvements have been made to the Toolbox Settings user interface.
Improvements:

- Icons are updated to match those used in SOLIDWORKS, and are moved to consistent locations.
- Forms are updated to display more information in more consistent format.
- In various Toolbox component tables, some columns have been hidden. Previously, the columns (such as **Sort**, **OnFeatures**, and **OffFeatures**) were erroneously shown and were not meant to be user-editable.
This chapter includes the following topics:

- **SOLIDWORKS Design Checker Misaligned Mates**

**SOLIDWORKS Design Checker Misaligned Mates**

SOLIDWORKS Design Checker can detect the presence of misaligned concentric mates. You can check for:
- Any misaligned mates
- Misaligned mates where the deviation exceeds a maximum deviation value
- Misaligned mates where the deviation exceeds a specified value
This chapter includes the following topics:

- 3DConnexion Spacemouse Support
- Area Light Enhancements
- Cloud Library Enhancements
- Decal Improvements
- Help Menu Improvements
- Import all SOLIDWORKS Cameras, Custom Views, and Lights
- Interactivity Performance Improvements
- Remove Camera Post-Processing from Backplates
- Stereoscopic and 360° Cameras for Virtual Reality
- Updated User Interface

SOLIDWORKS Visualize is available as a separately purchased product that can be used with SOLIDWORKS Standard, SOLIDWORKS Professional, and SOLIDWORKS Premium or as a completely separate application.

3DConnexion Spacemouse Support

SOLIDWORKS Visualize 2018 supports all 3DConnexion® 3D motion controllers.

Navigation Modes

You can apply the controller motion information to three different navigation modes. To specify the Navigation Mode, click Tools > Options > User Interface > Spacemouse Options.

**Navigation Mode - Object (Default)**

Object mode navigation makes the user believe that he is holding the object in his hand. This mode is used in the modeling and inspection of parts and assemblies. This mode uses a smart algorithm to automatically set the rotation center of the camera. While the entire scene is visible in the viewport, the center of the scene is taken as the rotation center. When a user zooms close to objects to investigate details, the rotation center is set to a point on the 3D object’s surface that is in the middle of the viewport. This mode is also most commonly used in the SOLIDWORKS software.

**Navigation Mode - Camera**

Camera mode gives the user the impression that he is moving around in the scene he is observing. A typical use for a camera mode is exploring virtual sceneries, similar to the navigation known from first
person games. This mode requires the user to move and turn in the direction that the cap on the 3D Mouse moves, and causes the objects displayed to move in the opposite direction to object mode described above. In camera mode, the center of rotation is at the eye or view point (actually the position of the camera itself).

**Navigation Mode - Fly**

Fly mode is used to describe navigation mode where the horizon is required to always remain leveled or horizontal. Fly mode is the same as camera mode with the additional horizontal constraint.

**Object Manipulation**

In addition to changing the view or camera, you can use the 3D motion controller to move and transform the selected 3D objects (Models, Groups and Parts). Press the **SHIFT** key while using the 3D motion controller.

The selection of 3D objects cannot be empty.

These object manipulation modes in the Main toolbar are supported:

<table>
<thead>
<tr>
<th>Mode</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Move</td>
<td>Translates or rotates objects according to the input from the 3D motion controller.</td>
</tr>
<tr>
<td>Scale</td>
<td>Scales objects along the X, Y, and Z axes.</td>
</tr>
<tr>
<td>Pivot</td>
<td>Translates the Pivot or rotation center of objects along the X, Y, and Z axes.</td>
</tr>
</tbody>
</table>

**Virtual 3D Mouse Commands**

SOLIDWORKS Visualize supports a set of commands that are predefined by 3DConnexion® to reset the view or choose commonly-used orthographic and isometric views. These commands are supported by a wide range of 3D applications and often have dedicated buttons on the motion controller devices.

**Application Commands**

SOLIDWORKS Visualize offers a wide range of application or action commands that you can customize and allocate to device buttons or virtual menus to speed up your most common workflows.

SOLIDWORKS Visualize includes more than 90 application commands that you can customize using the 3DConnexion® properties menu from the motion controller’s device driver.
Area Light Enhancements

You can create light sources simulated as rectangles, discs, spheres, and cylinders. These area light sources are extremely efficient in Fast mode. They can replace the emissive-plane technique for creating simulated light cards in scenes, which provide more reflections in your geometry and actual emissivity in Fast mode.

Additional improvements let you create and place lights on the fly. The lights are matched to the current camera’s position and direction, or you can place them by clicking on the model where you want the lights to shine.

You can create new lights by selecting Pick Target or Match Current Camera from the New Light menu. For example, on the Scenes tab, click Add and choose New Light, Pick Target, or Match Current Camera.

New area light types in Fast mode, from left to right: Cylinder, Disc, Rectangle, and Sphere

Cloud Library Enhancements

The Cloud Library performance improvements let you quickly select individual or multiple assets to download without interrupting your workflow.

- Hover over an asset’s thumbnail of content that hasn’t been downloaded for quick and easy downloading.
- Cancel a download at any time.
- Press CTRL and select multiple assets to download them all at once.
- This download is now a separate process, so you can continue using SOLIDWORKS Visualize while downloading assets.

Decal Improvements

SOLIDWORKS Visualize 2018 introduces an all new decal system, providing several key improvements and new functionality.

Support of all SOLIDWORKS Decal Types

Cylindrical Maps all points onto a cylinder
Maps all points onto a sphere

**Planar/Projection**
Maps all points onto a specified plane and then projects the decal onto the reference entity

**Label**
Maps decals onto the model faces, including multiple contiguous nonplanar surfaces with no stretching or shrinking

---

**Animation Keyframe Support**

You can create unique decal animations by right-clicking a decal and clicking **Add Keyframe**. You can scale and position decals. In addition, you can animate the **Opacity** (visibility) to show items such as multiple decal options, slide shows, flashing billboards, and flickering TV screens.

**Additional Key Improvements**

- Floating decal issues, with noticeable drop shadow, are resolved
- Improved overall performance and files with many decals are handled properly
- No limit on the number of decals per project/part
- Support for up to 6 overlapping decals on a single part
Help Menu Improvements

The Help menu improves access to the help and documentation resources and aligns with other SOLIDWORKS products.

All documentation resources, including SOLIDWORKS Visualize Help, Tutorials, Release Notes, and What’s New, are accessible from the Help menu. To guarantee the documents remain up-to-date and to minimize the required installation and installer size, the links reference online resources.

All SOLIDWORKS Visualize documentation is now available online only. An internet connection is required to access the documentation, however, you can then download the documents for future offline use.

The following actions to manage licenses are now accessible from the Help menu:

- Activate License (for Standalone licenses)
- Deactivate License (for Standalone licenses)
- SolidNetWork License Manager (for Network licenses)

Import all SOLIDWORKS Cameras, Custom Views, and Lights

When you import a SOLIDWORKS model into SOLIDWORKS Visualize, you can now import all custom defined SOLIDWORKS Cameras, custom saved views, and physical lights.

Cameras and Saved Views

When you import a SOLIDWORKS model and choose to import Cameras, all cameras and custom SOLIDWORKS views are imported into SOLIDWORKS Visualize. These import as SOLIDWORKS Visualize Cameras and are displayed in the Camera’s tab in SOLIDWORKS Visualize. All aspects of SOLIDWORKS cameras and saved views are maintained and replicated in SOLIDWORKS Visualize.

To import cameras and saved views, the model must be saved in SOLIDWORKS 2018.
Physical Lights

When you import a SOLIDWORKS model and choose to import Lights, all directional, point, and spot lights saved in the SOLIDWORKS model are imported as SOLIDWORKS Visualize Lights on the Scenes tab. All aspects of SOLIDWORKS lights are maintained when translated to SOLIDWORKS Visualize.

All imported lights are disabled by default when imported, regardless of whether they were ON in SOLIDWORKS and/or PhotoView 360 when the model was saved. Ambient light sources are never imported from SOLIDWORKS.
Interactivity Performance Improvements

SOLIDWORKS Visualize 2018 includes three main improvements to the raytracing performance:

- Faster interactivity directly in the Viewport with Fast and Accurate raytracing modes
- Added new Fast raytracing mode switch for even faster Fast mode
- Ability to set the default number of passes for Fast raytracing mode

Faster Interactivity Directly in the Viewport

Officially included in the 2017 SP2 release, Viewport interactivity performance was significantly improved when interacting with the camera and/or geometry with Fast or Accurate modes enabled. No setting change is required to see these performance improvements.

Fast Raytracing Mode Switch

SOLIDWORKS Visualize 2018 includes a Fast mode toggle switch: Speed or Quality. You can access this switch from the Main toolbar.

**Speed**: Recommended for fastest interactivity in the Viewport.
- This new Fast render setting completes renders almost two times faster than in previous versions by removing self-shadowing and time-consuming reflections.
- This is ideal for projects without glass, clear plastics, or transparent objects.

**Quality**: Recommended for final renders.
- This new Fast render mode is actually more realistic and advanced than the previous Fast render mode. This mode has some of the more photorealistic features found in Accurate mode, but with the faster raytracing speeds of Fast mode.
- This new Fast mode allows for a greater usage of Fast raytracing mode throughout more and more projects. Accurate raytracing mode is only required for interior scenes.
Set Default Number of Passes for Fast Raytracing Mode

With the **Fast** mode toggle switch between Speed and Quality, you have the option to set the default number of **Render Passes** for the Fast render mode. Click **Tools > Options > 3D Viewport > Fast Rendering Mode**.

Some **Fast** mode renders can still be noisy, so this setting allows you to adjust the default number of **Fast** mode render passes to reduce any visible noise in final **Fast** mode renders.

The accumulation process stops once this number is reached. Small values lead to shorter render times but may produce noisy images. The default number is sufficient for most projects.

The **Fast** mode setting (**Speed** or **Quality**) and Render Pass count selected in the Viewport are the settings used during an offline render if you select **Fast** mode.
Remove Camera Post-Processing from Backplates

When using a backplate image or background color as the visible background in your scene, you can choose to have the Camera Post Processing Options only impact the model. Click **Cameras > Filters**. Under **Post-Processing Options**, select **Apply To Geometry Only**. This option results in the post-processing effects only applying to the model, and not a backplate or background color.

If the visible background is the HDR environment image itself, this option has no visible effect.

---

Stereoscopic and 360° Cameras for Virtual Reality

SOLIDWORKS Visualize Professional provides tools and methods to create three dimensional (3D) and 360° images and videos (animations) that can be used to prepare interactive Virtual Reality (VR) content.

These new VR features are only available in SOLIDWORKS Visualize Professional.
Application Examples

Social Media

You can post 360° images on social media sites such as Facebook® 360 Photos to create interactive, panoramic experiences. You can also export 360° videos that are handled in a similar way, for example Facebook® 360 Videos. While these videos are playing, you can choose your perspective throughout the entire 360°. When played on mobile devices that employ gyroscopes, the motion of the device defines the perspective or viewing direction, giving you the illusion of having a window into the virtual world.

VR Headsets

You can use stereographic and 360° images as input for VR headsets, giving users the impression they are in the virtual scene while allowing them to look in every direction. These stereographic and 360° images can also be exported as videos and uploaded to YouTube® where they appear as VR-360 videos, ready to be streamed and consumed from any VR device.

HDR Environments

When you export 360° images in a high dynamic range format such as .HDR or .EXR, you can reload the resulting images as HDR Environments into SOLIDWORKS Visualize. You can then set up your own scenes to customize reflections and lighting for subsequent visualization purposes.

360 Lens

In addition to Perspective and Orthographic camera projections, 360 is now available. 360 is not supported in the Preview render mode.

The 360 lens is a nonlinear type of projection that captures the whole 360° environment around the camera’s position into a single wide screen image. The result displays in a Lat/Long or Equirectangular image that resembles a photo with an extreme fish eye lens.

In this example, two images of an interior scene are created from the same camera position using Perspective and 360 projections.
Stereoscopy

Stereo rendering computes two images at the same time, one for the left eye and one for the right eye.

**To use Stereo rendering:**

1. On the Palette, on the Cameras tab, on the General subtab, for **Type**, select **Perspective** or **360**.
2. On the Stereo subtab, for **Mode**, select **Stereo Two-Up** or **Stereo Anaglyph**.

**Perspective** and **360** camera projection types support stereo rendering. SOLIDWORKS Visualize provides two modes to display the left and right eye images.

**Stereo Two-Up Mode**

Stereo Two-Up Mode displays both images at the same time. The left image is on top; the right image is on the bottom.
Stereo Anaglyph Mode

Stereo Anaglyph Mode overlays the two images using color filters (chromatically opposite colors red and cyan) to produce 3D images that you can view using inexpensive red/cyan stereo glasses. In addition, it helps to see the stereo parallax effect. In this example, the zero parallax or focal point is set on the wine bottle in the center of the image.

Other Stereo Parameters

You can control the intensity of the stereo effect using the **Eye Separation** and **Focal Distance** parameters. The **Focal Distance** (distance from camera position in viewing direction) defines the zero parallax or point of convergence between the left and right images for a given **Eye Separation**. Click **Pick** and select an object in the 3D viewport using the crosshairs cursor to specify the **Focal Distance**.

Updated User Interface

SOLIDWORKS Visualize 2018 has a restyled user interface with a modern, clean design theme that reflects current industry and market trends. This modernized user interface
includes restyled icons that complement the new design theme and increased spacing that helps with touchscreen support.

Use **Tools > Options > User Interface > Interface Options** to switch between **Dark** and **Light** themes.

---

### Dark

![Dark Theme](image)

### Light

![Light Theme](image)

---

**Other Main User Interface Updates**

- Palette subtabs simplify lengthy settings.
• To toggle the palette layout between vertical and horizontal, click **Change Layout** (Palette toolbar).
• In **Large List** palette views, additional information is available.
• Simplified right-click context menu.

• Reorganized Output tools.

• New Camera Orthographic and Isometric view presets on the Main toolbar that are similar to SOLIDWORKS.
To toggle the camera between locked and unlocked, press L.
For camera zoom to fit, press F.
You can enable a SOLIDWORKS Visualize watermark, which is overlaid on the lower-right corner of the viewport and final renders. Click Tools > Options > 3D Viewport > Display Options > Show Watermark.
Larger viewport resolutions (up to 4K) are now supported.
This chapter includes the following topics:

- Customizing Description for Bounding Box Properties
- Linking a Cut List Folder to a Cut List Property

Customizing Description for Bounding Box Properties

You can customize the default description settings for new and existing bounding box properties for solid and sheet metal cut list bodies in **Tools > Options > Document Properties > Weldments**.

To customize description settings in bounding box properties:

1. With a document open, click **Options** (Standard toolbar). On the **Document Properties** tab, select **Weldments**.
2. In the Bounding Box Properties section, to change a description for solid bodies:
   a) Clear **Use default description**.
   b) In the description field, overwrite **Plate** and type a new description.
   c) Click the drop down arrow to change the order of **SW-Thickness**, **SW-Length**, or **SW-Width**. If you select **None** from the list, the element is removed from the text expression.
3. To change a description for sheet metal bodies:
   a) Clear **Use default description**.
   b) In the description field, type a new description.
4. Select an option to apply the changes to existing and new bounding boxes, or new bounding boxes only.

<table>
<thead>
<tr>
<th>Changes to existing bounding box descriptions cannot be reversed.</th>
</tr>
</thead>
</table>

5. Click **OK**.

Linking a Cut List Folder to a Cut List Property

In the Cut-List Properties dialog box, you can add a custom property that links a cut list folder to its cut list folder name. You can then include this cut-list property in BOMs,
notes, and sheet formats. This property helps to identify members in large multibody weldments.

**To link a cut list folder to a cut list property:**

1. In the FeatureManager design tree, right-click a **Cut-List-Folder** and click **Properties**.
2. On the **Cut List Summary** tab, click an empty cell under **Property Name** and add a new property.
3. Under **Value/Text Expression**, choose **Cut List Item Name** from the list.

The text in **Value/Text Expression** displays `SW-CutListName@@<Cutlist folder name>@<Part name.Sldprt` and the evaluated value displays the cut list folder name.