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manually, for any purpose without the express written permission of DS SolidWorks.
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copied only in accordance with the terms of the license. All warranties given by DS SolidWorks
as to the software and documentation are set forth in the license agreement, and nothing
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Patent Notices
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FeatureWorks is a registered trademark of Geometric Ltd.
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names of DS SolidWorks.

Other brand or product names are trademarks or registered trademarks of their respective
holders.
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1
SOLIDWORKS PDM Installation
Guide

SOLIDWORKS PDM Installation Guide provides installation and configuration instructions for
SOLIDWORKS PDM, SQL Server Express, and SQL Server.

SOLIDWORKS PDM Standard is a new product based on SOLIDWORKS Enterprise PDM. It is
included with SOLIDWORKS Professional and SOLIDWORKS Premium.

SOLIDWORKS PDM Professional is the name of the product previously called SOLIDWORKS
Enterprise PDM. It is available as a separately purchased product.

Required and optional installation components, deployment
scenarios, and installation summary.

Installation Overview on page
13

SQL Server 2014 and SQL Server 2012 installation and
upgrade. Includes changing the SQL Server login account.

Installing and Configuring
SQL Server on page 20

SQL Server 2014 Express installation.Installing and Configuring
SQL Server Express

The installation of SOLIDWORKS PDM database server,
archive server, SolidNetWork License Manager, Web server,
and SOLIDWORKS PDM clients. Client installation includes
creating and deploying admin images, and scripting silent
installations.

Installing SOLIDWORKS PDM
on page 52

Creating file vault views using the View Setup wizard.
Includes applying licenses, using shared views, scripting file
vault view setup, and distributing file vault views.

Creating and Distributing File
Vault Views on page 107

Configuration of the SOLIDWORKS PDM Professional Index
Service. Includes indexing file vault archives, updating the
index server name, changing login accounts, and adding
index server filters.

Configuring Content Search
(For SOLIDWORKS PDM
Professional only) on page 131

Upgrade of the database, archive, and Web servers, the file
vault database and archives, and SOLIDWORKS PDM clients.

Upgrading SOLIDWORKS
PDM on page 147

Backing up the file vault database and SOLIDWORKS PDM
Master database, including archive server settings. Includes
scheduling database backups and restoring file vaults.

Backing Up and Restoring
File Vaults on page 140
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Managing the SQL transaction log size, configuring
SOLIDWORKS PDM communication with IP addresses only,
and moving server components to another system.

Additional Configuration on
page 182
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2
Installation Overview

You can install SOLIDWORKS PDM Standard or SOLIDWORKS PDM Professional using:

• SOLIDWORKS Installation Manager (SLDIM)
• SOLIDWORKS PDM InstallShield Wizard

Based on the installation method you use, client and server components are installed under
different folders:

• Using SLDIM

C:\Program Files\SOLIDWORKS Corp\SOLIDWORKS PDM

• Using InstallShield Wizard

C:\Program Files\SOLIDWORKS PDM

The installation guide refers to either path, use the path that is appropriate to your
environment.

You must install the SolidNetWork License Manager separately.

You can install SOLIDWORKS PDM client and SOLIDWORKS PDM server either on different
machines or on the same machine. To install both on the same machine, you must run the
server install.

You cannot install client and server on the same machine by running separate installs.

You can select a product type based on the license available. The following add-ins specific to
the product type are available.

Product types and add-insClient

SOLIDWORKS PDM CAD Editor

• SOLIDWORKS
• DraftSight

SOLIDWORKS PDM Contributor

• DraftSight

SOLIDWORKS PDM Viewer: No add-in

SOLIDWORKS PDM Standard
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Product types and add-insClient

SOLIDWORKS PDM CAD Editor

• Microsoft Office Integration
• SOLIDWORKS
• DraftSight
• Autodesk Inventor
• AutoCAD

SOLIDWORKS PDM Contributor

• Microsoft Office Integration
• DraftSight

SOLIDWORKS PDM Viewer

• Microsoft Office Integration

SOLIDWORKS PDM Professional

This chapter includes the following topics:

• Required Installation Components
• Optional Installation Components (SOLIDWORKS PDM Professional Only)
• SOLIDWORKS PDM Deployment Scenarios
• System Requirements
• Installation Summary
• Installation Assistance

Required Installation Components
To use SOLIDWORKS PDM, these components must be installed and configured.

The SOLIDWORKS PDM Professional file vault
database must be hosted on SQL Server 2014, SQL
Server 2012, or SQL Server 2008 R2.

The SQL Server software is not included on the
SOLIDWORKS DVD and must be installed separately.

Microsoft SQL Server

The SOLIDWORKS PDM Standard file vault database
must be hosted on SQL Server 2014 Express.

The SQL Server Express software is included on the
SOLIDWORKS DVD.

Microsoft SQL Server Express

The database server periodically polls SOLIDWORKS
PDM databases for updates such as notifications, local
view refresh, replication schedule updates, and index
server changes. It also manages data import and
export rules.

SOLIDWORKS PDM database
server

The archive server hosts the physical files stored in
a file vault, and manages users and their credentials.

SOLIDWORKS PDM archive server
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The SolidNetWork License Manager manages licensing
of SOLIDWORKS PDM.

If you already have a SolidNetWork License Manager
installed for SOLIDWORKS, you can use it with
SOLIDWORKS PDM. You must ensure that it is
updated to the SOLIDWORKS PDM release version.

SolidNetWork License Manager

Each computer accessing the SOLIDWORKS PDM
Professional file vault must have one of the following
clients installed:

Supports working with all file
types, including enhanced
management and previewing of
CAD formats such as
SOLIDWORKS. CAD add-ins
allow users to access
SOLIDWORKS PDM Professional
from within the CAD application.

SOLIDWORKS
PDM
Professional
CAD Editor &
Web

Supports working with all file
types, including CAD files.
However, the CAD add-ins are
not supported on this client type.

SOLIDWORKS
PDM
Professional
Contributor &
Web

Allows read-only access to file
vaults; user cannot add or
modify (check out, check in,
update values) files or use CAD
add-ins.

SOLIDWORKS
PDM
Professional
Viewer

SOLIDWORKS PDM Professional
client
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Each computer accessing the SOLIDWORKS PDM
Standard file vault must have one of the following
clients installed:

Supports working with
SOLIDWORKS, DWG/DXF format,
Microsoft Word, and Microsoft
Excel files. All file formats that
Office plug-in handles behave in
the same way in SOLIDWORKS
PDM Standard except Preview.

SOLIDWORKS
PDM Standard
CAD Editor

Supports working with
SOLIDWORKS, DWG/DXF format,
Microsoft Word, and Microsoft
Excel files.

SOLIDWORKS
PDM Standard
Contributor

Allows read-only access to file
vaults; user cannot add or
modify (check out, check in,
update values) files.

SOLIDWORKS
PDM Standard
Viewer

SOLIDWORKS PDM Standard

Optional Installation Components (SOLIDWORKS PDM
Professional Only)

The following installation components are optional:

The Web server provides access to a file vault from the
Internet or an intranet.

SOLIDWORKS PDMWeb server

The SOLIDWORKS PDM index server provides for full
content search in many file types stored in a file vault.

SOLIDWORKS PDM index
server

SOLIDWORKS PDM Deployment Scenarios
The deployment of SOLIDWORKS PDM components depends on the size and type of
organization where SOLIDWORKS PDM is used.

Medium Office Network

A server running SQL Server for SOLIDWORKS PDM Professional or SQL Server Express
for SOLIDWORKS PDM Standard hosts the archive server, database server, and SNL
server. Windows workstations installed with the SOLIDWORKS PDM client attach to the
server.
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Large Office Network

One server running SQL Server hosts the file vault databases and the database server.
One server hosts the archive server and another server hosts the SNL server. Workstations
installed with the SOLIDWORKS PDM Professional client attach to the servers. A Web
server allows access over the Internet using SOLIDWORKS PDM Web clients.
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WAN Connected Offices

One main server running SQL Server hosts the central database server. A second server
hosts the archive server and a third server hosts the SNL server. Each WAN office has a
server hosting a local archive server with a replicated file vault archive.

Workstations installed with the SOLIDWORKS PDM Professional client attach to their local
archive server and to the central database server.

System Requirements
SOLIDWORKS PDM system requirements are available on the SOLIDWORKS Web site.

http://www.solidworks.com/sw/support/pdmsystemrequirements.html.
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Installation Summary
Although components can be installed in any order, the recommended sequence for a
LAN installation is described.

To install SOLIDWORKS PDM Professional components:

1. Install SQL Server on the system that hosts the SOLIDWORKS PDM Professional file
vault database or install SQL Express on the system that hosts the SOLIDWORKS
PDM Standard file vault database, unless you have an existing SQL Server or SQL
Express running.
For details, see Installing and Configuring SQL Server on page 20.

2. Install the database server component on the system running the SQL Server.
For details, see Installing SOLIDWORKS PDM Database Server on page 53.

3. Install the archive server on the system running the SQL Server or on a separate
system.

For details, see Installing SOLIDWORKS PDM Archive Server on page 56.

4. Install and configure the SolidNetWork License Manager on a server that is accessible
to all clients, preferably the SQL database server.

For details, see Installing and Configuring SolidNetWork Licensing on page 64.

5. Install the SOLIDWORKS PDM client on all workstations that will work in the file vault.
For details, see Installing the SOLIDWORKS PDM Client on page 89.

6. Create a new file vault using the SOLIDWORKS PDM administration tool on a system
where the SOLIDWORKS PDM client is installed.
For details, see Vault Creation.

7. Attach the remaining clients to the archive server and create local file vault views
using the View Setup wizard.
For details, see Creating a File Vault View Using the View SetupWizard on page
115.

8. Optionally, set up the SOLIDWORKS PDM Professional index server for content search
support.
For details, see Configuring Content Search (For SOLIDWORKS PDM
Professional only) on page 131.

Installation Assistance
First level technical support for SOLIDWORKS products is provided by your reseller.

For help contacting your reseller:

• Refer to
http://www.solidworks.com/sw/support/customer-software-support.htm.

• Call 1-800-693-9000 from the USA or Canada.
• Call 1 978-371-5011 from other locations.
• Send e-mail to customercenterSR@solidworks.com.
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3
Installing and Configuring SQL
Server

SOLIDWORKS PDM Professional uses a Microsoft SQL-based database to store information
about files and activities in a file vault. File vaults require SQL Server 2014, SQL Server 2012,
or SQL Server 2008R2.

Recommendation: Use SQL Server 2014 to host the file vault database.

A Microsoft SQL Server 2014 DVD is included with the SOLIDWORKS PDM media kit. If you
install from a downloaded kit, you must obtain SQL Server software separately; it is not
included in the download.

If you already have the required version of SQL Server installed, continue to Installing
SOLIDWORKS PDM on page 52.

If you are uncertain of which SQL Server version is installed, see Microsoft Knowledge Base
article 321185 to identify version and edition:

http://support.microsoft.com/default.aspx/kb/321185/en-us

This chapter includes the following topics:

• SQL Server 2016 Support
• Installing SQL Server 2016
• Upgrading to SQL Server 2016
• SQL Server 2014 Support
• Installing SQL Server 2014
• Upgrading to SQL Server 2014
• Installing SQL Server 2012
• Upgrading to SQL Server 2012
• SQL Server Troubleshooting
• Changing the SQL Server Login Account

SQL Server 2016 Support
SOLIDWORKS PDM Professional 2017 supports the use of SQL Server 2016.

For those customers who have obtained SQL Server 2016 through other channels,
SOLIDWORKS now supports its use with SOLIDWORKS PDM 2017 provided that there
are sufficient SQL Client Access Licenses for the existing SQL server.
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Installing SQL Server 2016
The SQL Server 2016 installer provides help, including considerations for running on
Windows Vista or later. The SQL Server 2016 Books Online provide hardware and software
requirements and detailed installation instructions.

For details, see https://msdn.microsoft.com/en-us/library/bb500469.aspx.

Before Installing SQL Server 2016
For local installations, you must run Setup as an administrator. If you install SQL Server
2016 from a remote share, you must use a domain account that has read and execute
permissions on the remote share.

If SOLIDWORKS PDM is installed on the system, use Uninstall a program to uninstall
the Microsoft SQL Server 2014 Backward Compatibility package before starting the
SQL Server 2016 installation.

Microsoft .Net framework version 3.5 SP01 and Windows Installer 4.5 are required. If
they are not installed, the Installation Wizard installs them before starting the SQL Server
2016 installation. These installations may require you to restart your computer.

For Windows Server 2008 R2 x64, to install .Net framework 3.5 SP01, right-click My
Computer and selectManage > Features. In the Add Features Wizard, on the Features
page, expand .Net Framework 3.5.1 Features and select .Net Framework 3.5.1
(Installed).

Performing the SQL Server 2016 Installation

1. Close all Windows applications, including Windows Explorer.
2. Insert the SQL Server 2016 installation media. From the root folder, double-click

setup.exe and use the default selections unless otherwise instructed.

ActionScreen

In the left pane, click Installation.SQL Server Installation
Center/Planning

Click New SQL Server stand-alone installation or
add features to an existing installation.

SQL Server Installation
Center/Installation

1. Select Enter the product key and type your license
key.

2. Click Next.

Product Key

1. Read and accept the license agreement.
2. Click Next.

License Terms
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ActionScreen

The installer performs an additional check:

• If no problems are reported, click Next.
• If problems are reported:

1. Click Show details to list the components that
failed or prompted warnings.

2. Click Cancel to stop the installation and fix the
problems.

Install Rules

1. Under Instance Features, select Database Engine
Services.

2. Under Shared Features, select:
• Client Tools Connectivity
• Integration Services
• Client Tools Backward Compatibility
• Documentation Components

3. Click Next.

Feature Selection

If this is a new installation:

1. Select Default instance.
2. Click Next.

If SQL Server is already installed on the system and you
opted not to upgrade:

1. Select Named Instance.
2. Enter a unique instance name for this installation:

computername\instancename.

3. Click Next.

Instance Configuration
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ActionScreen

SQL Server Agent:
• Account Name: NT Service\SQLSERVERAGENT
• Startup Type: Automatic

Server
Configuration/Service
Account tab

SQL Server Database Engine:
• Account Name: NT Service\MSSQLSERVER
• Startup Type: Automatic

SQL Server Integration Services 13.0:
• Account Name: NT Service\MsDtsServer130
• Startup Type: Automatic

SQL Server Browser:
• Account Name: NT AUTHORITY\LOCAL SERVICE
• Startup Type: Automatic

1. Select Mixed Mode (SQL Server authentication
andWindows authentication). SOLIDWORKS PDM
Professional uses SQL Server authentication for
database communication.

2. Type a strong password for the system administrator
account (sa). Do not leave the password blank. For
password rules, click Help.

Retype the password to confirm it.

Remember the password for use when setting up
SOLIDWORKS PDM Professional file vault
databases.

3. Under Specify SQL Server administrators, click
Add Current User.

4. Click Next.

Database Engine
Configuration

Do not change settings
on the Data Directories
or Filestream tabs.

The installer checks for problems that will prevent the
installation of SQL Server 2016.

• If no problems are reported, click Next.
• If problems are reported:

1. Click Show details to list the components that
failed or prompted warnings.

2. Click Cancel to stop the installation and fix the
problems.

Installation Rules
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ActionScreen

Click Install.Ready to Install

Installation may take a long time.

If you get an error regarding the SQL Server
Backwards-Compatibility Files, cancel the installation.
Use Uninstall a program to uninstall the Microsoft SQL
Server 2014 Backward Compatibility package. Then
restart the SQL Server 2016 installation.

When the progress bar shows Setup process
complete, click Next.

Installation Progress

Click Close.

If you receive a message that computer restart is
required, click OK. If a restart does not begin
automatically, manually restart your computer.

Complete

After Installing SQL Server 2016
To use secure SQL communication over the network and have a certificate server, you
can enable SSL encryption.

For details, see the Microsoft articles:

• https://msdn.microsoft.com/en-us/library/bb500395.aspx
• https://msdn.microsoft.com/en-us/library/ms143219.aspx

Verifying SQL Server 2016 Installation

To verify that SQL Server 2016 was installed correctly:

1. Start the SQL Server Configuration Manager.
2. Click SQL Server 2016 Services and see whether SQL Server (MSSQLSERVER)

is running.
3. If it is not, start the service by right-clicking SQL Server (MSSQLSERVER) and

selecting Start.
4. Exit the SQL Server Configuration Manager.

Upgrading to SQL Server 2016
Follow these instructions to upgrade an existing SQL Server SQL 2012 instance to SQL
Server 2016.

If upgrading to SQL Server 2016, see the SQL Server 2016 books online for detailed
instructions:

• https://msdn.microsoft.com/en-us/library/ms144267.aspx
• https://msdn.microsoft.com/en-us/library/bb677622.aspx
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If you are uncertain of which SQL Server version is installed, refer to Microsoft Knowledge
Base article 321185 to identify version and edition:

https://support.microsoft.com/en-us/kb/321185

All file vault databases are automatically upgraded to SQL Server 2016 format when the
server instance is upgraded.

Performing the Upgrade to SQL Server 2016

1. Close all Windows applications, including Windows Explorer.
2. Insert the SQL Server 2016 installation media. From the root folder, double-click

setup.exe and use the default selections unless otherwise instructed.
Use the default selections unless otherwise instructed.

ActionScreen

In the left pane, click Installation.SQL Server Installation
Center/Planning page

Click Upgrade from a previous version of SQL
Server.

SQL Server Installation
Center/Installation page

1. Select Enter the product key and type your
license key.

2. Click Next.

Product Key

1. Read and accept the license agreement.
2. Click Next.

License Terms

The installer performs an additional check.

• If no problems are reported, click Next.
• If problems are reported:

1. Click Show details to list the components
that failed or prompted warnings.

2. Click Cancel to stop the installation and fix
the problems.

Upgrade Rules

Select the SQL Server instance to upgrade.
MSSQLSERVER is the default.

Select Instance

Lists the installed SQL features that will be
upgraded.

Click Next.

Select Features

Lists the named instance that will be upgraded.

Click Next.

Instance Configuration
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ActionScreen

Click Next.Server Configuration

The installer checks for problems that will prevent
the upgrade to SQL Server 2014.

• If no problems are reported, click Next.
• If problems are reported:

1. Click Show details to list the components
that failed or prompted warnings.

2. Click Cancel to stop the installation and fix
the problems.

Upgrade Rules

Click Upgrade.Ready to Upgrade

When the upgrade finishes for all components,
click Next.

Upgrade Progress

Click Close.Complete

Click X in the upper right corner to close.SQL Server Installation Center

After Upgrading to SQL Server 2016

• Verify the upgrade.

For details, see Verifying SQL Server 2016 Installation.
• Troubleshoot problems.

For details, see SQL Server Troubleshooting.

SQL Server 2014 Support
SOLIDWORKS PDM Professional 2016 supports the use of SQL Server 2014.

For those customers who have obtained SQL Server 2014 through other channels,
SOLIDWORKS now supports its use with SOLIDWORKS PDM 2016 provided that there
are sufficient SQL Client Access Licenses for the existing SQL server.

Installing SQL Server 2014
The SQL Server 2014 installer provides help, including considerations for running on
Windows Vista or later. The SQL Server 2014 Books Online provide hardware and software
requirements and detailed installation instructions.

For details, see http://msdn.microsoft.com/en-in/library/bb545450.aspx.
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Before Installing SQL Server 2014
For local installations, you must run Setup as an administrator. If you install SQL Server
2014 from a remote share, you must use a domain account that has read and execute
permissions on the remote share.

If SOLIDWORKS PDM is installed on the system, use Uninstall a program to uninstall
the Microsoft SQL Server 2012 Backward Compatibility package before starting the
SQL Server 2014 installation.

Microsoft .Net framework version 3.5 SP01 and Windows Installer 4.5 are required. If
they are not installed, the Installation Wizard installs them before starting the SQL Server
2014 installation. These installations may require you to restart your computer.

For Windows Server 2008 R2 x64, to install .Net framework 3.5 SP01, right-click My
Computer and selectManage > Features. In the Add Features Wizard, on the Features
page, expand .Net Framework 3.5.1 Features and select .Net Framework 3.5.1
(Installed).

Performing the SQL Server 2014 Installation

1. Close all Windows applications, including Windows Explorer.
2. Insert the SQL Server 2014 installation media. From the root folder, double-click

setup.exe and use the default selections unless otherwise instructed.

ActionScreen

In the left pane, click Installation.SQL Server Installation
Center/Planning

Click New SQL Server stand-alone installation or
add features to an existing installation.

SQL Server Installation
Center/Installation

The installer checks for problems that will prevent the
installation of the SQL Server support files:

• If no problems are reported, click OK.
• If problems are reported:

1. Click Show details to list the components that
failed or prompted warnings.

2. Click Cancel to stop the installation and fix the
problems.

Setup Support Rules

1. Select Enter the product key and type your license
key.

2. Click Next.

Product Key

1. Read and accept the license agreement.
2. Click Next.

License Terms
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ActionScreen

Click Install.Setup Support Files

The installer performs an additional check:

• If no problems are reported, click Next.
• If problems are reported:

1. Click Show details to list the components that
failed or prompted warnings.

2. Click Cancel to stop the installation and fix the
problems.

Setup Support Rules

1. Under Instance Features, select Database Engine
Services.

2. Under Shared Features, select:
• Client Tools Connectivity
• Integration Services
• Client Tools Backward Compatibility
• Documentation Components
• Management Tools - Basic
• Management Tools - Complete

3. Click Next.

Feature Selection

If this is a new installation:

1. Select Default instance.
2. Click Next.

If SQL Server is already installed on the system and you
opted not to upgrade:

1. Select Named Instance.
2. Enter a unique instance name for this installation:

computername\instancename.

3. Click Next.

Instance Configuration

If disk space requirements are met, click Next.

If disk space requirements are not met:

1. Note the space required.
2. Click Cancel.
3. Add the required space.
4. Run the installation again.

Disk Space Requirements
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ActionScreen

SQL Server Agent:
• Account Name: NT Service\SQLAgent$MSSQLSERVER
• Startup Type: Automatic

Server
Configuration/Service
Account tab

SQL Server Database Engine:
• Account Name: NT Service\MSSQL$MSSQLSERVER
• Startup Type: Automatic

SQL Server Integration Services 12.0:
• Account Name: NT Service\MsDtsServer120
• Startup Type: Automatic

SQL Server Browser:
• Account Name: NT AUTHORITY\LOCAL SERVICE
• Startup Type: Automatic

1. For Database Engine, click Customize.
2. In the dialog box, select Windows Collation
designator and sort order, and the Collation
designator that matches your locale. Keep the other
selections.

You cannot use SOLIDWORKS PDM on a server
using binary settings.

3. Click Next.

Server
Configuration/Collation tab
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ActionScreen

1. Select Mixed Mode (SQL Server Authentication
andWindows Authentication). SOLIDWORKS PDM
Professional uses SQL Server authentication for
database communication.

2. Type a strong password for the system administrator
account (sa). Do not leave the password blank. For
password rules, click Help.

Retype the password to confirm it.

Remember the password for use when setting up
SOLIDWORKS PDM Professional file vault
databases.

3. Under Specify SQL Server administrators, click
Add.

4. In the Select Users, Computers, or Groups dialog
box, enter the name of the local administrator of the
system or the Administrators group.

5. Click Next.

Database Engine
Configuration/Account
Provisioning tab

Do not change settings
on the Data Directories
or Filestream tabs.

(Optional) To change the default folder where databases
created by SOLIDWORKS PDM Professional are stored,
change the location for User database directory and
User database log directory.

Database Engine
Configuration/Data
Directories tab

Click Next.Error and Usage Reporting

The installer checks for problems that will prevent the
installation of SQL Server 2014.

• If no problems are reported, click Next.
• If problems are reported:

1. Click Show details to list the components that
failed or prompted warnings.

2. Click Cancel to stop the installation and fix the
problems.

Installation Rules

Click Install.Ready to Install
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ActionScreen

Installation may take a long time.

If you get an error regarding the SQL Server
Backwards-Compatibility Files, cancel the installation.
Use Uninstall a program to uninstall the Microsoft SQL
Server 2012 Backward Compatibility package. Then
restart the SQL Server 2014 installation.

When the progress bar shows Setup process
complete, click Next.

Installation Progress

Click Close.

If you receive a message that computer restart is
required, click OK. If a restart does not begin
automatically, manually restart your computer.

Complete

After Installing SQL Server 2014
To use secure SQL communication over the network and have a certificate server, you
can enable SSL encryption.

For details, see the Microsoft article:

http://support.microsoft.com/kb/318605/en-us

Verifying SQL Server 2014 Installation

To verify that SQL Server 2014 was installed correctly:

1. Start the SQL Server Configuration Manager.
2. Click SQL Server 2014 Services and see whether SQL Server (MSSQLSERVER)

is running.
3. If it is not, start the service by right-clicking SQL Server (MSSQLSERVER) and

selecting Start.
4. Exit the SQL Server Configuration Manager.

Upgrading to SQL Server 2014
Follow these instructions to upgrade an existing SQL Server SQL 2008R2 or SQL Server
SQL 2012 instance to SQL Server 2014.

If upgrading to SQL Server 2014, see the SQL Server 2014 books online for detailed
instructions:

http://msdn.microsoft.com/en-in/library/bb677622.aspx

http://msdn.microsoft.com/en-in/library/bb545450.aspx

If you are uncertain of which SQL Server version is installed, refer to Microsoft Knowledge
Base article 321185 to identify version and edition:

http://support.microsoft.com/default.aspx/kb/321185/en-us
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All file vault databases are automatically upgraded to SQL Server 2014 format when the
server instance is upgraded.

Performing the Upgrade to SQL Server 2014

1. Close all Windows applications, including Windows Explorer.
2. Insert the SQL Server 2014 installation media, and from the root folder, double-click

setup.exe.
Use the default selections unless otherwise instructed.

ActionScreen

In the left pane, click Installation.SQL Server Installation
Center/Planning page

Click Upgrade from SQL Server 2005, SQL
Server 2008, SQL Server 2008 R2 or SQL
Server 2012.

SQL Server Installation
Center/Installation page

The installer checks for problems that will prevent
the installation of the SQL Server support files:

• If no problems are reported, click OK.
• If problems are reported:

1. Click Show details to list the components
that failed or prompted warnings.

2. Click Cancel to stop the installation and fix
the problems.

Setup Support Rules

1. Select Enter the product key and type your
license key.

2. Click Next.

Product Key

1. Read and accept the license agreement.
2. Click Next.

License Terms

Click Install.Setup Support Files

The installer performs an additional check.

• If no problems are reported, click Next.
• If problems are reported:

1. Click Show details to list the components
that failed or prompted warnings.

2. Click Cancel to stop the installation and fix
the problems.

Setup Support Rules
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ActionScreen

Select the SQL Server instance to upgrade.
MSSQLSERVER is the default.

Select Instance

Lists the installed SQL features that will be
upgraded.

Click Next.

Select Features

Lists the named instance that will be upgraded.

Click Next.

Instance Configuration

If disk space requirements are met, click Next.

If disk space requirements are not met:

1. Note the space required.
2. Click Cancel.
3. Add the required space.
4. Run the installation again.

Disk Space Requirements

Click Next.Server Configuration

Select Import and click Next.Full-text Upgrade

Click Next.Error and Usage Reporting

The installer checks for problems that will prevent
the upgrade to SQL Server 2014.

• If no problems are reported, click Next.
• If problems are reported:

1. Click Show details to list the components
that failed or prompted warnings.

2. Click Cancel to stop the installation and fix
the problems.

Upgrade Rules

Click Upgrade.Ready to Upgrade

When the upgrade finishes for all components,
click Next.

Upgrade Progress

Click Close.Complete

Click X in the upper right corner to close.SQL Server Installation Center
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After Upgrading to SQL Server 2014

• Verify the upgrade.

For details, see Verifying SQL Server 2014 Installation on page 31.
• Troubleshoot problems.

For details, see SQL Server Troubleshooting on page 41.

Installing SQL Server 2012
The SQL Server 2012 installer provides help, including considerations for running on
Windows Vista or later. The SQL Server 2012 Books Online (SQL Server 2012
Documentation Components) provide hardware and software requirements and detailed
installation instructions.

For details, see
http://sqlish.com/installing-books-online-for-microsoft-sql-server-2012/.

Before Installing SQL Server 2012
For local installations, you must run Setup as an administrator. If you install SQL Server
2012 from a remote share, you must use a domain account that has read and execute
permissions on the remote share.

If SOLIDWORKS PDM is installed on the system, use Uninstall a program to uninstall
the Microsoft SQL Server 2008 Backward Compatibility package before starting the
SQL Server 2012 installation.

Microsoft .Net framework version 3.5 SP01 and Windows Installer 4.5 are required. If
they are not installed, the Installation Wizard installs them before starting the SQL Server
2012 installation. These installations may require you to restart your computer.

For Windows Server 2008 R2 x64, to install .Net framework 3.5 SP01, right-click My
Computer and selectManage > Features. In the Add Features Wizard, on the Features
page, expand .Net Framework 3.5.1 Features and select .Net Framework 3.5.1
(Installed).

Performing the SQL Server 2012 Installation

1. Close all Windows applications, including Windows Explorer.
2. Insert the SQL Server 2012 installation media. From the root folder, double-click

setup.exe and use the default selections unless otherwise instructed.

ActionScreen

In the left pane, click Installation.SQL Server Installation
Center/Planning

Click New SQL Server stand-alone installation or
add features to an existing installation.

SQL Server Installation
Center/Installation
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ActionScreen

The installer checks for problems that will prevent the
installation of the SQL Server support files:

• If no problems are reported, click OK.
• If problems are reported:

1. Click Show details to list the components that
failed or prompted warnings.

2. Click Cancel to stop the installation and fix the
problems.

Setup Support Rules

1. Select Enter the product key and type your license
key.

2. Click Next.

Product Key

1. Read and accept the license agreement.
2. Click Next.

License Terms

Click Install.Setup Support Files

The installer performs an additional check:

• If no problems are reported, click Next.
• If problems are reported:

1. Click Show details to list the components that
failed or prompted warnings.

2. Click Cancel to stop the installation and fix the
problems.

Setup Support Rules

1. Under Instance Features, select Database Engine
Services.

2. Under Shared Features, select:
• Client Tools Connectivity
• Integration Services
• Client Tools Backward Compatibility
• Documentation Components
• Management Tools - Basic
• Management Tools - Complete

3. Click Next.

Feature Selection
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ActionScreen

If this is a new installation:

1. Select Default instance.
2. Click Next.

If SQL Server is already installed on the system and you
opted not to upgrade:

1. Select Named Instance.
2. Enter a unique instance name for this installation:

computername\instancename.

3. Click Next.

Instance Configuration

If disk space requirements are met, click Next.

If disk space requirements are not met:

1. Note the space required.
2. Click Cancel.
3. Add the required space.
4. Run the installation again.

Disk Space Requirements

SQL Server Agent and SQL Server Database
Engine:
• Account Name: NT AUTHORITY\SYSTEM
• Startup Type: Automatic

Server
Configuration/Service
Account tab

SQL Server Integration Services 10.0:
• Account Name: NT AUTHORITY\SYSTEM
• Startup Type: Automatic

SQL Server Browser:
• Account Name: NT AUTHORITY\LOCAL SERVICE
• Startup Type: Automatic

1. For Database Engine, click Customize.
2. In the dialog box, select Windows Collation
designator and sort order, and the Collation
designator that matches your locale. Keep the other
selections.

You cannot use SOLIDWORKS PDM on a server
using binary settings.

3. Click Next.

Server
Configuration/Collation tab
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ActionScreen

1. Select Mixed Mode (SQL Server Authentication
andWindows Authentication). SOLIDWORKS PDM
Professional uses SQL Server authentication for
database communication.

2. Type a strong password for the system administrator
account (sa). Do not leave the password blank. For
password rules, click Help.

Retype the password to confirm it.

Remember the password for use when setting up
SOLIDWORKS PDM Professional file vault
databases.

3. Under Specify SQL Server administrators, click
Add.

4. In the Select Users, Computers, or Groups dialog
box, enter the name of the local administrator of the
system or the Administrators group.

5. Click Next.

Database Engine
Configuration/Account
Provisioning tab

Do not change settings
on the Data Directories
or Filestream tabs.

(Optional) To change the default folder where databases
created by SOLIDWORKS PDM Professional are stored,
change the location for User database directory and
User database log directory.

Database Engine
Configuration/Data
Directories tab

Click Next.Error and Usage Reporting

The installer checks for problems that will prevent the
installation of SQL Server 2012.

• If no problems are reported, click Next.
• If problems are reported:

1. Click Show details to list the components that
failed or prompted warnings.

2. Click Cancel to stop the installation and fix the
problems.

Installation Rules

Click Install.Ready to Install

37

Installing and Configuring SQL Server



ActionScreen

Installation may take a long time.

If you get an error regarding the SQL Server
Backwards-Compatibility Files, cancel the installation.
Use Uninstall a program to uninstall the Microsoft SQL
Server 2008 Backward Compatibility package. Then
restart the SQL Server 2012 installation.

When the progress bar shows Setup process
complete, click Next.

Installation Progress

Click Close.

If you receive a message that computer restart is
required, click OK. If a restart does not begin
automatically, manually restart your computer.

Complete

After Installing SQL Server 2012
To use secure SQL communication over the network and have a certificate server, you
can enable SSL encryption.

For details, see the Microsoft articles:

http://support.microsoft.com/kb/318605/en-us

Verifying SQL Server 2012 Installation

To verify that SQL Server 2012 was installed correctly:

1. Start the SQL Server Configuration Manager.
2. Click SQL Server Services and see whether SQL Server (MSSQLSERVER) is

running.
3. If it is not, start the service by right-clicking SQL Server (MSSQLSERVER) and

selecting Start.
4. Exit the SQL Server Configuration Manager.

Upgrading to SQL Server 2012
Follow these instructions to upgrade an existing SQL Server SQL 2008 instance to SQL
Server 2012.

If upgrading to SQL Server 2012, see the SQL Server 2012 books online for detailed
instructions:

http://sqlish.com/installing-books-online-for-microsoft-sql-server-2012/

If upgrading to SQL Server 2008 R2, see
http://msdn.microsoft.com/en-us/library/bb677622(v=sql.105).aspx.

If you are uncertain of which SQL Server version is installed, refer to Microsoft Knowledge
Base article 321185 to identify version and edition:
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http://support.microsoft.com/default.aspx/kb/321185/en-us

All file vault databases are automatically upgraded to SQL Server 2012 format when the
server instance is upgraded.

Performing the Upgrade to SQL Server 2012

1. Close all Windows applications, including Windows Explorer.
2. Insert the SQL Server 2012 installation media, and from the root folder, double-click

setup.exe.
Use the default selections unless otherwise instructed.

ActionScreen

In the left pane, click Installation.SQL Server Installation
Center/Planning page

Click Upgrade from SQL Server 2008.SQL Server Installation
Center/Installation page

The installer checks for problems that will prevent
the installation of the SQL Server support files:

• If no problems are reported, click OK.
• If problems are reported:

1. Click Show details to list the components
that failed or prompted warnings.

2. Click Cancel to stop the installation and fix
the problems.

Setup Support Rules

1. Select Enter the product key and type your
license key.

2. Click Next.

Product Key

1. Read and accept the license agreement.
2. Click Next.

License Terms

Click Install.Setup Support Files

The installer performs an additional check.

• If no problems are reported, click Next.
• If problems are reported:

1. Click Show details to list the components
that failed or prompted warnings.

2. Click Cancel to stop the installation and fix
the problems.

Setup Support Rules
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ActionScreen

Select the SQL Server instance to upgrade.
MSSQLSERVER is the default.

Select Instance

Lists the installed SQL features that will be
upgraded.

Click Next.

Select Features

Lists the named instance that will be upgraded.

Click Next.

Instance Configuration

If disk space requirements are met, click Next.

If disk space requirements are not met:

1. Note the space required.
2. Click Cancel.
3. Add the required space.
4. Run the installation again.

Disk Space Requirements

Click Next.Server Configuration

Select Import and click Next.Full-text Upgrade

Click Next.Error and Usage Reporting

The installer checks for problems that will prevent
the upgrade to SQL Server 2012.

• If no problems are reported, click Next.
• If problems are reported:

1. Click Show details to list the components
that failed or prompted warnings.

2. Click Cancel to stop the installation and fix
the problems.

Upgrade Rules

Click Upgrade.Ready to Upgrade

When the upgrade finishes for all components,
click Next.

Upgrade Progress

Click Close.Complete

Click X in the upper right corner to close.SQL Server Installation Center

40

Installing and Configuring SQL Server



After Upgrading to SQL Server 2012
• Verify the upgrade.

For details, see Verifying SQL Server 2012 Installation on page 38.
• Troubleshoot problems.

For details, see SQL Server Troubleshooting on page 41 .

SQL Server Troubleshooting

Clients Cannot Work in the File Vault

The SQL password has expired or the account has been locked
out.

Cause

Unlock the account by logging in using Windows Authentication.Solution

To unlock the SQL Server Account

1. Open Microsoft SQL Server Management Studio.
2. In the Connect to Server dialog box:

a) For Authentication, select Windows Authentication.
b) Click Connect.

3. In the left pane, expand Security and select Logins.
4. Right-click the SQL login that is defined for use in the archive server (typically the

sa account) and select Properties.
5. In the Login Properties dialog box, in the left pane, click Status.
6. Under Status, for SQL Server authentication, clear Login is locked out.
7. Exit Microsoft SQL Server Management Studio.

SOLIDWORKS PDM Administrative Features Fail

Remote connections are not allowed.Cause

Enable the SQL Server remote access option.Solution

To enable the SQL server remote access option:

1. Open Microsoft SQL Server Management Studio.
2. Log in as system administrator.
3. Right-click the server and select Properties.
4. In the Server Properties dialog box, click Connections.
5. In the right pane, under Remote server connections, verify that Allow remote

connections to this server is selected, and click OK.
6. Exit Microsoft SQL Server Management Studio.
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SOLIDWORKS PDM Cannot Connect to the Server

TCP/IP is not enabled, or the TCP port is wrong.Cause

Activate the TCP/IP protocol for client connections and ensure
that TCP port 1433 is open.

Solution

To activate the SQL Server TCP/IP protocol:

1. Open the SQL Server Configuration Manager.
2. In the left pane, expand SQL Server 2008 Network Configuration, and click

Protocols for MSSQLSERVER.
3. In the right pane, verify that TCP/IP is enabled.
4. Right-click TCP/IP and select Properties.
5. On the IP Addresses tab, ensure that TCP is using port 1433.
6. Exit the SQL Server Configuration Manager.

Changing the SQL Server Login Account
The archive and/or database server services must be able to reach any SOLIDWORKS
PDM Professional databases they manage using an SQL login that has at least db_owner
access to the databases. Normally when SQL Server is installed, a system administrator
login (sa) is created that has full access to all databases on the SQL Server.

Use this system administrator, or create a new user with db_owner access to the
SOLIDWORKS PDM Professional databases.

If you plan to create new file vault databases using a db_owner SQL login, create this
SQL login first.

To create a new file vault database, you must log in as a SQL system administrator.
If you use a db_owner SQL login, you are prompted for the system administrator (sa)
login during vault creation.

Creating a New SQL Login Account

1. Open Microsoft SQL Server Management Studio.
2. Log in as a system administrator.
3. In the left pane, expand Security.
4. Right-click Logins and select New Login.
5. In the Login - New dialog box, select General:

a) Type a Login name for the new SQL user.
b) Select SQL Server Authentication and enter a password.
c) Clear Enforce password policy.
d) Click OK.

6. Close Microsoft SQL Server Management Studio.
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This login does not need any additional permissions to be used by SOLIDWORKS PDM
Professional.

Using the New SQL Login with the SOLIDWORKS PDM
Archive

1. On the system running the SOLIDWORKS PDM archive server, open the SOLIDWORKS
PDM Archive Server dialog box by doing one of the following:

• On Windows 7 and Windows Server systems prior to Windows Server 2012, from
the Windows Start menu, click All Programs > SOLIDWORKS PDM > Archive
Server Configuration.

• On Windows 8.1 and Windows Server 2012 or later, on the Apps screen, under
SOLIDWORKS PDM, click Archive Server Configuration.

2. Select Tools > Default settings.
3. In the Settings dialog box, under SQL login, click Change.
4. In the Change SQL User Login dialog box, enter the SQL user login and password of

the new SQL user and click OK twice.

From now on, new file vault databases that are created are assigned db_owner
access for this user.

5. Exit the SOLIDWORKS PDM Archive Server dialog box.
6. On the system running the SOLIDWORKS PDM database server, open the

SOLIDWORKS PDM Database Server dialog box by doing one of the following:

• On Windows 7 and Windows Server systems prior to Windows Server 2012, from
the Windows Startmenu, click All Programs > SOLIDWORKS PDM > Database
Server Configuration.

• On Windows 8.1 and Windows Server 2012 or later, on the Apps screen, under
SOLIDWORKS PDM, click Database Server Configuration.

7. Enter the new SQL user login and password, and click OK.
8. Restart the SOLIDWORKS PDM Database Server service.

Giving an SQL User db_owner Access to Existing
SOLIDWORKS PDM File Vault Databases

1. On the SQL server that hosts the new SOLIDWORKS PDM databases, open Microsoft
SQL Server Management Studio.

2. Log in as a system administrator.
3. In the left pane, expand Security and click Logins.
4. Right-click the SQL user and select Properties.
5. In the Login Properties dialog box:

a) In the left pane, select User Mapping.
b) In the right pane, under Users mapped to this login, select Map for all
SOLIDWORKS PDM databases (file vault databases and ConisioMasterDb.)
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c) For each database, under Database role membership, select db_owner.
d) Click OK.

6. Right-click the server and select New Query.
7. In the right pane, enter the following query statement on the new db_owner user

and click Execute.
GRANT VIEW SERVER STATE TO [SQL_USER_NAME]

8. Exit Microsoft Microsoft SQL Server Management Studio.
9. On the system running the SOLIDWORKS PDM archive server, open the SOLIDWORKS

PDM Archive Server dialog box by doing one of the following:

• On Windows 8.1 and Windows Server 2012 or later, on the Apps screen, under
SOLIDWORKS PDM, click Archive Server Configuration.

10. Select Tools > Default settings.
11. In the Settings dialog box, under SQL login, click Change.
12. In the Change SQL User Login dialog box, enter the SQL user login and password of

the new SQL user and click OK.
13. Close the SOLIDWORKS PDM Archive Server dialog box.
14. On the system running the SOLIDWORKS PDM database server, open the

SOLIDWORKS PDM Database Server dialog box by doing one of the following:

• On Windows 8.1 and Windows Server 2012 or later, on the Apps screen, under
SOLIDWORKS PDM, click Database Server Configuration.

15. Enter the new SQL user login and password and click OK.
16. Restart the SOLIDWORKS PDM Database Server service.

Insufficient SQL Permissions
If you do not assign the SQL user sufficient SQL permissions, you cannot log in to any
file vault views.

Warning messages are displayed if the SQL user does not have at least db_owner access:

• To the ConisioMasterDb database

For example:

Could not log in to the database “filevault on Server servername".

• To the file vault database

For example:

Could not access the item in the database.
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4
Installing and Configuring SQL
Server Express

SOLIDWORKS PDM Standard uses a Microsoft SQL Server Express database to store information
about files and activities in a file vault.

You must use SQL Server 2014 Express to host the file vault database.

Microsoft SQL Server 2014 Express is included with the SOLIDWORKS DVD.

This chapter includes the following topics:

• SQL Server 2014 Express Support
• Installing and Managing SQL Server 2014 Express

SQL Server 2014 Express Support
SOLIDWORKS PDM Standard supports the use of Microsoft SQL Server 2014 Express.

For those customers who have obtained SQL Server 2014 Express through other channels,
SOLIDWORKS now supports its use with SOLIDWORKS PDM Standard 2016.

Installing and Managing SQL Server 2014 Express
To install and manage SQL Server 2014 Express, install the SQL Server database engine
and the SQL Server Management Studio.

Each installation package is available on the SOLIDWORKS installation media. You can
install the SQL Server database engine and the SQL Server Management Studio
individually. For details, see Installing the SQL Server Express Database Engine and
Installing the SQL Server Express Management Studio.

To install the SQL Server database engine and the SQL Server Management Studio at the
same time, download and install the combined installation package
SQLEXPRWT_x64_ENU.exe available at
https://www.microsoft.com/en-us/download/details.aspx?id=42299.

Before Installing SQL Server 2014 Express
For local installations, you must run the installation as an administrator.

If Microsoft SQL Server 2012 Backward Compatibility is installed on the system, use
Uninstall a program to uninstall the Microsoft SQL Server 2012 Backward
Compatibility package before starting the SQL Server 2014 Express installation.
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Microsoft .Net framework version 3.5 SP01 and Windows Installer 4.5 are required. If
they are not installed, the Installation Wizard installs them before starting the SQL Server
2014 Express installation. These installations may require you to restart your computer.

For Windows Server 2008 R2 x64, to install .Net framework 3.5 SP01, right-click My
Computer and selectManage > Features. In the Add Features Wizard, on the Features
page, expand .Net Framework 3.5.1 Features and select .Net Framework 3.5.1
(Installed).

Installing the SQL Server Express Database Engine

1. Close all Windows applications, including Windows Explorer.
2. Insert the SOLIDWORKS DVD.

Cancel the SOLIDWORKS Installation Manager, if it starts.

3. Browse to \PreReqs\SQLServer\sqlexpr_x64_enu.exe and click Run as
administrator.
The extraction begins and launches the InstallShield wizard.

4. Use the default selections unless otherwise instructed.

ActionScreen

Click New SQL Server stand-alone
installation or add features to an
existing installation.

SQL Server Installation Center/Installation

1. Read and accept the license
agreement.

2. Click Next.

License Terms

The installer performs an additional check:

• If no problems are reported, click Next.
• If problems are reported:

1. Click Show details to list the
components that failed or prompted
warnings.

2. Click Cancel to stop the installation
and fix the problems.

Install Rules
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ActionScreen

1. Under Instance Features, select
Database Engine Services.

2. Under Shared Features, select:
• Client Tools Connectivity
• Client Tools Backward
Compatibility

• Client Tools SDK

3. Click Next.

Feature Selection

If this is a new installation:

1. Select Default instance.
2. Click Next.

If SQL Server is already installed on the
system and you opted not to upgrade:

1. Select Named Instance.
2. Enter a unique instance name.
3. Click Next.

Instance Configuration

SQL Server Database Engine:
• Account Name: NT
Service\MSSQL$MSSQLSERVER

• Startup Type: Automatic

SQL Server Browser:
• Account Name: NT AUTHORITY\LOCAL
SERVICE

• Startup Type: Automatic

Server Configuration/Service Accounts
tab

1. Keep the default value,
SQL_Latin1_General_CP1_CI_AS.

2. Optionally, click Customize, select
Windows collation designator and
sort order, and the Collation
designator that matches your locale.
Keep the other selections.

You cannot use SOLIDWORKS PDM
Standard on a server using binary
settings.

3. Click Next.

Server Configuration/Collation tab
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ActionScreen

1. Select Mixed Mode (SQL Server
Authentication and Windows
Authentication). SOLIDWORKS PDM
Standard uses SQL Server
authentication for database
communication.

2. Type a strong password for the system
administrator account (sa). Do not
leave the password blank. For
password rules, click Help.

Retype the password to confirm it.

Remember the password for use
when setting up SOLIDWORKS PDM
Standard file vault databases.

3. Under Specify SQL Server
administrators, click Add.

4. In the Select Users, Computers, or
Groups dialog box, enter the name of
the local administrator of the system
or the Administrators group.

5. Click Next.

Database Engine Configuration/Server
Configuration tab

Optionally, set the remaining paths.

Keep the default settings in the
FILESTREAM tab.

Database Engine Configuration/Data
Directories tab/ FILESTREAM tab

Installation may take a long time.

If you get an error regarding the SQL
Server Backwards-Compatibility Files,
cancel the installation. Use Uninstall a
program to uninstall the Microsoft SQL
Server 2012 Backward Compatibility
package. Then restart the SQL Server
2014 installation.

When the progress bar shows Setup
process complete, click Next.

Installation Progress

Click Close.

If you receive a message that computer
restart is required, click OK. If a restart
does not begin automatically, manually
restart your computer.

Complete
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Installing the SQL Server Express Management Studio

1. Close all Windows applications, including Windows Explorer.
2. Insert the SOLIDWORKS DVD.

Cancel the SOLIDWORKS Installation Manager, if it starts.

3. Browse to \SQLMNGMNT\sqlmanagementstudio_x64_enu.exe and click Run as
administrator.
The extraction begins and launches the InstallShield wizard.

4. Use the default selections unless otherwise instructed.

ActionScreen

Click New SQL Server stand-alone
installation or add features to an
existing installation.

SQL Server Installation Center

Select Use Microsoft Update to check
for updates and click Next.

Microsoft Update

Click Next.Product Updates

Select Perform a new installation of
SQL Server 2014 and click Next.

Installation Type

1. Read and accept the license
agreement.

2. Click Next.

License Terms

The installer performs an additional check:

• If no problems are reported, click Next.
• If problems are reported:

1. Click Show details to list the
components that failed or prompted
warnings.

2. Click Cancel to stop the installation
and fix the problems.

Install Rules

1. Under Shared Features, select:
• Client Tools Connectivity
• Client Tools Backward
Compatibility

• Management Tools - Basic
• Management Tools - Complete

2. Click Next.

Feature Selection
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ActionScreen

Click Close.

If you receive a message that computer
restart is required, click OK. If a restart
does not begin automatically, manually
restart your computer.

Complete

After Installing SQL Server 2014 Express
To connect to the SQL Server Express instance from remote clients ensure to configure
the server to accept remote connections and enable the TCP/IP protocol. You must set
the SQL server TCP port to a fixed port number instead of the default dynamic port
number.

Enabling the SQL Server Remote Access Option

To enable the SQL server remote access option:

1. Open Microsoft SQL 2014 Server Management Studio.
2. Select the SQL Server instance name and log in as system administrator.
3. Right-click the server and select Properties.
4. In the Server Properties dialog box, click Connections.
5. In the right pane, under Remote server connections, verify that Allow remote

connections to this server is selected, and click OK.
6. Exit Microsoft SQL Server Management Studio.

Activating the SQL Server TCP/IP Protocol

To activate the SQL Server TCP/IP protocol:

1. Open the SQL Server 2014 Configuration Manager.
2. In the left pane, expand SQL Server Network Configuration, and click Protocols

for <instance name>.
3. In the right pane, verify that TCP/IP is enabled.

If TCP/IP is disabled, right-click TCP/IP and select Enable.

4. In the right pane, select SQL Server Services.
5. Right-click SQL Server(<instance name >) and select Restart.
6. Exit the SQL Server Configuration Manager.

Configuring the SQL Server Express Instance to Listen to a Fixed
TCP Port
The SQL Server Express instance listens to a dynamic port by default. When the SQL
Server service starts up, the port number changes. If the server has a firewall enabled,
it is difficult to configure the port exceptions to allow client access.

For details about configuring the firewall for SQL Server access, see
https://msdn.microsoft.com/en-us/library/cc646023(v=sql.120).aspx.
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To configure the SQL Server Express Instance to Listen to a Fixed TCP Port:

1. Open the SQL Server 2014 Configuration Manager.
2. In the left pane, expand SQL Server Network Configuration, and click Protocols

for <instance name>.
3. Double-click TCP/IP and select the IP Addresses tab.
4. Under IPAll, clear the value in TCP Dynamic Ports.
5. Set the TCP Port to the static port number that you want the SQL Server Express

instance to listen to.

• If SQL Express is the only SQL Server instance on the system, set the port to 1433.
• If other SQL Server instances exist on the system, set the port to a unique value,
for example 1440.

6. Click OK.
7. In the right pane, select SQL Server Services.
8. Right-click SQL Server(<instance name >) and select Restart.
9. Double-click SQL Server Browser and select the Service tab.
10. Set the Start Mode to Automatic and click OK.
11. Right-click SQL Server Browser and start the service if it is not running.

Verifying SQL Server 2014 Express Installation

1. Start the SQL Server Configuration Manager.
2. Click SQL Server Services and see whether SQL Server (<instance name >) is

running.
3. If it is not, start the service by right-clicking SQL Server (<instance name >) and

selecting Start.
4. Exit the SQL Server Configuration Manager.

Upgrading SQL Server Express 2014 to SQL Server 2014

1. Close all Windows applications, including Windows Explorer.
2. Insert the SQL Server 2014 installation media, and from the root folder, double-click

setup.exe.
3. On the SQL Server Installation Center page, in the left pane, select Maintenance.
4. Select Edition Upgrade.
5. Complete the steps in the Upgrade the Edition for SQL Server 2014.
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5
Installing SOLIDWORKS PDM

The SOLIDWORKS media contains the server and client components.

You can install each server component separately, or select multiple components to install in
a single operation.

For example, to install the database server and archive server on the same computer, you
can select both options on the Server Installation screen.

When you install multiple components, the screens appropriate to those components are
displayed. For simplicity, the procedures in this chapter describe the component installations
separately.

You can install SOLIDWORKS PDM Standard or SOLIDWORKS PDM Professional using:

• SOLIDWORKS PDM InstallShield Wizard
• SOLIDWORKS Installation Manager (SLDIM)

If you use SOLIDWORKS PDM InstallShield Wizard, you must install the SolidNetWork License
Manager separately. The SolidNetWork License Manager can be installed with SOLIDWORKS
PDM when using SLDIM.

You can install SOLIDWORKS PDM client and SOLIDWORKS PDM server either on different
machines or on the same machine. To install both on the same machine, you must run the
server install.

You cannot install client and server on the same machine by running separate installs.

This chapter includes the following topics:

• Initiating SOLIDWORKS PDM Installations
• Installing SOLIDWORKS PDM Database Server
• Installing SOLIDWORKS PDM Archive Server
• Installing and Configuring SolidNetWork Licensing
• Installing SOLIDWORKS PDM Web Server
• Installing SOLIDWORKS PDM Web2 (For SOLIDWORKS PDM Professional only)
• Installing the SOLIDWORKS PDM Client

Initiating SOLIDWORKS PDM Installations
You perform the same initial steps to begin all SOLIDWORKS PDM installations.

The following components must be installed to install SOLIDWORKS PDM:

• Windows Installer 3.1
• MSXML 6.0
• .NET Framework 4.0
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• Visual C++ 2008 redistributable - x86
• Visual C++ 2008 redistributable - x64

You can find the installation files for the prerequisite components on the Installation
media under \PreReqs\ directory.

Adobe Acrobat must be installed if you want to view documentation provided on the
SOLIDWORKS DVD.

To initiate the SOLIDWORKS PDM installation:

1. Insert the SOLIDWORKS DVD.
2. Cancel SOLIDWORKS Installation Manager, if it starts.
3. Run \SWPDMServer\setup.exe to install SOLIDWORKS PDM server.
4. Run \SWPDMClient\setup.exe to install SOLIDWORKS PDM client.

Ensure that you met all prerequisites.

When done, the installation wizard continues. Initiate the installation using these
instructions:

ActionScreen

Click Next.Welcome

Accept the license agreement and click Next.License Agreement

To accept the default installation location, click Next.

To specify a different installation location:

1. Click Change.
2. Browse to the new location.
3. Click OK.
4. Click Next.

Destination Folder

Select one of the following to install:

• SOLIDWORKS PDM Standard
• SOLIDWORKS PDM Professional

Select PDM Product

Installing SOLIDWORKS PDM Database Server
The database server periodically polls SOLIDWORKS PDM databases for updates such as
notifications, local view refresh, replication schedule updates, and index server changes.

It must be installed for:
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Workflow and other automatic notifications, such as change
state, check out, check in, add, and deadline

Automatic notifications

Automatic updates (refresh) of listings in file vault views
and add-ins

View updates

Periodic updates of card lists that use SQL queries for their
content

Card list updates

Updates of archive servers with changes made to cold store
schedules

Cold store scheduling

Updates of archive servers with changes made to replication
schedules

Replication scheduling

Administration of the indexing service for content searchesIndex server administration

Execution of data import and export rules at predefined
intervals

Data import/export

It is recommended that you install the database server on the same system as Microsoft
SQL Server. You can install it on another system, but some network overhead may occur.

Before Installing the Database Server
• Ensure that the database server has access to the archive server over TCP port 3030
and to the SQL Server over TCP port 1433.

• Obtain the following information:

• SQL Server name
• Name and password of an SQL user account with read/write access

If you do not know the name of a user with read and write access, you can use the
SQL sa account that has these permissions. You can also create a login for this purpose.

For details, see Changing the SQL Server Login Account.
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Performing the Database Server Installation

1. Login locally or remotely as a user with local administrative rights on the system
where you are installing the database server.

2. Begin the installation, as described in Initiating SOLIDWORKS PDM Installations.
3. Complete the installation using these instructions:

ActionScreen

Select Database Server and click Next.

You can install multiple server components on the
same system.

If you want to install SOLIDWORKS PDM client on
the machine, you must also select Client.

For details on client installation, see Installing Clients
using the Installation Wizard.

Server Installation

1. Specify the name of the SQL server to host the
file vault databases, by doing one of the following:

• Type the name of the SQL server.
• Click Browse to select from the list of available
SQL server instances on the network and click
OK.

If SQL server is installed on the system where
you are installing the database server, type or
select (local).

2. In the Login name field, type the name of an
SQL user on the server who has read and write
access (i.e., db_owner permission) to all
SOLIDWORKS PDM databases hosted on the SQL
server (the file vault databases and
ConisioMasterDb.)

3. In the Password field, enter the SQL user's
password.

4. Click Next.

The login information is verified. If it is incorrect, a
warning is displayed.

SOLIDWORKS PDM
Database Server SQL Login

Click Install.Ready to Install the
Program

Click Finish.InstallShield Wizard
Completed
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Installing SOLIDWORKS PDM Archive Server
The archive server hosts the physical files (drawings, documents, etc.) stored in a file
vault and manages users and their credentials.

All clients using SOLIDWORKS PDM must connect to one or more archive servers hosting
one or more file vault archives.

The archive server runs as a service on the system account of the computer where it is
installed, sending and receiving files between the clients and the file vault archive. It also
stores passwords and user login information. Only one archive server installation is
required per computer, hosting one or more file vault archives.

In a replicated environment, multiple archive servers can be set up to host replicated
copies of the same file vault archive. See the SOLIDWORKS PDM Professional Replication
Guide.

To prevent problems attaching to the archive server, the server name should be 15
characters or less.

Before Installing the Archive Server
Set up the users, accounts, and permissions required to complete the archive server
installation.

The system account must have full access rights to create folders
and files under the folder to be designated as the archive server
root folder. The root folder can also be on a network share that
allows the archive server service to both read and write files.

You can change the archive server service log-on account to
users other than the system account in the service properties.

Root folder access

The SQL user that communicates with file vault databases must
have at least db_owner permissions to any existing file vault
databases on the SQL Server.

You can use the sa account that was created when the SQL
Server was installed.

For more information about SQL logins, see Changing the SQL
Server Login Account.

SQL user account
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If you want to assign user and group access rights to the archive
server during the installation, create the users and groups before
you begin.

To use domain users, create a domain group on the domain
controller and add domain users that should be able to log
into SOLIDWORKS PDM Professional.

• During installation, add the domain group using the Find
User or Group dialog; the users will appear in the
SOLIDWORKS PDM administration tool.

• After installation, you can run the Archive Server
Configuration tool to add or change user and group
assignments.

User and group
accounts

Performing the Archive Server Installation

1. Login as a user with local administrative rights on the system where you are installing
the archive server.

2. Begin the installation, as described in Initiating SOLIDWORKS PDM Installations
on page 52.

3. Complete the installation using the following instructions:

ActionScreen

Select Archive Server and click Next.

You can install multiple server components on the
same system.

If you want to install SOLIDWORKS PDM client on
the machine, you must also select Client.

For details on client installation, see Installing Clients
using the Installation Wizard.

Server Installation

Click Install.

If you see a message that your local security
network access is set to “Guests only” and should
be changed to “Classic,” click Yes to accept the
change.

If it is new install, when the installation finishes, the
Archive Server Configuration wizard appears.

Ready to Install the
Program

Archive Server Configuration Wizard

Click Next.Welcome
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Archive Server Configuration Wizard

1. Do one:

• Accept the default location for the archive server root folder.
• Change the location by doing one of the following:

• Click Browse and browse to a folder.
• Type the path.

If the folder you specified does not exist, you are asked
if it should be created.

The root folder path is assigned the name Archives, which
is used when setting up or attaching to a file vault from the
View Setup wizard on a client.

You must include the root folder and its subfolders (i.e.,
file vault archives) in the daily backup routines.

2. Click Next.

Root folder

1. Type and confirm a password for the Admin user.

The Admin user account is assigned full administrative rights
to file vaults. Admin can create users, set up workflows, delete
files, etc. It is the only user present in a newly created file
vault.

You can change the password at any time using the Archive
Server Configuration tool.

2. Click Next.

Admin
password

1. Type the login information for the SQL user who will
communicate with the file vault databases hosted on the SQL
Server.

You can use the SQL Server system administrator user sa.

If you specify an SQL user with low permissions on the SQL
Server, this user will be assigned db_owner access to any new
file vaults created.

2. Click Next.

SQL user login
and password
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Archive Server Configuration Wizard

To define the Windows user accounts that are allowed access to
this archive server, by select the accounts under Available users
and groups and click the arrow pointing to Administrative
access or Attach access.

All local users and groups found on the system
are listed by default.

To add domain accounts to the list:

Available
users and
groups

1. Click Find User or Group.
2. In the Find User or Group dialog box, search
for additional user or group accounts. To add
a domain group, for example, type domain\
groupname and click OK.

Provides sufficient access to create new file
vaults, or remove, attach, or upgrade existing
file vaults on this archive server.

When you create a file vault, enter the username
and password of an account added to this
section.

Administrative
access

Provides sufficient access to attach to existing
file vaults managed by this archive server.

When you create a file vault view or connect to
a file vault, enter the username and password
of an account added to this section.

Attach access

Security

59

Installing SOLIDWORKS PDM



Archive Server Configuration Wizard

Select one of the following authentication methods to use by
default when creating new file vaults managed by this archive
server:

SOLIDWORKS PDM user names and passwords
are stored on the archive server. You can add
and remove them using the administration tool
on SOLIDWORKS PDM client.

SOLIDWORKS
PDM login

Synchronizes logins to a file vault with the
logged-in Windows users (Active Directory).
Passwords and names are defined using
standard Windows account management.

In the Windows login settings dialog box, select
accounts under Available users and groups
and add them to Added users and groups
by clicking the right-arrow button.

To add domain accounts to the list:

Windows login
(SOLIDWORKS
PDM
Professional
only)

1. Click Find User or Group.
2. In the Find User or Group dialog box, search
for additional user or group accounts. To add
a domain group, for example, type domain\
groupname and click OK.

Retrieves user accounts from a server using
the LDAP method (for example, Novell servers).
The users are available when adding users to
a file vault using the administration tool.
Passwords and user names are defined on the
LDAP server managing the accounts.

To define the connection settings to the server
using LDAP:

LDAP login
(SOLIDWORKS
PDM
Professional
only)

Login type

Type the name or IP address of an LDAP server.Server name

Type the port used for LDAP on the server. The
default port is 389.

Port

Add at least one context with users that should
be listed in the user manager.

The context names must be entered as
distinguished names; for example, O-company,
OU=department, O=company or CN=Users,
DC=company, DC=com.

Contexts

User Context
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Archive Server Configuration Wizard

Type a context for the user login used by the
archive server to connect to the LDAP server.

Type a username that exists in the user context
selected. This user is used by the archive server
to connect to the LDAP server.

Username

Type the password for the selected user.Password

Click Finish.Completed

Opening Ports for Client/Server Communication
Windows Server, Windows 7, and Windows 8.1 have built-in firewalls activated by default.
These can restrict network access to applications requiring connections over the TCP/IP
interface.

The archive server uses TCP port 3030 to communicate with the clients. This port must
be fully opened in the firewall for a SOLIDWORKS PDM installation to accept incoming
connections. If the port is not opened, the archive server is not available.

It is recommended that you also allow inbound traffic on the corresponding UDP ports to
allow the servers to broadcast (announce themselves) on the network, for example by
showing the name in a drop-down list for users to attach to a server from a client.

To allow the SQL server to communicate with clients, you must open TCP ports 1433 and
1434. If you install the SOLIDWORKS PDM Web Server, you must open ports 80 and 443.

To check out a client license, you must open ports 25734 and 25735 on the SolidNetwork
License Server.

This table summarizes the ports that must be reachable. You open the firewall ports on
the listening/receiving side.

Communication Originating From

Listening and
Receiving

Web
Server

SQL ServerDatabase
Service

Archive
Server

Client

Client

3030303030303030Archive Server

Database Service

1433/14341433/14341433/14341433/1434SQL Server

25734/2573525734/25735SNL Server

80/443Web Server
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Microsoft disables outbound filtering by default. However, your administrators may have
created outbound rules that restrict traffic to applications that are approved on the your
organization's network. If a SOLIDWORKS PDM client or replicated server cannot reach
the SQL server or Archive server, make sure that the network administrator has not
restricted access to the server ports in the Windows firewall settings.

SOLIDWORKS PDM Standard vaults use SQL Server Express that listens to a dynamic
port by default. You must set the SQL Server instance to a static port that you open in
the firewall. This is also applicable to the additional named SQL Server instances. For
details, see Configuring the SQL Server Express Instance to Listen to a Fixed TCP
Port.

Opening Ports on Windows and Windows Server Systems
You use Windows Firewall with Advanced Security to open the ports needed to
communicate with clients.

You create port rules that enable TCP and UPD ports for inbound SOLIDWORKS PDM
traffic.

Open the ports for the archive server first. Then follow the same instructions to open the
ports for the SQL server and Web Server.

To open the ports for the archive server:

1. Open the Control Panel.
2. On the Adjust your computer’s settings page, click System and Security.
3. In the right pane, click Windows Firewall.
4. In the left pane, click Advanced settings.
5. In the right pane, under View and create firewall rules, click Inbound Rules.
6. In the far right pane, under Actions, Inbound Rules, click New Rule.
7. In the New Inbound Rule Wizard , on the Rule Type screen, in the right pane, select

Port and click Next.
8. In the right pane of the Protocol and Ports screen:

a) Select TCP.
b) Select Specific local ports and type 3030.
c) Click Next.

9. In the right pane of the Action screen, select Allow the connection and click Next.
10. In the right pane of the Profile screen, clear Public and click Next.
11. In the Name screen, for Name, type the exception name – for example, Enable TCP

port 3030 for inbound SOLIDWORKS PDM traffic and click Finish.
The wizard closes and the rule is added to the list of inbound rules. It is enabled by
default.

12. Repeat steps 6 through 11 to create an inbound rule for UDP port 3030.
13. On the system hosting the SQL Server, repeat steps 6 through 12 to create inbound

TCP and UDP rules for ports 1433 and 1434.
14. On the system hosting the SolidNetwork License Server, repeat steps 6 through 12

to create inbound TCP rules for ports 25734 and 25735.
15. On the system hosting the Web Server, repeat steps 6 through 12 to create inbound

TCP and UDP rules for ports 80 and 443.
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16. Click File > Exit to close the Windows Firewall with Advanced Security window.
17. Close the Control Panel.

Adding Archive Servers in a WAN Environment
SOLIDWORKS PDM clients are normally set up to communicate with the Archive Server
and SQL server using the server system names. These system names are resolved to IP
addresses.

If this name lookup fails or is slow it can cause the following problems:

• Clients cannot find the servers at all. This is a common problem when using subnets
or WAN configurations.

• Overall performance using SOLIDWORKS PDM features such as logging in, browsing,
or adding files is slow.

• In case of SOLIDWORKS PDM Professional, replication between servers fails.

Verifying That the Server Name Can Be Resolved
To ensure optimal performance, make sure that the DNS server configuration is set up
to resolve names correctly and efficiently.

1. Open the command prompt by clicking Start > Run > CMD.
2. Type Ping server_name.

If the server can be reached by name, a reply with the server IP address appears.
For example:

PING SRV-DEV-15
Reply from 192.168.1.71: bytes=32 time<1ms TTL=128

3. Verify that the correct IP is returned.
If DNS returns the wrong IP address, a different system than the server responds.

If the server name cannot be resolved, the DNS server configuration is not correctly
configured. For example:

PING SRV-DEV-15
Ping request could not find host SRV-DEV-15. Please check the name and
try again.

Configuring the Hosts File to Resolve the Server Name
If the DNS servers cannot be configured or performance is still bad, update the client’s
hosts file with the correct server name and IP address. This ensures that the hosts file is
queried for the server address directly instead of waiting for the DNS name resolve.

To configure the hosts file to resolve the server name:

1. On the SOLIDWORKS PDM client, locate the Hosts file.
The default location is:

C:\Windows\System32\Drivers\Etc\

2. Open the file as an administrator in a text editor (for example, Notepad).
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3. Add a new line and enter the server IP address followed by the server name.
For example:

192.168.1.71 SRV-DEV-15

4. Repeat Step 3 for any additional servers used by SOLIDWORKS PDM.
5. Save and close the hosts file.

Installing and Configuring SolidNetWork Licensing
SOLIDWORKS PDM manages licensing using SolidNetWork License (SNL) Manager.
Installing SolidNetWork Licensing includes:

• Installing the SolidNetWork License Manager.

If you already have a SolidNetWork License Manager installed for SOLIDWORKS,
you can use it with SOLIDWORKS PDM. You must ensure that it is updated to the
SOLIDWORKS PDM release version.

• Activating client licenses.
• Configuring the SolidWorks NetWork License server for use with the file vault.
• Ensuring that the SolidNetWork License server is accessible to all clients.

Installing a SolidNetWork License Manager
You use the SolidNetWork License serial number to install the SolidNetWork License
Manager on a server that is accessible to all clients, preferably the SQL database server.

The SolidNetWork License software is included with the SOLIDWORKS installation media.

To install SolidNetWork License Manager from the standalone installer:

1. Change directory to the appropriate setup folder on the SOLIDWORKS installation
media.

2. Cancel SOLIDWORKS Installation Manager, if it starts.
3. Start the installation by running swlicmgr\setup.exe.
4. Enter the SolidNetWork License serial number.

If you have multiple serial numbers, enter and separate them by comma.

5. Retain the default install folder and click Next.
6. Click Install.
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Activating a SolidNetWork License
You must activate a SolidNetWork License to log in to the SOLIDWORKS PDM vault as a
client.

To activate the SolidNetWork License:

1. Start the SolidNetWork License Manager by doing one of the following:

• On Windows 7 and Windows Server systems prior to Windows Server 2012, click
Start > All Programs > SOLIDWORKS version > SOLIDWORKS Tools >
SolidNetWork License Manager Server version.

• On Windows 8.1 and Windows Server 2012 or later, on the Apps screen, under
SOLIDWORKS Tools, click SolidNetWork License Manager Serverversion.

2. When prompted to activate, click Yes.
If you have an activated SolidNetWork License, click Modify.

3. On the SolidNetWork License Server Information screen:

• If your company uses a firewall, select A firewall is in use on this server.

For more information, see Using SolidNetWork License Server with Firewalls
on page 65.

• Use the default value for Port Number (and for Vendor Daemon Port Number
if you have a firewall) or specify the port numbers your company uses.

The port number is a TCP/IP port number in the 1024-60000 range, used
exclusively by this process. Normally, the default (25734) is suitable and is
unlikely to be the same as any other FLEXnet server process currently on the
license manager server.

4. On the Activate Your SOLIDWORKS Product screen:

• Select the Internet or email procedure.
• Supply email contact information.
• Click Next to proceed.
• Internet: Activation occurs automatically.
• Email: Press Save to create a request file, then send the file to
activation@solidworks.com. When you receive the email containing the response
file, extract the file from email and then click Open to load it.

If necessary, you can exit and rerun the activation procedure to open the
response file.

5. Click Finish.

Using SolidNetWork License Server with Firewalls
If your server uses a firewall, you must configure ports to support SolidNetWork Licensing.

You must configure the firewall on the server side.

65

Installing SOLIDWORKS PDM



Modifying SolidNetWork License Manager Settings for Windows
Firewall
If you are using Windows Firewall, you must modify the SolidNetWork License file to use
the firewall ports to distribute licenses to the license client computers.

1. Start the SolidNetWork License Manager by doing one of the following:

• On Windows 7 and Windows Server systems prior to Windows Server 2012, click
Start > All Programs > SOLIDWORKS version > SOLIDWORKS Tools >
SolidNetWork License Manager Server version.

• On Windows 8.1 and Windows Server 2012 or later, on the Apps screen, under
SOLIDWORKS Tools, click SolidNetWork License Manager Server version.

2. On the Server Administration tab, under License Server, click Stop. (Click Yes when
prompted for confirmation and OK to complete stopping the license server.)

3. Under License Information, click Modify.
4. Under Server Type, select the server arrangement for your network (Single or

Triad) and then click Next.
5. Under Server Information:

a) Select A firewall is in use on this server.
b) Port Number and Vendor Daemon Port Number should contain the port numbers
specified for the Windows Firewall.

c) Select Options File and click Browse to locate the file. Click Edit to change any
of its parameters.

The options file allows the license administrator to control various operating
parameters of FLEXnet Licensing.

The recommended location for the options file is in the SolidNetwork License
Manager installation directory (SolidNetwork_License_Manager_install_dir\
Licenses \sw_d.opt). This file must in the same directory as the sw_d.lic
file.

For more information about the options file, see the FLEXnet Publisher License
Administration Guide in the SolidNetwork License Manager installation directory
(\Docs\flexuser\licensingenduserguide.pdf).

d) Click Next and then click Finish.

6. On the Server Administration tab, under License Server, click Start.
7. Click OK to close the SolidNetWork License Manager.
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SolidNetWork License Administration
Tasks include starting, upgrading, and uninstalling the license manager licenses.

Starting the SolidNetWork License Manager
You can start the SolidNetWork License Manager from the Windows Start menu.

Start the SolidNetWork License Manager by doing one of the following:

• On Windows 7 and Windows Server systems prior to Windows Server 2012, click
Start > All Programs > SOLIDWORKS version > SOLIDWORKS Tools >
SolidNetWork License Manager Server version.

• On Windows 8.1 and Windows Server 2012 or later, on the Apps screen, under
SOLIDWORKS Tools, click SolidNetWork License Manager Server version.

Upgrading the SolidNetWork License Manager
For major releases of SOLIDWORKS PDM, upgrading the license manager consists of
uninstalling the old license manager, installing a new one, and re-activating the
SolidNetWork License.

To upgrade the SolidNetWork License Manager:

1. Start the SolidNetWork License Manager by doing one of the following:

• On Windows 7 and Windows Server systems prior to Windows Server 2012, click
Start > All Programs > SOLIDWORKS version > SOLIDWORKS Tools >
SolidNetWork License Manager Server version.

• On Windows 8.1 and Windows Server 2012 or later, on the Apps screen, under
SOLIDWORKS Tools, click SolidNetWork License Manager Server version.

2. On the License Usage tab, verify that no client computers on the network are running
SOLIDWORKS PDM.

3. Uninstall the old license manager. For details, see Uninstalling the SolidNetWork
License Manager.

4. Install the new license manager and re-activate the SolidNetWork License on the
license manager server. For details, see Installing a SolidNetWork License
Manager on page 64.

Uninstalling the SolidNetWork License Manager
If you want to upgrade the SolidNetWork License Manager, you must uninstall it before
installing the new one. If you want to transfer the SolidNetWork License to another server,
you must transfer before removing it from this server.

1. Start the SolidNetWork License Manager by doing one of the following:

• On Windows 7 and Windows Server systems prior to Windows Server 2012, click
Start > All Programs > SOLIDWORKS version > SOLIDWORKS Tools >
SolidNetWork License Manager Server version.

• On Windows 8.1 and Windows Server 2012 or later, on the Apps screen, under
SOLIDWORKS Tools, click SolidNetWork License Manager Server version.

2. Verify that no clients on the network are running SOLIDWORKS PDM.
The License Usage tab shows the clients using the licenses.
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3. On the Server Administration tab, under License Server, click Stop.
4. Click OK to exit the license manager.
5. In Windows, open Control Panel > Programs > Programs and Features.
6. Select SOLIDWORKS SolidNetWork License Manager, click Uninstall, and confirm

the deletion.

You now are ready to install a new version of the license manager. For details, see
Installing a SolidNetWork License Manager and Activating a SolidNetWork License
on page 65.

Transferring a SolidNetWork License
To transfer a SolidNetWork License to a new or upgraded server, first transfer the license
to the license key server at Dassault Systèmes SOLIDWORKS Corporation, then reactivate
it on the other server.

If you were unable to transfer the license to Dassault Systèmes SOLIDWORKS
Corporation (because of hard drive failure, for example), reactivation is still successful
in most cases. If not, contact your VAR for help.

You can have only one activated SolidNetWork License server per serial number.

To transfer a SolidNetWork License back to the server:

1. Start the SolidNetWork License Manager by doing one of the following:

• On Windows 7 and Windows Server systems prior to Windows Server 2012, click
Start > All Programs > SOLIDWORKS version > SOLIDWORKS Tools >
SolidNetWork License Manager Server version.

• On Windows 8.1 and Windows Server 2012 or later, on the Apps screen, under
SOLIDWORKS Tools, click SolidNetWork License Manager Server version.

2. Under License Information, click Modify. The SOLIDWORKS Product Activation
wizard starts.

3. UnderWhat would you like to do?, select Transfer a software license and then
click Next.

4. Under How would you like to transfer?, select Automatically over the internet
(recommended).

5. Under Contact Information, specify an email contact address.
6. Click Next. The product license transfer completes.

Installing Temporary Licenses
The temporary "ANY" license can be used temporarily when the original SolidNetWork
License is not available.

By installing the "ANY" license file, you agree to implement the traditional license upon
receipt of a SolidNetWork license from Dassault Systèmes SOLIDWORKS Corporation.
Compliance with license restrictions still is required.
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To install an "ANY" license:

1. If you are an existing SolidNetWork user, uninstall the SolidNetWork License Manager
and delete the installation folder. For details, see Uninstalling the SolidNetWork License
Manager.

2. Install the SolidNetWork License Manager from SOLIDWORKS PDM installer.

You can also install the SolidNetWork License Manager from a standalone installer.
For details, see Installing a SolidNetWork License Manager on page 64.

a) On the SOLIDWORKS SolidNetWork License Manager Setup page, enter the
SolidNetWork License serial number and click Next.

b) Click Install.

3. Start the SolidNetWork License Manager (Start > All Programs > SOLIDWORKS
version > SOLIDWORKS Tools > SolidNetWork License Manager version).

4. If you are prompted to activate, click No.
The Server Administration tab of the SOLIDWORKS SolidNetwork License Manager
appears.

5. Under Advanced Options, click Options.
The Advanced Options dialog box appears.

6. Under SolidNetWork Server License Mode, click Use a License File and click OK.
The Advanced Options dialog box closes.

7. Under License Information, click Modify.
The SolidNetWork License File Wizard appears.

8. Under Server Type, select Single and click Next.
9. When you see this message:

Could not read the dongle ID number. click Cancel.

The ID "ANY" appears automatically.

If your computer uses a firewall, you might have to make some additional
specifications on this screen. For more information, see Using SolidNetWork
License Server with Firewalls on page 65.

10. Continue with the installation.

Troubleshooting SolidNetWork Licenses
If the SolidNetWork License Manager installation fails, check for these possible
explanations.

Accessing the SolidNetWork License log files

When a license error occurs, the answer often appears in the SNL_Manager_install_dir\
lmgrd.log file.

Could not obtain a license for SOLIDWORKS PDM or Cannot connect to
license server

Typically, these problems are caused by port settings.
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• Port settings between the SolidNetWork License Manager and the license client might
not match.

• Additional port settings for multiple versions of SolidNetWork License Managers might
not have been specified.

• Check that the client machine can accurately resolve and route to the server, given
the server name. Also, check that the server can accurately resolve and route to the
client, given the client machine name.

• Check that the port number in the log file under Server Administration tab is correct.
• Check that the firewall on the SolidNetWork License server does not block the port
access.

When a log error occurs, you can check the Log File in the Administration tool.

Licensing

License Types
SOLIDWORKS PDM uses floating client licenses. When you log in to a vault, the license
installed on your system is taken from a pool of licenses that are managed by the
SolidNetWork License Server. When you log out or exit SOLIDWORKS PDM, the license
is returned to the pool and can be used by another client.

Licenses for SOLIDWORKS PDM Professional

License Types IncludedLicense

Editor: Supports working with all file types, including
enhanced management and previewing of CAD formats
such as SOLIDWORKS. CAD add-ins allow users to
access SOLIDWORKS PDM Professional functionality
from within the CAD application.

Web: Remote users can use the WEB client to search
the vault and perform basic functions to enable remote
work processes.

SOLIDWORKS PDM Professional
CAD Editor & Web

Contributor: Users on a local area network (LAN), wide
area network (WAN or virtual private network (VPN)
can perform the same functions as with the Editor
license type, except that CAD add-ins are not enabled.

Web: Remote users can use the WEB client to search
the vault and perform basic functions to enable remote
work processes.

SOLIDWORKS PDM Professional
Contributor & Web

Allows read-only access to vaults. Users cannot add or
modify (check out, check in, update values) files or
use CAD add-ins.

SOLIDWORKS PDM Professional
Viewer
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Licenses for SOLIDWORKS PDM Standard

License Types IncludedLicense

Supports working with SOLIDWORKS, DWG/DXF
format, Microsoft Word, and Microsoft Excel files. All
file formats that Office plug-in handles behave in the
same way in SOLIDWORKS PDM Standard except
Preview.

SOLIDWORKS PDM Standard
CAD Editor

Supports working with SOLIDWORKS, DWG/DXF
format, Microsoft Word, and Microsoft Excel files.

SOLIDWORKS PDM Standard
Contributor

Allows read-only access to file vaults; user cannot add
or modify (check out, check in, update values) files.

SOLIDWORKS PDM Standard
Viewer

Changing the Client License Type
You select the client license type during installation.

Pre-requisites:

• To change the license type, you must have local administrative permissions to Windows.
• For clients installed from an administrative image (via active directory deployment or
a similar scripted install), you must reinstall the client using another administrative
image of the specified client type.

You can change the license type by:

• Using Control Panel > Programs > Uninstall a program to remove SOLIDWORKS
PDM and then reinstalling.

• Opening the Uninstall or change a program dialog box, and selecting SOLIDWORKS
PDM Client > Change. In the SOLIDWORKS PDM Installation Wizard, select Modify.

In the Uninstall or change a program dialog box, SOLIDWORKS PDM Client or
SOLIDWORKS PDM Server is listed if you have installed SOLIDWORKS PDM using
MSIs. You must modify SOLIDWORKS installation if you have installed SOLIDWORKS
PDM using SLDIM.

• Using the About SOLIDWORKS PDM dialog box.

To change the client license type from the About SOLIDWORKS PDM dialog box:

1. Click Help > SOLIDWORKS PDM Administration.
2. Use the Client type drop-down list to select a different client license type.
3. Click OK.
4. When instructed to restart your computer, click OK.
5. Restart your computer.

Depending on the license type that was used when the client was installed, changing
to the CAD Editor license type from the About SOLIDWORKS PDM dialog box might not
enable the CAD Add-in. If it does not, remove SOLIDWORKS PDM as described above
and select SOLIDWORKS PDM CAD Editor when you reinstall.
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Viewing Version Information for Non-client Systems

To find the version of SOLIDWORKS PDM software on a server that does not
have a client installed:

1. Open the Control Panel > Programs > Uninstall a program.
2. Click SOLIDWORKS PDM Server .

The Version column displays the currently installed version.

Viewing Version Information for Client Systems

To find the version of SOLIDWORKS PDM software on a client:

1. Log in to the SOLIDWORKS PDM Administration tool.
2. Click Help > SOLIDWORKS PDM Administration.
3. View the Client version and click OK.

Adding and Modifying SolidNetWork License Server
To log in to a vault from a SOLIDWORKS PDM client, a license that matches the currently
installed license type and version must be available. The license is retrieved from the
SolidNetWork License server that is defined in the license setting. To add or modify
SolidNetWork License server, you use the Set License dialog box available from the
Administration tool.

To add or modify license server:

1. Open the Administration tool by doing one of the following:

• On Windows 7 and Windows Server systems prior to Windows Server 2012, click
Start > All Programs > SOLIDWORKS PDM > Administration.

• On Windows 8.1 and Windows Server 2012 or later, on the Apps screen, under
SOLIDWORKS PDM, click Administration.

2. Create a file vault or expand the existing file vault.
3. Right-click the License node and select Open.
4. On the Server List tab, click Add.
5. Enter the SolidNetWork License Manager's address in the form: port@SNLServerName

The default port number is 25734. You can enter either the host name or IP address
of the SolidNetWork License server for SNLServerName. Ensure that all clients are
able to connect to the server by IP address or host name.

6. Click OK.
7. Click the License Usage tab to ensure that SOLIDWORKS PDM licenses are available.
8. Click OK.
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Set License Dialog Box
Use the Set License dialog box to add or modify license servers. To log in to a vault from
a SOLIDWORKS PDM client, a license that matches the currently installed license type
and version must be available.

To open this dialog box, do one of the following:
• Double-click License.
• Right-click License and select Open.

Server

Lists the SolidNetWork License servers.

For example, Port@SNLServerName

Server List

Lets you add license servers.Add

Lets you remove selected license servers.Remove

License Usage

Lets you select the SolidNetWork License server.Server

Lets you select the SOLIDWORKS PDM license type to view
license details.

See License Types on page 70.

Product

Shows total number of licenses.Total licenses

Shows number of available licenses.Free licenses

Shows details of used licenses.Licenses used by

Installing SOLIDWORKS PDM Web Server
The SOLIDWORKS PDM Professional Web server gives users live access to one or more
file vaults from any system using Windows Internet Explorer over the Internet or an
intranet.

To learn how to install and use the Web server and client, see the SOLIDWORKS PDM
Web Server Guide.
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Installing SOLIDWORKS PDM Web2 (For SOLIDWORKS
PDM Professional only)

Web2 lets users connect to SOLIDWORKS PDM Professional vault from the most devices
with an Internet browser. Web2 client is beneficial for external and internal users who
are not connected to their office network or have an unsupported operating system.

Before Installing Web2

The following components must be installed to install Web2:

• Microsoft .Net Framework 4.0
• Microsoft Internet Information Services 7 or higher versions (IIS)

You must install the SOLIDWORKS PDM client and create the local vault view that
is accessed by Web2 on the server running IIS.

• Windows Server 2008 R2 or higher operating systems

Installing Microsoft .NET Framework 4.0

For details to install Microsoft .NET Framework 4.0, see
http://www.microsoft.com/en-us/download/details.aspx?id=17718.

Enabling Microsoft IIS on Windows Server 2008 R2
SOLIDWORKS PDM Professional supports IIS 7 or higher versions.

To enable Microsoft IIS on Windows Server 2008 R2:

1. From the Windows Start menu, click Control Panel > System and Security >
Administrative Tools > Server Manager.

2. In the left pane, click Roles.
3. In the right pane, on the Roles page, click Add Roles.
4. Complete the Add Roles wizard:

a) On the Select Server Roles screen, select Web Server (IIS) and click Next.
If your vault contains add-ins that are dependent on .NET 3.5 or earlier versions,
enable the framework on the Select features screen.

b) If you are prompted to add the features required for IIS, click Add Required
Features. Otherwise, click Next.

c) On the Select Role Services screen, expand Web Server and select the following
options.

OptionFolder

Static Content

Default Document

Directory Browsing

HTTP Errors

Common HTTP Features
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OptionFolder

.NET Extensibility

ASP.NET

ISAPI Extensions

ISAPI Filters

Server Side Includes

Application Development

HTTP Logging

Request Monitor

Health and Diagnostics

Request FilteringSecurity

Static Content CompressionPerformance

IIS Management ConsoleManagement Tools

5. Click Next.
6. Click Close.

Enabling Microsoft IIS on Windows Server 2012

1. From the Windows Start menu, type Server Manager, click Server Manager.
2. Select Manage > Add Roles and Features.
3. Complete the Add Roles and Features Wizard:

a) On the Select Server Roles screen, select Web Server (IIS) and click Next.
b) On the Select features screen, enable .NET Framework 4.5 features and
include options .NET Framework 4.5 and ASP .NET 4.5.
If your vault contains add-ins that are dependent on .NET 3.5 or earlier versions,
also enable .NET Frameworks 3.5 features on the Select features screen.

c) If you are prompted to add the features required for IIS, click Add Required
Features. Otherwise, click Next.

d) On the Select Role Services screen, expand Web Server and select the following
options.

OptionFolder

Default Document

Directory Browsing

HTTP Errors

Static Content

Common HTTP Features
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OptionFolder

HTTP LoggingHealth and Diagnostics

Static Content CompressionPerformance

Request FilteringSecurity

.NET Extensibility 4.5 (and 3.5 if installed)

ASP

ASP.NET 4.5 (and 3.5 if installed)

CGI

ISAPI Extensions

ISAPI Filters

Application Development

IIS Management ConsoleManagement Tools

4. Complete the wizard and click Install.

Enabling Microsoft IIS on Windows 7

Microsoft Windows 7 is not recommended for running SOLIDWORKS PDM Web2 in a
production environment.

To enable Microsoft IIS on Windows 7:

1. In Windows, open Control Panel > Programs > Programs and Features > Turn
Windows features on or off.

2. In the dialog box, turn on Internet Information Services.
3. Expand Web Management Tools and select IIS Management Console.
4. Expand World Wide Web Services and select the following options:

OptionFolder

.NET Extensibility

ASP

CGI

ISAPI Extensions

ISAPI Filters

Application Development
Features
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OptionFolder

Static Content

Default Document

Directory Browsing

HTTP Errors

Common HTTP Features

5. Click OK.

Enabling Microsoft IIS on Windows 8.1

Microsoft Windows 8.1 are not recommended for running SOLIDWORKS PDM Web2 in
a production environment.

To enable Microsoft IIS on Windows 8.1:

1. In Windows, open Control Panel > Programs > Programs and Features > Turn
Windows features on or off.

2. In the dialog box, turn on Internet Information Services.
3. Expand Web Management Tools and select IIS Management Console.
4. Expand World Wide Web Services and select the following options:

OptionFolder

.NET Extensibility 4.5

ASP.NET 4.5

ISAPI Extensions

ISAPI Filters

Server-Side Includes

Application Development
Features

Static Content

Default Document

Directory Browsing

HTTP Errors

Common HTTP Features

HTTP LoggingHealth and Diagnostics

Static Content CompressionPerformance Features

Request FilteringSecurity
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Registering ASP .Net 4
You must register ASP .Net 4 and make it available to the IIS server if you are running
IIS on Windows Server 2008 R2 or Windows 7.

To register ASP .Net 4:

1. In Windows Explorer, browse to C:\Windows\Microsoft.NET\Framework64 and verify
the name of the .NET 4.0 framework folder.

2. In the Windows Start menu, type cmd, right-click cmd.exe, and select Run as
administrator.

3. Type cd C:\Windows\Microsoft.NET\Framework64\v4.0.30319.
4. Type aspnet_regiis –iru.
5. Close the command prompt when it displays Finished installing ASP.Net.

Performing the Web2 Server Installation

1. Log on to the IIS system as a user with local administrative rights.
2. Insert the SOLIDWORKS DVD.
3. Cancel SOLIDWORKS Installation Manager, if it starts.
4. Run \SWPDMServer\setup.exe to start the server install.
5. Follow the instructions on the installation screens until you get to the Select PDM

Product screen.
6. On the Select PDM Product screen, select SOLIDWORKS PDM Professional.
7. On the Server Installation screen, select Web2 Server and Client.

• The Web2 server requires a client be installed on the same machine.
• The client type must be a Contributor or CAD Editor if files are to be edited or
added via Web2. If Web2 users are limited to Viewer functions only, a Viewer
client must be installed or enabled on the server (regardless of the license type
they choose on the log in screen).

• You can install multiple server components on the same system.

8. On the Ready to Install the Program screen, click Install.
9. On the InstallShield Wizard Completed screen, click Finish.

Creating a Vault View on the IIS Server Running Web2

Create a local file vault view to the file vault that is accessible by the Web2 server.

• Ensure that the view is created as a Shared view for all users.
• The Windows user that you define later as an application pool identity, must have
browsed into the vault view and right-clicked a file or a folder at least once to ensure
add-ins and registry settings are properly registered.

If the vault is using Windows login you must disable Automatic login to the vault view on
the Web2 server as follows:

1. Start the Administration tool.
2. Expand Local Settings > Settings.
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3. In the Automatic Login tab, select the vault that is accessed by Web2 from the Vault
list.

4. Turn off Use server default and Use automatic login for this vault.
5. Click OK.

Configuring SOLIDWORKS PDM Web2
You can configure SOLIDWORKS PDM Web2 by accessing the Application Settings function
in the IIS Manager or by editing the Web.config file that is located at inetpub\wwwroot\
SOLIDWORKSPDM\Web2.

Editing the Web.config File
To access the file vaults for which you have created local file vault views on the IIS server,
you must update the VaultName and VisibleVaults keys in the Web.config file.

You can edit the XML-based Web.config file using Notepad or any XML editing application.

Ensure that the Web.config file is not read-only. When you edit Web.config file, ensure
to include values inside double quotes.

1. Open Web.config in the XML editing application.
2. Add the primary vault name that you wish to access via Web2 to the VaultName key.

For example:

<add key="VaultName" value="PDM_Pro_Vault">

This name is case-sensitive.

3. If you want to access more than one vault via Web2, set AllowAccessToOtherVaults
to "true".

<add key="AllowAccessToOtherVaults" value="true">

4. To access multiple vaults, type their names separated by ¦ for VisibleVaults.

<add key="VisibleVaults" value="PDM_Test|PDM_Pro_Vault" />

5. To control download permissions for users and groups, add and configure the following
settings into the <configuration> node of the Web.config file.

<vaultSettings>
<vault name="EPDM" defaultDelimiter="|" denyDownloadGroups="">

<user name="admin" denyDownload="false"/>
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</vault>
</vaultSettings>

DescriptionVault setting

The name of the vault. Create a separate
<vaultSettings> section for each vault that needs
download permissions controlled.

name

The delimiter used to separate group names in the
denyDownloadGroups setting. The default delimiter is |.defaultDelimiter

The groups that should have download denied in the
specified vault. Group names should be separated by the
delimiter specified in the defaultDelimiter setting.

denyDownloadGroups

DescriptionUser setting

The login name of the user. Create a separate <user>
node for each user.name

The setting to deny or allow download for the specified
user. If set to false, the groups can download the files.
If set to true, the groups cannot download the files.

denyDownload

Configuring Microsoft IIS

1. In the Windows Start menu, type IIS to open Internet Information Services (IIS)
Manager.

2. In the left pane, expand the computer name, select Application Pools.
3. Right-click SOLIDWORKS PDM Web2 > Advanced Settings.
4. Ensure that Load User Profile is set to True.
5. In the Advanced Settings dialog box, click the button to set the Identity.

a) In the Application Pool Identity dialog box, select Custom account and click Set.
b) In the Set Credentials dialog box, type windows credentials of the user that has
currently logged into windows or a user that has logged into the IIS system,
browsed the file vault, and clicked a folder at least once.

c) Click OK thrice.

If the password for this user changes, the application pool stops working until the
user updates the password.

Ensure that the custom account user is a member of the IIS_IUSRS group:
Right-click Computer > Manage > Local Users and Groups > Groups >
IIS_IUSRS.
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Accessing Web2
You can access Web2 on a computer or on a mobile device.

To access Web2 on a computer in the local network, type the following URL into the
address field of a web browser:

http://ComputerName/SOLIDWORKSPDM

If the Web2 login page is not displayed, ensure that the Windows firewall on the IIS
server allows access over port 80 and the IIS server service is started.

To access Web2 on a mobile device, type the following URL into the address field of a
web browser:

http://ComputerName/SOLIDWORKSPDM/m

Creating a New Web2 Application
When you install the Web2 server, a Web2 application named SOLIDWORKSPDM is
automatically created under the default web site.

To create a new Web2 application:

1. Open the Internet Information Services (IIS) Manager.
2. In the left pane, expand the computer name and expand Sites.
3. Right-click Default Web Site and select Add Application.
4. In the Alias field, type a name.

This alias is a part of the connection address to the Web2 application i.e.
http://ComputerName/applicationalias.

5. Click Select and choose SOLIDWORKS PDM Web2 for Application pool.
6. For Physical path, browse to inetpub\wwwroot\SOLIDWORKSPDM\Web2.

7. Click OK twice.
If you want to create separate Web2 URL addresses to access different vaults you
can copy the inetpub\wwwroot\SOLIDWORKSPDM\Web2 and point the new application
physical path to this copy. Update the Web.config in the copied folder with the vault
name to access.
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Settings in the Application Settings Dialog Box
You can configure SOLIDWORKS PDM Professional Professional by accessing the Application
Settings function in the IIS Manager or by editing the Web.config file located in the
application files.

Default ValueTypeSetting

TrueTrue/FalseAllowAccessToOtherVaults

TrueTrue/FalseAllowDataCardEdit

TrueTrue/FalseClientValidationEnabled

Explorer
Text

ColumnSetName

MM/dd/yy
Text

DateFormat

TrueTrue/FalseDaysInState_Sortable

TrueTrue/FalseDaysInState_Visible

en
Text

DefaultLanguage

Files.zip
Text

DownloadZipFilename

*
Text

EditableDataCardVariables

15
Number

FileList_PageSize

10
Number

FileList_PageSize_Mobile
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Default ValueTypeSetting

FileUploadPath \Content\Uploads\
Text

FalseTrue/FalseFreeSearch

TrueTrue/FalseOnlySearchLatestVersion

780
Number

PopupWindowHeight

1040
Number

PopupWindowWidth

30
Number

PreviewGenerationTimeOut

7
Number

RememberMe_Days

TrueTrue/FalseRememberMe_Visible

Comment|Description
Separated text list

SearchDataCardVariables

TrueTrue/FalseUnobtrusiveJavaScriptEnabled

EPDM
Text

VaultName

EPDM_Test|EPDM
Separated text list

VisibleVaults

1.0.0.0
Number string

webpages:Version
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Variables in the Application Settings Dialog Box

DescriptionSetting

If set to True, you can log in to multiple vaults on the
server. If set to False, the VaultName setting lets you
connect to a single Vault View set in the
VisibleVaults setting.

When set to True, other vaults use the Query String
variable, Vault, to log in.

AllowAccessToOtherVaults

If set to True, you can edit the value of data fields
with check out permissions assigned. Use this setting
with EditableDataCardVariables setting that
controls variables to be edited.

SOLIDWORKS PDM Web2 does not automatically
update all configuration values. Variable values that
are set using transition actions update all
configurations as specified.

AllowDataCardEdit

Do not change.
ClientValidationEnabled

SOLIDWORKS PDM Web2 displays custom column set
that is defined in your vault. You can display only one
column set and it is same for all users.

Custom column sets that have columns defined as
Name, Checked Out, Size, State,Modified, and
Version are not supported because these names
are reserved for default Web2 columns.

ColumnSetName

DateFormat
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DescriptionSetting

Controls the display of date fields in SOLIDWORKS
PDM Web2. You can set the date using different
delimiters. Various options for displaying date fields:

"M">1-12, "MM">01-12,
"MMM">Dec, "MMMM">December

"M"Month

"d">1-31, "dd">01-31, "ddd">Sat,
"dddd">Saturday

"d"Day

"y">0-99, "yy">00-99 ,
"yyyy">0000-9999

"y"Year

Examples:

• "MM/dd/yy">06/07/09
• "dddd, MMMM-d, yyyy">Sunday, June-7, 2009

If set to True, sets days in State column as sortable.
The default columns in SOLIDWORKS PDM Web2 are
sortable however, columns that appear by defining
column set are not sortable.

DaysInState_Sortable

If set to True, displays days in the State column. This
column is unique to SOLIDWORKS PDM Web2.DaysInState_Visible

DefaultLanguage

85

Installing SOLIDWORKS PDM



DescriptionSetting

Sets the default language, en, that appears in the first
login. You can change the language from Web2 user
interface.

Web2 user interface displays the changed language
until you clear internet cookies.

The language codes used for this setting:

esSpanishenEnglish

itItalianfrFrench

koKoreanjaJapanese

plPolishdeGerman

ptPortuguesezhsChinese
simplified

ruRussianzhtChinese
traditional

trTurkishcsCzech

When you select multiple files for downloading, Web2
combines into a compressed file. This setting sets the
name of the compressed file.

DownloadZipFilename

If AllowDataCardEdit is set to True, this setting
controls variables to be edited. The default value is *
that lets you edit all non-read only variables. Separate
multiple values with | . For example, to edit
Description and Number, enter
”Description|Number”.

EditableDataCardVariables

Sets the default number of files and folders to display
in the full SOLIDWORKS PDM Web2 version.FileList_PageSize

Sets the default number of files and folders to display
in the mobile SOLIDWORKS PDM Web2 version.FileList_PageSize_Mobile

FileUploadPath
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DescriptionSetting

When you upload new files or create new versions,
SOLIDWORKS PDM Web2 copies the files to the
Uploads folder. The full path to this folder depends
on the location of Web2 application files. For example,
if the Web2 application files are located in C:\Program
Files\SOLIDWORKS Corp\SOLIDWORKS PDM\Web2 then
the path to the Uploads folder would be C:\Program
Files\SOLIDWORKS Corp\SOLIDWORKS PDM\Web2\
Content\Uploads.

Enables SOLIDWORKS PDM Web2 to search all file
and folder names, variable values, configuration
names, comments, and labels.

FreeSearch

Limits the search to the latest version of files. When
set to True, the search finds values only in the latest
versions.

OnlySearchLatestVersion

Sets the width, in pixels, for the pop up viewing
window that appears when you click on the preview
image.

PopupWindowHeight

Sets the height, in pixels, for the pop up viewing
window that appears when you click on the preview
image.

PopupWindowWidth

Controls how long the preview converter can wait (in
seconds) before ending the conversion operation. The
minimum value for this setting is 30 seconds (with no
limit on the maximum value). Large files and files with
complex formatting or graphics take longer for the
conversion process. Timeout errors on the file preview
page indicate that the conversion time needed for a
file exceeds this value. Increasing the timeout value
allows the converter more time to complete the
longer-running conversions.

PreviewGenerationTimeOut

Sets number of days the system remembers user log
in information for vault name, license type, and user
name.

RememberMe_Days

Controls the display of Remember me check box on
the log in screen.RememberMe_Visible

SearchDataCardVariables
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DescriptionSetting

If you set FreeSearch to False, SOLIDWORKS PDM
Web2 searches on file names, folder names, and
variable names entered. Separate each variable name
with |. The search box in the user interface displays:

• Free Search if it set to True.
• File/Folder name, varaible1, varaible2, if Free
Search is set to False.

Do not change.
UnobtrusiveJavaScriptEnabled

Specifies the vault name that SOLIDWORKS PDM
Web2 connects to and displays it in the log in screen.
If you want to access only single vault, clear values
in the VisibleVaults setting.

VaultName

If you want to access multiple vaults, enter vault
names separated by |.VisibleVaults

Do not change.
webpages:Version

Variable Name and Variable Value Alias Settings
If a vault contains variable names that are not user friendly, you can set alias’ so that
the names that appear on the data card preview are meaningful.

For example: If a vault contains the variable, PAR_NUM, that holds a part number value,
it is meaningful to display the variable as Part Number on the data card preview. You
can set this in the property name alias setting.

The data card Preview page displays the variables and their values in list form. It does
not display the data card as it appears in the thick clients or the existing web client,
so any formatting, pictures, labels, and other card controls are not supported.

You can also specify an alias for the variable value. For example: If a text type variable
is connected to a check box control that displays whether the file is a spare part or not,
the values in SOLIDWORKS PDM Web2 appear as 1 or 0 depending on the check box
selected or cleared. You can set the variable value to display Yes or No via the transform
alias value settings.

Setting Variable Name Alias

1. Open the Web.config file in either Notepad or an XML editing program.<!-- Section
used to handle property alias and value mappings --> <propertySettings>
<property name="SPARE_PART" alias="Spare part"> <transform value="1"
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alias="Yes" /> <transform value="" alias="No" /> </property>
</propertySettings>

2. Scroll down to the propertySettings section.
3. Enter the following:

ExampleActionAttribute

name="SPARE_PART"Actual variable namename

alias="Spare part"Desired variable namealias

4. To set alias' for variable values, enter the actual values in the transform value
attribute.
This step is optional. You can delete the transform lines if the variable values do not
need alias'.

Desired ValueValueAlias

alias="Yes""1"value

alias="No"""value

System Maintenance
You should monitor and empty two folders periodically for disk space availability.

The folders to be monitored are:

Uploads: The folder in which the system adds files that are uploaded before they are
copied into the vault.

tempFiles: The folder that is located under the Content folder in the application file
location and used for previewing purposes.

Installing the SOLIDWORKS PDM Client
For a system to work with a SOLIDWORKS PDM file vault, it must have the SOLIDWORKS
PDM client installed.

The following types of SOLIDWORKS PDM Professional client are available:
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Supports working with all file types, including enhanced
management and previewing of many CAD formats such as
SOLIDWORKS, AutoCAD, Inventor, SolidEdge, and
Pro/ENGINEER. Should be used on any system working with
CAD files.

To work with Pro/ENGINEER files, install the Pro/ENGINEER
CAD add-in after installing the SOLIDWORKS PDM
Professional client. The Pro/ENGINEER connector requires
separate installation media. Contact your SOLIDWORKS
Value Added Reseller for more information.

SOLIDWORKS PDM
Professional CAD Editor
& Web

Includes support for SOLIDWORKS PDM Web client access.

Supports working with all file types, including CAD files.
However, CAD add-ins are not supported on this client type.

SOLIDWORKS PDM
Professional
Contributor & Web

Includes support for SOLIDWORKS PDM Web client access.

Allows read-only access to file vaults; user cannot add or
modify (check out, check in, update values) any files. CAD
add-ins are not supported on this client type.

SOLIDWORKS PDM
Professional
Professional Viewer

The following types of SOLIDWORKS PDM Standard client are available:

Supports working with SOLIDWORKS, DWG/DXF format,
and Microsoft Word, and Microsoft Excel files. All file
formats that Office plug-in handles behave in the same
way in SOLIDWORKS PDM Standard except Preview.

SOLIDWORKS PDM
Standard CAD Editor

Supports working with SOLIDWORKS, DWG/DXF format,
and Microsoft Word, and Microsoft Excel files.

SOLIDWORKS PDM
Standard Contributor

Allows read-only access to file vaults; user cannot add
or modify (check out, check in, update values) files.

SOLIDWORKS PDM
Standard Viewer

You can install clients:

• By using the installation wizard on the SOLIDWORKS DVD.
• By using the SOLIDWORKS Installation Manager.
• By creating an administrative deployment image to install multiple seats.

Before Installing Clients
• Find out the type of client your license agreement entitles you to use.

The floating license manager in SOLIDWORKS PDM prevents logging into a file vault if
the wrong client type is installed.

• If you are installing the SOLIDWORKS PDM Editor Client, you can install optional add-ins.

Add-ins make version management features such as check out, check in, and get
available from menus and toolbars within your CAD and Office software. They are
optional and do not affect which file formats can be managed by SOLIDWORKS PDM
using the Windows Explorer interface or file open/save dialogs.
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SOLIDWORKS PDM Standard provides DraftSight add-in and SOLIDWORKS add-in.

• To log in to the Professional vault, you must have SOLIDWORKS PDM Professional
license available on the license server. Similarly, to log in to the Standard vault, you
must have SOLIDWORKS PDM Standard license available on the license server.

To install both client and server components, ensure to select Client option in the
server installation.

The following product-specific prerequisites apply:

You can manage SOLIDWORKS files without having
SOLIDWORKS installed. It is recommended to have the
eDrawings viewer installed for previewing.

SOLIDWORKS

To manage Inventor files (add, check out, check in,
preview, etc.), the client system must have either the full
Autodesk Inventor application or the Inventor Design
Assistant software installed. For previewing Inventor files,
Inventor View should be installed.

Autodesk Inventor (For
SOLIDWORKS PDM
Professional only)

AutoCAD does not have to be installed to manage
DWG/DXF format files. It is recommended to have the
eDrawings or DWG TrueView application installed for
previewing DWG files and the DWF viewer for previewing
DWF files.

Autodesk AutoCAD (For
SOLIDWORKS PDM
Professional only)

You can install Microsoft Office Add-in when you install
SOLIDWORKS PDM Professional. You do not need
additional licenses to use the Microsoft Office Add-in but
must have a Contributor, CAD Editor, or PSL license to
check files out and in.

Microsoft Office
Integration (For
SOLIDWORKS PDM
Professional only)

SOLIDWORKS PDM Professional requires the full Solid
Edge application installed for managing and previewing
Solid Edge files.

Solid Edge (For
SOLIDWORKS PDM
Professional only)

SOLIDWORKS PDM Professional requires the full
Pro/ENGINEER application installed for managing and
previewing Pro/ENGINEER files.

The Pro/ENGINEER Connector requires a separate
installation after the SolidWorks client installation. The
software can be obtained from your SolidWorks Value
Added Reseller.

Pro/ENGINEER (For
SOLIDWORKS PDM
Professional only)

These requirements apply to installations performed from the SOLIDWORKS PDM media
or from an administrative image.
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Installing Clients Using the Installation Wizard

1. Log on to the client computer as a user with local administrative rights.
2. Begin the installation, as described in Initiating SOLIDWORKS PDM Installations

on page 52.
3. Complete the installation using the following instructions:

ActionScreen

Select the type of client to install:

• SOLIDWORKS PDM Professional: Select if
you connect to SOLIDWORKS PDM Professional
server only.

To install the client with Item Explorer, select
Customize and click Next.

• SOLIDWORKS PDM Standard: Select if you
connect to SOLIDWORKS PDM Standard server
only.

Select PDM Product

Select Item Explorer and click Next.

This option is available for SOLIDWORKS PDM
Professional only.

Custom Setup

1. Select the type of client to install, based on
your license:

• SOLIDWORKS PDM CAD Editor
• SOLIDWORKS PDM Contributor
• SOLIDWORKS PDM Viewer

2. Click Next.

Choose Product Type

If the product type is SOLIDWORKS PDM CAD
Editor,

1. You can select:

• Microsoft Office Integration,
SOLIDWORKS ,DraftSight, Inventor, and
AutoCAD add-ins for SOLIDWORKS PDM
Professional client.

• SOLIDWORKS and DraftSight add-ins for
SOLIDWORKS PDM Standard client.

2. Click Next.

Select Add-Ins

Click Install.Ready to Install the Program

Click Finish.InstallShield Wizard Completed
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Installing eDrawings
Install eDrawings on SOLIDWORKS PDM client to view the preview for SOLIDWORKS files.
eDrawings® is also available as a free download.

1. Insert the SOLIDWORKS DVD.
2. Cancel SOLIDWORKS Installation Manager, if it starts.
3. Run \eDrawings\setup.exe.
4. Click Next.
5. Do not enter the license keys and click Next.

eDrawings runs as a Professional license if it is installed on a SOLIDWORKS PDM
Professional client.

6. Click Install.
The installation continues.

7. Click Finish after the installation is complete.

Upgrading the SOLIDWORKS PDM Standard Client/Server
to Professional

If you have installed the Standard client/server via InstallShield Wizard, perform the
following steps.

To upgrade:

1. In Windows, open Control Panel > Programs and Features.
2. Right-click SOLIDWORKS PDM Client or SOLIDWORKS PDM Server and select

Change.
If you have installed the client via SLDIM, modify the SOLIDWORKS installation to
upgrade the client install.

3. On the Welcome screen, click Next.
4. On the Program Maintenance screen, click Modify.
5. On Select PDM Product screen, select SOLIDWORKS PDM Professional.
6. Continue with the installation of SOLIDWORKS PDM Professional.

If you have installed the Standard client/server via SLDIM, modify SOLIDWORKS
2016 listed under Programs and Features for an upgrade.

Enabling Logging to Troubleshoot Installation
An installation log is useful when troubleshooting a failing installation.

1. Open a command prompt.
2. Change directory to the appropriate setup folder on the SOLIDWORKS DVD.
3. Type the appropriate command to start a logged installation:

93

Installing SOLIDWORKS PDM



• For client:

MSIEXEC /i "SOLIDWORKS PDM Client.msi" /L*v C:\LOGFILE.TXT

• For server:

MSIEXEC /i "SOLIDWORKS PDM Server.msi" /L*v C:\LOGFILE.TXT

An installation log is created with information about the installation.

Creating SOLIDWORKS PDM Client Administrative Image
An administrative installation image lets you control the installation and upgrade of the
client on multiple client machines.

You can create one image for all client license types and select a script for a specific client
type to install on a machine.

The installation wizard creates a setup package (SOLIDWORKS PDM Client.msi and
required files) that you can distribute using Microsoft Active Directory or another
distribution method.

Keep a copy of the administration image, which includes all options you select, to make
it easier to uninstall when doing an upgrade.

To create an administrative image:

1. From the Windows Start menu, run command prompt.
2. Type the location of setup.exe on your SOLIDWORKS DVD and add the command

switch E:\SWPDMClient\setup.exe /a.
You can drag and drop setup.exe on the command prompt and add the command
switch.

3. Click OK.
4. Create the administrative image using these instructions:

ActionScreen

Click Next.Welcome

Read and accept the license agreement and click
Next.

License Agreement

Enter a location where the SOLIDWORKS PDM
client administrative image should be created.

If you plan to distribute this image, place it on
a network resource that is available to all client
systems.

Network Location

Click Install.Ready to Install the Program
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ActionScreen

Click Finish.InstallShield Wizard Completed

Deploying Clients Using Windows Active Directory
By using the Group Policy features of Windows Active Directory, you can centrally deploy,
install, and manage SOLIDWORKS PDM clients throughout an organization.

You can also perform routine maintenance tasks such as upgrading, patching, and
removing clients from a central location, without going to individual workstations.

If you distribute the clients using an administrative image, you must deploy Microsoft
XML Core Services (MSXML) 6.0 and .Net Framework 4.0 to all clients.

For information on distributing MSXML and .Net Framework, see
http://msdn.microsoft.com/en-us/library/ee390831.aspx.

Only the SOLIDWORKS PDM client can be deployed using this method. Install the
archive server and database server using the standard installation method.

Active Directory deployment considerations:

• Because SOLIDWORKS PDM is installed on a computer level, before any user has logged
on, the deployment package should be available (i.e. shared with sufficient access
rights) to all systems assigned for deployment.

• When you deploy a client, SOLIDWORKS PDM changes the default language that matches
the locale of the machine. If the locale is not a supported language, SOLIDWORKS PDM
sets the default language as English.

• Once deployed, you can add file vault views to the clients:

• Using a policy

For details, see Distributing the File Vault View Using Microsoft Windows
Active Directory on page 120.

• Using a scripted view installation

For details, see Scripting File Vault View Setup on page 119.

To deploy a client admin image using Windows Server 2008 Active Directory:

1. Create an administrative image (SOLIDWORKS PDM Client.msi) in a network location
that is accessible by UNC path to all systems where SOLIDWORKS PDM should be
deployed.
For details, see Creating SOLIDWORKS PDM Client Administrative Image on
page 94.

2. Open the Control Panel and click System and Security > Administrative Tools
> Active Directory Users and Computers.
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3. Create a security group, or use an existing security group.
To create a security group:
a) In the Active Directory User and Computers dialog box, right-click Users and select
New > Group.

b) In the New Object - Group dialog box, type a Group name.
c) Under Group type, select Security and click OK.

4. Add the computers where SOLIDWORKS PDM should be deployed.
To add domain computers to the security group:
a) Right-click the security group and select Properties.
b) On the Members tab, click Add and add the computers.

5. Exit the Active Directory User and Computers dialog box.
6. In the Control Panel, click System and Security > Administrative Tools > Group

Policy Management.
7. In the Group Policy Management console, create a new group policy for the security

group you created in steps 3 and 4.
8. Expand Group Policy Objects in the forest and domain that contains the new group

policy and select the group policy.
9. In the right pane, on the Settings tab, right-click Computer Configuration and click

Edit.
10. In the Group Policy Management Editor, navigate to Computer Configuration >

Policies > Software Settings > Software Installation.
11. Right-click and select New > Package.
12. Browse to the SOLIDWORKS PDM Client.msi file in the location where you created

the SOLIDWORKS PDM client administrative image.

You should browse to the location through My Network Places to use the UNC
path correctly. Do not use a mapped drive.

13. Click Open.
14. In the Deploy Software dialog box, select Assigned and click OK.
15. Select Advanced published or Assigned.
16. On the Modifications tabbed page, click Add to select one or more transforms to

be applied.
Ensure that the transform files are available on a network drive that is accessible by
remote computers, preferably where the source image is available.

You can use MSI tools, like Orca, to generate the transform files. For syntax, see
Scripting a Silent Installation of SOLIDWORKS PDM.

17. Exit the Group Policy Management Editor and Group Policy Management console.

The client image is ready for deployment and will be installed to the computers in the
security group the next time the systems start up.
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Enabling Logging When Deploying SOLIDWORKS PDM
To troubleshoot installation problems that occur when you deploy a SOLIDWORKS PDM
client administrative image using Windows Active Directory, you should enable logging
of the installation procedure. This is done through a Group Policy.

1. On the Active Directory server, locate the OU where the deployment package is
assigned.

2. Right-click the OU, and select Properties.
3. In the Properties dialog box, on the Group Policy tab, click New to add a new Group

Policy object. Name the policy (for example, Logging) and click OK.
4. Select the new policy (or an existing deployment policy) and click Edit.
5. In the Group Policy Object Editor, expand Computer Configuration >

Administrative Templates > Windows Components > Windows Installer.
6. In the right pane, double-click the Logging setting.
7. In the policy object’s Properties dialog box:

a) Enable the policy.
b) In the Logging text box, type the full logging arguments:

iwearucmpvo

c) Click OK.

8. On the Group Policy tab, if you created a new group policy object, make sure that
the new policy is listed at the top of the list.

When you deploy SOLIDWORKS PDM, an .msi installation log will be created in the Temp
folder under the Windows system folder.

Scripting a Silent Installation of SOLIDWORKS PDM
You can script the client installation from an administrative image (for example, to run
the installation from a .bat file).

To script a silent installation:

1. Create an administrative image for the client type you are installing to create the
SOLIDWORKS PDM Client.msi installation package that is used in the following
commands.
For details, see Creating SOLIDWORKS PDM Client Administrative Image.

2. Update your installation script using the following command line options in
SOLIDWORKS PDM Command-Line Properties.

Silent Installation Switches

DescriptionSwitch

No UI/qn

Basic UI/qb
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DescriptionSwitch

Reduced UI with a modal dialog box displayed at the end of the
installation

/qr

Full UI with a modal dialog box displayed at the end of the
installation

/qf

No UI except for a modal dialog box displayed at the end of the
installation

/qn+

Basic UI with a modal dialog box displayed at the end of the
installation

/qb+

Basic UI with no modal dialog boxes/qb-

Do not prompt for rebootREBOOTYESNO=NO

Suppresses the prompt for reboot when used with REBOOTYESNO

If you upgrade a previous installation with this option, you
must perform a reboot at the end of the installation to reload
any replaced files that are in use.

REBOOT=REALLYSUPPRESS

Excludes a feature from installingREMOVE=[string]

SOLIDWORKS PDM Command-Line Properties

DescriptionProperty

Installation directoryINSTALLDIR=[string]

Client type

• 0 = PDM Standard
• 1 = PDM Professional

PDMTYPE=0, 1

{CC72DD26-1A34-4209-B50B-21C7DD5E29F6}SOLIDWORKS
PDM Viewer

{E2BE88CF-6E17-43e2-A837-C1051F3E4EDB}SOLIDWORKS
PDM
Contributor

{05AD35C4-8A9A-4114-B51F-32186222ABA1}SOLIDWORKS
PDMCAD Editor

PTID=
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DescriptionProperty

ClientMain feature

OfficeOffice Add-in

SolidWorksSolidWorks Add-in

InsoViewerOracle Viewer

WebClientWeb Client helper

ItemExplorerItem Explorer

AutoCAD64Autocad Add-in(only support x64
now)

InventorInventor Add-in

DraftSightDraftSight Add-in

SharedCommon files

Shared64Common Files 64-bit

ADDLOCAL=

R17.0AutoCAD 2007

R17.1AutoCAD 2008

R17.2AutoCAD 2009

R18.0AutoCAD 2010

R18.1AutoCAD 2011

R18.2AutoCAD 2012

R19.0AutoCAD 2013

R19.1AutoCAD 2014

R20.0AutoCAD 2015

R20.1AutoCAD 2016

ACADVERSION64=

For more details, refer to the following sample scripts:

• SOLIDWORKS PDM Professional Viewer with no add-ins
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Msiexec /I <path to SOLIDWORKS PDM Client.msi> INSTALLDIR="C:\Program
Files\SOLIDWORKS PDM" PDMTYPE=1 PTID={CC72DD26-1A34-4209-B50B-21C7DD5E29F6}
ADDLOCAL=Client,Shared,Shared64,WebClient,InsoViewer /qb

• SOLIDWORKS PDM Professional CAD Editor with SOLIDWORKS and Office Add-ins

Msiexec /I <path to SOLIDWORKS PDM Client.msi> INSTALLDIR="C:\Program
Files\SOLIDWORKS PDM" PDMTYPE=1 PTID={05AD35C4-8A9A-4114-B51F-32186222ABA1}
ADDLOCAL=Client,Shared,Shared64,WebClient,InsoViewer,SolidWorks,Office
/qb

• SOLIDWORKS PDM Professional CAD Editor with SOLIDWORKS, Office, and AutoCAD
2014 Add-in

Msiexec /I <path to SOLIDWORKS PDM Client.msi> INSTALLDIR="C:\Program
Files\SOLIDWORKS PDM" PDMTYPE=1 PTID={05AD35C4-8A9A-4114-B51F-32186222ABA1}
ADDLOCAL=Client,Shared,Shared64,WebClient,InsoViewer,SolidWorks,Office,AutoCAD64
ACADVERSION=R19.1 /qb

• SOLIDWORKS PDM Standard CAD Editor with SOLIDWORKS Add-in

Msiexec /I <path to SOLIDWORKS PDM Client.msi> INSTALLDIR="C:\Program
Files\SOLIDWORKS PDM" PDMTYPE=0 PTID={05AD35C4-8A9A-4114-B51F-32186222ABA1}
ADDLOCAL=Client,Shared,Shared64,SolidWorks /qb
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6
Using SOLIDWORKS Installation
Manager

SLDIM faciliates the installation of PDM servers and client components. However, to configure
and troubleshoot PDM components and SQL Server databases, you will need to refer to advanced
topics in other sections of this guide.

This chapter includes the following topics:

• SOLIDWORKS PDM
• Listing of PDM Server Components
• Understanding Differences between PDM Clients
• Before Installing PDM Server
• Installing a PDM Server with SLDIM
• Installing a PDM Client with SLDIM

SOLIDWORKS PDM
SOLIDWORKS PDM is a document management product based on the client/server
architecture known formerly as SOLIDWORKS Enterprise PDM.

SOLIDWORKS PDM is available in two types:

• SOLIDWORKS PDM Standard
• SOLIDWORKS PDM Professional

SOLIDWORKS PDM uses a Microsoft SQL Server database to manage file vaults.

This table lists the database systems, server components and client options available for
each product type.

PDM ProfessionalPDM Standard

Large office networks, large
numbers of concurrent users

Small to medium office
networks, generally with less
than 20 concurrent users.

Designed for

SQL Standard limits: Lesser
of 4 sockets or 16 cores, 128
GB of RAM, and 524 PB
database size

Lesser of 1 sockets or 4
cores, 1 GB of RAM, and 10
GB database size

Limits
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PDM ProfessionalPDM Standard

Microsoft SQL Server 2014
(included separately with
SOLIDWORKS), or previously
installed instances of
Microsoft SQL Server 2014,
2012, or 2008 R2

Microsoft SQL Server Express
2014 (included and installed
with SOLIDWORKS)

Database Management
System

YesYesRequires SolidNetWork
License Manager?

YesYesIncludes Archive Server and
Database Server?

YesNoIncludes SOLIDWORKS PDM
Web server and Web2
Server?

Native, browser-basedNativeClient types

SOLIDWORKS, DraftSight,
Microsoft Office Integration,
Autodesk Inventor, AutoCAD

SOLIDWORKS, DraftSightClient add-ins for CAD
Editors

DraftSight, Microsoft Office
Integration

DraftSightClient add-ins for
Contributors

Microsoft Office IntegrationClient add-ins for Viewers

Listing of PDM Server Components
This table summarizes the server components of the SOLIDWORKS PDM Server.

InstallationFunctionServer

Can install with PDM
Standard, or use a version
previously licensed and
installed.

Manages data in
SOLIDWORKS PDM data
vaults.

Microsoft SQL Server Express
for PDM Standard

Ships separately with PDM
Professional. You can also
use a version previously
licensed and installed.

Manages data in
SOLIDWORKS PDM data
vaults.

Microsoft SQL Server for
PDM Professional
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InstallationFunctionServer

Must be installed before new
vaults can be created.

Can be installed with
SOLIDWORKS PDM server
components when using
SLDIM.

Manages SOLIDWORKS PDM
licenses.

SolidNetWork License
Manager

Required. Install with PDM
Standard or Professional.

Manages transfers of files
between clients and the file
vault archive, and manages
users and their credentials.

Archive Server

Required. Install with PDM
Standard or Professional.

Polls PDM databases for
updates, manages data
import and export rules,
manages the message
system, and schedules
replication and cold storage.

Database Server

Optional. Install with PDM
Professional only.

Provides access to file vaults
over the Internet from
browser-based clients.

Web Server and Web2
Server

Archive servers run as services on the system account of the computers where they are
installed. One archive server can host multiple file vaults on the same computer.

In a standalone installation, the archive server, database server, and license server, as
well as the SQL Express or SQL Server database, can all be installed on the same machine.

In a distributed environment, the server components can reside on different machines.
Also, you can set up multiple archive servers on different computers to host replicated
copies of the same file vault archive. See the SOLIDWORKS PDM Professional Replication
Guide.

Understanding Differences between PDM Clients
Before installing the client software, you must determine what clients are needed
depending on your PDM environment.

This table summarizes the clients for SOLIDWORKS PDM Standard:

DescriptionStandard Client type

Supports working with SOLIDWORKS,
DWG/DXF format, Microsoft Word, and
Microsoft Excel files. All file formats, that
Office plug-in handles, behave in the same
way in SOLIDWORKS PDM Standard except
Preview.

CAD Editor
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DescriptionStandard Client type

Supports working with SOLIDWORKS,
DWG/DXF format, Microsoft Word, and
Microsoft Excel files.

Contributor

Allows read-only access to file vaults. User
can transition files through a workflow, but
user cannot add or modify (check out, check
in, update values) files.

Viewer

This table summarizes the clients for SOLIDWORKS PDM Professional:

DescriptionProfessional Client type

Supports working with all file types,
including enhanced management and
previewing of CAD formats such as
SOLIDWORKS. CAD add-ins allow users to
access SOLIDWORKS PDM Professional from
within the CAD application. Remote users
can search vaults and perform basic
functions over the Internet using the Web
and Web2 clients.

CAD Editor & Web

Supports working with all file types,
including CAD files. However, the CAD
add-ins are not supported on this client
type. Remote users can search vaults and
perform basic functions over the Internet
using the Web and Web2 clients.

Contributor & Web

Allows read-only access to file vaults. User
can transition files through a workflow, user
cannot add or modify (check out, check in,
update values) files or use CAD add-ins.

Viewer

Before Installing PDM Server
Keep these requirements in mind before installing PDM server components:

• Obtain full administrative rights to the machines on which you are going to install
servers and clients.

• Ensure that the database server has access to the archive server over TCP port 3030
and to the SQL Server over TCP port 1433.

• If you are going to use an existing SQL Server Express or SQL Server database, obtain
the name of the SQL Server database and the account ID and password of a SQL Server
administrator or database owner with read/write access to the database. You cannot
use the tew user.

• If a PDM client is already installed on the system, uninstall it. If you want the PDM
Server and PDM Client on the same system, you can install them both from the Server
products page in the SOLIDWORKS Installation Manager.
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Installing a PDM Server with SLDIM
When you install the PDM Server for PDM Standard, you can install the archive server,
the database server, and the PDM CAD Editor client on the same machine. You do not
need to run the client installation separately.

When installing the PDM Server for PDM Professional, you can include these components,
and also the Web server and Web2 server.

To install a PDM Server and its components:

1. Start the SOLIDWORKS Installation Manager.
2. On the Welcome page, select Server Products, and check the following:

• Install SOLIDWORKS PDM Server components on this computer.
• Install SolidNetWork License Manager on this computer.

If the SolidNetwork License Manager is installed, this option does not display.

3. If the SolidNetwork License Manager Options page displays, type a serial number and
specify a location for the directory, and click Next.

4. Follow instructions for system warnings and click Next.
5. On the Summary page, for SOLIDWORKS PDM Server, click Change.
6. In the SOLIDWORKS PDM Server Options page:

a) For Select Server Product, click SOLIDWORKS PDM Standard or Professional.
b) For Installation Location, click Browse to specify a file path.
c) In Select Features:

1. Click Archive Server, Database Server, and Client to install these components
on the same machine. If you are in a distributed environment, you can install
the archive server and database server by running the Installation Manager on
another machine.

If a PDM client is already installed on the machine, you must cancel the
installation and uninstall the client. You can then run the SLDIM to install the
PDM server with the client together.

2. If you are installing PDM Professional, you can also clickWeb server andWeb2
server.

d) In SQL Server, you can install a new instance of the database and management
tools that comes with PDM Server (SQL Server Express for PDM Standard), or you
can specify the database name, username, and password of an existing instance.

A full edition of SQL Server ships separately with PDM Professional.

e) Click Back to Summary.

7. On the Summary page, accept the terms of the SOLIDWORKS License Agreement
and click Install Now.

When the SOLIDWORKS Installation Manager completes installing, the Archive Server
Configuration Tool launches. Follow the prompts in the wizard to configure the archive
server.
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To set up, configure, and troubleshoot the archive server, database server, Web and
Web2 servers, and SQL Server databases, see the relevant topics in the SOLIDWORKS
PDM 2016 Installation Guide.

Installing a PDM Client with SLDIM
To install a PDM Client:

1. Start the SOLIDWORKS Installation Manager.
2. On the Welcome page, select Individual.
3. On the Serial Number page, click Next.

SOLIDWORKS PDM clients do not require a separate serial number.

4. Follow instructions for system warnings and click Next.
5. On the Summary page, under Products, click Change.
6. On the Product Selection page, click Select different packages or products.
7. In the Select the package you want to show dialog box, select an edition of

SOLIDWORKS. Then click OK.
8. On the Product Selection page, select SOLIDWORKS PDM Client. Then select

eDrawings to enable the PDM Preview functionality. If you are using SOLIDWORKS
PDM Professional, you can also select Item Explorer.

9. On the Summary page, expand SOLIDWORKS PDM Options and click Change.
10. On the SOLIDWORKS PDM Client Options page, select the following and click Back

to Summary:

• PDM product type
• PDM client type
• Add-ins

11. On the Summary page, accept the terms of the SOLIDWORKS License Agreement
and click Install Now.

Administrators can also use the Administrative Image Option Editor to create and
deploy images of PDM clients. For details, see Using Administrative Images in the
SOLIDWORKS Installation and Administration Guide.
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7
Creating and Distributing File Vault
Views

SOLIDWORKS PDM file vaults store the files and information managed by SOLIDWORKS PDM.

To add a file to a file vault, you place it in a local file vault view, which is a working folder
where all intermediate file modifications are performed.

The file vault view is directly connected to:

• The archive server, which stores the physical files in a file vault archive
• The file vault database, which stores information about files and activities in the file vault

You can access files and information stored in a file vault only from a system with the
SOLIDWORKS PDM client installed by logging in as a user with sufficient access rights.

This chapter includes the following topics:

• Vault Creation
• Configuring the SolidNetWork License Server for the File Vault
• Creating a File Vault View Using the View Setup Wizard
• Distributing the File Vault View Using Microsoft Windows Active Directory
• Distributing File Vault Views in a WAN Environment

Vault Creation
Use the SOLIDWORKS PDM Administration tool to create the vault on the archive server.

Prerequisites

Before creating a vault:

• Verify that all SOLIDWORKS PDM components have been installed.
• Ensure the archive server is available.

If the archive server you want to use is on another system, you may need to add it.

The archive server may not be accessible if a firewall on the archive system is blocking
TCP port 3030.

• If the SQL Server is on a different system than the archive server, ensure that it is
available. It may not be accessible if a firewall is blocking port 1433.

If the SQL server is using a named instance or is SQL Server Express, the TCP port
may be set to a dynamic value instead of 1433. For details, see Configuring the
SQL Server Express Instance to Listen to a Fixed TCP Port.
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• Ensure you have sufficient access rights.

Your Windows user account must have Administrative access to the archive server. If
you create the vault on the same system as the archive server, the local administrator
has this access by default.

• Obtain SQL Server information.

You must know:

• The SQL server name.
• Login information for a user with sufficient system administrator privileges to create
a vault.

Adding an Archive Server
To create a vault, you must be able to connect to an archive server. If an archive server
is installed but is not visible in the Administration tool, you can add it.

1. Start the Administration tool by doing one of the following:

• On Windows 7 and Windows Server systems prior to Windows Server 2012, from
the Windows Start menu, select All Programs > SOLIDWORKS PDM >
Administration.

• On Windows 8.1 and Windows Server 2012 or later, on the Apps screen, under
SOLIDWORKS PDM, click Administration.

2. Click File > Add Server.
3. In the Add Server dialog box, for Server name, select or type the server to add.

Use the server system name, not the IP address, unless the environment is configured
for IP-only communication, as described in the Installation Guide.

When adding an archive server to a wide-area network (WAN), DNS can fail when
looking up the IP address of the server host name. As a workaround, ensure that the
client can successfully ping the server by name. If the ping does not work, update
the local HOSTS file.

For details, see Adding Archive Servers in a WAN Environment in the SOLIDWORKS
PDM Installation Guide.

4. Click OK.

Logging In to an Archive Server
Before creating a new vault, you may need to log in. If the logged in Windows user account
has administrative access on the archive server, login is not required.

To log in to an archive server:

1. In the Login dialog box, enter the Windows user name and password of a user with
access to vaults on the archive server.

• To add the archive server and list its vaults, log in as a user who is a member of
the attach access list in the Archive Server Configuration tool.

• To perform administrative tasks such as creating, upgrading, or removing a vault,
log in as a user with administrative access.

2. If the Login dialog box includes a Domain list, do one of the following:
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• If you are using a local user account on the archive server, select the system name
that is followed by (local account).

• If you are using a domain account, select or type the correct domain.

3. Click Log In.

Creating a Vault

To create a vault:

1. Log in to a system where the SOLIDWORKS PDM client is installed.
2. Start the Administration tool by doing one of the following:

• On Windows 7 and Windows Server systems prior to Windows Server 2012, from
the Windows Start menu, select All Programs > SOLIDWORKS PDM >
Administration.

• On Windows 8.1 and Windows Server 2012 or later, on the Apps screen, under
SOLIDWORKS PDM, click Administration.

3. If the archive server you want to work with is not listed, add it as described in Adding
an Archive Server on page 108.

4. In the left pane, right-click the archive server in which to create the vault, then select
Create new vault.

If you are prompted to log in, see Logging In to an Archive Server.

5. In the vault setup wizard:

ActionScreen

Click Next.Welcome

Select either SOLIDWORKS PDM Standard Vault or
SOLIDWORKS PDM Professional Vault.

This screen appears only for SOLIDWORKS PDM
Professional.

Choose Vault Type

Type a name and description for the new vault.Choose vault name

Under Vault root folder, select the root folder to store the
vault archives.

The default root folder is Archives.

Select vault root
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ActionScreen

The vault database contains information about files and
activities in the vault.

Select or enter the SQL Server Express to host the vault
database in Select database server.

A Standard vault database must be hosted on SQL Server
Express.

Type the Database name.

The SQL login dialog box appears in one of the following
cases:

• Stored SQL login has insufficient privileges
• User is invalid on the SQL server
• Username or password is incorrect

Specify a SQL user such as sa with sufficient permissions.

Choose database

Enter the SolidNetWork License server address in the form:
port@SNLServerName.

For SOLIDWORKS PDM Standard vault, add the server name
that has activated license for the Standard vault.

For SOLIDWORKS PDM Professional vault, add the server
name that has activated license for the Professional vault.

License Server for
Vault

Language

Select the language to use in the vault.

Select regional settings

Do one of the following:

• Select Use the default 'admin' password for this
archive server.

The Admin user password defined during the archive server
installation is used for the vault's admin user.

• Clear the option to enter and confirm a password.

This login is set to the vault-specific admin login settings
for the new vault.

Create the admin user
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ActionScreen

Do one of the following:

• Use a configuration based on an administrative export
file (*.cex)

Browse to a .cex file containing the settings to use for the
vault, for example vault settings you have exported from
another vault.

If you import a .cex file to use for a Standard vault,
features specific to Standard get imported. Any feature
that contains elements that are not supported by
Standard will not be imported.

• Use a predefined configuration

Select one:

Empty

Creates a data folder with no files, which makes it easier
to import or create data cards, workflows, and so on.

Default

Installs the data set installed with previous versions of
SOLIDWORKS PDM.

Quick Start

Installs a simple data set, including predefined groups and
permissions, which enable companies installing
SOLIDWORKS PDM for the first time to quickly use the
software in a production environment.

Configure vault
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ActionScreen

Your choice on the Configure vault screen determines what
is displayed on this screen.

Select configuration
details

• If you chose to use a configuration based on an
administrative export file, this screen does not display.

• If you chose Empty, no data options are installed to the
vault to make it easier to import custom .cex files you have
created.

• If you chose SOLIDWORKS Quick Start, the following
options, designed for an entry-level SOLIDWORKS
implementation, are installed:

Bills of Materials
• Standard Bill of Materials
• Weldment Bill of Materials
• Weldment Cut List

Cards
• Default Folder Card
• SOLIDWORKS

Single card used for all SOLIDWORKS files.

Search Support

Displayed to users when they search the vault

• Complete File Search
• Quick Start Search

• If you chose the Default option, the following options are
available. Click an option name to display a description.

Add-ins (SOLIDWORKS PDM Professional)
• Dispatch

The SWTaskAddin is added to the vault if you select
Convert and Print under Task Execution.

Bills of Materials
• Standard Bill of Materials
• Weldment Bill of Materials
• Weldment Cut List
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ActionScreen

Cards

File and folder data cards for SOLIDWORKS PDM Professional:

• Adobe Acrobat
• AutoCAD
• Autodesk Inventor
• Bitmap Images
• CAL
• Default Folder Card
• Microsoft Office
• MP3
• Pro/ENGINEER

Pro/ENGINEER requires a separate Pro/ENGINEER
Connector installation.

• SolidEdge
• SOLIDWORKS
• Text Files
• XML

File and folder data cards for SOLIDWORKS PDM Standard:

• AutoCAD
• Default Folder Card
• Microsoft Office
• SOLIDWORKS
• Text Files

Items (SOLIDWORKS PDM Professional)
• Support items

Support of items includes the item search cards.

Search Support

Displayed to users when they search the vault

• Complete File Search

Only the items that are supported for Standard are
available.

• User Search
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ActionScreen

Task Execution (Server-side Add-ins) (SOLIDWORKS
PDM Professional)

Tasks available with the SWTaskAddin.dll

• Convert
• Design Checker
• Print

Review the vault parameters, then click Finish.Review Information

Click CloseCompleted

Configuring the SolidNetWork License Server for the File
Vault

You can configure the server for the file vault after you install the SolidNetWork License
Manager and activate the license on the server.

You need to configure the license server only once since all SOLIDWORKS PDM vaults
on the SQL server use the same SNL server.

1. Open the Administration tool by doing one of the following:

• On Windows 7 and Windows Server systems prior to Windows Server 2012, click
Start > All Programs > SOLIDWORKS PDM > Administration.

• On Windows 8.1 and Windows Server 2012 or later, on the Apps screen, under
SOLIDWORKS PDM, click Administration.

2. Create a file vault or expand the existing file vault.
3. Right-click the License node and select Open.
4. On the Server List tab, click Add.
5. Enter the SolidNetWork License Manager's address in the form: port@SNLServerName.

The default port number is 25734. You can enter either the host name or IP address
of SolidNetWork License server for SNLServerName. All clients must be able to
connect to the server by IP address or host name.

6. Click OK.
7. Click the License Usage tab to ensure that SOLIDWORKS PDM licenses are available.
8. Click OK.
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Creating a File Vault View Using the View Setup Wizard
Users managing files must connect to a file vault through a local file vault view (working
folder) created on each client.

To set up the file vault view, the SOLIDWORKS PDM client must be installed.

You also can create a local file vault view using the SOLIDWORKS PDM Administration
tool. See the section on creating a local file vault view in the SOLIDWORKS PDM
Administration Guide.

To create the file vault view using the View Setup wizard:

1. Run View Setup by doing one of the following:

• On Windows 7 and Windows Server systems prior to Windows Server 2012, click
Start > All Programs > SOLIDWORKS PDM > View Setup.

• On Windows 8.1 and Windows Server 2012 or later, on the Apps screen, under
SOLIDWORKS PDM, click View Setup.

2. Create the file vault view using the following instructions:

ActionScreen

Click Next.Welcome

The available archive servers on the network are listed.

1. If the archive server you want to attach to is listed, select it.
2. If the archive server you want is not shown:

a. Click Add.
b. In the Add Server manually dialog box, type the system
name and click OK.

A login dialog box is displayed if your account does not have
sufficient access rights. Log in with a user account with
attach access to file vaults on the archive server.

c. Select the new archive server.

3. To connect to other archive servers with file vaults, select
them.

4. Click Next.

Select archive
server(s)

All file vaults on the selected archive servers are listed.

1. Select the vaults for which you want to create a local file vault
view.

2. Click Next.

Select vault(s)
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ActionScreen

1. Choose where the file vault view will be created.

You can place the view in any location; however, for a shared
view that is accessible to all profiles on the system, create it
in the root of the local hard drive to make it easily accessible.

2. Select the type of view to create:

The local view is only accessible to the Windows
profile that is currently logged on the system.
Use this option when multiple users are using
the same system. Place the local file vault view
in a user folder that is accessible to the currently
logged-in profile.

For details, see Using SOLIDWORKS PDM on a
Terminal Server.

Only for
me

The local view is accessible to all Windows
profiles on this system (preferred). The user
currently logged in must have local
administrator rights to use this option because
it requires updating the local system registry.

For details, see Using a Shared File Vault View
with Multiple User Profiles.

For all
users on
this
computer

3. Click Next.

Select location

Click Finish.Review actions

Click Closed.Completed

Enabling Broadcast with Windows Firewalls
If you are running SOLIDWORKS PDM on a workstation where the Windows firewall is
activated, you must enable broadcast to list archive servers when users create file vault
views using View Setup.

This is because SOLIDWORKS PDM uses a broadcast method to get a list of all available
archive servers on the network. This broadcast is sent to the default port 3030 on the
server system from a dynamic port on the client. By default, Windows firewall only allows
a three-second time period to return the broadcast result from the server to the dynamic
client port. After that, the broadcast reply is stopped by the firewall.

For the archive server broadcast to work correctly on a client with Windows firewall active,
you must allow the applications that request the broadcast through the firewall. For
SOLIDWORKS PDM, these are the View Setup wizard (ViewSetup.exe) and the
SOLIDWORKS PDM administration tool (ConisioAdmin.exe).

This Microsoft Knowledge Base article describes this issue in detail:
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http://support.microsoft.com/?kbid=885345

Enabling Broadcast on Windows 7
If you are running SOLIDWORKS PDM on Windows 7 to enable broadcast, you add the
applications to the list of allowed programs.

1. From the Windows Start menu, click Control Panel.
2. On the Adjust your computer’s settings page, click Windows Firewall.
3. In the left pane, click Allow a program or feature through Windows Firewall.
4. On the Allow programs to communicate through Windows Firewall screen, under the

list of allowed programs, click Allow another program.
5. In the Add a Program dialog box, click Browse to locate ViewSetup.exe (found by

default in \Program Files\SOLIDWORKS PDM\) and then click Open.
If the product is installed via SLDIM, browse to locate ViewSetup.exe at Program
Files\SOLIDWORKS Corp\SOLIDWORKS PDM.

6. Click Add.
The dialog box closes and the program is added to the list of allowed programs and
features.

7. Repeat steps 4 through 6 to add ConisioAdmin.exe, which displays list as
Administration.

8. Click OK to close the Allow programs to communicate through Windows Firewall
screen.

9. Close the Control Panel.

Using a Shared File Vault Viewwith Multiple User Profiles
A shared file vault view is created by a user with local administrative Windows permissions.
The local administrator group is, by default, given full file permissions to any files created
(or cached) in that view.

On many systems, the local user or power user groups have only limited file permissions
to folders in Windows. If a user with local administrative permissions caches a file in the
shared vault view, other Windows user profiles with only user or power user access
permissions might not have sufficient permissions to fully access the file or change the
read-only state when checking out the file.

If you plan to use a shared file vault view with Windows user or power user profiles, you
should define folder access permissions for those groups.

Changing Access Permissions on a Shared ViewUsing the Properties
Dialog Box

1. Log into the system as a user with local administrative permissions.
2. In Windows Explorer, navigate to the file vault view folder and select it.
3. Right-click the file vault view folder and select Properties.
4. In the file vault view’s Properties dialog box, click the Security tab.
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5. Under Group or user names, select the Windows profile groups to use the shared
file vault view and make sure that they have all access permissions checked (i.e.,
Full Control).

6. Click OK.

Changing Access Permissions on a Shared View Using the Command
Prompt

1. Log into the system as a user with local administrative permissions.
2. Open a command prompt and open the parent folder containing the file vault view

(usually C:\).
3. Use the cacls command to assign sufficient access control to the user and power

user groups.

CACLS “vault_view_name” /E /G “group_or_username”:F

For example, to grant a local users group sufficient access control, type:

CACLS “c:\EPDM File Vault” /E /G “users”:F

Read more about the cacls command at:
http://support.microsoft.com/kb/162786/EN-US/

Using SOLIDWORKS PDM on a Terminal Server

The following recommendation applies to installing SOLIDWORKS PDM clients in a Terminal
Server environment:

• The client software is installed once on the terminal server because all terminal profiles
use the same core system and program files. You cannot combine different client license
types on the same terminal system; the same license type is used by all terminal client
profiles.

• When creating local file vault views for terminal clients, you must be logged in as the
Windows profile that should have access to the view. Make the views private by selecting
the Only for me or For all users on this computer (requires local administrator
rights) option.

To make it easier to administer views to multiple terminal client profiles, use the
SOLIDWORKS PDM policy or create an administrative view setup file.

Only the Windows profile for which the view was created can log in to the file vault
view because the view information is stored in the current user section of the registry,
which is only available to the current profile.

• To have the private views rooted to the same location for all profiles, place them in
the terminal user’s home folder. For example, use the environment variables
%HOMEDRIVE%%HOMEPATH%. These have the same path for most users.

• You should not create a shared view accessible by everyone on the terminal server in
a terminal environment. If using a shared view, all terminal users will work in the same
local cache, meaning they may overwrite each others file changes.
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Creating a File Vault View Setup File
If you create a view setup file (.cvs), you can attach clients to a file vault by running the
.cvs file, without having to use the View Setup wizard.

The .cvs file can also be launched silently using triggers, as described in Scripting File
Vault View Setup.

You can create a .cvs file from any existing SOLIDWORKS PDM client.

To create the .cvs file:

1. Launch View Setup using the trigger /a.
For example, from the Windows Startmenu, click Run and then enter this command:

“C:\Program Files\SOLIDWORKS PDM\ViewSetup.exe” /a

2. Step through the View Setup wizard as if creating local views.
See Creating a File Vault View Using the View Setup Wizard. You can select any
number of views.

On the Review Actions screen, the available action is Save to file.

3. Click Finish and specify a location and filename for the view setup file.
4. Click Close.

Using a File Vault View Setup File
You can attach clients to a file vault by running the .cvs file, without having to use the
View Setup wizard.

The .cvs file can also be launched silently using triggers, as described in Scripting File
Vault View Setup.

To use the View Setup file:

1. Copy the .cvs file to a client that you want to attach to the file vault.
2. Double-click the .cvs file.

The View Setup wizard opens to the Finish screen, which lists the vaults for which
local views will be created.

3. Click Finish.

Scripting File Vault View Setup
The View Setup wizard can be launched using the ViewSetup.exe command with the
following triggers to automate view installations. This can be useful when you want to
distribute the file vault view using login scripts or a similar distribution method.

ActionOption or Argument

Creates a view setup file./a
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ActionOption or Argument

Opens the view setup file and lets you attach using the
information from the file.

The complete path to the .cvs file must be used.

path_to_.cvs_file

Performs attach silently without showing wizard. Will only
work in combination with /s switch or a .cvs file.

/q

Find the Vault ID by selecting the properties of the vault
in the SOLIDWORKS PDM administration tool.

If you have more than one archive server hosting the
vault, see Distributing File Vault Views in a WAN
Environment.

/s {VaultID}

Examples
• Create a vault view silently from the .cvs file:

ViewSetup.exe PDMWEVault.cvs /q

• Create a .cvs file with the two file vaults supplied by ID:

ViewSetup.exe /s
{A8E07E93-F594-42c9-A01B-F613DBA53CB5}{699C4EC3-60FC-452f-940E-8786A7AAF1B2}
/a

Distributing the File Vault View Using Microsoft Windows
Active Directory

By using the SOLIDWORKS PDM user policy for Microsoft Windows Active Directory, you
can centrally deploy file vault views on client workstations.

Before you configure Active Directory, find the unique vault ID of the vault view you want
to distribute, as described in Finding the SOLIDWORKS PDM Vault ID.

Most policy dialog boxes have an Explain tab with descriptive text about the policy.

To distribute a vault view using Windows Server Active Directory:

1. Open the Control Panel and click System and Security > Administrative Tools
> Active Directory Users and Computers.

2. Create a security group (or use an existing group).
3. Right-click the security group and select Properties.
4. In the security group’s Properties dialog box, on the Members tab, add the users to

which the SOLIDWORKS PDM file vault view should be deployed.
5. Right-click the top domain container (or any top organizational unit (OU) containing

the target users) and select Properties.
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6. In the domain Properties dialog box, on the Group Policy tab, click New to create a
new policy object.

7. Select the new object and click Properties.
8. In the object’s Properties dialog box, on the Security tab:

a) Add the group containing the users to the list and select it.
b) Under Permissions, in the Allow column, select Apply Group Policy to assign
the policy to the group.

If you do not want the policy to be set on other domain groups, make sure that
the permission is turned off on the other groups.

c) Click OK.

9. In the domain Properties dialog box, select the new object again and click Edit.
10. In the Group Policy Object Editor:

a) Browse to User Configuration > Administrative Templates.
b) Right-click and select Add/Remove Templates.

11. In the Policy Templates dialog box, on the SOLIDWORKS DVD, navigate to \
SWPDMClient\Support\Policies. Select PDMWorks Enterprise.ADM and click Open.

12. When the policy is loaded, click Close.
A new SOLIDWORKS PDM Settings option appears under Administrative
Templates > Classic Administrative Templates (ADM).

13. Browse to the View Setup folder and double-click Automatic View Setup.
14. In the Automatic View Setup Properties dialog box:

a) Select Enabled.
b) Click Show to show the views to install.
c) In the Show Contents dialog box, click Add to add the file vault view.
d) In the Add Item dialog box, assign a name for the view to be distributed (preferably
the same name as the file vault).

e) Add the Vault ID to the item value field.
f) Click OK three times.

If you have more than one archive server hosting the vault, see Distributing File
Vault Views in a WAN Environment.

15. For the new view to be announced when the user logs in, SOLIDWORKS PDM must
be started. To automate this, browse to the Login Manager folder and enable the
Start SOLIDWORKS PDM Login manager at Windows login policy.

16. Close the Policy Editor.

Finding the SOLIDWORKS PDM Vault ID

1. On a client computer, open the Administration tool by doing one of the following:
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• On Windows 7 and Windows Server systems prior to Windows Server 2012, from
the Windows Start menu, click All Programs > SOLIDWORKS PDM >
Administration

• On Windows 8.1 and Windows Server 2012 or later, on the Apps screen, under
SOLIDWORKS PDM, click Administration.

2. Right-click the vault view and click Properties.
3. In the File Vault Properties dialog box, you can copy the vault ID and paste it into a

file.

You can also find the vault ID in the vault database SystemInfo table.

Receiving a Distributed File Vault View
When you distribute a file vault view, users receive automatic notifications.

• When users in the distributed group next log in, the following balloon tip informs them
that a new vault view is available:

Your system administrator has assigned new vaults for you to attach.
Click here to attach them.

Clicking the message box displays the Select Location screen of the View Setup wizard
to let the user select where the view should be placed.

If the user does not click the message box before it disappears, clicking the
SOLIDWORKS PDM icon in the system tray shows an Attach option where the
distributed views are available.

• If the automatic view setup policy had the option Setup Views Silent selected, users
see the following message:

Your system administrator has attached you to new vaults.
Click here to browse.

Clicking the message box opens the vault view in Windows Explorer.

For the silent view setup policy to work, the domain user profiles that use the policy
must be part of the Attach access (or administrative access) list in the security section
of the Archive Server Configuration tool. Otherwise, the view must be manually created
using the Attach option.

Distributing File Vault Views in a WAN Environment
By default, an archive server announces itself over the network to clients using a broadcast
interface (over port 3030). When creating views, this lets the View Setup wizard or
Administration tool list the archive server automatically.

When a script or Active Directory policy distributes a file vault view, the client uses the
first archive server that is announced to it. In some situations such as a replicated
environment with multiple servers, this may not be the correct server.

If you have problems using scripted views or policies over WAN or restricted networks,
add the appropriate server manually using the SOLIDWORKS PDM Settings policy.
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Manually Configuring the Archive Server That Is
Announced to SOLIDWORKS PDM Clients

1. Open the Administration tool by doing one of the following:

• On Windows 7 and Windows Server systems prior to Windows Server 2012, click
Start > All Programs > SOLIDWORKS PDM > Administration.

• On Windows 8.1 and Windows Server 2012 or later, on the Apps screen, under
SOLIDWORKS PDM, click Administration.

2. Under Local Settings, click Group Policies.
3. In the Group Policy dialog box, click User Configuration > Administrative

Templates > SOLIDWORKS PDM Settings.
4. Disable the normal broadcast for the SOLIDWORKS PDM policy:

a) In the right pane, double-click Disable broadcast.
b) In the Disable Broadcast Properties dialog box, select Disabled, and click OK.

5. Add the archive server that clients should connect to:
a) Click View Setup.
b) Double-click Configure Select Server Page.
c) In the Configure Select Server Page Properties dialog box, select Enabled.
d) Click Show to show the default servers.
e) In the Show Contents dialog box, click Add to add the server.
f) In the Add Item dialog box, type the archive server name and port, normally 3030.
g) Click OK to close each dialog box.

When file vault views are distributed, clients are forced to use the specified archive server.

Specifying SOLIDWORKS PDM Settings Group Policy
Manually
You can use Windows Active Directory policy options to distribute the SOLIDWORKS PDM
settings. If you are not using Active Directory to distribute group policies, you can add
the SOLIDWORKS PDM Settings policy manually on a client as a local group policy.

For details about using Active Directory to distribute SOLIDWORKS PDM settings, see
Distributing the File Vault View Using Microsoft Windows Active Directory.

To add the policy manually:

1. Open the Administration tool by doing one of the following:

• On Windows 7 and Windows Server systems prior to Windows Server 2012, click
Start > All Programs > SOLIDWORKS PDM > Administration.

• On Windows 8.1 and Windows Server 2012 or later, on the Apps screen, under
SOLIDWORKS PDM, click Administration.

2. Select Local settings.
3. Right-click Group policies and click Open.
4. In the Group Policy dialog box, select User Configuration.
5. Right-click Administrative Templates and select Add/Remove Templates.
6. In the Add/Remove Templates dialog box, click Add.
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7. In the Policy Templates dialog box, browse to the PDMWorks Enterprise.ADM policy
template on the SOLIDWORKS DVD under \SWPDMClient\Support\Policies and
click Open.

8. Click Close.

The SOLIDWORKS PDM Settings policy options appear under Administrative
Templates > Classic Administrative Templates (ADM).

SOLIDWORKS PDM Settings Policy Options

DescriptionPolicy

Settings

Defines the port used for broadcast, by default, port 3030.
This port must match the archive server port. You should not
have to change it.

Configure Broadcast Port

Prevents users from using broadcast to find archive servers
on the local subnet. Only manually added servers will be used.
Use this policy to make sure that a specific archive server is
used.

For details, see Distributing the File Vault View Using Microsoft
Windows Active Directory.

Disable Broadcast

Normally, broadcast updates (refreshes) the Explorer file view
when another SOLIDWORKS PDM client modifies something
in the view (for example, by renaming or checking out a file).

Use this option to prevent views from being updated
automatically. Users must press F5 to manually refresh the
folder listing in a view.

Disable Automatic View
Refresh

Login Manager Settings

If a file vault is replicated, enabling this policy creates a list
in the login dialog box of archive servers hosting the replicated
vault that the user can connect to.

Use this policy if working on a laptop and working in both
locations hosting a replicated vault. Only the servers that are
broadcasted are listed. You might have to include the server
in the Add alternative servers policy.

Enable Alternative Servers

Set this policy when you distribute views with the Automatic
View Setup policy. It starts the SOLIDWORKS PDM login
manager at login so that views can be added.

Start SOLIDWORKS PDM
Login Manager at
Windows Login
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DescriptionPolicy

The alternative servers list contains available broadcasted
servers hosting the replicated vault. If the broadcast does
not list the server, you might have to add it manually using
this policy. Add the server name as the Value Name, and
server port as the Value.

Add Alternative Servers

DescriptionPolicy

View Setup settings

Prevents the user from manually adding servers to the list
of vault sources in the View Setup wizard. Use this policy in
combination with Disable Broadcast and Select Server
page to restrict clients to a specified set of servers.

Disable Add Server

Controls the Select Location screen of the View Setup wizard.
It should be defined when adding views silently.

Sets the default file vault attach location. This
can be used in terminal services environments
to force file vault views to be created in a specific
directory (commonly the user's home drive).

Location

Sets the default file vault attach type. A restricted
Windows user does not typically have the right
to add file vault views per computer.

Type

Select Attach Page

Controls the Select Archive Server screen of the View Setup
wizard. Adds default archive server names to the list of
servers to choose from in the wizard. Type the name of the
archive server and the port (3030) as value.

Use this in combination with Disable Broadcast and Disable
Add Server to force clients to use a specified set of servers.
You should also use this policy when broadcast prevents
archive servers from being listed in the View Setup wizard
(for example, over a WAN).

Select Server Page

Use this policy to distribute file vault views to client
computers. Add the vault name and vault ID for the views
that should be announced.

When using Setup views silent, the views are added without
any user interaction. When you use this option, to make sure
that the view is created in the correct location, you should
also define the Select Attach Page policy. If the client
computers reside in different subnets and cannot receive
broadcast, you must define the Select Server Page policy.

Automatic View Setup

125

Creating and Distributing File Vault Views



DescriptionPolicy

Explorer settings

Defines the size and color depth of thumbnails that are
created on the archive server.

Configure Thumbnails

Lets you can add other extensions that should behave like
drawings in the BOM view. By default, SLDDRW and IDW files
are counted as drawings.

When you clear the Bill Of Material view option Include
selected, drawing files are normally not considered the
top-node; therefore both drawing and assembly are excluded.

Drawing Extensions

Removes the Copy Tree item from the shortcut menu for
the root of the vault.

Remove Copy Tree From
Root

Configure thread options used when retrieving files to the
client. Use a value between 1 and 20. The default is 5.

Configure Get File

SQL

Configures when to use bulk operations when communicating
with the SQL server.

When not doing bulk operations, the statement is built up by
text and concatenated to the execute statement if possible.

For use only when directed by SOLIDWORKS support.

Configure bulk operations
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8
Upgrading a Vault from Standard to
Professional

Once upgraded, you cannot downgrade a Professional vault to a Standard vault. The procedure
cannot be undone without a backup.

To upgrade a vault from Standard to Professional:

1. Back up the file vault database for the SOLIDWORKS PDM Standard vault.
For details, see Backing Up the File Vault Database on page 140.

2. Upgrade the license from Standard to Professional.
For details, see Upgrading the SolidNetWork License from Standard to Professional
on page 128.

3. Upgrade the vault.
4. Upgrade SQL Server 2014 Express to SQL Standard 2014.

For details, see Upgrading SQL Server Express 2014 to SQL Server 2014 on page
51.

5. Upgrade SOLIDWORKS PDM Standard Client/Server to Professional Client/Server.
For details, see Upgrading the SOLIDWORKS PDM Standard Client/Server to
Professional on page 93.

This chapter includes the following topics:

• Upgrading the SolidNetWork License from Standard to Professional
• Activating the Professional License
• Upgrading the Standard Vault
• Upgrading the SOLIDWORKS PDM Standard Client/Server to Professional
• After Upgrading the File Vault
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Upgrading the SolidNetWork License from Standard to
Professional

Before you upgrade a vault, you must upgrade the SolidNetWork License from Standard
to Professional.

To upgrade the SolidNetWork License from Standard to Professional:

1. In Windows, open Control Panel > Programs > Programs and Features.
2. On the current license server, right-click SOLIDWORKS SolidNetWork License

Manager, click Change > Next .
3. On the Program Maintenance screen, select Modify.
4. On the License Information screen, type the serial number for Professional and click

Next.
5. Click Install.

Activating the Professional License
You must activate the license to log in to the Professional vault.

To activate the Professional license:

1. Start the SolidNetWork License Manager by doing one of the following:

• On Windows 7 and Windows Server systems prior to Windows Server 2012, click
Start > All Programs > SOLIDWORKS version > SOLIDWORKS Tools >
SolidNetWork License Manager Server version.

• On Windows 8.1 and Windows Server 2012 or later, on the Apps screen, under
SOLIDWORKS Tools, click SolidNetWork License Manager Serverversion.

2. When prompted to activate, click Yes.
If you have an activated SolidNetWork License, click Modify.

3. On the SolidNetWork License Server Information screen:

• If your company uses a firewall, select A firewall is in use on this server.

For more information, see Using SolidNetWork License Server with Firewalls.
• Use the default value for Port Number (and for Vendor Daemon Port Number
if you have a firewall) or specify the port numbers your company uses.

The port number is a TCP/IP port number in the 1024-60000 range, used
exclusively by this process. Normally, the default (25734) is suitable and is
unlikely to be the same as any other FLEXnet server process currently on the
license manager server.

4. On the Activate Your SOLIDWORKS Product screen:

• Select the Internet or email procedure.
• Supply email contact information.
• Click Next to proceed.

128

Upgrading a Vault from Standard to Professional



• Internet: Activation occurs automatically.
• Email: Press Save to create a request file, then send the file to
activation@solidworks.com. When you receive the email containing the response
file, extract the file from email and then click Open to load it.

If necessary, you can exit and rerun the activation procedure to open the
response file.

5. Click Finish.

Upgrading the Standard Vault
To upgrade a Standard vault to a Professional vault, you must have the Professional
license activated on the license server.

To upgrade a vault from Standard to Professional:

1. Log in to the SOLIDWORKS PDM Administration tool with File vault management
permission.

You must log in to the computer with an account that has Administrative access
on the Archive server. If you are not, you will be prompted to enter credentials for
a user with Administrative access to the server.

2. Right-click the vault and select Upgrade to Professional Vault.
3. On Upgrade to Professional Vault screen, click Next.
4. Select the check box and click Next.
5. Select the license server that has activated Professional license.
6. Click Finish.

Upgrading the SOLIDWORKS PDM Standard Client/Server
to Professional

If you have installed the Standard client/server via InstallShield Wizard, perform the
following steps.

To upgrade:

1. In Windows, open Control Panel > Programs and Features.
2. Right-click SOLIDWORKS PDM Client or SOLIDWORKS PDM Server and select

Change.
If you have installed the client via SLDIM, modify the SOLIDWORKS installation to
upgrade the client install.

3. On the Welcome screen, click Next.
4. On the Program Maintenance screen, click Modify.
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5. On Select PDM Product screen, select SOLIDWORKS PDM Professional.
6. Continue with the installation of SOLIDWORKS PDM Professional.

If you have installed the Standard client/server via SLDIM, modify SOLIDWORKS
2016 listed under Programs and Features for an upgrade.

After Upgrading the File Vault
After upgrading the file vault, complete the post-processing configuration steps.

After upgrading to the Professional vault:

• The Administration tool displays the Professional specific features.
• Administrators must configure the Professional vault explicitly.
• Administrative Permissions and Folder Permissions (specific to Professional) are
assigned to the built in admin user. The admin user must assign these permissions to
users and groups.
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9
Configuring Content Search (For
SOLIDWORKS PDM Professional
only)

When you index a file vault archive, the search tool can use the content search option to search
a document’s contents or properties.

For example, you can search for all documents containing the word “product” or you can search
for all Microsoft Office documents written by a specific author.

This chapter includes the following topics:

• Content Search Overview
• Recommended Computer Configuration
• Using Windows Search for Content Search
• Installing Windows Search Service
• Setting Up Windows Search
• Indexing the Archives for Windows Search
• Using Microsoft Indexing Service for Content Search
• Adding Index Server Filters
• Managing File Vault Index Catalogs
• Removing a File Vault Index

Content Search Overview
SOLIDWORKS PDM Professional content search uses the Microsoft Indexing Service or
Windows Search Service to create a catalog for each indexed file vault. The catalog
contains index information and stored properties for all versions of all documents in the
file vault archive folders.

Administrators can choose an indexing method, Indexing Service, or Windows Search.
Administrators of upgraded systems can still use the Indexing Service, while administrators
of new systems that have not been previously indexed should use Windows Search.

Microsoft does not support the Indexing Service for Windows 8 or Windows Server
2012 operating systems.

The Indexing Server periodically scans the file vault archive folders and extracts the
content using filter components. Microsoft Indexing Service supplies filters for Microsoft
Office files, HTML files, MIME messages, and plain-text files. You can install other document
filters for content search in, for example, PDF files.
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The indexing process creates a catalog with a master index that stores words and their
locations within a set of indexed documents. SOLIDWORKS PDM Professional content
search queries the catalogs for word combinations using the master index as well as word
lists and shadow indexes to execute content searches.

Recommended Computer Configuration
The minimum hardware configuration for the index server is the same as for the
SOLIDWORKS PDM Professional database server. However, the performance of the indexing
and search tool depends on the number and size of documents to be indexed and the
resources available to the indexing service.

If the number of documents (and versions) in the file vault is very large, insufficient
memory on the index server will seriously affect performance.

The total size of the documents to be indexed affects the disk space required for storing
index server data. The space required for the catalog is about 15% of the amount of
documents indexed.

Using Windows Search for Content Search
SOLIDWORKS PDM can use the Windows Search service to perform content searches.

Because Microsoft does not support the Indexing Service for Windows 8 or newer or
Windows Server 2012 operating systems, SOLIDWORKS PDM uses the Windows Search
service to support content search on these operating systems.

To use the Windows Search for Content Search:

• The administrator must configure the Windows Search service and index a file vault
archive folder.

• The file vault archive folder that is being indexed must be:

• On the same machine as the configured Windows Search service.

Windows Search does not support indexing remote network shares or mapped
network drives. The archive folders must be accessible on locally attached storage
or SAN storage.

• Accessible to the Windows Search service to build a system index.

• If the archive server is on a different machine than the SQL server:

• The administrator must share the file vault archive folder.
• The logged in user running the SQL server service must have full permission to the
shared folder.

• The Windows Search service must be installed on the SQL server machine as well
as the Archive server hosting the vault archives.

When the Windows Search service builds the system index, the administrator can set up
SOLIDWORKS PDM to use the system index.
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Installing Windows Search Service
Install the Windows Search Service on the Archive Server system. If the vault database
is hosted on a separate SQL server system, you must also install Windows Search Service
on that SQL server.

EnablingWindows Search Service onWindows 7,Windows
8.1, or Later

Windows Search Service is on by default on client operating systems. If it is turned off,
you must turn it on.

To enable Windows Search Service on Windows 7, Windows 8.1, or later:

1. In Windows, open Control Panel > Programs > Programs and Features > Turn
Windows features on or off .

2. Select Windows Search.
3. Click OK.

Enabling Windows Search Service on Windows Server
2008 R2

1. In Windows, open Control Panel > System and Security > Administrative Tools
> Server Manager.

2. In the left pane, click Roles.
3. In the right pane, on the Roles page, click Add Roles.
4. On the Before You Begin page of the Add Roles Wizard, click Next.
5. On the Select Server Roles page, turn on File Services, and click Next twice.
6. On the Select Role Services page, turn onWindows Search Service and click Next.
7. Click Install.
8. After Windows Search is installed, click Close to exit the Add Roles Wizard.

Enabling Windows Search Service on Windows Server
2012

1. From the Windows Start screen, type Server Manager, click Server Manager.
2. Select Manage > Add Roles and Features.
3. On the Select Features page, select Windows Search Service and click Next.
4. Click Install.
5. After Windows Search is installed, click Close to exit the Add Roles and Features

Wizard.
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Setting Up Windows Search
Configuring the SOLIDWORKS PDM Professional Content Search to use Windows Search
requires installing the Windows Search Service, adding the archive folder path to the
indexing settings, and indexing the file vault archives.

To set up Windows Search:

1. In the Administration tool, log into the file vault to be indexed as SOLIDWORKS PDM
user with Can update index settings permissions.

2. Right-click Indexing and click Open.
3. In the Indexing Settings dialog box, select Index File Vault Archives.
4. Under Select the File Vault Indexing Method, select Windows Search.
5. Under Archive Locations, double-click the archive path to configure index locations.
6. In the Edit File Vault Archive Folder Path dialog box, type a path to a file vault archive

folder from the SQL server.

• If the Archive server is on a different machine than the SQL server, enter a UNC
path to the archive folder share.

• The archive folders must be accessible on locally attached storage or SAN storage
on the archive server machine.

7. Click OK twice.
For details, see SOLIDWORKS PDM Installation Guide: Installing Windows Search
Service.

Indexing the Archives for Windows Search
For SOLIDWORKS PDM content search to find indexed documents, the archive folders
need to be indexed by the Windows Search Service.

To index the Archives for Windows Search:

1. On the archive server, open Windows Indexing Options by doing one of the
following:

• On Windows 7, click Start, type Indexing Options, and click Indexing Options.
• On Windows 8.1 and Windows Server 2012 or later, on the Start screen, type
Indexing Options and click Indexing Options.

2. In the Indexing Options dialog box, click Modify.
3. In the Indexed Locations dialog box, browse to the folder containing the file vault

archives.
If the Archive Server hosts multiple file vault archives that should be indexed, add
the root folder of all archives in this dialog box.

4. Select the check box next to the archive folder and ensure the individual 0-F subfolders
are also included.

5. Click OK.
6. Make sure the archive folder is listed under the Included Locations column.

The Windows Search indexer starts scanning the archive folders and build an index
of the content found in the files. This process runs in the background and depending
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on archive size can take several hours to complete. Content searches might be
incomplete until the index is fully rebuilt.

Using Microsoft Indexing Service for Content Search
Configuring the SOLIDWORKS PDM Professional content search on the SQL Server requires
verifying the Microsoft Indexing Service installation, monitoring and tuning the indexing
service, and then indexing the SOLIDWORKS PDM Professional file vault archives.

Microsoft Indexing Service is not supported for Windows 8 or later or Windows Server
2012 operating systems. Use Windows Search Service instead.

Verifying Microsoft Indexing Service Installation

By default, the Indexing Service is not installed on a Windows Server 2008-based
computer. For instructions on installing and configuring the Indexing Service on Windows
Server 2008, see http://support.microsoft.com/kb/954822.

1. On the SQL Server hosting the file vault to be indexed, open Control Panel >
Programs > Programs and Features > Turn Windows features on or off.

2. In the Windows Features dialog box, verify that Indexing Service is enabled
(checked). If not, select it to install it.

Monitoring and Tuning the Microsoft Indexing Service

1. In the Start menu, right-click Computer and select Manage.
2. In the Computer Management dialog box, expand Services and Application >

Indexing Service.

Indexing SOLIDWORKS PDM Professional File Vault
Archives
This procedure describes index server setup when the index server and database server
are installed on the SQL Server hosting the file vault databases.

To install the index server on a separate system, see Configuring the Index Service
on a Non-SQL Server System.

Before indexing the file vault archives:

• Make sure that the database server has been installed and configured.
• Obtain the user name and password of a SOLIDWORKS PDM Professional user with
Can update index settings permissions.

• If the index server is located on a system other than the archive server, obtain one of
the following:

• The domain login information of a user with full (read and write) access to the UNC
share to the archive folder.

• The login information of a local Windows user on the index server.
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To set up the index server on the SQL Server system:

1. On a client system, open the Administration tool by doing one of the following:

• On Windows 7 and Windows Server systems prior to Windows Server 2012, click
Start > All Programs > SOLIDWORKS PDM > Administration.

• On Windows 8.1 and Windows Server 2012 or later, on the Apps screen, under
SOLIDWORKS PDM, click Administration.

2. Log into the file vault to be indexed as SOLIDWORKS PDM user with Can update
index settings permissions.

3. In the left pane, under the file vault, right-click Indexing and select Open.
4. If prompted, log into the archive server as a user with administrative access.
5. In the Indexing Settings dialog box, to enable content search in this file vault, select

Index File Vault Archives.
6. Under the Select the File Vault Indexing Method, select Indexing Service.
7. Under Archive Locations, double-click the archive path.
8. In the Edit File Vault Archive Folder Path dialog box, in the second field, specify the

path to the archive as seen from the system running the Indexing Service. You can
use the Browse button to locate the archive folder.
• If the index server (typically, the SQL Server) is located on the same system as
the archive server, copy the path displayed in the first field and paste it into the
second field.

• If the index server is located on a system other than the archive server, provide a
UNC path to the archive folder.

Type one of the following:

• The domain login of a user, such as the domain administrator, with full access
to the UNC share

• The username and password of a local Windows user on the index server

9. Click OK and close the Index Settings dialog box.
A new index service catalog for the file vault, named Conisio_vaultID, is created
on the index server. Any file vault archives containing supported file types are indexed
when the indexing service runs, which may be instantly or somewhat delayed.

10. To verify, right-click My Computer and select Manage.
11. In the Computer Management dialog box, expand Services and Application >

Indexing Service and ensure that the Conisio catalog has been created.

Configuring the Index Service on a Non-SQL Server
System
To set up the indexing service, the SOLIDWORKS PDM database server and Microsoft
SQL Server must be able to communicate with the system used as the index server.

To use a system other than the SQL Server as the index server, perform these steps
before setting up the indexing for a file vault.

After the service accounts and file vault database have been configured, add the indexing
service and index the file vault archives as described in Indexing SOLIDWORKS PDM
Professional File Vault Archives.
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Updating the File Vault Database with the Index Server Name

1. Open Microsoft SQL Server Management Studio and click Connect.
2. In the left pane, expand Databases > file_vault_database > Tables.
3. Right-click the SystemInfo table (dbo.SystemInfo) and select Open Table.
4. In the right pane, update the IndexServer column with the name of the index server

system.

If the server name includes hyphens (-), enclose the name in double quotes (" ").

If you do not update the SystemInfo table with the correct index server name,
the Microsoft Indexing Service on the SQL server is used as the index server.

5. Save your changes and exit Microsoft SQL Server Management Studio.

Changing the Database Server Login Account
If the database and archive services and the index server service are running on separate
systems, they must be able to communicate using a service account other than the system
account.

Before changing the database server login account, obtain the login information of a
Windows user with local administrative rights on the database server and the index server.

The user must have the same name, password, and local account privileges on both
systems.

To change the login account for the database server:

1. From the Windows Start menu, click Control Panel > Administrative Tools >
Services.

2. Right-click SOLIDWORKS PDM Database Server and select Properties.
3. In the SOLIDWORKS PDM Database Server Properties dialog box, on the Log On tab,

under Log on as, select This account.
4. Specify a Windows user account, such as a domain administrator, with local

administrative rights on both the system running the database server and the index
server and click OK.

5. Stop and start the SOLIDWORKS PDM Database Server service.

If the database server cannot communicate with the index server, you will not be
able to create or remove indexing for the file vault archives. The following error
message may be displayed: Access is denied. The SOLIDWORKS PDM Database
Server failed to contact servername.

Changing the SQL Server Login Account
If the SQL Server service and index server service are running on separate systems and
are not part of the same domain, they must be able to communicate using a service
account other than the system account. If they are in the same domain, this procedure
is not necessary.

Before changing the SQL Server login account, obtain the login information of a Windows
user with local administrative rights on the SQL Server and the index server.
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The user must have the same name, password, and local account privileges on both
systems.

To change the login account for the Microsoft SQL Server:

1. From the Windows Start menu, click Control Panel > Administrative Tools >
Services.

2. Scroll down to the SQL Server (MSSQLSERVER), right-click it, and select Properties.
3. In the SQL Server (MSSQLSERVER) Properties dialog box, on the Log On tab, under

Log on as, select This account.
4. Specify a Windows user account such as a domain administrator, with local

administrative rights on both the system running the Microsoft SQL Server and the
index server and click OK.

5. Stop and start the MSSQL Service.

If the SQL server cannot communicate with the index server, running a content
search in SOLIDWORKS PDM fails and results in the following error message:

A communication link failure occurred when accessing the database
server. The database service might have been restarted or the network
might have gone down. Please try the operation again and contact your
system administrator if the problem persists. “vaultname”

Adding Index Server Filters
By default, the Microsoft Indexing Service and Windows Search Service support content
indexing for the following file formats: Microsoft Office files, HTML files, MIME messages,
and plain-text files. By installing third party index filters (iFilters) on the index server,
you can include content search support for many other file formats.

After you install a new index filter on an Index Server that has already indexed the archives
you will have to rebuild the indexes. For details, see Rebuilding the Index Catalog.

Compressed Archives (gzip) Filter
When installing the SOLIDWORKS PDM Server components the GZ iFilter is automatically
registered. This filter allows the index server to catalog archives that have been
compressed using archive server compression (gzip).

Rebuilding the Index Catalog
If the index server has already indexed the archives, you must launch a re-scan of the
entire index catalog to refresh its content.

Rebuilding the index can take several hours to complete. Content searches might be
incomplete until the index is fully rebuilt.
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Rebuilding the Windows Search Service Catalog

1. On the archive server, open Windows Indexing Options by doing one of the
following:

• On Windows 7, click Start, type Indexing Options, and click Indexing Options.
• On Windows 8.1 and Windows Server 2012 or later, on the Start screen, type
Indexing Options and click Indexing Options.

2. In the Indexing Options dialog box, click Advanced.
3. In the Advanced Options dialog box, click the Index Settings tab, and click Rebuild.

Rebuilding the Microsoft Indexing Service Catalog

1. Right-click My Computer and select Manage.
2. In the Computer Management dialog box, expand Services and Applications >

Indexing Service, Conisio_vaultID.
3. Click Directories.
4. In the right pane, right-click the directory and select All Tasks > Rescan (Full).

Managing File Vault Index Catalogs
There are many ways to configure the behavior of the Microsoft indexing service.

For detailed information, about configuring Windows Search and Microsoft Indexing
service, see the Windows Help regarding the index server node and online at
http://support.microsoft.com.

Removing a File Vault Index
When you remove a file vault index, only the index catalog is removed; no physical file
archives are affected by this operation.

Before removing a file vault index, obtain login information for a user with the following
permissions:

• Administrative access to the archive server
• SOLIDWORKS PDM permission to update index settings

To remove an index for a file vault archive:

1. On a client system, open the Administration tool by doing one of the following:

• On Windows 7 and Windows Server systems prior to Windows Server 2012, click
Start > All Programs > SOLIDWORKS PDM > Administration.

• On Windows 8.1 and Windows Server 2012 or later, on the Apps screen, under
SOLIDWORKS PDM, click Administration.

2. Log into the file vault from which you want to remove the index.
3. Right-click Indexing and select Open.
4. If prompted, log into the archive server as a user that has administrative access to

the archive server.
5. Clear Index File Vault Archives and click OK.
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10
Backing Up and Restoring File
Vaults

File vault backups must be part of the daily management of SOLIDWORKS PDM. They are also
required before you upgrade your SOLIDWORKS PDM components.

You can use the SQL Maintenance Wizard in SQL Server Standard to schedule a planned backup
of the file vault databases. The physical file vault archives on all archive servers must be
backed up regularly using scheduled file backup software.

When backing up the vault, the latest updates in files that are still checked out and modified
on client workstations are not included since they are stored in the local file vault view (cache)
of the client. To ensure that the latest information of all files is always included in a backup,
the files should be checked in.

A complete file vault backup must include backing up the file vault database and all physical
file vault archive files. The database backup must be performed at the same time as the archive
file backup to avoid any data loss from mismatched backup sets. Without both the database
and archives it is not possible to recover the vault in case of failure.

This chapter includes the following topics:

• Backing Up the File Vault Database
• Backing Up the SOLIDWORKS PDM Master Database
• Backing Up the Archive Server Settings
• Backing Up the Archive Files
• Scheduling Database Backups
• Restoring a File Vault

Backing Up the File Vault Database
Back up the file vault database hosted on the SQL Server ideally using a professional
backup solution that supports live SQL database backups. You can also perform the backup
using the SQL Management tools that are included with the SQL Server.

1. Open SQL Server Management Studio.
2. Expand the Databases folder.
3. Right-click the database to be backed up, and select Tasks > Back Up.
4. In the Back Up Databases dialog box, under Source:

a) For Backup type, select Full.
b) For Backup component, select Database.

5. Under Destination, click Add.
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6. In the Select Backup Destination dialog box, enter a destination path and filename
for the backed up database and click OK.

7. Click OK to start the backup.
8. When the backup completes, click OK.
9. Repeat the backup procedure for any additional file vault databases.
10. Exit SQL Server Management Studio.

Backing Up the SOLIDWORKS PDM Master Database
In addition to the file vault database(s), the SOLIDWORKS PDM master database called
ConisioMasterDb must be backed up.

To back up this database, follow the same instructions used for backing up the file vault
database. For details, see Backing Up the File Vault Database.

Backing Up the Archive Server Settings
The archive server contains file vault settings such as passwords and defined login types.
It is also the physical location of the SOLIDWORKS PDM vault archive files. Backing up
the archive server settings does not back up the archive files.

After backing up the archive server settings, include the backup file in your normal file
backup.

To backup the archive server settings:

1. On the archive server, open the SOLIDWORKS PDM Archive Server dialog box by
doing one of the following:

• On Windows 7 and Windows Server systems prior to Windows Server 2012, from
the Windows Startmenu, select All Programs > SOLIDWORKS PDM > Archive
Server Configuration.

• On Windows 8.1 and Windows Server 2012 or later, on the Apps screen, under
SOLIDWORKS PDM, click Archive Server Configuration.

2. Select Tools > Backup settings.
3. In the Backup Settings dialog box:

a) Select Include all vaults. (preferred setting)
Alternatively, you can select Include selected vaults and specify the file vaults
for which settings will be backed up.

b) Specify or select the Backup location.
The default location is the archive root folder.

c) To schedule an automatic backup, click Schedule and specify the schedule.
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d) Type and confirm a password for the backup file.

This password is required to restore settings.

e) Do one of the following:

• To perform the backup immediately, click Launch backup. When a message
confirms the backup, click OK.

• To perform the backup at the scheduled time, click OK.

4. Close the SOLIDWORKS PDM Archive Server dialog box.

The backup file is saved in the specified location and called Backup.dat.

Backing Up the Archive Files
The file vault archives contain the physical files that are stored in a file vault. A file added
to the vault is stored in the archive folder specified by the archive server.

1. Locate the archive folder with the same name as the file vault.
This folder is stored under the defined root folder path on the archive server. For
details, see Installing SOLIDWORKS PDM Archive Server.

If you are uncertain where the file vault archives are stored, view the registry key
HKEY_LOCAL_MACHINE\SOFTWARE\SOLIDWORKS\Applications\PDMWorks Enterprise\
ArchiveServer\Vaults\vaultname\ArchiveTable.

2. Use a backup application such as Backup Exec to back up this folder and its contents.

Scheduling Database Backups
You can schedule database backups using a maintenance plan in SQL Server Standard
edition. You must take daily file vault backups in SQL Express because there are no in
built maintenance plans or automated backup options.

To set up a recurring automatic backup of the file vault SQL databases, you can use the
SQL Server Management Studio maintenance plans. A maintenance plan lets you create
complete backups of the databases, which you can include in your normal file backup
routine.

Before scheduling database backups:

• The SSIS (Integration Services) must be installed on the SQL Server. The Integration
Services are normally included as part of the Workstation Components step in the SQL
Server install wizard.

• The SQL Server Agent must be running.

The SQL Server Express edition is a free version of SQL Server and does not include the
SQL Management Tools and SQL agent. For Standard vaults, to set a daily file vault
backups, see Microsoft Knowledge Base article 2019698:
https://support.microsoft.com/en-us/kb/2019698#/en-us/kb/2019698.
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Starting the SQL Server Agent
If the SQL Server Agent is not running, you could see a message that the ‘Agent XPs’
component is turned off as part of the security configuration of your computer.

1. Open the SQL Server Configuration Manager.
2. In the left pane, select SQL Server Services.
3. If the state of SQL Server Agent is Stopped, right-click it and select Start.

Ensure that the Start Mode of the agent is set to Automatic. If it is not, right-click
the agent and select Properties, then configure the Start Mode on the Services
tab.

4. Exit the SQL Server Configuration Manager.

Setting Up a Maintenance Plan for Database Backup (For
SOLIDWORKS PDM Professional only)
The easiest way to set up a backup maintenance plan in SQL Server Standard is using
the SQL Maintenance wizard.

When the backup maintenance plan is run, the file vault databases are backed up and
placed in a folder you specify. Include the backup folder in your normal daily backup
procedure.

To set up a backup maintenance plan:

1. Open Microsoft SQL Server Management Studio and click Connect.
2. In the left pane, under the SQL Server, expand Management.
3. Right-click Maintenance Plans and select Maintenance Plan Wizard.

ActionScreen

Click Next.SQL Server Maintenance Plan
Wizard

1. Enter a name and description for the maintenance
plan.

2. Click Change to set up a schedule.

In the Job Schedule Properties dialog box, specify
a name for the schedule and choose the recurring
times to run the database backups. Set the times
close to the start time of the normal daily file
backups. The backup of a database to a hard drive
usually completes within minutes.

3. Click OK.
4. Click Next.

Select Plan Properties

143

Backing Up and Restoring File Vaults



ActionScreen

1. Select Back Up Database (Full).

If you rely on daily backups, you can select
Back Up Database (Differential) as well. You
should create at least one full backup set each
week.

2. Click Next.

Select Maintenance Tasks

1. Ensure that the backup task is listed.
2. Click Next.

Select Maintenance Task Order

1. Expand the Databases list.
2. Select All user databases.

This selects all SOLIDWORKS PDM databases and
excludes the SQL system databases, which are
not required by SOLIDWORKS PDM.

To select databases individually, select These
databases and make your selections. Be sure
to select the file vault database(s) and the
ConisioMasterDb database.

3. Click OK.
4. Select Backup set will expire and define how
many days the existing backup set files should be
kept.

5. Select Back up to Disk.
6. Select Create a backup file for every database.
7. For Folder, enter a local path on the SQL Server
to an existing folder where the backup files should
be created.

8. Click Next.

Define Back Up Database
(Full) Task

1. For backup task report, select Write a report to
a text file or E-mail report, and specify where
it should be saved or sent.

2. Click Next.

Select Report Options

Click Finish.Complete the Wizard

When all tasks have been completed, click Close.Maintenance Plan Wizard
Progress

4. Exit Microsoft SQL Server Management Studio.
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Restoring a File Vault
Restoring a file vault requires recent backups of the file vault databases, ConisioMasterDb
database, archive server configuration settings, and file vault archive files.

Use SQL Server Express to restore the Standard vault database.

Restoring the SQL Server File Vault Databases

1. Install the SQL Server:
a) Configure the SQL login type to mixed mode.
b) Select to install the management tools.
For details, see Installing and Configuring SQL Server.

2. Apply the latest SQL service pack.
3. Restore the SQL database backup files to a temporary folder on the SQL Server.
4. Open Microsoft SQL Server Management Studio and click Connect.
5. In the left pane, right-click Databases and select Restore Database.
6. In the Restore Database dialog box, in the To database field, enter the name of the

file vault database exactly as it was named when backed up.
7. Under Source for restore, select From device and click the Browse button.
8. In the Specify Backup dialog box, click Add.
9. In the Locate Backup File dialog box, select the database backup file and click OK

twice to return to the Restore Database dialog box.
10. Under Select the backup sets to restore, click Restore for the database to restore.
11. In the left pane, select Options.
12. In the right pane, verify that the paths to the database files are correct.

SQL defaults to the paths used when backing up the database.

13. Click OK to start the restore.
14. Repeat this procedure for additional file vault databases, including the

ConisioMasterDb database.
15. Exit Microsoft SQL Server Management Studio.

Verifying the ConisioMasterDb Restore
After you restore the ConisioMasterDb database, ensure that information in the
VaultName and DatabaseName columns of the FileVaults table is correct. If either
entry is missing, notifications cannot be processed.

1. Open Microsoft SQL Server Management Studio and click Connect.
2. Expand Databases > ConisioMasterDb > Tables > dbo.FileVaults.
3. Click Columns, and verify the VaultName and DatabaseName.
4. Exit Microsoft SQL Server Management Studio.
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Restoring the Archive Server and File Vault Archives
Use this procedure to restore the archive server setting to the previous settings, including
all login settings and user information.

1. On the new archive server, restore the physical vault archives from the backup (folders
0-F) to the same location as before the backup.

2. Install the archive server.
Use the settings you used in the original install. If unsure, use the default options.
Define the root folder path as you defined it originally.

3. Restore the archive server configuration settings backup file Backup.dat to the archive
root folder.

4. Open the SOLIDWORKS PDM Archive Server dialog box by doing one of the following:

• On Windows 7 and Windows Server systems prior to Windows Server 2012, from
the Windows Startmenu, select All Programs > SOLIDWORKS PDM > Archive
Server Configuration.

• On Windows 8.1 and Windows Server 2012 or later, on the Apps screen, under
SOLIDWORKS PDM, click Archive Server Configuration.

5. Select Tools > Backup settings.
6. In the Backup Settings dialog box, click Load Backup.
7. Locate the archive server settings backup file Backup.dat and click Open.
8. In the Enter Password dialog box, type the backup file password.
9. When the settings are restored, click OK.
10. Close the SOLIDWORKS PDM Archive Server dialog box.
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11
Upgrading SOLIDWORKS PDM

You can upgrade from Enterprise PDM 2015 or earlier to SOLIDWORKS PDM Professional using
the SOLIDWORKS PDM installation wizard. The wizard automatically uninstalls any old software
components found and then installs the new software.

You cannot upgrade from Enterprise PDM to SOLIDWORKS PDM Standard.

Follow these instructions when upgrading from a previous PDMWorks Enterprise or SOLIDWORKS
PDM version or service pack. For preliminary System Requirements, see System
Requirements.

SOLIDWORKS PDM allows a service pack mismatch between client and server components
within the same major version.

To find out which version is currently installed, see Determining the Current Version on
page 148.

This chapter includes the following topics:

• About Enterprise PDM Upgrade
• Upgrading the Archive Server
• Upgrading the Database Server
• Installing or Upgrading the SolidNetWork License Manager
• Upgrading File Vaults
• Upgrading Toolbox in SOLIDWORKS PDM

About Enterprise PDM Upgrade

Before Upgrading
Perform these tasks before upgrading SOLIDWORKS PDM.

• Ensure your SOLIDWORKS PDM serial number has valid activated licenses for the new
version.

• Check in all files.
• Back up:
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SQL Server file vault database•
• Complete file vault archive
• Archive server settings

• Make sure that no users are working in the old file vault. On all clients, users should
close all tools started using the file vault, click the SOLIDWORKS PDM icon on the
right side of the task bar, and choose Log Off.

Determining the Current Version
You can find out the current version of Conisio or SOLIDWORKS Enterprise PDM software
and the file vault database.

1. Open Windows Control Panel.
2. Double-click Uninstall a program.
3. On the Uninstall or change a program screen, locate Conisio or SOLIDWORKS

Enterprise PDM.
The Version column shows the currently installed version.

If the Version column is not shown, right-click the column headings and select
Version.

You can also determine the current version by opening the SOLIDWORKS Enterprise
PDM Administration tool and clicking Help > About.

The version numbers correspond to the following installed versions:

Installed Product VersionPublisher Version Number

Conisio 6.26.02

Conisio 6.36.03

Conisio 6.46.04

PDMWorks Enterprise 20066.05

PDMWorks Enterprise 2007 32-bit Edition7.00.0027 through 7.05.0074

PDMWorks Enterprise 2007 64-bit Edition7.07.0032 through 7.09.0042

PDMWorks Enterprise 20088.00

SOLIDWORKS Enterprise PDM 20099.00

SOLIDWORKS Enterprise PDM 201010.00

SOLIDWORKS Enterprise PDM 201111.00

SOLIDWORKS Enterprise PDM 201212.00

SOLIDWORKS Enterprise PDM 201313.00
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Installed Product VersionPublisher Version Number

SOLIDWORKS Enterprise PDM 201414.00

SOLIDWORKS Enterprise PDM 201515.00

SOLIDWORKS PDM 201616.00

Determining Which Updates Have Been Applied

1. Start the Administration tool by doing one of the following:

• On Windows 7 and Windows Server systems prior to Windows Server 2012, from
the Windows Start menu, select All Programs > SOLIDWORKS Enterprise
PDM > Administration.

• On Windows 8.1 and Windows Server 2012 or later, on the Apps screen, under
SOLIDWORKS Enterprise PDM, click Administration.

2. In the left pane, right-click on the file vault name and select Properties.
3. In the File Vault Properties dialog box, check the Installed Updates list.

This list shows the update product, version, and upgrade date.

Upgrading the Archive Server
If both the archive server and database server software are installed on the same system,
you can upgrade and install both components at the same time.

All settings from the previous installation of the archive server are retained.

1. Log in locally or remotely as a user with local administrative rights on the system
where the archive server is installed.

2. Insert the SOLIDWORKS DVD and cancel SOLIDWORKS Installation Manager, if it
starts.

3. Run \SWPDMServer\setup.exe to start the SOLIDWORKS PDM server upgrade.
A warning is displayed stating that older versions of the SOLIDWORKS PDM software
have been found and will be upgraded.

4. Click OK.
5. Follow the install wizard steps by clicking Next at each screen.
6. The Select Product screen defaults to SOLIDWORKS PDM Professional if upgrading

from a previous Enterprise PDM or SOLIDWORKS PDM Professional version.
7. On the Setup Type screen, select Server Installation and click Next.
8. On the Server Installation screen, ensure that the Archive Server is selected and

click Next.
If you want to install SOLIDWORKS PDM client on the machine, you must also select
Client.

9. When the upgrade is complete, click Finish.
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Upgrading the Database Server
If you upgraded the database server while upgrading the archive server, skip to Upgrading
the File Vault Database on page 151.

Before upgrading the database server, obtain the following:

• Login information for a user with local administrative rights
• SQL Server name
• Name and password of an SQL user account with read/write access to all SOLIDWORKS
PDM databases hosted on the SQL Server

If you do not know the name of a user with read and write access, you can use the
SQL sa account that has these permissions. You can also create a login for this
purpose. For details, see Changing the SQL Server Login Account.

To upgrade the database server:

1. Log in locally or remotely to the SQL Server where the vault database is hosted.
2. Insert the SOLIDWORKS DVD and cancel SOLIDWORKS Installation Manager, if it

starts.
3. Run \SWPDMServer\setup.exe to start the SOLIDWORKS PDM server upgrade.

A message states that an older version of the SOLIDWORKS PDM server software has
been found and will be upgraded.

4. Click OK.
5. Follow the install wizard steps by clicking Next at each screen.

ActionScreen

Select Database Server and click Next.

If you want to install SOLIDWORKS PDM client
on the machine, you must also select Client.

Server Installation
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ActionScreen

1. Do one of the following:

• Type the name of the SQL Server to host
the file vault databases the database server
will manage.

• Click Browse to display a list of available
SQL servers and instances on the network.

Select the appropriate name and click OK.

2. In the Login name field, type the name of
an SQL user on the server who has read and
write access (i.e., db_owner permission) to
all SOLIDWORKS PDM databases hosted on
the SQL Server (the file vault databases and
ConisioMasterDb.)

Use the sa login if unsure.
3. In the Password field, type the SQL user’s
password.

4. Click Next.

The login information is verified. If it is incorrect,
a warning is displayed.

SOLIDWORKS PDM Database
Server SQL Login

Click Install.Ready to Install the Program

Click Finish.InstallShield Wizard Completed

Installing or Upgrading the SolidNetWork License Manager
If you upgrade SOLIDWORKS PDM, you need to install or upgrade the SolidNetWork
License Manager.

Upgrade the SolidNetWork License Manager.

For more information, see Upgrading the SolidNetWork License Manager.

Upgrading File Vaults
To upgrade file vaults, you first upgrade the file vault database and then optionally the
file vault archives.

Upgrading the File Vault Database
You can run the SOLIDWORKS PDM Database Upgrade Wizard on the archive or database
server, or from a system running SOLIDWORKS PDM client. However, all installed
SOLIDWORKS PDM software on the system must match the upgrade wizard version. You
cannot run the upgrade wizard on a client or server system that is still using an older
version of the software. The database upgrade process may take some time to finish,
depending on the database size and version.

151

Upgrading SOLIDWORKS PDM



Before upgrading the file vault database:

• Ensure that your SOLIDWORKS PDM serial number has valid licenses for the new
version.

• Make sure that no users are working in the vault.
• Back up the file vault database.

For details, see Backing Up the File Vault Database on page 140.
• Install or upgrade the archive server software.

For details, see Upgrading the Archive Server on page 149.
• Install or upgrade the database server software.

For details, see Upgrading the Database Server on page 150.

Do not uninstall old clients until the database upgrade has been completed.

You can upgrade the file vault from SOLIDWORKS Enterprise PDM 2015 or earlier to
SOLIDWORKS PDM Professional. This tool is used for upgrading major versions or
service packs and not for upgrading vaults from Standard to Professional.

To upgrade the file vault database:

1. Insert the SOLIDWORKS DVD and cancel SOLIDWORKS Installation Manager, if it
starts.

2. Start the upgrade wizard manually from the Upgrade folder on the install DVD by
running SWPDMServer\Upgrade\Upgrade.exe.

3. When a message box warns that the database and file vault upgrade wizard should
only be run by administrators, click Yes.

4. Complete the steps of the SOLIDWORKS PDM Database Update Wizard.

ActionScreen

Verify that you have performed all of the upgrade prerequisites,
and click Next.

Step 1

1. From the server list, select the SQL Server hosting the file
vault database you want to upgrade.

If the server is not listed, you can type the name of the SQL
system.

2. Click Next.
3. In the login dialog box, type the user name and password of
an SQL user with sysadmin permissions, such as sa, and click
Login.

Step 2

Select the file vault database(s) to upgrade and click Next.Step 3

Click Next to begin the upgrade process.

Do not close the upgrade wizard or turn off the SQL Server
until the upgrade is completed.

Step 4
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ActionScreen

When the file vault database upgrade finishes, a log is displayed
with the actions and results of the upgrade.

To keep a copy of the upgrade log, select and copy the results
and paste them to a text file.

Click Finish.

Step 5

5. You should reboot the Microsoft SQL Server after the databases have been upgraded.
If you do not, you may experience performance drops until you reboot the server.

Upgrading File Vault Archives
After you upgrade the file vault database, you can upgrade the file vault archives using
the SOLIDWORKS PDM administration tool, which is only available on client installations.

You must upgrade the file vault archive if you are upgrading a file vault from Enterprise
PDM 2008 or earlier version.

Upgrading archives are not needed if upgrading newer versions.

Upgrading file vault archives consists of these tasks:

• Upgrading or installing an initial SOLIDWORKS PDM client on the computer where you
will upgrade the file vault archives.

You will upgrade other clients after the file vault archives are updated.

• Upgrading the file vault archive using the SOLIDWORKS PDM administration tool on
the initial client computer.

• Upgrading the remaining SOLIDWORKS PDM clients.

The vault archive upgrade process can take several hours to complete depending on the
number of files and size of the archive. During the upgrade, users cannot work in the file
vault.

Upgrading the Initial SOLIDWORKS PDM Client

1. Log in to a client workstation as a user with local administrative rights.
2. Insert the SOLIDWORKS DVD and cancel SOLIDWORKS Installation Manager, if it

starts.
3. Run \SWPDMClient\setup.exe to start the SOLIDWORKS PDM server upgrade.
4. On the SOLIDWORKS PDM installation screen:

If an older version of SOLIDWORKS PDM client is installed, click Upgrade.

At the message that the current client software will be upgraded, click OK.

5. On the Select PDM Product screen, ensure that SOLIDWORKS PDM Professional
is selected.

6. To include the Item Explorer, select Customize.
7. On the Custom Setup screen, under Client, click Item Explorer, and select This

feature will be installed on local hard drive.
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8. Follow the install wizard steps by clicking Next in each screen.
9. Follow the installation wizard as you would if you were installing a new client.

For details, see Installing Clients Using the Installation Wizard.

On the Choose Product Type screen, select the correct product for your client license
type.

Upgrading the File Vault Archives

Upgrading archives are only needed if upgrading from EPDM 2008 or older.

1. Start the Administration tool by doing one of the following:

• On Windows 7 and Windows Server systems prior to Windows Server 2012, from
the Windows Start menu, select All Programs > SOLIDWORKS PDM >
Administration.

• On Windows 8.1 and Windows Server 2012 or later, on the Apps screen, under
SOLIDWORKS PDM, click Administration.

2. If the archive server hosting the upgraded file vault is not shown in the left pane:
a) Select File > Add Server.
b) In the Add Server dialog box, select or type the name of the archive server, specify
the port, and click OK.

c) Log in to the archive server using a Windows user account with administrative
access to the archive server.

3. Expand the archive server in the left pane. File vault archives that require upgrading
are listed under the archive server with a red icon .

• If the icon is not shown, refresh the view by right-clicking the archive server name
and selecting Refresh.

• If the icon is still not shown after refreshing, the file vault archive is up to date
and no upgrade is required.

4. Right-click the archive name and click Upgrade.
If you are prompted to log in, enter a SOLIDWORKS PDM username and password
for a user with file vault management permission (usually Admin).
Two messages are displayed:

• The first warns that the upgrade can take a long time and that no users should be
logged in.

• The second states that a backup of the archive server should exist.

If you have met these prerequisites, click Yes for both.

During the archive upgrade, the Work Monitor window displays a progress bar. Do
not abort the process until the word “Completed!” appears.

If you have multiple file vault archives to upgrade, you can start the upgrade on
those also. They are added to the Work Monitor.

When the upgrade finishes, you can view a log of the upgrade results by clicking
Show Log.
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5. Close the Work Monitor.
6. To verify that the upgrade was successful, log in to the file vault view and try to

retrieve a file.

Upgrading a Replicated File Vault Archive (For SOLIDWORKS PDM
Professional Only)
Upgrading file vault archives replicated on other servers requires additional configuration
processes.

When upgrading archive servers hosting a replicated file vault, file vaults that require
upgrading are listed with a red icon .

If the icon is not shown, refresh the view by right-clicking the archive server name and
selecting Refresh. If the icon is still now shown, no upgrade is required.

If the icon is shown:

• You must upgrade the archive server software on all servers hosting the replicated
vault. The selected archive will still be upgraded and you will have to launch the archive
upgrade for the replicated servers separately once the software is upgraded.

• If the archive server software is upgraded on all replicated archive servers and they
show up in the administration tree, the replicated file vault archive will be upgraded
on all servers simultaneously.

• If the vault is replicated and the replicated archive servers are not listed in the
administration tree, a dialog is shown where you can select to attach to the replicated
server. If you opt not to connect, only the selected archive will be upgraded and you
will have to launch the archive upgrade for the replicated servers separately.

After Upgrading File Vault Databases
SOLIDWORKS Enterprise PDM 2009 SP02 or later includes functionality to create and
manage items. If you install this version and then upgrade a vault database from a
previous installation, the upgraded database will not include the default item cards, item
BOM, or the serial number that is used to generate item numbers.

To work with items in this vault, use the SOLIDWORKS PDM Administration tool to import
the following cards and serial number:

• all(Item Card)_gb.crd
• all(Item Search Property)_gb.crd
• all(Item Search Simple)_gb.crd
• all(Item Search)_gb.crd
• all_Item Setup_languagecode.cex, where languagecode is the code for your
language

Importing Item Cards (For SOLIDWORKS PDM Professional
Professional Only)

1. Start the Administration tool by doing one of the following:
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• On Windows 7 and Windows Server systems prior to Windows Server 2012, from
the Windows Start menu, select All Programs > SOLIDWORKS PDM >
Administration.

• On Windows 8.1 and Windows Server 2012 or later, on the Apps screen, under
SOLIDWORKS PDM, click Administration.

2. Right-click Cards and click Open.
3. In the Card Editor, click File > Import.
4. In the Open dialog box, for Look in, navigate to install_dir\Default Cards.
5. In the card list, select all(item Card)_gb.crd, and click Open.
6. Click File > Save to save the card to the vault.
7. Repeat Steps 3 through 6 to import the rest of the item data cards.

Importing the Serial Number and Item BOM (For SOLIDWORKS PDM
Professional Professional Only)

1. Right-click the upgraded vault and select Import.
2. In the Open dialog box, for Look in, navigate to install_dir\Default Data.
3. In the file list, select all_Item Setup_language.cex, and click Open.
4. In the confirmation message, click OK.

Upgrading the Remaining Clients
When the file vault database and archive have been upgraded and you have verified that
the upgraded vault is accessible, you can upgrade the remaining clients to SOLIDWORKS
PDM.

Use the same procedure as when you upgraded the first client. For details, see Upgrading
the Initial SOLIDWORKS PDM Client.

After Upgrading Clients
After updating SOLIDWORKS PDM clients, complete the post-processing configuration
steps.

After upgrading:

• In the SOLIDWORKS PDM administration tool, ensure that you have valid license.
• Update the dispatch and task add-ins.

When you perform these tasks on one client, they are distributed to other clients
automatically.

Viewing the License Server for the Vault

1. Start the Administration tool by doing one of the following:
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• On Windows 7 and Windows Server systems prior to Windows Server 2012, from
the Windows Start menu, select All Programs > SOLIDWORKS PDM >
Administration.

• On Windows 8.1 and Windows Server 2012 or later, on the Apps screen, under
SOLIDWORKS PDM, click Administration.

2. Browse to the file vault in the left pane and log in as Admin.
3. Under the file vault, double-click License.
4. In the Set License dialog box, ensure a valid license server is displayed.

Updating Dispatch Add-in (For SOLIDWORKS PDM Professional Only)

1. In the SOLIDWORKS PDM administration tool, under the file vault, expand Add-ins.
2. To update the Dispatch add-in:

a) Right-click Dispatch and click Remove.
b) Click Yes to confirm that you want to remove the add-in.
c) Select File > Open and browse to C:\Program Files\SolidWorks Corp\

SOLIDWORKS PDM\Default Data.
d) Change filter to show .caf files.
e) Open Dispatch.caf.
f) Drag and drop Dispatch add-in from the .caf file under the Add-ins node for
the vault.

g) Close the administration vault.

The updated add-ins are distributed automatically to the other clients when they log in.

Upgrading the SOLIDWORKS Task Add-in (For SOLIDWORKS PDM
Professional Only)
To ensure that the latest, updated version of an add-in such as the SOLIDWORKS Task
Add-in is running, you must manually upgrade the add-in.

When you upgrade a file vault to a new service pack or version, existing add-ins are not
automatically updated. This is to prevent updated information in the add-ins from
overwriting your customizations.

For example, you may have customized the tasks controlled by the SOLIDWORKS Task
Add-in. You can continue to use your customized tasks and not upgrade. However, you
will not be able to use new task functionality and may have problems starting tasks and
processing upgraded SOLIDWORKS files.

To allow you to manually upgrade tasks, .cex files containing updates for the
SWTaskAdd-in and the Convert, Design Checker, and Print tasks are copied to the C:\
Program Files\SOLIDWORKS PDM\Default Data\ folder. You import one or more of these
files to update the SWTaskAdd-in and the tasks it supports.
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Determining the Current Versions of SOLIDWORKS PDM and the
SOLIDWORKS Task Add-in
To ensure that you have the latest updates to the SOLIDWORKS Task Add-in, the
SOLIDWORKS PDM Professional version and the SWTaskAddin version should be the
same.

1. To determine the SOLIDWORKS PDM version, in the SOLIDWORKS PDM administration
tool, click Help > About SOLIDWORKS PDM Administration.
The Client version field shows the version as:

YY.SS.BBBB

where:

• YY is the last two digits of the major version. For example, 15 = 2015.
• SS is the service pack. For example, 03 = SP03.
• BBBB is the build number. For example, 903.

2. To determine the version number of the currently installed SWTaskAddin:

a) In the Windows notification area, right-click the SOLIDWORKS PDM icon and
click Task Host Configuration.

b) In the Task Host Configuration dialog box, select the vault for which you want to
verify the SWTaskAddin version.
The Version column displays the version in the following format:

YYYYSSBBBB

where:

• YYYY is the major version.
• SS is the service pack.
• BBBB is the build number.

Performing the SWTaskAddin Upgrade (For SOLIDWORKS PDM
Professional Only)
If the version of SWTaskAddin is earlier than the version of SOLIDWORKS PDM Professional,
you can upgrade SWTaskAddin by importing a .cex file.

1. Start the administration tool by doing one of the following:

• On Windows 7 and Windows Server systems prior to Windows Server 2012, from
the Windows Start menu, select All Programs > SOLIDWORKS PDM >
Administration.

• On Windows 8.1 and Windows Server 2012 or later, on the Apps screen, under
SOLIDWORKS PDM, click Administration.

2. Log in to the vault where you want to upgrade SWTaskAddin as an administrator.
3. Click File > Open.
4. Navigate to C:\Program Files\SOLIDWORKS PDM\Default Data\ and select

Convert_GB.cex.
5. In the dialog box that appears, expand Convert_GB.cex, select SWTaskAddin, and

drag it to the Addins node in the left pane.
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6. In the message box, select Yes to update the existing add-in.

7. In the Windows notification area, right-click the SOLIDWORKS PDM icon and click
Task Host Configuration to verify that SWTaskAddin has been upgraded.

If the client you just upgraded acts as a task host, exit SOLIDWORKS PDM and log
in again before performing the verification.

Upgrading Tasks
After you upgrade the SWTaskAddin, you can import the latest versions of the Convert,
Print, and Design Checker tasks.

This procedure describes how to upgrade the Convert task.

1. In the Administration tool, expand the Tasks node.
2. If any tasks have the default names Convert, Print, or Design Checker, rename

them so that customizations you have made to the tasks are not overwritten.
3. Click File > Open.
4. To upgrade the Convert task, navigate to C:\Program Files\SOLIDWORKS PDM\

Default Data\ and select Convert_GB.cex.
If the product is installed via SLDIM, the default path is C:\Program Files\
SOLIDWORKS Corp\SOLIDWORKS PDM.

5. In the dialog box that appears, under Tasks, select Convert, and drag it to the Tasks
node in the left pane.

6. Make changes to the newly imported task to match the previously used task and
configure any new options as required.
This includes the file paths and name formats, conversions types, which computers
run as a task host, permissions for the task, notifications etc.

7. If the existing task had modifications to the Advanced Scripting options (accessed
from the Output File Details page), make those changes to the new version of the
script.
The Advanced Script is often updated for a new version of SOLIDWORKS PDM to make
use of new features in SOLIDWORKS or to add new features to the task. Therefore
you may need to merge the new scripting with your custom scripting.

Add comments to the script to make it easier to understand and easier to transfer
the customization the next time you update.

Retain the default Convert task for reference and for testing if problems arise with a
customized Convert task. Set permissions so that it can only be seen by the Admin
user.

8. Modify workflow transitions that caused the original task to be executed and select
the updated task as the task to execute.
Save the workflow changes.
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Upgrading Toolbox in SOLIDWORKS PDM
If you have integrated SOLIDWORKS Toolbox with SOLIDWORKS PDM, when you upgrade
the SOLIDWORKS software, Toolbox is upgraded if parts have been added.

Before you run SOLIDWORKS Installation Manager to start the upgrade, you must prepare
the Toolbox folder.

• On the first computer to perform the upgrade, you must check out the Toolbox database
so that the SOLIDWORKS Installation Manager can write to it. Use Get Latest Version
to download the Toolbox parts to the local cache so that the installer can verify whether
parts need to be updated or added.

• To upgrade additional computers, get the latest versions of the Toolbox files from
SOLIDWORKS PDM before running SOLIDWORKS Installation Manager.

To upgrade the first SOLIDWORKS PDM computer:

1. In Windows Explorer, log in to the vault as a user with full permissions (check out,
check in, add, delete).

2. Navigate to the Toolbox folder in the vault.
3. Right-click the Toolbox folder and click Get Latest Version to copy all Toolbox files

and the toolbox database to the local cache.

If your archive server is remote, this may take several minutes.

4. For upgrades, you must check out the Toolbox database file:

• From SOLIDWORKS 2014 or earlier, check out: vault_name\Toolbox_folder_name\
lang\your_language\SWBrowser.mdb.

• From later versions of SOLIDWORKS, check out: vault_name\
Toolbox_folder_name\lang\your_language\swbrowser.sldedb.

5. Run the SOLIDWORKS Installation Manager to upgrade the SOLIDWORKS software
(including SOLIDWORKS Toolbox).

6. On the Summary screen, ensure that the Toolbox Options installation location is
the location in the vault.

If it is not, click Change, select Reference or upgrade an existing Toolbox, and
browse to the Toolbox location in the vault.

7. For upgrades from SOLIDWORKS 2014 or earlier, when the upgrade completes, in
Windows Explorer, browse to the folder noted in step 4 and add the Toolbox database
file swbrowser.sldedb to the vault.
You can add other local files that are created in this folder to the vault.

8. For all upgrades, check in the Toolbox folder to add any new or updated files to the
vault so that other users can work with Toolbox.

9. For upgrades to SOLIDWORKS 2012 or later, navigate to your Toolbox folder in the
vault and ensure that the following are present:

• \Toolbox_folder_name\Updates
• \Toolbox_folder_name\ToolboxStandards.xml
• \Toolbox_folder_name\Browser\ToolboxFiles.index

If they are not, contact your Value Added Reseller.
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To upgrade additional computers, before initiating the SOLIDWORKS PDM upgrade, use
Get Latest Version to download the vault Toolbox folder to the local cache.

SOLIDWORKS Installation Manager will verify that the Toolbox files are up to date when
you run the installation.
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12
Upgrading SOLIDWORKS Files

This chapter includes the following topics:

• Upgrading SOLIDWORKS Files
• Required Upgrade Utility Software
• System Requirements
• Installing the File Version Upgrade Utility
• Preparing to Upgrade
• Selecting Version Settings
• Performing a Trial File Upgrade
• Running the Upgrade Utility
• Creating and Using Work Instruction Files
• Completing an Interrupted Upgrade
• After Upgrading
• Managing Backup Files

Upgrading SOLIDWORKS Files
The SOLIDWORKS PDM File Version Upgrade tool upgrades SOLIDWORKS files from an
earlier version to a later SOLIDWORKS file format.

After you upgrade files, you cannot open them in older SOLIDWORKS versions.

The tool automatically checks out, upgrades, and checks in SOLIDWORKS files that are
stored in the SOLIDWORKS PDM vaults. File references, revision tags, and workflow states
are kept intact.

The only file formats that are upgraded are .sldprt, .slddrw, and .sldasm. Upgrade
SOLIDWORKS template and block files manually.

Several workstations, each running the upgrade tool, can perform concurrent upgrades
to reduce the upgrade time. The first workstation to run the upgrade tool acts as the
master workstation, which creates the upgrade plan. The plan consists of several work
instruction files, one for each workstation participating in the upgrade process. For more
details, see Creating and Using Work Instruction Files.
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The work instruction files contain tree structures that reflect the parent-child relationships
of the SOLIDWORKS files. Both master and slave workstations can run additional work
instruction files after they finish processing the first one. Although parts and subassemblies
can be shared by other assemblies, each file is only upgraded once.

If an assembly references parts that are not at the latest version, you can choose a
version setting that links the assembly with the latest version of the parts it references.
Alternatively, you can choose a version setting that overwrites the existing version of
referenced files with the latest version of the files. See Selecting Version Settings.

Required Upgrade Utility Software
The SOLIDWORKS PDM 2017 file version upgrade tool can be used with SOLIDWORKS
2017, 2016, and 2015.

System Requirements
System requirements depend on the vault database being upgraded. They are affected
by the structure of the database, including the number of files, versions, and references
being converted.

Use powerful workstations. As files are opened and resaved in SOLIDWORKS, it is important
that the workstations used have sufficient resources to handle even the largest assembly
structures. Use powerful workstations with at least 4GB RAM and plenty of free hard disk
space.

Stop any non-essential processes to free up as many resources as possible on the
workstations being used.

The following are specific recommendations:

• Archive server
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When the conversion is performed by overwriting existing versions of files, a backup
is created for each overwritten file. The archive server must have disk capacity to store
these backup files.

Before the upgrade begins, a screen message notifies you of the space needed, based
on the files you have selected to upgrade.

• Workstations

All workstations that will be used for the upgrade must have enough RAM to open the
largest assembly to be converted. A minimum of 4 GB RAM is recommended.

SOLIDWORKS recommends a minimum of 6 GB RAM (or more on Windows 7 x64
operating systems).

Installing the File Version Upgrade Utility
The File Version Upgrade Utility is provided on the SOLIDWORKS installation media in
the SWPDMClient\Support\File Version Upgrade\ directory.

To install the File Version Upgrade Utility:

1. Navigate to the SWPDMClient\Support\File Version Upgrade Utility\ on the
Installation media.

2. Double-click File Version Upgrade.exe.
3. In the Welcome screen, click Next.
4. Accept the license agreement and click Next.
5. Click Install.
6. Click Finish.

Preparing to Upgrade
Prepare the workstations involved in the upgrade before you begin the upgrade process.

Perform a complete vault backup, including:

• File vault database
• Archive files

On the master and slave workstations that are participating in the upgrade process:

1. Install the same version and revision level of SOLIDWORKS PDM client.
2. Create local views of the file vault to be upgraded.
3. Check all files into the vault.
4. Close SOLIDWORKS.

On the master workstation:

1. Give participating clients read/write access to all files in the vault you are upgrading.
2. Create a folder for the work instruction files and share it with full (read/write)
permissions for all participating clients.

164

Upgrading SOLIDWORKS Files



Selecting Version Settings
The Version Settings screen lets you specify which versions and revisions of your selected
file type will be upgraded and whether old versions will be overwritten.

Before you perform a full conversion, test the conversion of older files by opening a
sample set in the target version of SOLIDWORKS to check for any conversion errors.

Select Create new version of files if you want only the most recent versions of files to
be upgraded and to preserve the existing versions of the files in the older file format.
New SOLIDWORKS PDM versions are created.

Select Overwrite existing versions of files if you want to:
• Overwrite all versions of files with upgraded files.
• Specify which versions of files to overwrite by selecting one or both of the following:

• Latest version The tool upgrades the latest versions of files plus all files that they
reference.

• Versions with a revision The tool upgrades all files with revision tags.

If you choose to overwrite existing versions, the File Version Upgrade tool creates a
backup of files before upgrading them. You can delete backed up files after confirming
that the upgrade is successful. See Managing Backup Files.

Assemblies that contain cyclic references are not upgraded if you select to overwrite
existing versions of files.

Upgrade Scenarios

The following topics illustrate the possible upgrade scenarios for the set of files below.
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version increment

reference

Creating New Versions of Files
When you create new versions of files, the older versions still exist and can continue to
be opened in the older version of SOLIDWORKS.

Relinking to the Latest Version of Referenced Files
You can relink an assembly to the latest version of the files that it references.

If the assembly and its subassemblies reference versions of parts that are not the latest
version, the references are moved to the latest versions of the parts.

Older versions of the parts, assembly, and subassembly are not upgraded and their
references are not affected.

If the newer versions of referenced files have undergone geometry modifications, using
this option could result in unwanted assembly changes or rebuild errors. In addition,
if file properties such as Part Number, Description, or Material have changed, in the
newer versions, this could cause changes in Bills of Materials.

Selections represented In the diagram below are:

SelectionsOptionScreen

<All SW file types>Files of typeSearch Files to
Upgrade
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SelectionsOptionScreen

Files referencing older versions
• Are re-linked to the new version

Update revisions
• Do not update revision

Create new version
of files

Version Settings

Files before upgradeReference links before
upgrade

Upgraded filesReference links after
upgrade

Moving Existing Revision Tags
You can move the latest revision tag to the latest version of a file you are upgrading.

Selections represented In the diagram below are:
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SelectionsOptionScreen

<All SW file types>Files of typeSearch Files to
Upgrade

Files referencing older versions
• Are excluded

Update revisions
• Move revision

Create new version
of files

Version Settings

Files before upgrade, showing revision that is moved

Upgraded files

Incrementing Revision Tags
You can increment the revision tags on the latest versions of files as you upgrade the
files.

Selections represented In the diagram below are:
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SelectionsOptionScreen

<All SW file types>Files of typeSearch Files to
Upgrade

Files referencing older versions
• Are re-linked to the new version

Update revisions
• Increment revision

Create new version
of files

Version Settings

Files before upgrade, showing revision that
is moved and incremented

Reference links before
upgrade

Upgraded filesReference links after
upgrade
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Overwriting Existing Versions of Files
When you overwrite the existing versions of files, the existing files are replaced with
upgraded files. New versions are not created.

Overwriting the Latest Versions of Files
You can upgrade by overwriting the latest version of all files of the selected file type. Any
version of a file that is used in a reference from an upgraded file is also upgraded.

Overwriting the Latest Versions of All Files

SelectionsOptionScreen

<All SW file types>Files of typeSearch Files to
Upgrade

Overwrite
• Latest version

Overwrite existing
versions of files

Version Settings

Overwriting the Latest Version of Parts

SelectionsOptionScreen

*.sldprtFiles of typeSearch Files to
Upgrade
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SelectionsOptionScreen

Overwrite
• Latest version

Overwrite existing
versions of files

Version Settings

By default, part drawings are not upgraded. However, because drawings are parents
to parts, a Broken reference warning screen lets you select to upgrade the drawings
that reference the parts that are being upgraded.

Overwriting the Latest Version of Assemblies

SelectionsOptionScreen

*.sldasmFiles of typeSearch Files to
Upgrade
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SelectionsOptionScreen

Overwrite
• Latest version

Overwrite existing
versions of files

Version Settings

In a referenced version stream, the File Version Upgrade tool also upgrades the latest

parts, as indicated by the blue boxes.

By default, part and assembly drawings are not upgraded. However, because drawings
are parents to parts and assemblies, a Broken reference warning screen lets you select
to upgrade the drawings that reference parts and assembles that are being upgraded.

Overwriting the Latest Version of Drawings

SelectionsOptionScreen

*.slddrwFiles of typeSearch Files to
Upgrade
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SelectionsOptionScreen

Overwrite
• Latest version

Overwrite existing
versions of files

Version Settings

Overwriting Files with Revision Tags
You can include files with revision tags as files that are upgraded.

These examples show the files that are upgraded when you choose both Latest version
and Version with a revision. Red boxes indicate files that are upgraded because they
have revision tags, even though they are not the latest version.

Overwriting All Files with Revision Tags

SelectionsOptionScreen

<All SW file types>Files of typeSearch Files to
Upgrade

Overwrite
• Latest version
• Version with a revision

Overwrite existing
versions of files

Version Settings
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Overwriting Parts with Revision Tags

SelectionsOptionScreen

*.sldprtFiles of typeSearch Files to
Upgrade

Overwrite
• Latest version
• Version with a revision

Overwrite existing
versions of files

Version Settings
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By default, part drawings are not upgraded. However, because drawings are parents
to parts, a Broken reference warning screen lets you select to upgrade the drawings
that reference the parts that are being upgraded.

Overwriting Assemblies with Revision Tags

SelectionsOptionScreen

*.sldasmFiles of typeSearch Files to
Upgrade

Overwrite
• Latest version
• Version with a revision

Overwrite existing
versions of files

Version Settings
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In a referenced version stream, the File Version Upgrade tool also upgrades the latest

parts, as indicated by the blue boxes.

By default, part and assembly drawings are not upgraded. However, because drawings
are parents to parts and assemblies, a Broken reference warning screen lets you select
to upgrade the drawings that reference parts and assembles that are being upgraded.

Overwriting Drawings with Revision Tags

SelectionsOptionScreen

*.slddrwFiles of typeSearch Files to
Upgrade

Overwrite
• Latest version
• Version with a revision

Overwrite existing
versions of files

Version Settings
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Performing a Trial File Upgrade
Before upgrading the SOLIDWORKS files in a production vault, perform the upgrade on
a copy of the production vault to ensure that there are no upgrade problems. Contact
your value added reseller for help creating a copy of your vault.

1. Restore a complete backup of the file vault to a separate server.
2. Start the File Version Upgrade Utility by doing one of the following:

• On Windows 7 and Windows Server systems prior to Windows Server 2012, from
the Windows Start menu, select All Programs > SOLIDWORKS PDM > File
Version Upgrade.

• On Windows 8.1 and Windows Server 2012 or later, on the Apps screen, under
SOLIDWORKS PDM, click File Version Upgrade.

3. Follow the instructions in the upgrade wizard.
4. Verify that the upgrade is successful.

See After Upgrading.

Running the Upgrade Utility
To run the upgrade utility:

1. Start the File Version Upgrade Utility by doing one of the following:
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• On Windows 7 and Windows Server systems prior to Windows Server 2012, from
the Windows Start menu, select All Programs > SOLIDWORKS PDM > File
Version Upgrade.

• On Windows 8.1 and Windows Server 2012 or later, on the Apps screen, under
SOLIDWORKS PDM, click File Version Upgrade.

2. On the Welcome screen, do one of the following:

• To set up the upgrade, click Initiate a new upgrade process (Master
Workstation).

• To run a work instruction file created for the upgrade, click Participate in an
upgrade process (Slave Workstation).

• To retry an upgrade that was terminated unexpectedly, click Restart an
interrupted upgrade process (Master and Slave Workstation).

3. Follow the instructions in the upgrade wizard.

Creating and Using Work Instruction Files
By creating work instruction files, you can run the upgrade tool concurrently on several
workstations to reduce the upgrade time.

You create the work instruction files on the first workstation that runs the upgrade tool,
which becomes the master workstation.

To create and use work instruction files:

1. Create a shared folder and give each workstation that will participate in the upgrade
Read/Write access.

2. Start the File Version Upgrade Utility by doing one of the following:

• On Windows 7 and Windows Server systems prior to Windows Server 2012, from
the Windows Start menu, select All Programs > SOLIDWORKS PDM > File
Version Upgrade.

• On Windows 8.1 and Windows Server 2012 or later, on the Apps screen, under
SOLIDWORKS PDM, click File Version Upgrade.

3. On the Welcome screen, select Initiate a new upgrade process (Master
Workstation) and click Next.

4. Complete the wizard screens.
5. On the Upgrade Settings screen:

a) Under Upgrade Settings, select Divide the upgrade work into multiple work
instruction files.

b) Specify the number of work instruction files to create.
c) For Shared location for work instruction files, type the name of the shared
folder you created in step 1 or click the browse button to navigate to the folder.

The folder name must be in UNC format.

d) Click Next.

6. On the Ready to Upgrade Files screen, do one of the following:

• To upgrade now, click Yes.
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When a completion message appears, click OK.
• To exit the upgrade utility and run work instruction files at a later time, click No.

7. If you selected No in step 6, run the File Version Upgrade tool again to perform the
upgrade using the work instruction files.

8. On the Welcome screen, select Participate in an upgrade process [Slave
Workstation].

9. On the Select Work Instruction File screen:
a) Browse to the location of the work instruction files.
b) Select the work instruction file to process.
c) Click Next.
The Work Instruction File Summary displays with a read-only summary of the
settings specified for the upgrade.

d) Click Next.

10. On the Ready to Upgrade Files screen:
a) Click View Files to see a list of files that will be upgraded.
b) To upgrade the files, click Yes.
c) When a completion message appears, click OK.

Completing an Interrupted Upgrade
Sometimes an upgrade is interrupted unexpectedly, for example, when you lose a network
connection or lose power.

To complete an interrupted upgrade:

1. Click Retry in the error message.
2. In the message indicating that the conversion did not complete successfully, click OK
3. Click Exit.
4. Solve the problem that caused the interruption.

For example, restore the network or restart the computer.

5. Run the Upgrade utility again.
6. On the Welcome screen, select Restart an interrupted upgrade process (Master

and Slave Workstation).
7. On the Continue Interrupted Migration screen, click Next.
8. On the Work Instruction File Summary screen, click Next.
9. On the Ready to Upgrade Files screen, click Finish.

After Upgrading
When the upgrade is complete:

• View the upgrade log files.
• Manually upgrade files that the tool was unable to upgrade automatically.

Manual upgrade creates new versions. If you upgraded using Overwrite
existing versions, manual upgrade will invalidate the reference structure.
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• Optionally, use Get Latest Version to create local copies of files that were converted
on other workstations.

• Open a subset of converted files in SOLIDWORKS to verify that the conversion was
successful.

• If you selected to overwrite existing versions of files, after ensuring that the upgrade
was successful, remove the backup files from the archive server.

File Name Formats for Upgrade Logs

Files names in upgrade logs take the following formats:

• Files that have been upgraded

Upgrade Utility <id>Batch<n>.log

where:

• <id> is a unique alphanumeric string
• <n> is the number of the batch file for which the log was created

Example: Upgrade Utility 471F2FDS Batch 4.log

• Files that could not be upgraded

Upgrade Utility <id> Batch <n>.logExcluded.log

Example: Upgrade Utility 471F2FDS Batch 4.logExcluded.log

Managing Backup Files
If you choose to overwrite existing versions of files when you upgrade, the upgrade tool
creates a backup file for each overwritten file.

These backup files remain after the upgrade. You can remove them after you verify that
the upgrade succeeded.

Backup File Creation

It is not possible to disable the backup option, so ensure that you have sufficient free
disk space on the archive server before you start the upgrade.

The Ready to Upgrade Files screen gives an estimate of the amount of space that is
needed.

For each file that is overwritten:

1. The upgrade tool retrieves the original version of the file from the file archive folder
to the client system that is running a work instruction file to perform the upgrade.

2. The tool opens the file in SOLIDWORKS, upgrades it, and send it back to the archive
folder when the batch process completes.

3. Before the version is replaced, the original version in the archive is renamed using
the following format:
bak_counter_version.extension

Where:
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• bak is the prefix for all backup files.
• counter is a unique counter in case the existing file with the same backup name
exists from a previous upgrade.

• version is the number, in hexadecimal format, of the file version that is being
replaced.

• extension is the file extension.

4. The upgrade tool places the upgraded version of the file in the archive using the
original file name.

Restoring an Incorrectly Upgraded Version from a Backup
If an upgraded version of a file is incorrect, you can use the backup file to restore the
original content of the file.

1. In the local file vault view, determine the name of the file to find.
2. Open Microsoft SQL Server Management Studio and click Connect.
3. Expand Databases and select the vault containing the file you want to restore.
4. Click New Query.
5. In the right pane, type a query in the following format:

select * from documents
where filename like 'filename.ext'

For example:

select * from documents
where filename like 'speaker_frame.sldprt'

6. Click Execute.
Record the files DocumentID, which is listed in the Results tab.

7. Exit the SQl Server Management Studio.
8. Use a calculator to convert the DocumentID to hexadecimal format.
9. In an Explorer window, navigate to install_dir\Program Files\SOLIDWORKS PDM\

Data\vault_name.
10. Expand the vault archive that matches the last digit of the hexadecimal number.

For example, if the hexadecimal number is 3B, expand the folder labeled B.

11. Expand the folder that matches the hexadecimal number.
12. Rename or delete the version of the file you want to restore.

For example, rename 00000002.sldprt to 00000002.backup.

13. Rename the appropriate bak_ file to the original file name.
For example, rename bak_0_00000002.sldprt to 00000002.sldprt.

14. Exit Microsoft SQL Server Management Studio.
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13
Additional Configuration

This chapter includes the following topics:

• Managing the SQL Transaction Log Size
• Configuring SOLIDWORKS PDM to Communicate Using IP Addresses Only
• Moving Server Components to Another System

Managing the SQL Transaction Log Size
Each SQL database contains one database file (.mdf) and at least one transaction log file
(.ldf). The database file stores the physical data added to the database, and the
transaction log keeps records of database modifications. The SQL Server uses the
transaction log to maintain database integrity, particularly during recovery.

By default, the recovery method of an SQL database is set to full recovery model, which
means that every change to the database is logged. A large transaction log can grow
until it is out of disk space and causes the performance of the SQL Server to drop.

The full recovery model is preferred to restore to an exact point-in-time, but if you rely
on nightly database backups and want to ensure that the transaction log does not grow
and degrade SQL performance, you should change to the simple recovery model.

To reduce the size of a large transaction log after you change to simple recovery model,
shrink the transaction log.

For more details about changing the recovery model, see the SQL Server books online
and this Microsoft Knowledge Base article:

http://support.microsoft.com/?kbid=873235

Changing to the Simple Recovery Model

1. Open Microsoft SQL Server Management Studio and click Connect.
2. In the left pane, expand the Databases folder, right-click the database name and

select Properties.
3. In the Database Properties dialog box, in the left pane, select Options.
4. In the Recovery model list, select Simple and click OK.
5. Close Microsoft SQL Server Management Studio.
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Shrinking the Transaction Log

1. Right-click the database name, and select Tasks > Shrink > Files.
2. In the Shrink File dialog box, in the File type list, select Log.
3. Click OK.

Configuring SOLIDWORKS PDM to Communicate Using IP
Addresses Only

By default, when setting up a SOLIDWORKS PDM environment, clients communicate with
servers using system names. If the DNS lookup is unstable or not sufficient for the network
setup, you can configure SOLIDWORKS PDM to use only IP-numbers to communicate.

This setup involves:

1. Updating the archive server
2. Updating the SQL Server
3. Updating the SOLIDWORKS PDM clients

When connecting to the archive server, you can remove and re-attach the file vault
view using the archive server IP address instead of updating the registry manually.

Updating the Archive Server to Communicate Using IP
Addresses

1. On the system running the archive server, from the Windows Start menu, click Run
> regedit to open the registry.

2. Find the key for the archive server:
HKEY_LOCAL_MACHINE\SOFTWARE\SOLIDWORKS\Applications\PDMWorks
Enterprise\ArchiveServer

3. In the right pane, right-click and select New > String value and name the string
value ServerName.

4. Double-click ServerName.
5. In the Edit string dialog box, in the Value data field, type the IP address of the archive

server and click OK.
6. Find the key for the file vault:

HKEY_LOCAL_MACHINE\SOFTWARE\SOLIDWORKS\Applications\PDMWorks
Enterprise\ArchiveServer\Vaults\vaultname

7. Double-click Server, update the Value data field with the IP address to the SQL
Server hosting the vault database, and click OK.

8. Restart the archive server service.
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Updating the SQL Server to Communicate Using IP
Addresses

1. Open Microsoft SQL Server Management Studio and click Connect.
2. In the left pane, expand Databases, the vault database, and Tables.
3. Right-click dbo.ArchiveServers and select Open Table.
4. Under ArchiveServerName, change the entry to the IP address of the archive server

hosting the vault.
5. Right-click dbo.SystemInfo and select Open Table.
6. Under ArchiveServerName, change the entry to the IP address of the archive server

hosting the vault.
7. Exit Microsoft SQL Server Management Studio.

Updating SOLIDWORKS PDM Clients to Communicate
Using IP Addresses

1. If started, exit SOLIDWORKS PDM by clicking the SOLIDWORKS PDM icon on the
right side of the task bar and selecting Exit. Ensure the administration tool is not
running.

2. On the system running the archive server, from the Windows Start menu, click Run
> regedit to open the registry.

3. Find the key for the file vault view:
HKEY_LOCAL_MACHINE\SOFTWARE\SOLIDWORKS\Applications\PDMWorks
Enterprise\Databases\vaultname

4. Update the DbServer value with the IP address to the SQL Server hosting the vault
database.

5. Update the ServerLoc value with the IP address to the archive server hosting the
vault archive.

6. If the administration tool was used on the client, delete the following key:
HKEY_CURRENT_USER\Software\SOLIDWORKS\Applications\PDMWorks
Enterprise\ConisioAdmin

The key is recreated when starting the administration tool.
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Verifying IP Address Communication

1. When all servers and clients are updated, verify that you can:

• Log into the file vault.
• Add a new file.
• Retrieve an existing file.

2. If the vault is replicated, ensure you are using IP addresses in the replication settings
dialog.

3. If you experience problems connecting with the new addresses:

• Check the client and archive server log for errors.
• Ensure that you can ping the servers from the client using the supplied IP addresses.

Moving Server Components to Another System
Use these procedures when moving SOLIDWORKS PDM server components from one
system to another or when changing the name on the server system to verify which
database and registry entries should be updated.

Ensure to move the components of SOLIDWORKS PDM Standard server on a machine
that has SQL Server Express.

These instructions describe moving both the database and archive server. If you are
moving only one, follow only those instructions that apply.

Before you start, tell users to exit all SOLIDWORKS PDM vaults. Users can work off-line
while you are performing the move. After client registry keys are updated, users can
check the work they do off-line into the new vault location.

Copying Files to the New Server

1. On the old SQL Server, backup the file vault database and the ConisioMasterDb.
For details, see Backing Up the File Vault Database.

2. Copy the backup file to the new server.
3. Open the SOLIDWORKS PDM Archive Server dialog box by doing one of the following:

• On Windows 7 and Windows Server systems prior to Windows Server 2012, from
the Windows Startmenu, select All Programs > SOLIDWORKS PDM > Archive
Server Configuration.

• On Windows 8.1 and Windows Server 2012 or later, on the Apps screen, under
SOLIDWORKS PDM, click Archive Server Configuration.

4. To make a backup of the archive server settings:
a) Select Tools > Backup settings.
For details, see Backing Up the Archive Server Settings.

b) Clear or set a password, and click Launch backup.

185

Additional Configuration



c) Close the SOLIDWORKS PDM Archive Server dialog box.
d) Copy the backup file (backup.dat) to the new server.

5. Copy the entire file vault archive folder from the old server to the new server,
maintaining the same path.

If you are unsure where the archives are located, check this registry key:

HKEY_LOCAL_MACHINE\SOFTWARE\SOLIDWORKS\Applications\PDMWorks
Enterprise\ArchiveServer\Vaults\vaultname\ArchiveTable

Configuring the Moved SQL File Vault Database

1. On the new server, install the SQL Server software.
For details, see Installing and Configuring SQL Server.

2. To keep the collation settings the same as the old server:
a) Open the Microsoft SQL Server Management Studio and click Connect.
b) Right-click the server and select Properties.
c) In the Server Properties dialog box, in the right pane, note the Server Collation
setting of the old server.

d) During the new SQL install, select Custom and set the same collation.

3. Restore the backed-up database, keeping the original name.

Stop the old SQL Server service or take the old databases offline so that you do
not have two servers with the same vault database active.

4. In the restored file vault database, update with the new archive server name in tables
ArchiveServers and SystemInfo.

In a replicated environment, the ArchiveServers table contains each replicated
server. Be sure to update only the moved server entry. Do not change the
VaultName entry.

5. To allow indexing of the moved file vault database, create a linked server entry:

You need to create a linked server entry only while using Microsoft Indexing Service
on Windows 7 or Windows Server 2008 R2.

a) Open Microsoft SQL Server Management Studio and click Connect.
b) Right-click on the moved file vault database and select New Query.
c) Enter the following command in the query window, then press Execute (F5) to
run the query.
Exec Sys_IndexServerLink 1

If indexing is already set up on the old server, remove and recreate the index
catalog on the new server using the Indexing node in the Administration tool.

6. Exit Microsoft SQL Server Management Studio.
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Moving the SolidNetWork License Manager
If you need to move your license manager software to another server, you must transfer
activated licenses to the license key server at Dassault Systèmes SOLIDWORKS
Corporation.

To move the SolidNetWork License Manager software:

1. Transfer the activated license to the license key server.
For more information, see Transferring a SolidNetWork License on page 68.

2. Install the SolidNetwork License Manager on the new server.
3. Reactivate the license.

For more information, see Installing and Configuring SolidNetWork Licensing
on page 64.

Moving the SOLIDWORKS PDM Database Server
If you move the SOLIDWORKS PDM database to a new system, you must move or reinstall
the database server component.

Moving or reinstalling the database server component ensures that the database server
receives updates such as notifications, local view refresh, replication schedule updates,
and index server changes from the SOLIDWORKS PDM database.

To move the SOLIDWORKS PDM database server:

1. Uninstall the SOLIDWORKS PDM database server from the old server.
2. Install the SOLIDWORKS PDM database server on the new server.
3. When prompted to specify the SQL server that hosts the file vault databases, specify

the name of the SQL server where you have moved the vault database.
4. To verify the Mail Service configuration:

a) On the new server, expand the Start menu and type regedit in the Search
programs and files field.

b) Under Programs, right-click regedit.exe and click Run as administrator.
c) In the Registry Editor, expand HKEY_LOCAL_MACHINE > SOFTWARE >
SOLIDWORKS > Applications > PDMWorksEnterprise > MailService.

d) Verify the Server value.
The value is:

• Blank if you have installed the SOLIDWORKS PDM database server on the same
system as the SQL server and databases are running under the default SQL
instance.

• The SQL server name or instance name if the SQL server is on a different system
or using a named SQL instance.

Configuring the Moved Archive Server

1. Install the archive server on the new server. Use the default settings used on the old
server, if you can remember them.
For details, see Installing SOLIDWORKS PDM Archive Server.

2. Open the SOLIDWORKS PDM Archive Server dialog box by doing one of the following:
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• On Windows 7 and Windows Server systems prior to Windows Server 2012, from
the Windows Startmenu, select All Programs > SOLIDWORKS PDM > Archive
Server Configuration.

• On Windows 8.1 and Windows Server 2012 or later, on the Apps screen, under
SOLIDWORKS PDM, click Archive Server Configuration.

3. Select Tools > Backup settings.
4. In the Backup Settings dialog box, click Load Backup.

The old archive server settings are imported.

5. On the new archive server, from the Windows Start menu, click Run > regedit to
open the registry.

6. Update and verify the following keys, which may differ from the old server settings:

• HKEY_LOCAL_MACHINE\SOFTWARE\SOLIDWORKS\Applications\PDMWorks
Enterprise\ArchiveServer\Computers\local\Archives

Ensure that the default value points to the correct root folder (=parent) where the
file vault archive is stored (i.e., the path where the file vault archive folder was
copied to). For example, type:

C:\Program Files\SOLIDWORKS PDM\Data

If the product is installed via SLDIM, the default path is C:\Program Files\
SOLIDWORKS Corp\SOLIDWORKS PDM.

• HKEY_LOCAL_MACHINE\SOFTWARE\SOLIDWORKS\Applications\PDMWorks
Enterprise\ArchiveServer\Vaults\vaultname

Ensure that Server value is updated to the new SQL Server name and SQLDbName
matches the restored file vault database name. Do not change the DbName entry.

• HKEY_LOCAL_MACHINE\SOFTWARE\SOLIDWORKS\Applications\PDMWorks
Enterprise\ArchiveServer\Vaults\vaultname\ArchiveTable

Make sure all paths point to the file vault archive location where you copied the
files to (from the old server.)

7. Stop the old archive server from running.
Preferably disconnect the old server from the network so that it is not available until
all clients are updated, or stop the archive server and SQL Server service.

Updating Client Registry Keys

1. On each client, update the following registry key:
HKEY_LOCAL_MACHINE\SOFTWARE\SOLIDWORKS\Applications\PDMWorks
Enterprise\Databases\vaultname

Update the DbServer (database server) and ServerLoc (archive server) with the
new server name.
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On 64-bit clients update the DbServer and ServerLoc in this registry key:

HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\SOLIDWORKS\Applications\PDMWorks
Enterprise\Databases\vaultname

2. On each client, delete the following registry key:
HKEY_CURRENT_USER\Software\SOLIDWORKS\Applications\PDMWorks
Enterprise\ConisioAdmin

Updating Replication Settings (For SOLIDWORKS PDM
Professional only)
If you are moving the archive server components in a replicated environment, update
the replication settings to reflect the new archive server name.

1. From an updated client, open the Administration tool and log in to the vault.
2. Right-click Replication Settings and click Open.
3. In the Replication Settings dialog box, under Connections, select the first row.
4. Under Selected connection, for IP address or DNS name, type the new IP address

or name of the moved archive server.
5. Restart the archive server service on each archive server that is replicating the file

vault.

Verifying the Server Move

1. Log in as the Admin user and view the file vault listing.
2. Make sure that the archive server fully works by adding a text file, checking it in, and

deleting it.

If you cannot login to the vault, or add, check out, or modify files, make sure that the
path to the file vault archive folder that you specified in step 5 of Copying Files to the
New Server is correct.
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